linux-remoteproc.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Bjorn Andersson <bjorn.andersson@linaro.org>
To: Alex Elder <elder@linaro.org>
Cc: Mathieu Poirier <mathieu.poirier@linaro.org>,
	ohad@wizery.com, s-anna@ti.com, Markus.Elfring@web.de,
	linux-remoteproc@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 5/7] remoteproc: Restructure firmware name allocation
Date: Sun, 19 Apr 2020 22:17:23 -0700	[thread overview]
Message-ID: <20200420051720.GE1516868@builder.lan> (raw)
In-Reply-To: <9a4b6342-750e-284a-2343-8151b478589b@linaro.org>

On Wed 15 Apr 14:23 PDT 2020, Alex Elder wrote:

> On 4/15/20 3:48 PM, Mathieu Poirier wrote:
> > Improve the readability of function rproc_alloc_firmware() by using
> > a non-negated condition.
> > 
> > Suggested-by: Alex Elder <elder@linaro.org>
> > Signed-off-by: Mathieu Poirier <mathieu.poirier@linaro.org>
> 
> If it were me, I'd move the comment above the if statement and
> perhaps reword it a little bit to describe what's happening.
> But no matter, this looks good.
> 

This would also avoid the fact that we have a multiline block without
braces (which isn't needed, but looks odd to me). So that sounds like a
good idea.

Regards,
Bjorn

> Reviewed-by: Alex Elder <elder@linaro.org>
> 
> > ---
> >  drivers/remoteproc/remoteproc_core.c | 6 +++---
> >  1 file changed, 3 insertions(+), 3 deletions(-)
> > 
> > diff --git a/drivers/remoteproc/remoteproc_core.c b/drivers/remoteproc/remoteproc_core.c
> > index ebaff496ef81..0bfa6998705d 100644
> > --- a/drivers/remoteproc/remoteproc_core.c
> > +++ b/drivers/remoteproc/remoteproc_core.c
> > @@ -1984,14 +1984,14 @@ static int rproc_alloc_firmware(struct rproc *rproc,
> >  {
> >  	const char *p;
> >  
> > -	if (!firmware)
> > +	if (firmware)
> > +		p = kstrdup_const(firmware, GFP_KERNEL);
> > +	else
> >  		/*
> >  		 * If the caller didn't pass in a firmware name then
> >  		 * construct a default name.
> >  		 */
> >  		p = kasprintf(GFP_KERNEL, "rproc-%s-fw", name);
> > -	else
> > -		p = kstrdup_const(firmware, GFP_KERNEL);
> >  
> >  	if (!p)
> >  		return -ENOMEM;
> > 
> 

WARNING: multiple messages have this Message-ID (diff)
From: Bjorn Andersson <bjorn.andersson@linaro.org>
To: Alex Elder <elder@linaro.org>
Cc: Mathieu Poirier <mathieu.poirier@linaro.org>,
	ohad@wizery.com, s-anna@ti.com, Markus.Elfring@web.de,
	linux-remoteproc@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 5/7] remoteproc: Restructure firmware name allocation
Date: Sun, 19 Apr 2020 22:17:20 -0700	[thread overview]
Message-ID: <20200420051720.GE1516868@builder.lan> (raw)
Message-ID: <20200420051720.iBd8rr4h8HUIjG1ecVfBDpmHgL4uoj_qtLJazfeWqV8@z> (raw)
In-Reply-To: <9a4b6342-750e-284a-2343-8151b478589b@linaro.org>

On Wed 15 Apr 14:23 PDT 2020, Alex Elder wrote:

> On 4/15/20 3:48 PM, Mathieu Poirier wrote:
> > Improve the readability of function rproc_alloc_firmware() by using
> > a non-negated condition.
> > 
> > Suggested-by: Alex Elder <elder@linaro.org>
> > Signed-off-by: Mathieu Poirier <mathieu.poirier@linaro.org>
> 
> If it were me, I'd move the comment above the if statement and
> perhaps reword it a little bit to describe what's happening.
> But no matter, this looks good.
> 

This would also avoid the fact that we have a multiline block without
braces (which isn't needed, but looks odd to me). So that sounds like a
good idea.

Regards,
Bjorn

> Reviewed-by: Alex Elder <elder@linaro.org>
> 
> > ---
> >  drivers/remoteproc/remoteproc_core.c | 6 +++---
> >  1 file changed, 3 insertions(+), 3 deletions(-)
> > 
> > diff --git a/drivers/remoteproc/remoteproc_core.c b/drivers/remoteproc/remoteproc_core.c
> > index ebaff496ef81..0bfa6998705d 100644
> > --- a/drivers/remoteproc/remoteproc_core.c
> > +++ b/drivers/remoteproc/remoteproc_core.c
> > @@ -1984,14 +1984,14 @@ static int rproc_alloc_firmware(struct rproc *rproc,
> >  {
> >  	const char *p;
> >  
> > -	if (!firmware)
> > +	if (firmware)
> > +		p = kstrdup_const(firmware, GFP_KERNEL);
> > +	else
> >  		/*
> >  		 * If the caller didn't pass in a firmware name then
> >  		 * construct a default name.
> >  		 */
> >  		p = kasprintf(GFP_KERNEL, "rproc-%s-fw", name);
> > -	else
> > -		p = kstrdup_const(firmware, GFP_KERNEL);
> >  
> >  	if (!p)
> >  		return -ENOMEM;
> > 
> 

  parent reply	other threads:[~2020-04-20  5:17 UTC|newest]

Thread overview: 66+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-15 20:48 [PATCH v2 0/7] remoteproc: Refactor function rproc_alloc() Mathieu Poirier
2020-04-15 20:48 ` Mathieu Poirier
2020-04-15 20:48 ` [PATCH v2 1/7] remoteproc: Fix IDR initialisation in rproc_alloc() Mathieu Poirier
2020-04-15 20:48   ` Mathieu Poirier
2020-04-17 13:37   ` Suman Anna
2020-04-17 13:37     ` Suman Anna
2020-04-20  5:00   ` Bjorn Andersson
2020-04-20  5:00     ` Bjorn Andersson
2020-04-15 20:48 ` [PATCH v2 2/7] remoteproc: Split firmware name allocation from rproc_alloc() Mathieu Poirier
2020-04-15 20:48   ` Mathieu Poirier
2020-04-15 21:28   ` Alex Elder
2020-04-15 21:28     ` Alex Elder
2020-04-20  5:09   ` Bjorn Andersson
2020-04-20  5:09     ` Bjorn Andersson
2020-04-20  9:24   ` Arnaud POULIQUEN
2020-04-20  9:24     ` Arnaud POULIQUEN
2020-04-20 21:29     ` Mathieu Poirier
2020-04-20 21:29       ` Mathieu Poirier
2020-04-15 20:48 ` [PATCH v2 3/7] remoteproc: Simplify default name allocation Mathieu Poirier
2020-04-15 20:48   ` Mathieu Poirier
2020-04-15 21:26   ` Alex Elder
2020-04-15 21:26     ` Alex Elder
2020-04-20  5:10   ` Bjorn Andersson
2020-04-20  5:10     ` Bjorn Andersson
2020-04-15 20:48 ` [PATCH v2 4/7] remoteproc: Use kstrdup_const() rather than kstrup() Mathieu Poirier
2020-04-15 20:48   ` Mathieu Poirier
2020-04-15 21:25   ` Alex Elder
2020-04-15 21:25     ` Alex Elder
2020-04-17 13:44     ` Suman Anna
2020-04-17 13:44       ` Suman Anna
2020-04-20  5:21       ` Bjorn Andersson
2020-04-20  5:21         ` Bjorn Andersson
2020-04-17 16:12   ` [v2 4/7] remoteproc: Use kstrdup_const() rather than kstrdup() Markus Elfring
2020-04-17 16:12     ` Markus Elfring
2020-04-15 20:48 ` [PATCH v2 5/7] remoteproc: Restructure firmware name allocation Mathieu Poirier
2020-04-15 20:48   ` Mathieu Poirier
2020-04-15 21:23   ` Alex Elder
2020-04-15 21:23     ` Alex Elder
2020-04-20  5:17     ` Bjorn Andersson [this message]
2020-04-20  5:17       ` Bjorn Andersson
2020-04-16  6:26   ` Markus Elfring
2020-04-16  6:26     ` Markus Elfring
2020-04-17 13:39     ` Suman Anna
2020-04-17 13:39       ` Suman Anna
2020-04-17 15:48       ` [v2 " Markus Elfring
2020-04-17 15:48         ` Markus Elfring
2020-04-17 16:15         ` Suman Anna
2020-04-17 16:15           ` Suman Anna
2020-04-17 20:58         ` Mathieu Poirier
2020-04-17 20:58           ` Mathieu Poirier
2020-04-17 21:28       ` [PATCH v2 " Mathieu Poirier
2020-04-17 21:28         ` Mathieu Poirier
2020-04-15 20:48 ` [PATCH v2 6/7] remoteproc: Split rproc_ops allocation from rproc_alloc() Mathieu Poirier
2020-04-15 20:48   ` Mathieu Poirier
2020-04-17 13:49   ` Suman Anna
2020-04-17 13:49     ` Suman Anna
2020-04-17 15:35     ` Suman Anna
2020-04-17 15:35       ` Suman Anna
2020-04-17 21:56     ` Mathieu Poirier
2020-04-17 21:56       ` Mathieu Poirier
2020-04-15 20:48 ` [PATCH v2 7/7] remoteproc: Get rid of tedious error path Mathieu Poirier
2020-04-15 20:48   ` Mathieu Poirier
2020-04-17 13:50   ` Suman Anna
2020-04-17 13:50     ` Suman Anna
2020-04-17 13:34 ` [PATCH v2 0/7] remoteproc: Refactor function rproc_alloc() Suman Anna
2020-04-17 13:34   ` Suman Anna

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200420051720.GE1516868@builder.lan \
    --to=bjorn.andersson@linaro.org \
    --cc=Markus.Elfring@web.de \
    --cc=elder@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-remoteproc@vger.kernel.org \
    --cc=mathieu.poirier@linaro.org \
    --cc=ohad@wizery.com \
    --cc=s-anna@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).