linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2] Documentation: power: Use kcalloc() instead of kzalloc()
@ 2024-01-21 10:43 Erick Archer
  2024-01-22 17:11 ` Hu Haowen
  2024-01-23  6:11 ` Viresh Kumar
  0 siblings, 2 replies; 4+ messages in thread
From: Erick Archer @ 2024-01-21 10:43 UTC (permalink / raw)
  To: Viresh Kumar, Nishanth Menon, Stephen Boyd, Rafael J. Wysocki,
	Len Brown, Pavel Machek, Alex Shi, Yanteng Si, Jonathan Corbet,
	Gustavo A. R. Silva, Hu Haowen
  Cc: Erick Archer, linux-pm, linux-kernel, linux-doc, linux-hardening

As noted in the "Deprecated Interfaces, Language Features, Attributes,
and Conventions" documentation [1], size calculations (especially
multiplication) should not be performed in memory allocator (or similar)
function arguments due to the risk of them overflowing. This could lead
to values wrapping around and a smaller allocation being made than the
caller was expecting. Using those allocations could lead to linear
overflows of heap memory and other misbehaviors.

So, in the example code use the purpose specific kcalloc() function
instead of the argument size * count in the kzalloc() function.

At the same time, modify the translations accordingly.

Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
Link: https://github.com/KSPP/linux/issues/162
Signed-off-by: Erick Archer <erick.archer@gmx.com>
---
Hi,

This patch is a merger of two previous ones [1] [2].
As Hu Haowen and Jonathan Corbet suggested, the translation change
only makes sense if the original file is modified. So, with this
v2 version the original file and the translations are modified at
the same time.

[1] https://lore.kernel.org/linux-hardening/20240120120527.3866-1-erick.archer@gmx.com/
[2] https://lore.kernel.org/linux-hardening/20240120122204.4287-1-erick.archer@gmx.com/

Thanks,
Erick
---
 Documentation/power/opp.rst                    | 2 +-
 Documentation/translations/zh_CN/power/opp.rst | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/Documentation/power/opp.rst b/Documentation/power/opp.rst
index a7c03c470980..1b7f1d854f14 100644
--- a/Documentation/power/opp.rst
+++ b/Documentation/power/opp.rst
@@ -305,7 +305,7 @@ dev_pm_opp_get_opp_count
 	 {
 		/* Do things */
 		num_available = dev_pm_opp_get_opp_count(dev);
-		speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL);
+		speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL);
 		/* populate the table in increasing order */
 		freq = 0;
 		while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) {
diff --git a/Documentation/translations/zh_CN/power/opp.rst b/Documentation/translations/zh_CN/power/opp.rst
index 8d6e3f6f6202..7470fa2d4c43 100644
--- a/Documentation/translations/zh_CN/power/opp.rst
+++ b/Documentation/translations/zh_CN/power/opp.rst
@@ -274,7 +274,7 @@ dev_pm_opp_get_opp_count
 	 {
 		/* 做一些事情 */
 		num_available = dev_pm_opp_get_opp_count(dev);
-		speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL);
+		speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL);
 		/* 按升序填充表 */
 		freq = 0;
 		while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) {
--
2.25.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] Documentation: power: Use kcalloc() instead of kzalloc()
  2024-01-21 10:43 [PATCH v2] Documentation: power: Use kcalloc() instead of kzalloc() Erick Archer
@ 2024-01-22 17:11 ` Hu Haowen
  2024-01-23  1:30   ` Yanteng Si
  2024-01-23  6:11 ` Viresh Kumar
  1 sibling, 1 reply; 4+ messages in thread
From: Hu Haowen @ 2024-01-22 17:11 UTC (permalink / raw)
  To: Erick Archer, Viresh Kumar, Nishanth Menon, Stephen Boyd,
	Rafael J. Wysocki, Len Brown, Pavel Machek, Alex Shi, Yanteng Si,
	Jonathan Corbet, Gustavo A. R. Silva
  Cc: linux-pm, linux-kernel, linux-doc, linux-hardening


在 2024/1/21 18:43, Erick Archer 写道:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, in the example code use the purpose specific kcalloc() function
> instead of the argument size * count in the kzalloc() function.
>
> At the same time, modify the translations accordingly.
>
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162
> Signed-off-by: Erick Archer <erick.archer@gmx.com>
> ---
> Hi,
>
> This patch is a merger of two previous ones [1] [2].
> As Hu Haowen and Jonathan Corbet suggested, the translation change
> only makes sense if the original file is modified. So, with this
> v2 version the original file and the translations are modified at
> the same time.
>
> [1] https://lore.kernel.org/linux-hardening/20240120120527.3866-1-erick.archer@gmx.com/
> [2] https://lore.kernel.org/linux-hardening/20240120122204.4287-1-erick.archer@gmx.com/
>
> Thanks,
> Erick
> ---
>   Documentation/power/opp.rst                    | 2 +-
>   Documentation/translations/zh_CN/power/opp.rst | 2 +-
>   2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/Documentation/power/opp.rst b/Documentation/power/opp.rst
> index a7c03c470980..1b7f1d854f14 100644
> --- a/Documentation/power/opp.rst
> +++ b/Documentation/power/opp.rst
> @@ -305,7 +305,7 @@ dev_pm_opp_get_opp_count
>   	 {
>   		/* Do things */
>   		num_available = dev_pm_opp_get_opp_count(dev);
> -		speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL);
> +		speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL);
>   		/* populate the table in increasing order */
>   		freq = 0;
>   		while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) {
> diff --git a/Documentation/translations/zh_CN/power/opp.rst b/Documentation/translations/zh_CN/power/opp.rst
> index 8d6e3f6f6202..7470fa2d4c43 100644
> --- a/Documentation/translations/zh_CN/power/opp.rst
> +++ b/Documentation/translations/zh_CN/power/opp.rst
> @@ -274,7 +274,7 @@ dev_pm_opp_get_opp_count
>   	 {
>   		/* 做一些事情 */
>   		num_available = dev_pm_opp_get_opp_count(dev);
> -		speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL);
> +		speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL);


For the zh_CN translation,

Reviewed-by: Hu Haowen <2023002089@link.tyut.edu.cn>


Thanks,

Hu Haowen


>   		/* 按升序填充表 */
>   		freq = 0;
>   		while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) {
> --
> 2.25.1
>
>
>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] Documentation: power: Use kcalloc() instead of kzalloc()
  2024-01-22 17:11 ` Hu Haowen
@ 2024-01-23  1:30   ` Yanteng Si
  0 siblings, 0 replies; 4+ messages in thread
From: Yanteng Si @ 2024-01-23  1:30 UTC (permalink / raw)
  To: Hu Haowen, Erick Archer, Viresh Kumar, Nishanth Menon,
	Stephen Boyd, Rafael J. Wysocki, Len Brown, Pavel Machek,
	Alex Shi, Jonathan Corbet, Gustavo A. R. Silva
  Cc: linux-pm, linux-kernel, linux-doc, linux-hardening


在 2024/1/23 01:11, Hu Haowen 写道:
>
> 在 2024/1/21 18:43, Erick Archer 写道:
>> As noted in the "Deprecated Interfaces, Language Features, Attributes,
>> and Conventions" documentation [1], size calculations (especially
>> multiplication) should not be performed in memory allocator (or similar)
>> function arguments due to the risk of them overflowing. This could lead
>> to values wrapping around and a smaller allocation being made than the
>> caller was expecting. Using those allocations could lead to linear
>> overflows of heap memory and other misbehaviors.
>>
>> So, in the example code use the purpose specific kcalloc() function
>> instead of the argument size * count in the kzalloc() function.
>>
>> At the same time, modify the translations accordingly.
>>
>> Link: 
>> https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments 
>> [1]
>> Link: https://github.com/KSPP/linux/issues/162
>> Signed-off-by: Erick Archer <erick.archer@gmx.com>
>> ---
>> Hi,
>>
>> This patch is a merger of two previous ones [1] [2].
>> As Hu Haowen and Jonathan Corbet suggested, the translation change
>> only makes sense if the original file is modified. So, with this
>> v2 version the original file and the translations are modified at
>> the same time.
>>
>> [1] 
>> https://lore.kernel.org/linux-hardening/20240120120527.3866-1-erick.archer@gmx.com/
>> [2] 
>> https://lore.kernel.org/linux-hardening/20240120122204.4287-1-erick.archer@gmx.com/
>>
>> Thanks,
>> Erick
>> ---
>>   Documentation/power/opp.rst                    | 2 +-
>>   Documentation/translations/zh_CN/power/opp.rst | 2 +-
>>   2 files changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/Documentation/power/opp.rst b/Documentation/power/opp.rst
>> index a7c03c470980..1b7f1d854f14 100644
>> --- a/Documentation/power/opp.rst
>> +++ b/Documentation/power/opp.rst
>> @@ -305,7 +305,7 @@ dev_pm_opp_get_opp_count
>>        {
>>           /* Do things */
>>           num_available = dev_pm_opp_get_opp_count(dev);
>> -        speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL);
>> +        speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL);
>>           /* populate the table in increasing order */
>>           freq = 0;
>>           while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) {
>> diff --git a/Documentation/translations/zh_CN/power/opp.rst 
>> b/Documentation/translations/zh_CN/power/opp.rst
>> index 8d6e3f6f6202..7470fa2d4c43 100644
>> --- a/Documentation/translations/zh_CN/power/opp.rst
>> +++ b/Documentation/translations/zh_CN/power/opp.rst
>> @@ -274,7 +274,7 @@ dev_pm_opp_get_opp_count
>>        {
>>           /* 做一些事情 */
>>           num_available = dev_pm_opp_get_opp_count(dev);
>> -        speeds = kzalloc(sizeof(u32) * num_available, GFP_KERNEL);
>> +        speeds = kcalloc(num_available, sizeof(u32), GFP_KERNEL);
>
>
> For the zh_CN translation,
>
> Reviewed-by: Hu Haowen <2023002089@link.tyut.edu.cn>


Same here,

Reviewed-by: Yanteng Si <siyanteng@loongson.cn>


Thanks,

Yanteng

>
>
> Thanks,
>
> Hu Haowen
>
>
>>           /* 按升序填充表 */
>>           freq = 0;
>>           while (!IS_ERR(opp = dev_pm_opp_find_freq_ceil(dev, &freq))) {
>> -- 
>> 2.25.1
>>
>>
>>


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] Documentation: power: Use kcalloc() instead of kzalloc()
  2024-01-21 10:43 [PATCH v2] Documentation: power: Use kcalloc() instead of kzalloc() Erick Archer
  2024-01-22 17:11 ` Hu Haowen
@ 2024-01-23  6:11 ` Viresh Kumar
  1 sibling, 0 replies; 4+ messages in thread
From: Viresh Kumar @ 2024-01-23  6:11 UTC (permalink / raw)
  To: Erick Archer
  Cc: Viresh Kumar, Nishanth Menon, Stephen Boyd, Rafael J. Wysocki,
	Len Brown, Pavel Machek, Alex Shi, Yanteng Si, Jonathan Corbet,
	Gustavo A. R. Silva, Hu Haowen, linux-pm, linux-kernel,
	linux-doc, linux-hardening

On 21-01-24, 11:43, Erick Archer wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, in the example code use the purpose specific kcalloc() function
> instead of the argument size * count in the kzalloc() function.
> 
> At the same time, modify the translations accordingly.
> 
> Link: https://www.kernel.org/doc/html/next/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments [1]
> Link: https://github.com/KSPP/linux/issues/162
> Signed-off-by: Erick Archer <erick.archer@gmx.com>

Applied. Thanks.

-- 
viresh

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2024-01-23  6:11 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-01-21 10:43 [PATCH v2] Documentation: power: Use kcalloc() instead of kzalloc() Erick Archer
2024-01-22 17:11 ` Hu Haowen
2024-01-23  1:30   ` Yanteng Si
2024-01-23  6:11 ` Viresh Kumar

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).