linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Fabio Baltieri <fabio.baltieri@gmail.com>
To: Kurt Van Dijck <kurt.van.dijck@eia.be>
Cc: Marc Kleine-Budde <mkl@pengutronix.de>,
	Oliver Hartkopp <socketcan@hartkopp.net>,
	Wolfgang Grandegger <wg@grandegger.com>,
	linux-kernel@vger.kernel.org, linux-can@vger.kernel.org
Subject: Re: [PATCH] can: rename LED trigger name on netdev renames
Date: Thu, 6 Sep 2012 20:59:38 +0200	[thread overview]
Message-ID: <20120906185938.GA4043@gmail.com> (raw)
In-Reply-To: <1346750951-10451-1-git-send-email-kurt.van.dijck@eia.be>

Hi Kurt,

thanks for the patch!

On Tue, Sep 04, 2012 at 11:29:11AM +0200, Kurt Van Dijck wrote:
> The LED trigger name for CAN devices is based on the initial
> CAN device name, but does never change. The LED trigger name
> is not guaranteed to be unique in case of hotplugging CAN devices.
> 
> This patch tries to address this problem by modifying the
> LED trigger name according to the CAN device name when
> the latter changes.

That's an ideal solution, and I like the notifier implementation, but I
see a couple of problems with it.

> This patch is meant as illustration only.
> In case of VCAN device rename, a segmentation fault will occur.
> 
> Signed-off-by: Kurt Van Dijck <kurt.van.dijck@eia.be>
> ---
>  drivers/net/can/led.c |   57 +++++++++++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 57 insertions(+)
> 
> diff --git a/drivers/net/can/led.c b/drivers/net/can/led.c
> index eaa14ac..f62f908 100644
> --- a/drivers/net/can/led.c
> +++ b/drivers/net/can/led.c
> @@ -12,6 +12,7 @@
>  #include <linux/slab.h>
>  #include <linux/netdevice.h>
>  #include <linux/can/dev.h>
> +#include <linux/if_arp.h>
>  
>  #include <linux/can/led.h>
>  
> @@ -87,3 +88,59 @@ void devm_can_led_init(struct net_device *netdev)
>  	devres_add(&netdev->dev, res);
>  }
>  EXPORT_SYMBOL_GPL(devm_can_led_init);
> +
> +/*
> + * NETDEV rename notifier to rename the associated led triggers too
> + */
> +static int can_led_notifier(struct notifier_block *nb, unsigned long msg,
> +			void *data)
> +{
> +	struct net_device *netdev = (struct net_device *)data;
> +	struct can_priv *priv = netdev_priv(netdev);
> +	int busy = 0;
> +
> +	if (!net_eq(dev_net(netdev), &init_net))
> +		return NOTIFY_DONE;
> +
> +	if (netdev->type != ARPHRD_CAN)
> +		return NOTIFY_DONE;
> +
> +	if (msg != NETDEV_CHANGENAME)
> +		return NOTIFY_DONE;

That's the main problem, which I also got stuck into when I did my first
can-led implementation.  As LED structures are in netdev's private data,
you can only use it if your driver is based on the can-dev API, and
there are no way to be sure of that if you get outside driver's code
itself.

This would give problems with vcan, slcan, and probabily other
non-mainlined drivers.

Is there any way to register a notifier which fires only for devices
registered with devm_can_led_init?

> +	read_lock(&priv->tx_led_trig->leddev_list_lock);
> +	if (!list_empty(&priv->tx_led_trig->led_cdevs))
> +		++busy;
> +	read_unlock(&priv->tx_led_trig->leddev_list_lock);
> +	read_lock(&priv->rx_led_trig->leddev_list_lock);
> +	if (!list_empty(&priv->rx_led_trig->led_cdevs))
> +		++busy;
> +	read_unlock(&priv->rx_led_trig->leddev_list_lock);
> +
> +	if (busy)
> +		return notifier_from_errno(-EBUSY);

As we were discussing in the other thread, I don't think that this is
necessary.

> +	snprintf(priv->tx_led_trig_name, sizeof(priv->tx_led_trig_name),
> +		 "%s-tx", netdev->name);
> +	snprintf(priv->rx_led_trig_name, sizeof(priv->rx_led_trig_name),
> +		 "%s-rx", netdev->name);

I'm afraid that this is going to race against other code using trigger
name, so that's probabily needs a down_write(&led_cdev->trigger_lock),
which is a bit of a problem beacause that's static in led-triggers.c.

> +	return NOTIFY_DONE;
> +}
> +
> +/* notifier block for netdevice event */
> +static struct notifier_block can_netdev_notifier __read_mostly = {
> +	.notifier_call = can_led_notifier,
> +};
> +
> +static __init int can_led_init(void)
> +{
> +	return register_netdevice_notifier(&can_netdev_notifier);
> +}
> +
> +static __exit void can_led_exit(void)
> +{
> +	unregister_netdevice_notifier(&can_netdev_notifier);
> +}
> +
> +module_init(can_led_init);
> +module_exit(can_led_exit);

This breaks the driver when built as a module, as led.c is actually
linked together with can-dev.  The solution is to get it on a module by
its own or just to call init/exit functions from can_dev.

Besides those points I like the idea of renaming the trigger if we can
find a clean way to do that, so I'll try to look at those point further
in the weekend.

Fabio

  reply	other threads:[~2012-09-06 18:58 UTC|newest]

Thread overview: 67+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-07-30 19:20 [PATCH can-next v3 1/2] can: add tx/rx LED trigger support Fabio Baltieri
2012-07-30 19:20 ` [PATCH can-next v3 2/2] can: flexcan: add " Fabio Baltieri
2012-07-30 21:17 ` [PATCH can-next v3 1/2] can: add tx/rx " Marc Kleine-Budde
2012-07-31  6:57   ` Fabio Baltieri
2012-07-31  7:10     ` Marc Kleine-Budde
2012-07-31 11:57       ` Fabio Baltieri
2012-07-31 12:00         ` Marc Kleine-Budde
2012-07-31 22:05           ` [PATCH can-next v4] " Fabio Baltieri
2012-08-01  9:36             ` Marc Kleine-Budde
2012-08-01 10:07               ` Marc Kleine-Budde
2012-08-01 10:30               ` Fabio Baltieri
2012-08-01 11:37                 ` Marc Kleine-Budde
2012-08-01 11:49               ` [PATCH can-next v5 1/2] " Fabio Baltieri
2012-08-01 11:49                 ` [PATCH can-next v5 2/2] can: flexcan: add " Fabio Baltieri
2012-08-01 11:53                   ` Marc Kleine-Budde
2012-08-01 12:24                     ` Fabio Baltieri
2012-08-01 12:30                       ` Marc Kleine-Budde
2012-08-01 21:02                   ` Marc Kleine-Budde
2012-08-01 11:59                 ` [PATCH can-next v5 1/2] can: add tx/rx " Marc Kleine-Budde
2012-08-01 12:06                 ` Oliver Hartkopp
2012-08-01 12:18                   ` Marc Kleine-Budde
2012-08-01 18:21                     ` [PATCH can-next v6] " Fabio Baltieri
2012-08-01 21:00                       ` Marc Kleine-Budde
2012-08-01 22:38                         ` Fabio Baltieri
2012-08-01 21:05                       ` Oliver Hartkopp
2012-08-24  5:10                       ` Kurt Van Dijck
2012-08-24 11:28                         ` Marc Kleine-Budde
2012-08-24 12:42                           ` Kurt Van Dijck
2012-08-24 22:01                             ` Fabio Baltieri
2012-08-25 20:25                               ` Kurt Van Dijck
2012-09-03 12:40                               ` Marc Kleine-Budde
2012-09-03 18:13                                 ` Kurt Van Dijck
2012-09-03 18:29                                   ` Fabio Baltieri
2012-09-03 20:54                                     ` Oliver Hartkopp
2012-09-04  7:11                                       ` Kurt Van Dijck
2012-09-04  9:29                                         ` [PATCH] can: rename LED trigger name on netdev renames Kurt Van Dijck
2012-09-06 18:59                                           ` Fabio Baltieri [this message]
2012-09-06 19:31                                             ` Oliver Hartkopp
2012-09-06 20:46                                               ` Fabio Baltieri
2012-09-07  7:19                                                 ` Kurt Van Dijck
2012-09-09 16:17                                                   ` [PATCH v2] " Fabio Baltieri
2012-09-10 14:25                                                     ` [PATCH] can: export a safe netdev_priv wrapper for candev Kurt Van Dijck
2012-09-10 18:22                                                       ` Oliver Hartkopp
2012-09-10 18:29                                                       ` Fabio Baltieri
2012-09-10 19:55                                                         ` [PATCH v2] " Kurt Van Dijck
2012-09-10 14:28                                                     ` [PATCH v3] can: rename LED trigger name on netdev renames Kurt Van Dijck
2012-09-10 18:25                                                       ` Oliver Hartkopp
2012-09-10 18:40                                                         ` Fabio Baltieri
2012-09-10 19:01                                                           ` Oliver Hartkopp
2012-09-10 20:08                                                             ` Kurt Van Dijck
2012-09-11  5:42                                                               ` Oliver Hartkopp
2012-09-11  7:13                                                                 ` Fabio Baltieri
2012-09-12  7:22                                                                   ` Kurt Van Dijck
2012-09-11  8:05                                                               ` Kurt Van Dijck
2012-09-10 20:06                                                           ` [PATCH v4] " Kurt Van Dijck
2012-09-11 21:04                                                             ` Fabio Baltieri
2012-09-04 20:15                                         ` [PATCH can-next v6] can: add tx/rx LED trigger support Fabio Baltieri
2012-09-06 10:33                                           ` Kurt Van Dijck
2012-09-06 11:17                                             ` Fabio Baltieri
2012-09-06 15:11                                               ` Kurt Van Dijck
2012-09-06 20:57                                                 ` Fabio Baltieri
2012-09-07  7:04                                                   ` Kurt Van Dijck
2012-09-07 18:59                                                     ` Fabio Baltieri
2012-07-31  8:46 ` [PATCH can-next v3 1/2] " Wolfgang Grandegger
2012-07-31 10:12   ` Marc Kleine-Budde
2012-07-31 11:55     ` Fabio Baltieri
2012-07-31 12:14   ` Fabio Baltieri

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20120906185938.GA4043@gmail.com \
    --to=fabio.baltieri@gmail.com \
    --cc=kurt.van.dijck@eia.be \
    --cc=linux-can@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mkl@pengutronix.de \
    --cc=socketcan@hartkopp.net \
    --cc=wg@grandegger.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).