linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] RDS is not Radio Data System
@ 2018-08-05  6:59 Pavel Machek
  2018-08-05 10:19 ` Sowmini Varadhan
  2018-08-06  3:41 ` santosh.shilimkar
  0 siblings, 2 replies; 5+ messages in thread
From: Pavel Machek @ 2018-08-05  6:59 UTC (permalink / raw)
  To: ka-cheong.poon, santosh.shilimkar, kernel list, Netdev list; +Cc: Netdev list

[-- Attachment #1: Type: text/plain, Size: 861 bytes --]

Hi!

Getting prompt "The RDS Protocol" (RDS) is not too helpful, and it is
easily confused with Radio Data System (which we may want to support
in kernel, too).

I wonder if option should be named NET_RDS, instead?

And this sounds like a good idea:

(Plus, we normally have "module will be called foobar" and if unsure
say X. What happened to those?)

diff --git a/net/rds/Kconfig b/net/rds/Kconfig
index 41f7556..2738f14 100644
--- a/net/rds/Kconfig
+++ b/net/rds/Kconfig
@@ -1,6 +1,6 @@
 
 config RDS
-	tristate "The RDS Protocol"
+	tristate "The Reliable Datagram Sockets (RDS) Protocol"
 	depends on INET
 	---help---
 	  The RDS (Reliable Datagram Sockets) protocol provides reliable,



-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 181 bytes --]

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] RDS is not Radio Data System
  2018-08-05  6:59 [PATCH] RDS is not Radio Data System Pavel Machek
@ 2018-08-05 10:19 ` Sowmini Varadhan
  2018-08-05 10:37   ` Pavel Machek
  2018-08-06  3:41 ` santosh.shilimkar
  1 sibling, 1 reply; 5+ messages in thread
From: Sowmini Varadhan @ 2018-08-05 10:19 UTC (permalink / raw)
  To: Pavel Machek; +Cc: santosh.shilimkar, kernel list, Netdev list

On (08/05/18 08:59), Pavel Machek wrote:
> Getting prompt "The RDS Protocol" (RDS) is not too helpful, and it is
> easily confused with Radio Data System (which we may want to support
> in kernel, too).
> 
> I wonder if option should be named NET_RDS, instead?

RDS has been around for a while now (since 2.6). How will you
rename proposal manage backward compatibility? Why can't you call
your new option CONFIG_RADIO  or similar instead?

Are we going to rename NFS* to NET_NFS* because someone decided
to reuse the NFS acronym? 

> And this sounds like a good idea:
> -	tristate "The RDS Protocol"
> +	tristate "The Reliable Datagram Sockets (RDS) Protocol"

surn that sounds fine.

--Sowmini


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] RDS is not Radio Data System
  2018-08-05 10:19 ` Sowmini Varadhan
@ 2018-08-05 10:37   ` Pavel Machek
  2018-08-05 11:24     ` Sowmini Varadhan
  0 siblings, 1 reply; 5+ messages in thread
From: Pavel Machek @ 2018-08-05 10:37 UTC (permalink / raw)
  To: Sowmini Varadhan, arnd, gthelen, jgg
  Cc: santosh.shilimkar, kernel list, Netdev list

[-- Attachment #1: Type: text/plain, Size: 1306 bytes --]

On Sun 2018-08-05 06:19:45, Sowmini Varadhan wrote:
> On (08/05/18 08:59), Pavel Machek wrote:
> > Getting prompt "The RDS Protocol" (RDS) is not too helpful, and it is
> > easily confused with Radio Data System (which we may want to support
> > in kernel, too).
> > 
> > I wonder if option should be named NET_RDS, instead?
> 
> RDS has been around for a while now (since 2.6). How will you
> rename proposal manage backward compatibility? Why can't you call
> your new option CONFIG_RADIO  or similar instead?
> 
> Are we going to rename NFS* to NET_NFS* because someone decided
> to reuse the NFS acronym? 

Was it?

Because this was first time kernel asked that question... when I was
testing -next. Is this related?

commit 533d1daea8d8a389b37207ad7b50c4e750969231
    IB: Revert "remove redundant INFINIBAND kconfig dependencies"

> > And this sounds like a good idea:
> > -	tristate "The RDS Protocol"
> > +	tristate "The Reliable Datagram Sockets (RDS) Protocol"
> 
> surn that sounds fine.

Can you apply the patch, or do you want me to send it to davem?

Signed-off-by: Pavel Machek <pavel@ucw.cz>

Thanks,
									Pavel
-- 
(english) http://www.livejournal.com/~pavelmachek
(cesky, pictures) http://atrey.karlin.mff.cuni.cz/~pavel/picture/horses/blog.html

[-- Attachment #2: Digital signature --]
[-- Type: application/pgp-signature, Size: 181 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] RDS is not Radio Data System
  2018-08-05 10:37   ` Pavel Machek
@ 2018-08-05 11:24     ` Sowmini Varadhan
  0 siblings, 0 replies; 5+ messages in thread
From: Sowmini Varadhan @ 2018-08-05 11:24 UTC (permalink / raw)
  To: Pavel Machek
  Cc: arnd, gthelen, jgg, santosh.shilimkar, kernel list, Netdev list

On (08/05/18 12:37), Pavel Machek wrote:
> 
> Was it?

RDS was added in 2.6.30: see  https://kernelnewbies.org/Linux_2_6_30

Recent RDS commits may have triggered the observation you note below
(you may have had it disabled by default until now)

> Because this was first time kernel asked that question... when I was
> testing -next. Is this related?

> Can you apply the patch, or do you want me to send it to davem?
> Signed-off-by: Pavel Machek <pavel@ucw.cz>

please feel free to send the patch and add me as

Acked-by: Sowmini Varadhan <sowmini.varadhan@oracle.com>

--Sowmini

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] RDS is not Radio Data System
  2018-08-05  6:59 [PATCH] RDS is not Radio Data System Pavel Machek
  2018-08-05 10:19 ` Sowmini Varadhan
@ 2018-08-06  3:41 ` santosh.shilimkar
  1 sibling, 0 replies; 5+ messages in thread
From: santosh.shilimkar @ 2018-08-06  3:41 UTC (permalink / raw)
  To: Pavel Machek; +Cc: ka-cheong.poon, kernel list, Netdev list

On 8/4/18 11:59 PM, Pavel Machek wrote:
> Hi!
> 
> Getting prompt "The RDS Protocol" (RDS) is not too helpful, and it is
> easily confused with Radio Data System (which we may want to support
> in kernel, too).
>
Fair enough. Prompt change is fine Pavel.

> I wonder if option should be named NET_RDS, instead?
> 
> And this sounds like a good idea:
> 
> (Plus, we normally have "module will be called foobar" and if unsure
> say X. What happened to those?)
>
Module name is there for a while so please use different one if you
have a conflict with it.

> diff --git a/net/rds/Kconfig b/net/rds/Kconfig
> index 41f7556..2738f14 100644
> --- a/net/rds/Kconfig
> +++ b/net/rds/Kconfig
> @@ -1,6 +1,6 @@
>   
>   config RDS
> -	tristate "The RDS Protocol"
> +	tristate "The Reliable Datagram Sockets (RDS) Protocol"
>   	depends on INET
>   	---help---
>   	  The RDS (Reliable Datagram Sockets) protocol provides reliable,
> 
Please git format this patch with your SOB and send it to netdev.
Feel free to add my ack with it.

Acked-by: Santosh Shilimkar <santosh.shilimkar@oracle.com>

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2018-08-06  3:42 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-08-05  6:59 [PATCH] RDS is not Radio Data System Pavel Machek
2018-08-05 10:19 ` Sowmini Varadhan
2018-08-05 10:37   ` Pavel Machek
2018-08-05 11:24     ` Sowmini Varadhan
2018-08-06  3:41 ` santosh.shilimkar

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).