linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH -next] pstore/ram: Undefine the correct macro after a recent renaming
@ 2020-05-21 20:52 Tyler Hicks
  2020-05-21 21:56 ` Kees Cook
  0 siblings, 1 reply; 2+ messages in thread
From: Tyler Hicks @ 2020-05-21 20:52 UTC (permalink / raw)
  To: Kees Cook
  Cc: Anton Vorontsov, Colin Cross, Tony Luck, Pavel Tatashin, linux-kernel

Undefine parse_u32, instead of parse_size, as the name of the macro
recently changed but the #undef directive wasn't updated at that time.

Fixes: 6b31e99b85b0 ("pstore/ram: Refactor DT size parsing")
Signed-off-by: Tyler Hicks <tyhicks@linux.microsoft.com>
---

Hi Kees - Here's a minor fixup that I noticed was needed while reviewing
your for-next/pstore branch. It is only build-tested but I think that's
all that's needed here.

Tyler

 fs/pstore/ram.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/fs/pstore/ram.c b/fs/pstore/ram.c
index df8965817c7b..ca6d8a867285 100644
--- a/fs/pstore/ram.c
+++ b/fs/pstore/ram.c
@@ -674,7 +674,7 @@ static int ramoops_parse_dt(struct platform_device *pdev,
 	parse_u32("flags", pdata->flags, 0);
 	parse_u32("max-reason", pdata->max_reason, pdata->max_reason);
 
-#undef parse_size
+#undef parse_u32
 
 	/*
 	 * Some old Chromebooks relied on the kernel setting the
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH -next] pstore/ram: Undefine the correct macro after a recent renaming
  2020-05-21 20:52 [PATCH -next] pstore/ram: Undefine the correct macro after a recent renaming Tyler Hicks
@ 2020-05-21 21:56 ` Kees Cook
  0 siblings, 0 replies; 2+ messages in thread
From: Kees Cook @ 2020-05-21 21:56 UTC (permalink / raw)
  To: Tyler Hicks
  Cc: Anton Vorontsov, Colin Cross, Tony Luck, Pavel Tatashin, linux-kernel

On Thu, May 21, 2020 at 03:52:23PM -0500, Tyler Hicks wrote:
> Undefine parse_u32, instead of parse_size, as the name of the macro
> recently changed but the #undef directive wasn't updated at that time.
> 
> Fixes: 6b31e99b85b0 ("pstore/ram: Refactor DT size parsing")
> Signed-off-by: Tyler Hicks <tyhicks@linux.microsoft.com>
> ---
> 
> Hi Kees - Here's a minor fixup that I noticed was needed while reviewing
> your for-next/pstore branch. It is only build-tested but I think that's
> all that's needed here.

Whoops! Thanks; applied!

-Kees

> 
> Tyler
> 
>  fs/pstore/ram.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/fs/pstore/ram.c b/fs/pstore/ram.c
> index df8965817c7b..ca6d8a867285 100644
> --- a/fs/pstore/ram.c
> +++ b/fs/pstore/ram.c
> @@ -674,7 +674,7 @@ static int ramoops_parse_dt(struct platform_device *pdev,
>  	parse_u32("flags", pdata->flags, 0);
>  	parse_u32("max-reason", pdata->max_reason, pdata->max_reason);
>  
> -#undef parse_size
> +#undef parse_u32
>  
>  	/*
>  	 * Some old Chromebooks relied on the kernel setting the
> -- 
> 2.25.1
> 

-- 
Kees Cook

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-05-21 21:56 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-21 20:52 [PATCH -next] pstore/ram: Undefine the correct macro after a recent renaming Tyler Hicks
2020-05-21 21:56 ` Kees Cook

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).