linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH net-next 1/2] net: openvswitch: Use struct_size()
@ 2023-10-01 11:07 Christophe JAILLET
  2023-10-01 11:07 ` [PATCH net-next 2/2] net: openvswitch: Annotate struct mask_array with __counted_byUse struct_size() Christophe JAILLET
  0 siblings, 1 reply; 4+ messages in thread
From: Christophe JAILLET @ 2023-10-01 11:07 UTC (permalink / raw)
  To: keescook, Pravin B Shelar, David S. Miller, Eric Dumazet,
	Jakub Kicinski, Paolo Abeni
  Cc: linux-hardening, linux-kernel, kernel-janitors,
	Christophe JAILLET, netdev, dev

Use struct_size() instead of hand writing it.
This is less verbose and more robust.

Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
This is IMHO more readable, even if not perfect.

However (untested):
+	new = kzalloc(size_add(struct_size(new, masks, size),
			       size_mul(sizeof(u64), size)), GFP_KERNEL);

looks completely unreadable to me.
---
 net/openvswitch/flow_table.c | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)

diff --git a/net/openvswitch/flow_table.c b/net/openvswitch/flow_table.c
index 4f3b1798e0b2..d108ae0bd0ee 100644
--- a/net/openvswitch/flow_table.c
+++ b/net/openvswitch/flow_table.c
@@ -220,16 +220,13 @@ static struct mask_array *tbl_mask_array_alloc(int size)
 	struct mask_array *new;
 
 	size = max(MASK_ARRAY_SIZE_MIN, size);
-	new = kzalloc(sizeof(struct mask_array) +
-		      sizeof(struct sw_flow_mask *) * size +
+	new = kzalloc(struct_size(new, masks, size) +
 		      sizeof(u64) * size, GFP_KERNEL);
 	if (!new)
 		return NULL;
 
 	new->masks_usage_zero_cntr = (u64 *)((u8 *)new +
-					     sizeof(struct mask_array) +
-					     sizeof(struct sw_flow_mask *) *
-					     size);
+					     struct_size(new, masks, size));
 
 	new->masks_usage_stats = __alloc_percpu(sizeof(struct mask_array_stats) +
 						sizeof(u64) * size,
-- 
2.34.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* [PATCH net-next 2/2] net: openvswitch: Annotate struct mask_array with __counted_byUse struct_size()
  2023-10-01 11:07 [PATCH net-next 1/2] net: openvswitch: Use struct_size() Christophe JAILLET
@ 2023-10-01 11:07 ` Christophe JAILLET
  2023-10-02 16:51   ` [ovs-dev] " Ilya Maximets
  0 siblings, 1 reply; 4+ messages in thread
From: Christophe JAILLET @ 2023-10-01 11:07 UTC (permalink / raw)
  To: keescook, Pravin B Shelar, David S. Miller, Eric Dumazet,
	Jakub Kicinski, Paolo Abeni, Gustavo A. R. Silva,
	Nathan Chancellor, Nick Desaulniers, Tom Rix
  Cc: linux-hardening, linux-kernel, kernel-janitors,
	Christophe JAILLET, netdev, dev, llvm

Prepare for the coming implementation by GCC and Clang of the __counted_by
attribute. Flexible array members annotated with __counted_by can have
their accesses bounds-checked at run-time checking via CONFIG_UBSAN_BOUNDS
(for array indexing) and CONFIG_FORTIFY_SOURCE (for strcpy/memcpy-family
functions).

Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
This patch is part of a work done in parallel of what is currently worked
on by Kees Cook.

My patches are only related to corner cases that do NOT match the
semantic of his Coccinelle script[1].

In this case, in tbl_mask_array_alloc(), several things are allocated with
a single allocation. Then, some pointer arithmetic computes the address of
the memory after the flex-array.

[1] https://github.com/kees/kernel-tools/blob/trunk/coccinelle/examples/counted_by.cocci
---
 net/openvswitch/flow_table.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/openvswitch/flow_table.h b/net/openvswitch/flow_table.h
index 9e659db78c05..8d9e83b4d62c 100644
--- a/net/openvswitch/flow_table.h
+++ b/net/openvswitch/flow_table.h
@@ -48,7 +48,7 @@ struct mask_array {
 	int count, max;
 	struct mask_array_stats __percpu *masks_usage_stats;
 	u64 *masks_usage_zero_cntr;
-	struct sw_flow_mask __rcu *masks[];
+	struct sw_flow_mask __rcu *masks[] __counted_by(size);
 };
 
 struct table_instance {
-- 
2.34.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [ovs-dev] [PATCH net-next 2/2] net: openvswitch: Annotate struct mask_array with __counted_byUse struct_size()
  2023-10-01 11:07 ` [PATCH net-next 2/2] net: openvswitch: Annotate struct mask_array with __counted_byUse struct_size() Christophe JAILLET
@ 2023-10-02 16:51   ` Ilya Maximets
  2023-10-10  5:27     ` Christophe JAILLET
  0 siblings, 1 reply; 4+ messages in thread
From: Ilya Maximets @ 2023-10-02 16:51 UTC (permalink / raw)
  To: Christophe JAILLET, keescook, Pravin B Shelar, David S. Miller,
	Eric Dumazet, Jakub Kicinski, Paolo Abeni, Gustavo A. R. Silva,
	Nathan Chancellor, Nick Desaulniers, Tom Rix
  Cc: dev, netdev, llvm, kernel-janitors, linux-kernel,
	linux-hardening, i.maximets

On 10/1/23 13:07, Christophe JAILLET wrote:
> Prepare for the coming implementation by GCC and Clang of the __counted_by
> attribute. Flexible array members annotated with __counted_by can have
> their accesses bounds-checked at run-time checking via CONFIG_UBSAN_BOUNDS
> (for array indexing) and CONFIG_FORTIFY_SOURCE (for strcpy/memcpy-family
> functions).
> 
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> ---
> This patch is part of a work done in parallel of what is currently worked
> on by Kees Cook.
> 
> My patches are only related to corner cases that do NOT match the
> semantic of his Coccinelle script[1].
> 
> In this case, in tbl_mask_array_alloc(), several things are allocated with
> a single allocation. Then, some pointer arithmetic computes the address of
> the memory after the flex-array.
> 
> [1] https://github.com/kees/kernel-tools/blob/trunk/coccinelle/examples/counted_by.cocci
> ---
>  net/openvswitch/flow_table.h | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/net/openvswitch/flow_table.h b/net/openvswitch/flow_table.h
> index 9e659db78c05..8d9e83b4d62c 100644
> --- a/net/openvswitch/flow_table.h
> +++ b/net/openvswitch/flow_table.h
> @@ -48,7 +48,7 @@ struct mask_array {
>  	int count, max;
>  	struct mask_array_stats __percpu *masks_usage_stats;
>  	u64 *masks_usage_zero_cntr;
> -	struct sw_flow_mask __rcu *masks[];
> +	struct sw_flow_mask __rcu *masks[] __counted_by(size);

Did you mean 'max'?  There is no 'size' in the structure.

Also, the patch subject is messed up a bit.

Best regards, Ilya Maximets.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [ovs-dev] [PATCH net-next 2/2] net: openvswitch: Annotate struct mask_array with __counted_byUse struct_size()
  2023-10-02 16:51   ` [ovs-dev] " Ilya Maximets
@ 2023-10-10  5:27     ` Christophe JAILLET
  0 siblings, 0 replies; 4+ messages in thread
From: Christophe JAILLET @ 2023-10-10  5:27 UTC (permalink / raw)
  To: Ilya Maximets, keescook, Pravin B Shelar, David S. Miller,
	Eric Dumazet, Jakub Kicinski, Paolo Abeni, Gustavo A. R. Silva,
	Nathan Chancellor, Nick Desaulniers, Tom Rix
  Cc: dev, netdev, llvm, kernel-janitors, linux-kernel, linux-hardening

Le 02/10/2023 à 18:51, Ilya Maximets a écrit :
> On 10/1/23 13:07, Christophe JAILLET wrote:
>> Prepare for the coming implementation by GCC and Clang of the __counted_by
>> attribute. Flexible array members annotated with __counted_by can have
>> their accesses bounds-checked at run-time checking via CONFIG_UBSAN_BOUNDS
>> (for array indexing) and CONFIG_FORTIFY_SOURCE (for strcpy/memcpy-family
>> functions).
>>
>> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
>> ---
>> This patch is part of a work done in parallel of what is currently worked
>> on by Kees Cook.
>>
>> My patches are only related to corner cases that do NOT match the
>> semantic of his Coccinelle script[1].
>>
>> In this case, in tbl_mask_array_alloc(), several things are allocated with
>> a single allocation. Then, some pointer arithmetic computes the address of
>> the memory after the flex-array.
>>
>> [1] https://github.com/kees/kernel-tools/blob/trunk/coccinelle/examples/counted_by.cocci
>> ---
>>   net/openvswitch/flow_table.h | 2 +-
>>   1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/net/openvswitch/flow_table.h b/net/openvswitch/flow_table.h
>> index 9e659db78c05..8d9e83b4d62c 100644
>> --- a/net/openvswitch/flow_table.h
>> +++ b/net/openvswitch/flow_table.h
>> @@ -48,7 +48,7 @@ struct mask_array {
>>   	int count, max;
>>   	struct mask_array_stats __percpu *masks_usage_stats;
>>   	u64 *masks_usage_zero_cntr;
>> -	struct sw_flow_mask __rcu *masks[];
>> +	struct sw_flow_mask __rcu *masks[] __counted_by(size);
> 
> Did you mean 'max'?  There is no 'size' in the structure.

Hi,

Of courtse, yes. I'll resend.

'size' is the name of the variable that is written in mask_array->max in 
tbl_mask_array_alloc()

> 
> Also, the patch subject is messed up a bit.

Yes.
Will fix it as well.

CJ

> 
> Best regards, Ilya Maximets.
> 


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2023-10-10  5:28 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-10-01 11:07 [PATCH net-next 1/2] net: openvswitch: Use struct_size() Christophe JAILLET
2023-10-01 11:07 ` [PATCH net-next 2/2] net: openvswitch: Annotate struct mask_array with __counted_byUse struct_size() Christophe JAILLET
2023-10-02 16:51   ` [ovs-dev] " Ilya Maximets
2023-10-10  5:27     ` Christophe JAILLET

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).