linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* Re: [v2] coccinelle: semantic code search for missing of_node_put
       [not found] <201907041103003504524@zte.com.cn>
@ 2019-07-04  6:28 ` Markus Elfring
  2019-07-05  5:29 ` [PATCH v2] coccinelle: semantic code search for missingof_node_put Julia Lawall
  1 sibling, 0 replies; 2+ messages in thread
From: Markus Elfring @ 2019-07-04  6:28 UTC (permalink / raw)
  To: Wen Yang, Julia Lawall
  Cc: Yi Wang, Gilles Muller, Nicolas Palix, Michal Marek,
	Masahiro Yamada, cocci, linux-kernel

> We tested and found that both <...x...> and <+... x ...+> variants work fine.

Is the difference in the functionality from this SmPL construct clear already?


> We use <... x ...> instead of <+... x ...+> here to eliminate the following false positives:

Do we stumble on another software design challenge?

For which function parameter will the specified variable be required finally?


> 486 asd = v4l2_async_notifier_add_fwnode_subdev(
> 487 &camss->notifier, of_fwnode_handle(remote), ---> v4l2_async_notifier_add_fwnode_subdev will pass remote to camss->notifier.
> 488 sizeof(*csd));

Should any more special cases be taken better into account?

Regards,
Markus

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH v2] coccinelle: semantic code search for missingof_node_put
       [not found] <201907041103003504524@zte.com.cn>
  2019-07-04  6:28 ` [v2] coccinelle: semantic code search for missing of_node_put Markus Elfring
@ 2019-07-05  5:29 ` Julia Lawall
  1 sibling, 0 replies; 2+ messages in thread
From: Julia Lawall @ 2019-07-05  5:29 UTC (permalink / raw)
  To: wen.yang99
  Cc: Markus.Elfring, linux-kernel, wang.yi59, Gilles Muller,
	nicolas.palix, michal.lkml, yamada.masahiro, cocci

[-- Attachment #1: Type: text/plain, Size: 2124 bytes --]



On Thu, 4 Jul 2019, wen.yang99@zte.com.cn wrote:

> > > > +x = @p1\(of_find_all_nodes\|
> > >
> > > I would find this SmPL disjunction easier to read without the usage
> > > of extra backslashes.
> > >
> > > +x =
> > > +(of_…
> > > +|of_…
> > > +)@p1(...);
> >
> > Did you actually test this?  I doubt that a position metavariable can be
> > put on a ) of a disjunction.
> >
> > > > +|
> > > > +return x;
> > > > +|
> > > > +return of_fwnode_handle(x);
> > >
> > > Can a nested SmPL disjunction be helpful at such places?
> > >
> > > +|return
> > > +(x
> > > +|of_fwnode_handle(x)
> > > +);
> >
> > The original code is much more readable.  The internal representation will
> > be the same.
> >
> > > > +    when != v4l2_async_notifier_add_fwnode_subdev(<...x...>)
> > >
> > > Would the specification variant “<+... x ...+>” be relevant
> > > for the parameter selection?
> >
> > I'm indeed quite surprised that <...x...> would be accepted by the parser..
>
> Hi julia,
>
> Thank you for your comments.
> We tested and found that both <...x...> and <+... x ...+> variants work fine.
> We use <... x ...> instead of <+... x ...+> here to eliminate the following false positives:
>
> ./drivers/media/platform/qcom/camss/camss.c:504:1-7: ERROR: missing of_node_put; acquired a node pointer with refcount incremented on line 479, but without a corresponding object release within this function.
>
> 465 static int camss_of_parse_ports(struct camss *camss)
> 466 {
> ...
> 479 remote = of_graph_get_remote_port_parent(node);
> ...
> 486 asd = v4l2_async_notifier_add_fwnode_subdev(
> 487 &camss->notifier, of_fwnode_handle(remote), ---> v4l2_async_notifier_add_fwnode_subdev will pass remote to camss->notifier.
> 488 sizeof(*csd));
> ...
> 504 return num_subdevs;

I suspect that what is happening is that there is a runtime error, but
that error is caught somewhere and you don't see it.  Could you send me
again the entire semantic patch so I can check on this?

I think that what you want is:

when != v4l2_async_notifier_add_fwnode_subdev(...,<+...x...+>,...)

ie x occurring somewhere within some argument.

julia

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2019-07-05  5:29 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <201907041103003504524@zte.com.cn>
2019-07-04  6:28 ` [v2] coccinelle: semantic code search for missing of_node_put Markus Elfring
2019-07-05  5:29 ` [PATCH v2] coccinelle: semantic code search for missingof_node_put Julia Lawall

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).