All of lore.kernel.org
 help / color / mirror / Atom feed
From: Sascha Hauer <s.hauer@pengutronix.de>
To: linux-pm@vger.kernel.org
Cc: Zhang Rui <rui.zhang@intel.com>,
	Eduardo Valentin <edubezval@gmail.com>,
	linux-kernel@vger.kernel.org,
	Stephen Warren <swarren@wwwdotorg.org>,
	Mikko Perttunen <mikko.perttunen@kapsi.fi>,
	kernel@pengutronix.de, linux-mediatek@lists.infradead.org,
	linux-arm-kernel@lists.infradead.org,
	Brian Norris <computersforpeace@gmail.com>,
	Sascha Hauer <s.hauer@pengutronix.de>
Subject: [PATCH 04/16] thermal: Use IS_ENABLED instead of #ifdef
Date: Wed, 20 May 2015 15:20:34 +0200	[thread overview]
Message-ID: <1432128046-12921-5-git-send-email-s.hauer@pengutronix.de> (raw)
In-Reply-To: <1432128046-12921-1-git-send-email-s.hauer@pengutronix.de>

Use IS_ENABLED(CONFIG_THERMAL_EMULATION) to make the code more readable
and to get rid of the addtional #ifdef around the variable definitions
in thermal_zone_get_temp().

Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
---
 drivers/thermal/thermal_core.c | 45 ++++++++++++++++++------------------------
 1 file changed, 19 insertions(+), 26 deletions(-)

diff --git a/drivers/thermal/thermal_core.c b/drivers/thermal/thermal_core.c
index 1b68d20..3e0fe55 100644
--- a/drivers/thermal/thermal_core.c
+++ b/drivers/thermal/thermal_core.c
@@ -414,11 +414,9 @@ static void handle_thermal_trip(struct thermal_zone_device *tz, int trip)
 int thermal_zone_get_temp(struct thermal_zone_device *tz, int *temp)
 {
 	int ret = -EINVAL;
-#ifdef CONFIG_THERMAL_EMULATION
 	int count;
 	int crit_temp = INT_MAX;
 	enum thermal_trip_type type;
-#endif
 
 	if (!tz || IS_ERR(tz) || !tz->ops->get_temp)
 		goto exit;
@@ -426,25 +424,21 @@ int thermal_zone_get_temp(struct thermal_zone_device *tz, int *temp)
 	mutex_lock(&tz->lock);
 
 	ret = tz->ops->get_temp(tz, temp);
-#ifdef CONFIG_THERMAL_EMULATION
-	if (!tz->emul_temperature)
-		goto skip_emul;
-
-	for (count = 0; count < tz->trips; count++) {
-		ret = tz->ops->get_trip_type(tz, count, &type);
-		if (!ret && type == THERMAL_TRIP_CRITICAL) {
-			ret = tz->ops->get_trip_temp(tz, count, &crit_temp);
-			break;
-		}
-	}
 
-	if (ret)
-		goto skip_emul;
+	if (IS_ENABLED(CONFIG_THERMAL_EMULATION) && tz->emul_temperature) {
+		for (count = 0; count < tz->trips; count++) {
+			ret = tz->ops->get_trip_type(tz, count, &type);
+			if (!ret && type == THERMAL_TRIP_CRITICAL) {
+				ret = tz->ops->get_trip_temp(tz, count,
+						&crit_temp);
+				break;
+			}
+		}
 
-	if (*temp < crit_temp)
-		*temp = tz->emul_temperature;
-skip_emul:
-#endif
+		if (!ret && *temp < crit_temp)
+			*temp = tz->emul_temperature;
+	}
+ 
 	mutex_unlock(&tz->lock);
 exit:
 	return ret;
@@ -780,7 +774,6 @@ policy_show(struct device *dev, struct device_attribute *devattr, char *buf)
 	return sprintf(buf, "%s\n", tz->governor->name);
 }
 
-#ifdef CONFIG_THERMAL_EMULATION
 static ssize_t
 emul_temp_store(struct device *dev, struct device_attribute *attr,
 		     const char *buf, size_t count)
@@ -806,7 +799,6 @@ emul_temp_store(struct device *dev, struct device_attribute *attr,
 	return ret ? ret : count;
 }
 static DEVICE_ATTR(emul_temp, S_IWUSR, NULL, emul_temp_store);
-#endif/*CONFIG_THERMAL_EMULATION*/
 
 static DEVICE_ATTR(type, 0444, type_show, NULL);
 static DEVICE_ATTR(temp, 0444, temp_show, NULL);
@@ -1536,11 +1528,12 @@ struct thermal_zone_device *thermal_zone_device_register(const char *type,
 			goto unregister;
 	}
 
-#ifdef CONFIG_THERMAL_EMULATION
-	result = device_create_file(&tz->device, &dev_attr_emul_temp);
-	if (result)
-		goto unregister;
-#endif
+	if (IS_ENABLED(CONFIG_THERMAL_EMULATION)) {
+		result = device_create_file(&tz->device, &dev_attr_emul_temp);
+		if (result)
+			goto unregister;
+	}
+
 	/* Create policy attribute */
 	result = device_create_file(&tz->device, &dev_attr_policy);
 	if (result)
-- 
2.1.4


WARNING: multiple messages have this Message-ID (diff)
From: s.hauer@pengutronix.de (Sascha Hauer)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH 04/16] thermal: Use IS_ENABLED instead of #ifdef
Date: Wed, 20 May 2015 15:20:34 +0200	[thread overview]
Message-ID: <1432128046-12921-5-git-send-email-s.hauer@pengutronix.de> (raw)
In-Reply-To: <1432128046-12921-1-git-send-email-s.hauer@pengutronix.de>

Use IS_ENABLED(CONFIG_THERMAL_EMULATION) to make the code more readable
and to get rid of the addtional #ifdef around the variable definitions
in thermal_zone_get_temp().

Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
---
 drivers/thermal/thermal_core.c | 45 ++++++++++++++++++------------------------
 1 file changed, 19 insertions(+), 26 deletions(-)

diff --git a/drivers/thermal/thermal_core.c b/drivers/thermal/thermal_core.c
index 1b68d20..3e0fe55 100644
--- a/drivers/thermal/thermal_core.c
+++ b/drivers/thermal/thermal_core.c
@@ -414,11 +414,9 @@ static void handle_thermal_trip(struct thermal_zone_device *tz, int trip)
 int thermal_zone_get_temp(struct thermal_zone_device *tz, int *temp)
 {
 	int ret = -EINVAL;
-#ifdef CONFIG_THERMAL_EMULATION
 	int count;
 	int crit_temp = INT_MAX;
 	enum thermal_trip_type type;
-#endif
 
 	if (!tz || IS_ERR(tz) || !tz->ops->get_temp)
 		goto exit;
@@ -426,25 +424,21 @@ int thermal_zone_get_temp(struct thermal_zone_device *tz, int *temp)
 	mutex_lock(&tz->lock);
 
 	ret = tz->ops->get_temp(tz, temp);
-#ifdef CONFIG_THERMAL_EMULATION
-	if (!tz->emul_temperature)
-		goto skip_emul;
-
-	for (count = 0; count < tz->trips; count++) {
-		ret = tz->ops->get_trip_type(tz, count, &type);
-		if (!ret && type == THERMAL_TRIP_CRITICAL) {
-			ret = tz->ops->get_trip_temp(tz, count, &crit_temp);
-			break;
-		}
-	}
 
-	if (ret)
-		goto skip_emul;
+	if (IS_ENABLED(CONFIG_THERMAL_EMULATION) && tz->emul_temperature) {
+		for (count = 0; count < tz->trips; count++) {
+			ret = tz->ops->get_trip_type(tz, count, &type);
+			if (!ret && type == THERMAL_TRIP_CRITICAL) {
+				ret = tz->ops->get_trip_temp(tz, count,
+						&crit_temp);
+				break;
+			}
+		}
 
-	if (*temp < crit_temp)
-		*temp = tz->emul_temperature;
-skip_emul:
-#endif
+		if (!ret && *temp < crit_temp)
+			*temp = tz->emul_temperature;
+	}
+ 
 	mutex_unlock(&tz->lock);
 exit:
 	return ret;
@@ -780,7 +774,6 @@ policy_show(struct device *dev, struct device_attribute *devattr, char *buf)
 	return sprintf(buf, "%s\n", tz->governor->name);
 }
 
-#ifdef CONFIG_THERMAL_EMULATION
 static ssize_t
 emul_temp_store(struct device *dev, struct device_attribute *attr,
 		     const char *buf, size_t count)
@@ -806,7 +799,6 @@ emul_temp_store(struct device *dev, struct device_attribute *attr,
 	return ret ? ret : count;
 }
 static DEVICE_ATTR(emul_temp, S_IWUSR, NULL, emul_temp_store);
-#endif/*CONFIG_THERMAL_EMULATION*/
 
 static DEVICE_ATTR(type, 0444, type_show, NULL);
 static DEVICE_ATTR(temp, 0444, temp_show, NULL);
@@ -1536,11 +1528,12 @@ struct thermal_zone_device *thermal_zone_device_register(const char *type,
 			goto unregister;
 	}
 
-#ifdef CONFIG_THERMAL_EMULATION
-	result = device_create_file(&tz->device, &dev_attr_emul_temp);
-	if (result)
-		goto unregister;
-#endif
+	if (IS_ENABLED(CONFIG_THERMAL_EMULATION)) {
+		result = device_create_file(&tz->device, &dev_attr_emul_temp);
+		if (result)
+			goto unregister;
+	}
+
 	/* Create policy attribute */
 	result = device_create_file(&tz->device, &dev_attr_policy);
 	if (result)
-- 
2.1.4

  parent reply	other threads:[~2015-05-20 13:23 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-05-20 13:20 [PATCH v4] Thermal cleanups and hardware trip points Sascha Hauer
2015-05-20 13:20 ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 01/16] thermal: consistently use int for temperatures Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 02/16] thermal: trivial: fix typo in comment Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 03/16] thermal: remove useless call to thermal_zone_device_set_polling Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` Sascha Hauer [this message]
2015-05-20 13:20   ` [PATCH 04/16] thermal: Use IS_ENABLED instead of #ifdef Sascha Hauer
2015-05-20 13:20 ` [PATCH 05/16] thermal: Add comment explaining test for critical temperature Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 06/16] thermal: inline only once used function Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 07/16] thermal: streamline get_trend callbacks Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 08/16] thermal: Allow sensor ops to fail with -ENOSYS Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 09/16] thermal: of: always set sensor related callbacks Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 10/16] thermal: Make struct thermal_zone_device_ops const Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 11/16] thermal: bang-bang governor: act on lower trip boundary Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 12/16] thermal: thermal: Add support for hardware-tracked trip points Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 13/16] thermal: of: implement .set_trips for device tree thermal zones Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 14/16] dt-bindings: thermal: Add binding document for Mediatek thermal controller Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 15/16] thermal: Add Mediatek thermal controller support Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-05-20 13:20 ` [PATCH 16/16] ARM64: dts: mt8173: Add thermal/auxadc device nodes Sascha Hauer
2015-05-20 13:20   ` Sascha Hauer
2015-06-08  6:56 ` [PATCH v4] Thermal cleanups and hardware trip points Sascha Hauer
2015-06-08  6:56   ` Sascha Hauer
2015-06-22  6:38   ` Sascha Hauer
2015-06-22  6:38     ` Sascha Hauer
2015-06-22  6:38     ` Sascha Hauer

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1432128046-12921-5-git-send-email-s.hauer@pengutronix.de \
    --to=s.hauer@pengutronix.de \
    --cc=computersforpeace@gmail.com \
    --cc=edubezval@gmail.com \
    --cc=kernel@pengutronix.de \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=mikko.perttunen@kapsi.fi \
    --cc=rui.zhang@intel.com \
    --cc=swarren@wwwdotorg.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.