All of lore.kernel.org
 help / color / mirror / Atom feed
From: Byungchul Park <byungchul.park@lge.com>
To: peterz@infradead.org, mingo@kernel.org, axboe@kernel.dk
Cc: johan@kernel.org, tglx@linutronix.de,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org, tj@kernel.org,
	johannes.berg@intel.com, oleg@redhat.com, amir73il@gmail.com,
	david@fromorbit.com, darrick.wong@oracle.com,
	linux-xfs@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	linux-block@vger.kernel.org, hch@infradead.org,
	idryomov@gmail.com, kernel-team@lge.com
Subject: [PATCH v5 0/9] cross-release: Enhence performance and fix false positives
Date: Wed, 25 Oct 2017 17:55:56 +0900	[thread overview]
Message-ID: <1508921765-15396-1-git-send-email-byungchul.park@lge.com> (raw)

Changes from v4
- Use a prefix "(completion)" instead of "(complete)" for completions
- Use a prefix "(wq_completion)" instead of "(complete)" for workqueue's map
- Use a prefix "(work_completion)" instead of "(complete)" for work's map
- Use a prefix "(gendisk_completion)" instead of "(complete)" for gendisk's map
- Provide empty lockdep_map structure for !CONFIG_LOCKDEP
- Remove #ifdef in this series as much as possible
- Use canocical variable names in all_disk_node() macro

Changes from v3
- Exclude a patch removing white space
- Enhance commit messages as Ingo suggested
- Re-design patches adding a boot param and a Kconfig allowing unwind
- Simplify a patch assigning lock classes to genhds as Ingo suggested
- Add proper tags in commit messages e.g. reported-by and analyzed-by

Changes from v2
- Combine 2 serises, fixing false positives and enhance performance
- Add Christoph Hellwig's patch simplifying submit_bio_wait() code
- Add 2 more 'init with lockdep map' macros for completionm
- Rename init_completion_with_map() to init_completion_map()

Changes from v1
- Fix kconfig description as Ingo suggested
- Fix commit message writing out CONFIG_ variable
- Introduce a new kernel parameter, crossrelease_fullstack
- Replace the number with the output of *perf*
- Separate a patch removing white space

Byungchul Park (8):
  locking/lockdep: Provide empty lockdep_map structure for
    !CONFIG_LOCKDEP
  completion: Change the prefix of lock name for completion variable
  locking/lockdep: Add a boot parameter allowing unwind in cross-release
    and disable it by default
  locking/lockdep: Remove the BROKEN flag from
    CONFIG_LOCKDEP_CROSSRELEASE and CONFIG_LOCKDEP_COMPLETIONS
  locking/lockdep: Introduce
    CONFIG_BOOTPARAM_LOCKDEP_CROSSRELEASE_FULLSTACK
  completion: Add support for initializing completion with lockdep_map
  workqueue: Remove unnecessary acquisitions wrt workqueue flush
  block: Assign a lock_class per gendisk used for wait_for_completion()

Christoph Hellwig (1):
  block: use DECLARE_COMPLETION_ONSTACK in submit_bio_wait

 Documentation/admin-guide/kernel-parameters.txt |  3 +++
 block/bio.c                                     | 19 +++++--------------
 block/genhd.c                                   | 10 ++--------
 include/linux/completion.h                      | 18 ++++++++++++++++--
 include/linux/genhd.h                           | 22 ++++++++++++++++++++--
 include/linux/lockdep.h                         |  5 +++++
 include/linux/workqueue.h                       |  4 ++--
 kernel/locking/lockdep.c                        | 23 +++++++++++++++++++++--
 kernel/workqueue.c                              | 19 +++----------------
 lib/Kconfig.debug                               | 19 +++++++++++++++++--
 10 files changed, 94 insertions(+), 48 deletions(-)

-- 
1.9.1

WARNING: multiple messages have this Message-ID (diff)
From: Byungchul Park <byungchul.park@lge.com>
To: peterz@infradead.org, mingo@kernel.org, axboe@kernel.dk
Cc: johan@kernel.org, tglx@linutronix.de,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org, tj@kernel.org,
	johannes.berg@intel.com, oleg@redhat.com, amir73il@gmail.com,
	david@fromorbit.com, darrick.wong@oracle.com,
	linux-xfs@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	linux-block@vger.kernel.org, hch@infradead.org,
	idryomov@gmail.com, kernel-team@lge.com
Subject: [PATCH v5 0/9] cross-release: Enhence performance and fix false positives
Date: Wed, 25 Oct 2017 17:55:56 +0900	[thread overview]
Message-ID: <1508921765-15396-1-git-send-email-byungchul.park@lge.com> (raw)

Changes from v4
- Use a prefix "(completion)" instead of "(complete)" for completions
- Use a prefix "(wq_completion)" instead of "(complete)" for workqueue's map
- Use a prefix "(work_completion)" instead of "(complete)" for work's map
- Use a prefix "(gendisk_completion)" instead of "(complete)" for gendisk's map
- Provide empty lockdep_map structure for !CONFIG_LOCKDEP
- Remove #ifdef in this series as much as possible
- Use canocical variable names in all_disk_node() macro

Changes from v3
- Exclude a patch removing white space
- Enhance commit messages as Ingo suggested
- Re-design patches adding a boot param and a Kconfig allowing unwind
- Simplify a patch assigning lock classes to genhds as Ingo suggested
- Add proper tags in commit messages e.g. reported-by and analyzed-by

Changes from v2
- Combine 2 serises, fixing false positives and enhance performance
- Add Christoph Hellwig's patch simplifying submit_bio_wait() code
- Add 2 more 'init with lockdep map' macros for completionm
- Rename init_completion_with_map() to init_completion_map()

Changes from v1
- Fix kconfig description as Ingo suggested
- Fix commit message writing out CONFIG_ variable
- Introduce a new kernel parameter, crossrelease_fullstack
- Replace the number with the output of *perf*
- Separate a patch removing white space

Byungchul Park (8):
  locking/lockdep: Provide empty lockdep_map structure for
    !CONFIG_LOCKDEP
  completion: Change the prefix of lock name for completion variable
  locking/lockdep: Add a boot parameter allowing unwind in cross-release
    and disable it by default
  locking/lockdep: Remove the BROKEN flag from
    CONFIG_LOCKDEP_CROSSRELEASE and CONFIG_LOCKDEP_COMPLETIONS
  locking/lockdep: Introduce
    CONFIG_BOOTPARAM_LOCKDEP_CROSSRELEASE_FULLSTACK
  completion: Add support for initializing completion with lockdep_map
  workqueue: Remove unnecessary acquisitions wrt workqueue flush
  block: Assign a lock_class per gendisk used for wait_for_completion()

Christoph Hellwig (1):
  block: use DECLARE_COMPLETION_ONSTACK in submit_bio_wait

 Documentation/admin-guide/kernel-parameters.txt |  3 +++
 block/bio.c                                     | 19 +++++--------------
 block/genhd.c                                   | 10 ++--------
 include/linux/completion.h                      | 18 ++++++++++++++++--
 include/linux/genhd.h                           | 22 ++++++++++++++++++++--
 include/linux/lockdep.h                         |  5 +++++
 include/linux/workqueue.h                       |  4 ++--
 kernel/locking/lockdep.c                        | 23 +++++++++++++++++++++--
 kernel/workqueue.c                              | 19 +++----------------
 lib/Kconfig.debug                               | 19 +++++++++++++++++--
 10 files changed, 94 insertions(+), 48 deletions(-)

-- 
1.9.1

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>

             reply	other threads:[~2017-10-25  8:55 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-10-25  8:55 Byungchul Park [this message]
2017-10-25  8:55 ` [PATCH v5 0/9] cross-release: Enhence performance and fix false positives Byungchul Park
2017-10-25  8:55 ` [PATCH v5 1/9] block: use DECLARE_COMPLETION_ONSTACK in submit_bio_wait Byungchul Park
2017-10-25  8:55   ` Byungchul Park
2017-10-25 11:10   ` [tip:locking/core] block: Use DECLARE_COMPLETION_ONSTACK() in submit_bio_wait() tip-bot for Christoph Hellwig
2017-10-25  8:55 ` [PATCH v5 2/9] locking/lockdep: Provide empty lockdep_map structure for !CONFIG_LOCKDEP Byungchul Park
2017-10-25  8:55   ` Byungchul Park
2017-10-25 11:11   ` [tip:locking/core] " tip-bot for Byungchul Park
2017-10-25  8:55 ` [PATCH v5 3/9] completion: Change the prefix of lock name for completion variable Byungchul Park
2017-10-25  8:55   ` Byungchul Park
2017-10-25 11:11   ` [tip:locking/core] locking/lockdep, sched/completions: Change the prefix of lock name for completion variables tip-bot for Byungchul Park
2017-10-25  8:56 ` [PATCH v5 4/9] locking/lockdep: Add a boot parameter allowing unwind in cross-release and disable it by default Byungchul Park
2017-10-25  8:56   ` Byungchul Park
2017-10-25 11:11   ` [tip:locking/core] " tip-bot for Byungchul Park
2017-10-25  8:56 ` [PATCH v5 5/9] locking/lockdep: Remove the BROKEN flag from CONFIG_LOCKDEP_CROSSRELEASE and CONFIG_LOCKDEP_COMPLETIONS Byungchul Park
2017-10-25  8:56   ` Byungchul Park
2017-10-25 11:12   ` [tip:locking/core] " tip-bot for Byungchul Park
2017-10-25  8:56 ` [PATCH v5 6/9] locking/lockdep: Introduce CONFIG_BOOTPARAM_LOCKDEP_CROSSRELEASE_FULLSTACK Byungchul Park
2017-10-25  8:56   ` Byungchul Park
2017-10-25 11:12   ` [tip:locking/core] locking/lockdep: Introduce CONFIG_BOOTPARAM_LOCKDEP_CROSSRELEASE_FULLSTACK=y tip-bot for Byungchul Park
2017-10-25  8:56 ` [PATCH v5 7/9] completion: Add support for initializing completion with lockdep_map Byungchul Park
2017-10-25  8:56   ` Byungchul Park
2017-10-25 11:12   ` [tip:locking/core] sched/completions: Add support for initializing completions " tip-bot for Byungchul Park
2017-10-25  8:56 ` [PATCH v5 8/9] workqueue: Remove unnecessary acquisitions wrt workqueue flush Byungchul Park
2017-10-25  8:56   ` Byungchul Park
2017-10-25 11:13   ` [tip:locking/core] workqueue: Remove now redundant lock acquisitions wrt. workqueue flushes tip-bot for Byungchul Park
2017-10-25  8:56 ` [PATCH v5 9/9] block: Assign a lock_class per gendisk used for wait_for_completion() Byungchul Park
2017-10-25  8:56   ` Byungchul Park
2017-10-25 10:13   ` Ingo Molnar
2017-10-25 10:13     ` Ingo Molnar
2017-10-25 10:13     ` Ingo Molnar
2017-10-25 10:13     ` Ingo Molnar
2017-10-25 18:20     ` Jens Axboe
2017-10-25 18:20       ` Jens Axboe
2017-10-26  5:50       ` Ingo Molnar
2017-10-26  5:50         ` Ingo Molnar
2017-10-26  5:58         ` Byungchul Park
2017-10-26  5:58           ` Byungchul Park
2017-10-26  9:31   ` [tip:locking/core] block, locking/lockdep: " tip-bot for Byungchul Park

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1508921765-15396-1-git-send-email-byungchul.park@lge.com \
    --to=byungchul.park@lge.com \
    --cc=amir73il@gmail.com \
    --cc=axboe@kernel.dk \
    --cc=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=hch@infradead.org \
    --cc=idryomov@gmail.com \
    --cc=johan@kernel.org \
    --cc=johannes.berg@intel.com \
    --cc=kernel-team@lge.com \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=mingo@kernel.org \
    --cc=oleg@redhat.com \
    --cc=peterz@infradead.org \
    --cc=tglx@linutronix.de \
    --cc=tj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.