All of lore.kernel.org
 help / color / mirror / Atom feed
From: Gene Chen <gene.chen.richtek@gmail.com>
To: lee.jones@linaro.org, matthias.bgg@gmail.com
Cc: linux-arm-kernel@lists.infradead.org,
	linux-mediatek@lists.infradead.org, linux-kernel@vger.kernel.org,
	gene_chen@richtek.com, Wilma.Wu@mediatek.com,
	shufan_lee@richtek.com, cy_huang@richtek.com,
	benjamin.chao@mediatek.com
Subject: [PATCH v5 0/10] mfd: mt6360: Merge different sub-devices I2C read/write
Date: Tue, 22 Sep 2020 18:20:08 +0800	[thread overview]
Message-ID: <1600770019-11585-1-git-send-email-gene.chen.richtek@gmail.com> (raw)

This patch series merge different sub-device I2C read/write into one Regmap and
fix coding style for well-organized.

Gene Chen (10)
  mfd: mt6360: Rearrange include file
  mfd: mt6360: Remove redundant brackets around raw numbers
  mfd: mt6360: Indicate sub-dev compatible name by using
  mfd: mt6360: Combine mt6360 pmic/ldo resources into mt6360
  mfd: mt6360: Rename mt6360_pmu_data by mt6360_ddata
  mfd: mt6360: Rename mt6360_pmu by mt6360
  mfd: mt6360: Remove handle_post_irq callback function
  mfd: mt6360: Fix flow which is used to check ic exist
  mfd: mt6360: Merge header file into driver and remove unuse register define
  mfd: mt6360: Merge different sub-devices I2C read/write

 b/drivers/mfd/Kconfig       |    1 
 b/drivers/mfd/mt6360-core.c |  564 +++++++++++++++++++++++++++++---------------
 include/linux/mfd/mt6360.h  |  240 ------------------
 3 files changed, 380 insertions(+), 425 deletions(-)

changelogs between v2 & v3
- Replace mt6360_data to mt6360_ddata
- Split I2C read/write to regmap driver

changelogs between v3 & v4
- Merge back mt6360 regmap driver to MFD driver

changelogs between v4 & v5
- use devm_regmap_init
- define crc calculation magic number


WARNING: multiple messages have this Message-ID (diff)
From: Gene Chen <gene.chen.richtek@gmail.com>
To: lee.jones@linaro.org, matthias.bgg@gmail.com
Cc: gene_chen@richtek.com, linux-kernel@vger.kernel.org,
	cy_huang@richtek.com, benjamin.chao@mediatek.com,
	linux-mediatek@lists.infradead.org, Wilma.Wu@mediatek.com,
	linux-arm-kernel@lists.infradead.org, shufan_lee@richtek.com
Subject: [PATCH v5 0/10] mfd: mt6360: Merge different sub-devices I2C read/write
Date: Tue, 22 Sep 2020 18:20:08 +0800	[thread overview]
Message-ID: <1600770019-11585-1-git-send-email-gene.chen.richtek@gmail.com> (raw)

This patch series merge different sub-device I2C read/write into one Regmap and
fix coding style for well-organized.

Gene Chen (10)
  mfd: mt6360: Rearrange include file
  mfd: mt6360: Remove redundant brackets around raw numbers
  mfd: mt6360: Indicate sub-dev compatible name by using
  mfd: mt6360: Combine mt6360 pmic/ldo resources into mt6360
  mfd: mt6360: Rename mt6360_pmu_data by mt6360_ddata
  mfd: mt6360: Rename mt6360_pmu by mt6360
  mfd: mt6360: Remove handle_post_irq callback function
  mfd: mt6360: Fix flow which is used to check ic exist
  mfd: mt6360: Merge header file into driver and remove unuse register define
  mfd: mt6360: Merge different sub-devices I2C read/write

 b/drivers/mfd/Kconfig       |    1 
 b/drivers/mfd/mt6360-core.c |  564 +++++++++++++++++++++++++++++---------------
 include/linux/mfd/mt6360.h  |  240 ------------------
 3 files changed, 380 insertions(+), 425 deletions(-)

changelogs between v2 & v3
- Replace mt6360_data to mt6360_ddata
- Split I2C read/write to regmap driver

changelogs between v3 & v4
- Merge back mt6360 regmap driver to MFD driver

changelogs between v4 & v5
- use devm_regmap_init
- define crc calculation magic number


_______________________________________________
Linux-mediatek mailing list
Linux-mediatek@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-mediatek

WARNING: multiple messages have this Message-ID (diff)
From: Gene Chen <gene.chen.richtek@gmail.com>
To: lee.jones@linaro.org, matthias.bgg@gmail.com
Cc: gene_chen@richtek.com, linux-kernel@vger.kernel.org,
	cy_huang@richtek.com, benjamin.chao@mediatek.com,
	linux-mediatek@lists.infradead.org, Wilma.Wu@mediatek.com,
	linux-arm-kernel@lists.infradead.org, shufan_lee@richtek.com
Subject: [PATCH v5 0/10] mfd: mt6360: Merge different sub-devices I2C read/write
Date: Tue, 22 Sep 2020 18:20:08 +0800	[thread overview]
Message-ID: <1600770019-11585-1-git-send-email-gene.chen.richtek@gmail.com> (raw)

This patch series merge different sub-device I2C read/write into one Regmap and
fix coding style for well-organized.

Gene Chen (10)
  mfd: mt6360: Rearrange include file
  mfd: mt6360: Remove redundant brackets around raw numbers
  mfd: mt6360: Indicate sub-dev compatible name by using
  mfd: mt6360: Combine mt6360 pmic/ldo resources into mt6360
  mfd: mt6360: Rename mt6360_pmu_data by mt6360_ddata
  mfd: mt6360: Rename mt6360_pmu by mt6360
  mfd: mt6360: Remove handle_post_irq callback function
  mfd: mt6360: Fix flow which is used to check ic exist
  mfd: mt6360: Merge header file into driver and remove unuse register define
  mfd: mt6360: Merge different sub-devices I2C read/write

 b/drivers/mfd/Kconfig       |    1 
 b/drivers/mfd/mt6360-core.c |  564 +++++++++++++++++++++++++++++---------------
 include/linux/mfd/mt6360.h  |  240 ------------------
 3 files changed, 380 insertions(+), 425 deletions(-)

changelogs between v2 & v3
- Replace mt6360_data to mt6360_ddata
- Split I2C read/write to regmap driver

changelogs between v3 & v4
- Merge back mt6360 regmap driver to MFD driver

changelogs between v4 & v5
- use devm_regmap_init
- define crc calculation magic number


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

             reply	other threads:[~2020-09-22 10:20 UTC|newest]

Thread overview: 45+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-22 10:20 Gene Chen [this message]
2020-09-22 10:20 ` [PATCH v5 0/10] mfd: mt6360: Merge different sub-devices I2C read/write Gene Chen
2020-09-22 10:20 ` Gene Chen
2020-09-22 10:20 ` [PATCH v5 01/10] mfd: mt6360: Rearrange include file Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20 ` [PATCH v5 02/10] mfd: mt6360: Remove redundant brackets around raw numbers Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20 ` [PATCH v5 03/10] mfd: mt6360: Indicate sub-dev compatible name by using "-" Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20 ` [PATCH v5 04/10] mfd: mt6360: Combine mt6360 pmic/ldo resources into mt6360 regulator resources Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-10-01  9:10   ` Lee Jones
2020-10-01  9:10     ` Lee Jones
2020-10-01  9:10     ` Lee Jones
2020-09-22 10:20 ` [PATCH v5 05/10] mfd: mt6360: Rename mt6360_pmu_data by mt6360_ddata Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20 ` [PATCH v5 06/10] mfd: mt6360: Rename mt6360_pmu by mt6360 Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20 ` [PATCH v5 07/10] mfd: mt6360: Remove handle_post_irq callback function Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20 ` [PATCH v5 08/10] mfd: mt6360: Fix flow which is used to check ic exist Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20 ` [PATCH v5 09/10] mfd: mt6360: Merge header file into driver and remove unuse register define Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-10-01  9:11   ` Lee Jones
2020-10-01  9:11     ` Lee Jones
2020-10-01  9:11     ` Lee Jones
2020-09-22 10:20 ` [PATCH v5 10/10] mfd: mt6360: Merge different sub-devices I2C read/write Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-09-22 10:20   ` Gene Chen
2020-10-27  9:35   ` Gene Chen
2020-10-27  9:35     ` Gene Chen
2020-10-27  9:35     ` Gene Chen
2020-11-04 15:38   ` Lee Jones
2020-11-04 15:38     ` Lee Jones
2020-11-04 15:38     ` Lee Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1600770019-11585-1-git-send-email-gene.chen.richtek@gmail.com \
    --to=gene.chen.richtek@gmail.com \
    --cc=Wilma.Wu@mediatek.com \
    --cc=benjamin.chao@mediatek.com \
    --cc=cy_huang@richtek.com \
    --cc=gene_chen@richtek.com \
    --cc=lee.jones@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=matthias.bgg@gmail.com \
    --cc=shufan_lee@richtek.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.