All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mike Frysinger <vapier@gentoo.org>
To: Adrian McMenamin <adrian@newgolddream.dyndns.info>
Cc: greg KH <greg@kroah.com>, dwmw2 <dwmw2@infradead.org>,
	Paul Mundt <lethal@linux-sh.org>,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	LKML <linux-kernel@vger.kernel.org>,
	MTD <linux-mtd@lists.infradead.org>,
	linux-sh <linux-sh@vger.kernel.org>,
	linux-input <linux-input@vger.kernel.org>
Subject: Re: [PATCH] sh: maple: Add support for VMU devices (v2) [1/3]
Date: Tue, 03 Feb 2009 00:48:01 +0000	[thread overview]
Message-ID: <200902021948.04031.vapier@gentoo.org> (raw)
In-Reply-To: <1233620263.13918.31.camel@localhost.localdomain>

[-- Attachment #1: Type: text/plain, Size: 669 bytes --]

On Monday 02 February 2009 19:17:43 Adrian McMenamin wrote:
> +	if (src_ofs >= ((card->parts)[partition]).numblocks * card->blocklen)
> +	if (num > ((card->parts)[partition]).numblocks)
> +	pcache = (card->parts[partition]).pcache;

ive only quoted some, but the use of parenthesis here is pointless and imo 
makes the code harder to read.  it's like trying to parse lisp ;).

> +	vblock = kmalloc(sizeof(struct vmu_block), GFP_KERNEL);

sizeof(*vblock) ?

> +static int __init vmu_flash_map_init(void)
> +{
> +	maple_driver_register(&vmu_flash_driver);
> +	return 0;
> +}

shouldnt this be:
	return maple_driver_register(&vmu_flash_driver);
-mike

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 835 bytes --]

WARNING: multiple messages have this Message-ID (diff)
From: Mike Frysinger <vapier@gentoo.org>
To: Adrian McMenamin <adrian@newgolddream.dyndns.info>
Cc: greg KH <greg@kroah.com>, dwmw2 <dwmw2@infradead.org>,
	Paul Mundt <lethal@linux-sh.org>,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	LKML <linux-kernel@vger.kernel.org>,
	MTD <linux-mtd@lists.infradead.org>,
	"linux-sh" <linux-sh@vger.kernel.org>,
	"linux-input" <linux-input@vger.kernel.org>
Subject: Re: [PATCH] sh: maple: Add support for VMU devices (v2) [1/3]
Date: Mon, 2 Feb 2009 19:48:01 -0500	[thread overview]
Message-ID: <200902021948.04031.vapier@gentoo.org> (raw)
In-Reply-To: <1233620263.13918.31.camel@localhost.localdomain>

[-- Attachment #1: Type: text/plain, Size: 669 bytes --]

On Monday 02 February 2009 19:17:43 Adrian McMenamin wrote:
> +	if (src_ofs >= ((card->parts)[partition]).numblocks * card->blocklen)
> +	if (num > ((card->parts)[partition]).numblocks)
> +	pcache = (card->parts[partition]).pcache;

ive only quoted some, but the use of parenthesis here is pointless and imo 
makes the code harder to read.  it's like trying to parse lisp ;).

> +	vblock = kmalloc(sizeof(struct vmu_block), GFP_KERNEL);

sizeof(*vblock) ?

> +static int __init vmu_flash_map_init(void)
> +{
> +	maple_driver_register(&vmu_flash_driver);
> +	return 0;
> +}

shouldnt this be:
	return maple_driver_register(&vmu_flash_driver);
-mike

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 835 bytes --]

WARNING: multiple messages have this Message-ID (diff)
From: Mike Frysinger <vapier@gentoo.org>
To: Adrian McMenamin <adrian@newgolddream.dyndns.info>
Cc: linux-sh <linux-sh@vger.kernel.org>, greg KH <greg@kroah.com>,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	LKML <linux-kernel@vger.kernel.org>,
	Paul Mundt <lethal@linux-sh.org>,
	MTD <linux-mtd@lists.infradead.org>,
	linux-input <linux-input@vger.kernel.org>,
	dwmw2 <dwmw2@infradead.org>
Subject: Re: [PATCH] sh: maple: Add support for VMU devices (v2) [1/3]
Date: Mon, 2 Feb 2009 19:48:01 -0500	[thread overview]
Message-ID: <200902021948.04031.vapier@gentoo.org> (raw)
In-Reply-To: <1233620263.13918.31.camel@localhost.localdomain>

[-- Attachment #1: Type: text/plain, Size: 669 bytes --]

On Monday 02 February 2009 19:17:43 Adrian McMenamin wrote:
> +	if (src_ofs >= ((card->parts)[partition]).numblocks * card->blocklen)
> +	if (num > ((card->parts)[partition]).numblocks)
> +	pcache = (card->parts[partition]).pcache;

ive only quoted some, but the use of parenthesis here is pointless and imo 
makes the code harder to read.  it's like trying to parse lisp ;).

> +	vblock = kmalloc(sizeof(struct vmu_block), GFP_KERNEL);

sizeof(*vblock) ?

> +static int __init vmu_flash_map_init(void)
> +{
> +	maple_driver_register(&vmu_flash_driver);
> +	return 0;
> +}

shouldnt this be:
	return maple_driver_register(&vmu_flash_driver);
-mike

[-- Attachment #2: This is a digitally signed message part. --]
[-- Type: application/pgp-signature, Size: 835 bytes --]

  reply	other threads:[~2009-02-03  0:48 UTC|newest]

Thread overview: 39+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-02-03  0:06 [PATCH] sh: maple: Add support for VMU devices (v2) [0/3] Adrian McMenamin
2009-02-03  0:06 ` Adrian McMenamin
2009-02-03  0:17 ` [PATCH] sh: maple: Add support for VMU devices (v2) [1/3] Adrian McMenamin
2009-02-03  0:17   ` Adrian McMenamin
2009-02-03  0:17   ` Adrian McMenamin
2009-02-03  0:17   ` Adrian McMenamin
2009-02-03  0:48   ` Mike Frysinger [this message]
2009-02-03  0:48     ` Mike Frysinger
2009-02-03  0:48     ` Mike Frysinger
2009-02-03  0:17 ` [PATCH] sh: maple: Add support for VMU devices (v2) [2/3] Adrian McMenamin
2009-02-03  0:17   ` Adrian McMenamin
2009-02-03  0:17   ` Adrian McMenamin
2009-02-03  0:17 ` [PATCH] sh: maple: Add support for VMU devices (v2) [3/3] Adrian McMenamin
2009-02-03  0:17   ` Adrian McMenamin
2009-02-03 14:31 ` [PATCH] sh: maple: Add support for VMU devices (v3) [0/3] Adrian McMenamin
2009-02-03 14:31   ` Adrian McMenamin
2009-02-03 14:31   ` Adrian McMenamin
2009-02-03 14:35   ` [PATCH] sh: maple: Add support for VMU devices (v3) [1/3] Adrian McMenamin
2009-02-03 14:35     ` Adrian McMenamin
2009-02-03 14:35     ` Adrian McMenamin
2009-02-03 16:30     ` Mike Frysinger
2009-02-03 16:30       ` Mike Frysinger
2009-02-03 16:30       ` Mike Frysinger
2009-02-03 14:37   ` [PATCH] sh: maple: Add support for VMU devices (v3) [2/3] Adrian McMenamin
2009-02-03 14:37     ` Adrian McMenamin
2009-02-03 14:37     ` Adrian McMenamin
2009-02-03 14:39   ` [PATCH] sh: maple: Add support for VMU devices (v3) [3/3] Adrian McMenamin
2009-02-03 14:39     ` Adrian McMenamin
2009-02-03 16:59 ` [PATCH] sh: maple: Add support for VMU devices (v4) [0/3] Adrian McMenamin
2009-02-03 16:59   ` Adrian McMenamin
2009-02-03 16:59   ` Adrian McMenamin
2009-02-03 17:04   ` [PATCH] sh: maple: Add support for VMU devices (v4) [1/3] Adrian McMenamin
2009-02-03 17:04     ` Adrian McMenamin
2009-02-03 17:04     ` Adrian McMenamin
2009-02-03 17:06   ` [PATCH] sh: maple: Add support for VMU devices (v4) [2/3] Adrian McMenamin
2009-02-03 17:06     ` Adrian McMenamin
2009-02-03 17:06     ` Adrian McMenamin
2009-02-03 17:09   ` [PATCH] sh: maple: Add support for VMU devices (v4) [3/3] Adrian McMenamin
2009-02-03 17:09     ` Adrian McMenamin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=200902021948.04031.vapier@gentoo.org \
    --to=vapier@gentoo.org \
    --cc=adrian@newgolddream.dyndns.info \
    --cc=dmitry.torokhov@gmail.com \
    --cc=dwmw2@infradead.org \
    --cc=greg@kroah.com \
    --cc=lethal@linux-sh.org \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=linux-sh@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.