All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Josef 'Jeff' Sipek" <jeffpc@josefsipek.net>
To: Adrian McMenamin <adrian@newgolddream.dyndns.info>
Cc: LKML <linux-kernel@vger.kernel.org>,
	linux-fsdevel <linux-fsdevel@vger.kernel.org>,
	viro <viro@zeniv.linux.org.uk>,
	linux-sh <linux-sh@vger.kernel.org>
Subject: Re: [RFC][patch] VMUFAT filesystem - v2
Date: Sat, 11 Apr 2009 22:31:28 +0000	[thread overview]
Message-ID: <20090411223128.GO13936@josefsipek.net> (raw)
In-Reply-To: <1239487891.6523.17.camel@localhost.localdomain>

On Sat, Apr 11, 2009 at 11:11:31PM +0100, Adrian McMenamin wrote:
...
> diff --git a/fs/vmufat/inode.c b/fs/vmufat/inode.c
> new file mode 100644
> index 0000000..8ac0cba
> --- /dev/null
> +++ b/fs/vmufat/inode.c
...
> +#define VMUFAT_MAGIC 0x55555555

Last time I had a magic number lying around like that, I've been told to put
it in include/linux/magic.h.

...
> +struct memcard {
...
> +};
> +
> +struct vmufat_block_list {
...
> +};

Is this the code in a single file? Uf.

> +struct vmufat_file_info {
> +	__u8 ftype;
> +	__u8 copy_pro;
> +	__u16 fblk;
> +	char fname[12];

You had a #define for file name length near the top of the file. Why not use
it? :)

> +static inline int vmufat_index(int fno)
> +{
> +	return (fno % 0x10) * 0x20;
> +}
> +
> +static inline int vmufat_index_16(int fno)
> +{
> +	return (fno % 0x10) * 0x10;
> +}

I'd change the % and * to bit mask & shift.

Ok, I need to run out. I haven't seen the rest of the (rather long) patch.

Josef 'Jeff' Sipek.

-- 
Intellectuals solve problems; geniuses prevent them
		- Albert Einstein

WARNING: multiple messages have this Message-ID (diff)
From: "Josef 'Jeff' Sipek" <jeffpc@josefsipek.net>
To: Adrian McMenamin <adrian@newgolddream.dyndns.info>
Cc: LKML <linux-kernel@vger.kernel.org>,
	linux-fsdevel <linux-fsdevel@vger.kernel.org>,
	viro <viro@zeniv.linux.org.uk>,
	linux-sh <linux-sh@vger.kernel.org>
Subject: Re: [RFC][patch] VMUFAT filesystem - v2
Date: Sat, 11 Apr 2009 18:31:28 -0400	[thread overview]
Message-ID: <20090411223128.GO13936@josefsipek.net> (raw)
In-Reply-To: <1239487891.6523.17.camel@localhost.localdomain>

On Sat, Apr 11, 2009 at 11:11:31PM +0100, Adrian McMenamin wrote:
...
> diff --git a/fs/vmufat/inode.c b/fs/vmufat/inode.c
> new file mode 100644
> index 0000000..8ac0cba
> --- /dev/null
> +++ b/fs/vmufat/inode.c
...
> +#define VMUFAT_MAGIC 0x55555555

Last time I had a magic number lying around like that, I've been told to put
it in include/linux/magic.h.

...
> +struct memcard {
...
> +};
> +
> +struct vmufat_block_list {
...
> +};

Is this the code in a single file? Uf.

> +struct vmufat_file_info {
> +	__u8 ftype;
> +	__u8 copy_pro;
> +	__u16 fblk;
> +	char fname[12];

You had a #define for file name length near the top of the file. Why not use
it? :)

> +static inline int vmufat_index(int fno)
> +{
> +	return (fno % 0x10) * 0x20;
> +}
> +
> +static inline int vmufat_index_16(int fno)
> +{
> +	return (fno % 0x10) * 0x10;
> +}

I'd change the % and * to bit mask & shift.

Ok, I need to run out. I haven't seen the rest of the (rather long) patch.

Josef 'Jeff' Sipek.

-- 
Intellectuals solve problems; geniuses prevent them
		- Albert Einstein

  reply	other threads:[~2009-04-11 22:31 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-04-11 22:11 [RFC][patch] VMUFAT filesystem - v2 Adrian McMenamin
2009-04-11 22:11 ` Adrian McMenamin
2009-04-11 22:31 ` Josef 'Jeff' Sipek [this message]
2009-04-11 22:31   ` Josef 'Jeff' Sipek
2009-04-11 22:50 ` [RFC][patch] VMUFAT filesystem - v3 Adrian McMenamin
2009-04-11 22:50   ` Adrian McMenamin
2009-04-12  0:35 ` [RFC][patch] VMUFAT filesystem - v2 Sam Ravnborg
2009-04-12  0:35   ` Sam Ravnborg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20090411223128.GO13936@josefsipek.net \
    --to=jeffpc@josefsipek.net \
    --cc=adrian@newgolddream.dyndns.info \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-sh@vger.kernel.org \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.