All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Henrik Rydberg" <rydberg@euromail.se>
To: Benjamin Tissoires <benjamin.tissoires@gmail.com>
Cc: Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	Jiri Kosina <jkosina@suse.cz>, Stephane Chatty <chatty@enac.fr>,
	linux-input@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 11/11] HID: hid-multitouch: get rid of usbhid depedency for general path
Date: Wed, 31 Oct 2012 20:18:49 +0100	[thread overview]
Message-ID: <20121031191849.GA1780@polaris.bitmath.org> (raw)
In-Reply-To: <CAN+gG=GNucfg4-wCBZQtz0yJDjpTD_56Js3d68nm8VFi1UhZAA@mail.gmail.com>

> > In my drawer, I have a patchset that aims to remove all usbhid
> > dependence, from all the drivers. Perhaps the attached patch is
> > something to consider here?
> 
> yep, removing usbhid dependencies is a good thing.
> See my review below :)
> 
> > From 5d9a791e0a9e41bcea0fcb286e2849b403675f37 Mon Sep 17 00:00:00 2001
> > From: Henrik Rydberg <rydberg@euromail.se>
> > Date: Mon, 2 Jul 2012 20:38:21 +0200
> > Subject: [PATCH 3/7] hid: extend interface with report requests
> >
> > ---
> >  drivers/hid/usbhid/hid-core.c | 14 ++++++++++++++
> >  include/linux/hid.h           | 33 +++++++++++++++++++++++++++++++++
> >  2 files changed, 47 insertions(+)
> >
> > diff --git a/drivers/hid/usbhid/hid-core.c b/drivers/hid/usbhid/hid-core.c
> > index de1f9ac..3c618da 100644
> > --- a/drivers/hid/usbhid/hid-core.c
> > +++ b/drivers/hid/usbhid/hid-core.c
> > @@ -1251,6 +1251,18 @@ static int usbhid_power(struct hid_device *hid, int lvl)
> >         return r;
> >  }
> >
> > +static void usbhid_send(struct hid_device *hid, struct hid_report *rep, int req)
> > +{
> > +       switch (req) {
> > +       case HID_REQ_GET_REPORT:
> > +               usbhid_submit_report(hid, rep, USB_DIR_IN);
> > +               break;
> > +       case HID_REQ_SET_REPORT:
> > +               usbhid_submit_report(hid, rep, USB_DIR_OUT);
> > +               break;
> > +       }
> > +}
> > +
> >  static struct hid_ll_driver usb_hid_driver = {
> >         .parse = usbhid_parse,
> >         .start = usbhid_start,
> > @@ -1259,6 +1271,8 @@ static struct hid_ll_driver usb_hid_driver = {
> >         .close = usbhid_close,
> >         .power = usbhid_power,
> >         .hidinput_input_event = usb_hidinput_input_event,
> > +       .send = usbhid_send,
> 
> the name here is a little bit misleading. You are using "send" to also
> "get" reports...
> Maybe "hid_request" is a better name. This will allows us to add the
> missing function:
> Get_Descriptor, Set_Descriptor, Get_Report Request, Set_Report
> Request, Get_Idle, Set_Idle, Get_Protocol, Set_Protocol and maybe
> others - even WAIT for instance :)

Sounds good, I'll ponder this a bit.

> 
> > +       .wait = usbhid_wait_io,
> 
> is it really necessary to wait for IO? (I think it will not be one
> line for hid over i2c...).

We can certainly skip it for the scope of your patchset, but last time
I checked, it was needed in quite a few places.

Thanks,
Henrik

  reply	other threads:[~2012-10-31 19:14 UTC|newest]

Thread overview: 48+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-10-26  8:44 [PATCH v2 00/11] Win 8 support for digitizers Benjamin Tissoires
2012-10-26  8:44 ` [PATCH v2 01/11] HID: hid-input: export hidinput_calc_abs_res Benjamin Tissoires
2012-10-29 18:57   ` Henrik Rydberg
2012-10-30 10:04     ` Benjamin Tissoires
2012-10-26  8:44 ` [PATCH v2 02/11] HID: core: fix unit exponent parsing Benjamin Tissoires
2012-10-29 19:05   ` Henrik Rydberg
2012-10-30 10:07     ` Benjamin Tissoires
2012-10-26  8:44 ` [PATCH v2 03/11] HID: hid-input: add usage_index argument in input_mapping and event Benjamin Tissoires
2012-10-29 19:25   ` Henrik Rydberg
2012-10-30 10:09     ` Benjamin Tissoires
2012-11-06 13:56       ` Benjamin Tissoires
2012-11-06 15:24         ` Jiri Kosina
2012-10-26  8:44 ` [PATCH v2 04/11] HID: hid-multitouch: support arrays for the split of the touches in a report Benjamin Tissoires
2012-10-29 21:49   ` Henrik Rydberg
2012-10-30 10:11     ` Benjamin Tissoires
2012-10-26  8:44 ` [PATCH v2 05/11] HID: hid-multitouch: get maxcontacts also from logical_max value Benjamin Tissoires
2012-10-29 21:52   ` Henrik Rydberg
2012-10-26  8:44 ` [PATCH v2 06/11] HID: hid-multitouch: support T and C for win8 devices Benjamin Tissoires
2012-10-29 22:00   ` Henrik Rydberg
2012-10-30 10:16     ` Benjamin Tissoires
2012-10-31 18:47       ` Henrik Rydberg
2012-10-26  8:44 ` [PATCH v2 07/11] HID: hid-multitouch: move ALWAYS_VALID quirk check Benjamin Tissoires
2012-10-29 22:16   ` Henrik Rydberg
2012-10-30 10:19     ` Benjamin Tissoires
2012-10-26  8:44 ` [PATCH v2 08/11] HID: hid-multitouch: fix Win 8 protocol Benjamin Tissoires
2012-10-29 22:19   ` Henrik Rydberg
2012-10-30 10:24     ` Benjamin Tissoires
2012-10-31 18:53       ` Henrik Rydberg
2012-11-02 14:18         ` Benjamin Tissoires
2012-11-02 14:18           ` Benjamin Tissoires
2012-11-04 20:54           ` Henrik Rydberg
2012-11-05  9:51             ` Benjamin Tissoires
2012-11-05  9:51               ` Benjamin Tissoires
2012-10-26  8:44 ` [PATCH v2 09/11] HID: hid-multitouch: support for hovering devices Benjamin Tissoires
2012-10-29 22:31   ` Henrik Rydberg
2012-10-30 10:43     ` Benjamin Tissoires
2012-10-26  8:44 ` [PATCH v2 10/11] HID: introduce Scan Time Benjamin Tissoires
2012-10-29 22:43   ` Henrik Rydberg
2012-10-30 10:54     ` Benjamin Tissoires
2012-10-31 19:16       ` Henrik Rydberg
2012-11-02 14:23         ` Benjamin Tissoires
2012-10-26  8:44 ` [PATCH v2 11/11] HID: hid-multitouch: get rid of usbhid depedency for general path Benjamin Tissoires
2012-10-29 22:57   ` Henrik Rydberg
2012-10-30 11:04     ` Benjamin Tissoires
2012-10-31 19:18       ` Henrik Rydberg [this message]
2012-11-05 12:57       ` Henrik Rydberg
2012-11-05 13:28         ` Benjamin Tissoires
2012-11-05 13:32           ` Benjamin Tissoires

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20121031191849.GA1780@polaris.bitmath.org \
    --to=rydberg@euromail.se \
    --cc=benjamin.tissoires@gmail.com \
    --cc=chatty@enac.fr \
    --cc=dmitry.torokhov@gmail.com \
    --cc=jkosina@suse.cz \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.