All of lore.kernel.org
 help / color / mirror / Atom feed
From: Paul Mundt <lethal@linux-sh.org>
To: Linus Walleij <linus.walleij@linaro.org>
Cc: Grant Likely <grant.likely@secretlab.ca>,
	Alexandre Courbot <acourbot@nvidia.com>,
	Arnd Bergmann <arnd@arndb.de>,
	linux-arch <linux-arch@vger.kernel.org>,
	"linux-arm-kernel@lists.infradead.org" 
	<linux-arm-kernel@lists.infradead.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Alexandre Courbot <gnurou@gmail.com>,
	Mark Brown <broonie@opensource.wolfsonmicro.com>,
	Mike Turquette <mturquette@linaro.org>
Subject: Re: [PATCH 6/9] gpiolib: use descriptors internally
Date: Tue, 12 Feb 2013 00:40:29 +0900	[thread overview]
Message-ID: <20130211154028.GB6088@linux-sh.org> (raw)
In-Reply-To: <CACRpkdagLssOG3FW8Qr1zqFabGMgdupADwg1=c0eQ7e76_XM5A@mail.gmail.com>

On Mon, Feb 11, 2013 at 03:09:21PM +0100, Linus Walleij wrote:
> On Sat, Feb 9, 2013 at 10:17 AM, Grant Likely <grant.likely@secretlab.ca> wrote:
> 
> > The ERR_PTR()/IS_ERR() is a horrible pattern for code
> > readability because it breaks the expectations that programmers have for
> > what is and is not a bad pointer. There are decades of history where the
> > test for a bad pointer is 'if (!ptr)'. Not only does ERR_PTR make make
> > that test not work, but the compiler won't tell you when you get it
> > wrong.
> >
> > There are places where ERR_PTR makes sense. Particularly when
> > communicating with userspace where error codes have very specific
> > meanings, but I don't want it in the GPIO subsystem.
> 
> OK I disagree but you get to decide.
> 
> However if you take this all the way to the descriptor API
> it will make the consumer (driver) API for GPIO descriptors deviate
> from what is today used for clocks, regulators and pins.
> 
> With all the resulting confusion for users.
> I've seen worse subsystem deviations though.
> 
I've always considered it to be more of a complexity issue. If an
interface can fail for half a dozen different reasons, it's useful to be
able to encapsulate this and pass it down the line to the consumer
(particularly in cases where no useful debug output is provided, and the
first thing someone is going to do is go and instrument the registration
path with printks to figure out where things went wrong). In the case
where the work to do is relatively straightforward and there's not much
complexity, NULL is clearly the way to go.

There are already quite a few cases today converting NULLs over to
arbitrary ERR_PTR values or IS_ERR cases wrapping back to NULL, so it's
clear that both have to be supported interacting with one another
regardless. Then there's that whole IS_ERR_OR_NULL case which everyone
seems to get wrong, but that's another issue entirely.

WARNING: multiple messages have this Message-ID (diff)
From: lethal@linux-sh.org (Paul Mundt)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH 6/9] gpiolib: use descriptors internally
Date: Tue, 12 Feb 2013 00:40:29 +0900	[thread overview]
Message-ID: <20130211154028.GB6088@linux-sh.org> (raw)
In-Reply-To: <CACRpkdagLssOG3FW8Qr1zqFabGMgdupADwg1=c0eQ7e76_XM5A@mail.gmail.com>

On Mon, Feb 11, 2013 at 03:09:21PM +0100, Linus Walleij wrote:
> On Sat, Feb 9, 2013 at 10:17 AM, Grant Likely <grant.likely@secretlab.ca> wrote:
> 
> > The ERR_PTR()/IS_ERR() is a horrible pattern for code
> > readability because it breaks the expectations that programmers have for
> > what is and is not a bad pointer. There are decades of history where the
> > test for a bad pointer is 'if (!ptr)'. Not only does ERR_PTR make make
> > that test not work, but the compiler won't tell you when you get it
> > wrong.
> >
> > There are places where ERR_PTR makes sense. Particularly when
> > communicating with userspace where error codes have very specific
> > meanings, but I don't want it in the GPIO subsystem.
> 
> OK I disagree but you get to decide.
> 
> However if you take this all the way to the descriptor API
> it will make the consumer (driver) API for GPIO descriptors deviate
> from what is today used for clocks, regulators and pins.
> 
> With all the resulting confusion for users.
> I've seen worse subsystem deviations though.
> 
I've always considered it to be more of a complexity issue. If an
interface can fail for half a dozen different reasons, it's useful to be
able to encapsulate this and pass it down the line to the consumer
(particularly in cases where no useful debug output is provided, and the
first thing someone is going to do is go and instrument the registration
path with printks to figure out where things went wrong). In the case
where the work to do is relatively straightforward and there's not much
complexity, NULL is clearly the way to go.

There are already quite a few cases today converting NULLs over to
arbitrary ERR_PTR values or IS_ERR cases wrapping back to NULL, so it's
clear that both have to be supported interacting with one another
regardless. Then there's that whole IS_ERR_OR_NULL case which everyone
seems to get wrong, but that's another issue entirely.

  reply	other threads:[~2013-02-11 15:41 UTC|newest]

Thread overview: 115+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-02-02 16:29 [PATCH 0/9] gpiolib: remove gpio_desc[] static array Alexandre Courbot
2013-02-02 16:29 ` Alexandre Courbot
2013-02-02 16:29 ` Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-02 16:29 ` [PATCH 1/9] gpiolib: link all gpio_chips using a list Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-05 17:00   ` Linus Walleij
2013-02-05 17:00     ` Linus Walleij
2013-02-09  9:20     ` Grant Likely
2013-02-09  9:20       ` Grant Likely
2013-02-02 16:29 ` [PATCH 2/9] gpiolib: use gpio_chips list in gpiolib_sysfs_init Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-05 17:04   ` Linus Walleij
2013-02-05 17:04     ` Linus Walleij
2013-02-09  9:22     ` Grant Likely
2013-02-09  9:22       ` Grant Likely
2013-02-09  9:22       ` Grant Likely
2013-02-02 16:29 ` [PATCH 3/9] gpiolib: use gpio_chips list in gpiochip_find Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-05 17:05   ` Linus Walleij
2013-02-05 17:05     ` Linus Walleij
2013-02-09  9:25     ` Grant Likely
2013-02-09  9:25       ` Grant Likely
2013-02-09  9:25       ` Grant Likely
2013-02-02 16:29 ` [PATCH 4/9] gpiolib: use gpio_chips list in sysfs ops Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-05 17:15   ` Linus Walleij
2013-02-05 17:15     ` Linus Walleij
2013-02-09  9:37     ` Grant Likely
2013-02-09  9:37       ` Grant Likely
2013-02-09  9:37       ` Grant Likely
2013-02-09 13:53       ` Alexandre Courbot
2013-02-09 13:53         ` Alexandre Courbot
2013-02-09 13:53         ` Alexandre Courbot
2013-02-02 16:29 ` [PATCH 5/9] gpiolib: use gpio_chips list in gpiochip_find_base Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-05 17:21   ` Linus Walleij
2013-02-05 17:21     ` Linus Walleij
2013-02-06  4:48     ` Alex Courbot
2013-02-06  4:48       ` Alex Courbot
2013-02-06  4:48       ` Alex Courbot
2013-02-09  9:47       ` Grant Likely
2013-02-09  9:47         ` Grant Likely
2013-02-09  9:47         ` Grant Likely
2013-02-02 16:29 ` [PATCH 6/9] gpiolib: use descriptors internally Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-05 17:53   ` Linus Walleij
2013-02-05 17:53     ` Linus Walleij
2013-02-07  6:57     ` Alexandre Courbot
2013-02-07  6:57       ` Alexandre Courbot
2013-02-07  6:57       ` Alexandre Courbot
2013-02-09  9:17       ` Grant Likely
2013-02-09  9:17         ` Grant Likely
2013-02-09  9:17         ` Grant Likely
2013-02-09  9:17         ` Grant Likely
2013-02-11 14:09         ` Linus Walleij
2013-02-11 14:09           ` Linus Walleij
2013-02-11 14:09           ` Linus Walleij
2013-02-11 15:40           ` Paul Mundt [this message]
2013-02-11 15:40             ` Paul Mundt
2013-02-11 15:40             ` Paul Mundt
2013-02-11 17:39           ` Stephen Warren
2013-02-11 17:39             ` Stephen Warren
2013-02-11 17:39             ` Stephen Warren
2013-02-12 12:29             ` Linus Walleij
2013-02-12 12:29               ` Linus Walleij
2013-02-12 12:29               ` Linus Walleij
2013-02-12 15:59               ` Paul Mundt
2013-02-12 15:59                 ` Paul Mundt
2013-02-12 15:59                 ` Paul Mundt
2013-02-12 17:18                 ` Arnd Bergmann
2013-02-12 17:18                   ` Arnd Bergmann
2013-02-12 17:18                   ` Arnd Bergmann
2013-02-09 13:11   ` Grant Likely
2013-02-09 13:11     ` Grant Likely
2013-02-09 13:11     ` Grant Likely
2013-02-09 13:11     ` Grant Likely
2013-02-09 14:15     ` Alexandre Courbot
2013-02-09 14:15       ` Alexandre Courbot
2013-02-09 14:15       ` Alexandre Courbot
2013-02-09 13:24   ` Grant Likely
2013-02-09 13:24     ` Grant Likely
2013-02-09 13:24     ` Grant Likely
2013-02-09 13:24     ` Grant Likely
2013-02-09 14:18     ` Alexandre Courbot
2013-02-09 14:18       ` Alexandre Courbot
2013-02-09 14:18       ` Alexandre Courbot
2013-02-02 16:29 ` [PATCH 7/9] gpiolib: let gpio_chip reference its descriptors Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-05 18:00   ` Linus Walleij
2013-02-05 18:00     ` Linus Walleij
2013-02-09 13:28     ` Grant Likely
2013-02-09 13:28       ` Grant Likely
2013-02-02 16:29 ` [PATCH 8/9] gpiolib: use gpio_chips list in gpio_to_desc Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-05 18:01   ` Linus Walleij
2013-02-05 18:01     ` Linus Walleij
2013-02-05 18:01     ` Linus Walleij
2013-02-09  9:58   ` Grant Likely
2013-02-09  9:58     ` Grant Likely
2013-02-09  9:58     ` Grant Likely
2013-02-09  9:58     ` Grant Likely
2013-02-09 14:21     ` Alexandre Courbot
2013-02-09 14:21       ` Alexandre Courbot
2013-02-09 14:21       ` Alexandre Courbot
2013-02-09 14:37       ` Grant Likely
2013-02-09 14:37         ` Grant Likely
2013-02-09 14:37         ` Grant Likely
2013-02-02 16:29 ` [PATCH 9/9] gpiolib: dynamically allocate descriptors array Alexandre Courbot
2013-02-02 16:29   ` Alexandre Courbot
2013-02-05 18:02   ` Linus Walleij
2013-02-05 18:02     ` Linus Walleij

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130211154028.GB6088@linux-sh.org \
    --to=lethal@linux-sh.org \
    --cc=acourbot@nvidia.com \
    --cc=arnd@arndb.de \
    --cc=broonie@opensource.wolfsonmicro.com \
    --cc=gnurou@gmail.com \
    --cc=grant.likely@secretlab.ca \
    --cc=linus.walleij@linaro.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mturquette@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.