All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
To: Jason Gunthorpe <jgunthorpe@obsidianresearch.com>
Cc: tpmdd-devel@lists.sourceforge.net,
	linux-security-module@vger.kernel.org,
	Peter Huewe <peterhuewe@gmx.de>,
	Marcel Selhorst <tpmdd@selhorst.net>,
	open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] tpm: consolidate the TPM startup code
Date: Tue, 20 Jun 2017 23:46:22 +0200	[thread overview]
Message-ID: <20170620214622.lqt72f6fiqgno2rh@linux.intel.com> (raw)
In-Reply-To: <20170620205529.ku3nueglj3mqkd3s@linux.intel.com>

On Tue, Jun 20, 2017 at 10:55:29PM +0200, Jarkko Sakkinen wrote:
> On Tue, Jun 20, 2017 at 01:31:52PM -0600, Jason Gunthorpe wrote:
> > On Tue, Jun 20, 2017 at 08:13:34PM +0200, Jarkko Sakkinen wrote:
> > > Consolidated all the "manual" TPM startup code to a single function
> > > in order to make code flows a bit cleaner and migrate to tpm_buf.
> > > 
> > > Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
> > >  drivers/char/tpm/tpm-interface.c | 67 +++++++++++++++++++++++++---------------
> > >  drivers/char/tpm/tpm.h           |  6 +---
> > >  drivers/char/tpm/tpm2-cmd.c      | 32 +------------------
> > >  3 files changed, 44 insertions(+), 61 deletions(-)
> > 
> > Makes sense to me
> > 
> > > diff --git a/drivers/char/tpm/tpm-interface.c b/drivers/char/tpm/tpm-interface.c
> > > index d2b4df6d9894..fbef47d8bd06 100644
> > > +++ b/drivers/char/tpm/tpm-interface.c
> > > @@ -540,6 +540,47 @@ ssize_t tpm_transmit_cmd(struct tpm_chip *chip, struct tpm_space *space,
> > >  }
> > >  EXPORT_SYMBOL_GPL(tpm_transmit_cmd);
> > >  
> > > +#define TPM_ORD_STARTUP 153
> > > +#define TPM_ST_CLEAR 1
> > 
> > We should really have a tpm1.h and tpm2.h that has all these various
> > constants and things instead of open coding them randomly all over..
> > 
> > Jason
> 
> I agree.

I agree means here that I agree if you mean only protocol specific
constants. I do not think it would make sense with things like struct
tpm_readpubek_out that is a throw away only used by that one function as
helper (would compare it to a helper function). It would only make
reading the code slower.

It would make sense, for example, to have enum tpm_ordinals for all
TPM 1.2 ordinals in tpm1_proto.h (yes would add _proto for clarity).

/Jarkko

WARNING: multiple messages have this Message-ID (diff)
From: jarkko.sakkinen@linux.intel.com (Jarkko Sakkinen)
To: linux-security-module@vger.kernel.org
Subject: [PATCH] tpm: consolidate the TPM startup code
Date: Tue, 20 Jun 2017 23:46:22 +0200	[thread overview]
Message-ID: <20170620214622.lqt72f6fiqgno2rh@linux.intel.com> (raw)
In-Reply-To: <20170620205529.ku3nueglj3mqkd3s@linux.intel.com>

On Tue, Jun 20, 2017 at 10:55:29PM +0200, Jarkko Sakkinen wrote:
> On Tue, Jun 20, 2017 at 01:31:52PM -0600, Jason Gunthorpe wrote:
> > On Tue, Jun 20, 2017 at 08:13:34PM +0200, Jarkko Sakkinen wrote:
> > > Consolidated all the "manual" TPM startup code to a single function
> > > in order to make code flows a bit cleaner and migrate to tpm_buf.
> > > 
> > > Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen@linux.intel.com>
> > >  drivers/char/tpm/tpm-interface.c | 67 +++++++++++++++++++++++++---------------
> > >  drivers/char/tpm/tpm.h           |  6 +---
> > >  drivers/char/tpm/tpm2-cmd.c      | 32 +------------------
> > >  3 files changed, 44 insertions(+), 61 deletions(-)
> > 
> > Makes sense to me
> > 
> > > diff --git a/drivers/char/tpm/tpm-interface.c b/drivers/char/tpm/tpm-interface.c
> > > index d2b4df6d9894..fbef47d8bd06 100644
> > > +++ b/drivers/char/tpm/tpm-interface.c
> > > @@ -540,6 +540,47 @@ ssize_t tpm_transmit_cmd(struct tpm_chip *chip, struct tpm_space *space,
> > >  }
> > >  EXPORT_SYMBOL_GPL(tpm_transmit_cmd);
> > >  
> > > +#define TPM_ORD_STARTUP 153
> > > +#define TPM_ST_CLEAR 1
> > 
> > We should really have a tpm1.h and tpm2.h that has all these various
> > constants and things instead of open coding them randomly all over..
> > 
> > Jason
> 
> I agree.

I agree means here that I agree if you mean only protocol specific
constants. I do not think it would make sense with things like struct
tpm_readpubek_out that is a throw away only used by that one function as
helper (would compare it to a helper function). It would only make
reading the code slower.

It would make sense, for example, to have enum tpm_ordinals for all
TPM 1.2 ordinals in tpm1_proto.h (yes would add _proto for clarity).

/Jarkko
--
To unsubscribe from this list: send the line "unsubscribe linux-security-module" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

WARNING: multiple messages have this Message-ID (diff)
From: Jarkko Sakkinen <jarkko.sakkinen-VuQAYsv1563Yd54FQh9/CA@public.gmane.org>
To: Jason Gunthorpe
	<jgunthorpe-ePGOBjL8dl3ta4EC/59zMFaTQe2KTcn/@public.gmane.org>
Cc: linux-security-module-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	tpmdd-devel-5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org,
	open list <linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>
Subject: Re: [PATCH] tpm: consolidate the TPM startup code
Date: Tue, 20 Jun 2017 23:46:22 +0200	[thread overview]
Message-ID: <20170620214622.lqt72f6fiqgno2rh@linux.intel.com> (raw)
In-Reply-To: <20170620205529.ku3nueglj3mqkd3s-VuQAYsv1563Yd54FQh9/CA@public.gmane.org>

On Tue, Jun 20, 2017 at 10:55:29PM +0200, Jarkko Sakkinen wrote:
> On Tue, Jun 20, 2017 at 01:31:52PM -0600, Jason Gunthorpe wrote:
> > On Tue, Jun 20, 2017 at 08:13:34PM +0200, Jarkko Sakkinen wrote:
> > > Consolidated all the "manual" TPM startup code to a single function
> > > in order to make code flows a bit cleaner and migrate to tpm_buf.
> > > 
> > > Signed-off-by: Jarkko Sakkinen <jarkko.sakkinen-VuQAYsv1563Yd54FQh9/CA@public.gmane.org>
> > >  drivers/char/tpm/tpm-interface.c | 67 +++++++++++++++++++++++++---------------
> > >  drivers/char/tpm/tpm.h           |  6 +---
> > >  drivers/char/tpm/tpm2-cmd.c      | 32 +------------------
> > >  3 files changed, 44 insertions(+), 61 deletions(-)
> > 
> > Makes sense to me
> > 
> > > diff --git a/drivers/char/tpm/tpm-interface.c b/drivers/char/tpm/tpm-interface.c
> > > index d2b4df6d9894..fbef47d8bd06 100644
> > > +++ b/drivers/char/tpm/tpm-interface.c
> > > @@ -540,6 +540,47 @@ ssize_t tpm_transmit_cmd(struct tpm_chip *chip, struct tpm_space *space,
> > >  }
> > >  EXPORT_SYMBOL_GPL(tpm_transmit_cmd);
> > >  
> > > +#define TPM_ORD_STARTUP 153
> > > +#define TPM_ST_CLEAR 1
> > 
> > We should really have a tpm1.h and tpm2.h that has all these various
> > constants and things instead of open coding them randomly all over..
> > 
> > Jason
> 
> I agree.

I agree means here that I agree if you mean only protocol specific
constants. I do not think it would make sense with things like struct
tpm_readpubek_out that is a throw away only used by that one function as
helper (would compare it to a helper function). It would only make
reading the code slower.

It would make sense, for example, to have enum tpm_ordinals for all
TPM 1.2 ordinals in tpm1_proto.h (yes would add _proto for clarity).

/Jarkko

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot

  parent reply	other threads:[~2017-06-20 21:46 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-06-20 18:13 [PATCH] tpm: consolidate the TPM startup code Jarkko Sakkinen
2017-06-20 18:13 ` Jarkko Sakkinen
2017-06-20 18:13 ` Jarkko Sakkinen
2017-06-20 19:31 ` Jason Gunthorpe
2017-06-20 19:31   ` Jason Gunthorpe
2017-06-20 19:31   ` Jason Gunthorpe
2017-06-20 20:55   ` Jarkko Sakkinen
2017-06-20 20:55     ` Jarkko Sakkinen
2017-06-20 20:55     ` Jarkko Sakkinen
2017-06-20 21:25     ` Stefan Berger
2017-06-20 21:25       ` Stefan Berger
2017-06-20 21:32       ` Jarkko Sakkinen
2017-06-20 21:32         ` Jarkko Sakkinen
2017-06-20 21:38         ` Jarkko Sakkinen
2017-06-20 21:38           ` Jarkko Sakkinen
2017-06-20 22:16           ` Stefan Berger
2017-06-20 22:16             ` Stefan Berger
2017-06-20 21:46     ` Jarkko Sakkinen [this message]
2017-06-20 21:46       ` Jarkko Sakkinen
2017-06-20 21:46       ` Jarkko Sakkinen
2017-06-20 20:58   ` [tpmdd-devel] " Ken Goldman
2017-06-20 20:58     ` Ken Goldman
2017-06-20 20:58     ` Ken Goldman

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170620214622.lqt72f6fiqgno2rh@linux.intel.com \
    --to=jarkko.sakkinen@linux.intel.com \
    --cc=jgunthorpe@obsidianresearch.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-security-module@vger.kernel.org \
    --cc=peterhuewe@gmx.de \
    --cc=tpmdd-devel@lists.sourceforge.net \
    --cc=tpmdd@selhorst.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.