All of lore.kernel.org
 help / color / mirror / Atom feed
From: Bjorn Helgaas <helgaas@kernel.org>
To: linux-pci@vger.kernel.org
Cc: "Lorenzo Pieralisi" <lorenzo.pieralisi@arm.com>,
	"Michal Simek" <michal.simek@xilinx.com>,
	rfi@lists.rocketboards.org,
	"Sören Brinkmann" <soren.brinkmann@xilinx.com>,
	"Ley Foon Tan" <lftan@altera.com>,
	linux-arm-kernel@lists.infradead.org,
	"Tanmay Inamdar" <tinamdar@apm.com>
Subject: [PATCH v1 0/3] PCI: Rename host functions for consistency
Date: Mon, 13 Nov 2017 16:40:36 -0600	[thread overview]
Message-ID: <20171113224001.29024.87126.stgit@bhelgaas-glaptop.roam.corp.google.com> (raw)

All native host bridge driver probe functions are called *_pci_probe() or
*_pcie_probe() *except* X-Gene's.  All "is the link up?" functions are
called *_pcie_link_up() *except* Altera's and Xilinx's.  Rename them to be
consistent.

I plan to include these for v4.15 unless there are objections.

---

Bjorn Helgaas (3):
      PCI: xgene: Rename xgene_pcie_probe_bridge() to xgene_pcie_probe()
      PCI: altera: Rename altera_pcie_link_is_up() to altera_pcie_link_up()
      PCI: xilinx: Rename xilinx_pcie_link_is_up() to xilinx_pcie_link_up()


 drivers/pci/host/pci-xgene.c   |    4 ++--
 drivers/pci/host/pcie-altera.c |    8 ++++----
 drivers/pci/host/pcie-xilinx.c |    6 +++---
 3 files changed, 9 insertions(+), 9 deletions(-)

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

WARNING: multiple messages have this Message-ID (diff)
From: helgaas@kernel.org (Bjorn Helgaas)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v1 0/3] PCI: Rename host functions for consistency
Date: Mon, 13 Nov 2017 16:40:36 -0600	[thread overview]
Message-ID: <20171113224001.29024.87126.stgit@bhelgaas-glaptop.roam.corp.google.com> (raw)

All native host bridge driver probe functions are called *_pci_probe() or
*_pcie_probe() *except* X-Gene's.  All "is the link up?" functions are
called *_pcie_link_up() *except* Altera's and Xilinx's.  Rename them to be
consistent.

I plan to include these for v4.15 unless there are objections.

---

Bjorn Helgaas (3):
      PCI: xgene: Rename xgene_pcie_probe_bridge() to xgene_pcie_probe()
      PCI: altera: Rename altera_pcie_link_is_up() to altera_pcie_link_up()
      PCI: xilinx: Rename xilinx_pcie_link_is_up() to xilinx_pcie_link_up()


 drivers/pci/host/pci-xgene.c   |    4 ++--
 drivers/pci/host/pcie-altera.c |    8 ++++----
 drivers/pci/host/pcie-xilinx.c |    6 +++---
 3 files changed, 9 insertions(+), 9 deletions(-)

             reply	other threads:[~2017-11-13 22:40 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-11-13 22:40 Bjorn Helgaas [this message]
2017-11-13 22:40 ` [PATCH v1 0/3] PCI: Rename host functions for consistency Bjorn Helgaas
2017-11-13 22:40 ` [PATCH v1 1/3] PCI: xgene: Rename xgene_pcie_probe_bridge() to xgene_pcie_probe() Bjorn Helgaas
2017-11-13 22:40   ` Bjorn Helgaas
2017-11-13 22:40 ` [PATCH v1 2/3] PCI: altera: Rename altera_pcie_link_is_up() to altera_pcie_link_up() Bjorn Helgaas
2017-11-13 22:40   ` Bjorn Helgaas
2017-11-14 16:58   ` Ley Foon Tan
2017-11-14 16:58     ` Ley Foon Tan
2017-11-13 22:40 ` [PATCH v1 3/3] PCI: xilinx: Rename xilinx_pcie_link_is_up() to xilinx_pcie_link_up() Bjorn Helgaas
2017-11-13 22:40   ` Bjorn Helgaas
2017-11-14  7:17   ` Michal Simek
2017-11-14  7:17     ` Michal Simek
2017-11-14 17:21 ` [PATCH v1 0/3] PCI: Rename host functions for consistency Lorenzo Pieralisi
2017-11-14 17:21   ` Lorenzo Pieralisi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20171113224001.29024.87126.stgit@bhelgaas-glaptop.roam.corp.google.com \
    --to=helgaas@kernel.org \
    --cc=lftan@altera.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=lorenzo.pieralisi@arm.com \
    --cc=michal.simek@xilinx.com \
    --cc=rfi@lists.rocketboards.org \
    --cc=soren.brinkmann@xilinx.com \
    --cc=tinamdar@apm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.