All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Darrick J. Wong" <darrick.wong@oracle.com>
To: Dave Chinner <david@fromorbit.com>
Cc: sandeen@redhat.com, linux-nfs@vger.kernel.org,
	linux-cifs@vger.kernel.org, linux-unionfs@vger.kernel.org,
	linux-xfs@vger.kernel.org, linux-mm@kvack.org,
	linux-btrfs@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	ocfs2-devel@oss.oracle.com
Subject: Re: [PATCH 24/25] xfs: support returning partial reflink results
Date: Fri, 12 Oct 2018 09:06:30 -0700	[thread overview]
Message-ID: <20181012160630.GE28243@magnolia> (raw)
In-Reply-To: <20181012012226.GT6311@dastard>

On Fri, Oct 12, 2018 at 12:22:26PM +1100, Dave Chinner wrote:
> On Wed, Oct 10, 2018 at 09:15:19PM -0700, Darrick J. Wong wrote:
> > From: Darrick J. Wong <darrick.wong@oracle.com>
> > 
> > Back when the XFS reflink code only supported clone_file_range, we were
> > only able to return zero or negative error codes to userspace.  However,
> > now that copy_file_range (which returns bytes copied) can use XFS'
> > clone_file_range, we have the opportunity to return partial results.
> > For example, if userspace sends a 1GB clone request and we run out of
> > space halfway through, we at least can tell userspace that we completed
> > 512M of that request like a regular write.
> > 
> > Signed-off-by: Darrick J. Wong <darrick.wong@oracle.com>
> > ---
> >  fs/xfs/xfs_file.c    |    5 +----
> >  fs/xfs/xfs_reflink.c |   19 ++++++++++++++-----
> >  fs/xfs/xfs_reflink.h |    2 +-
> >  3 files changed, 16 insertions(+), 10 deletions(-)
> > 
> > 
> > diff --git a/fs/xfs/xfs_file.c b/fs/xfs/xfs_file.c
> > index bc9e94bcb7a3..b2b15b8dc4a1 100644
> > --- a/fs/xfs/xfs_file.c
> > +++ b/fs/xfs/xfs_file.c
> > @@ -928,14 +928,11 @@ xfs_file_remap_range(
> >  	loff_t		len,
> >  	unsigned int	remap_flags)
> >  {
> > -	int		ret;
> > -
> >  	if (!remap_check_flags(remap_flags, RFR_SAME_DATA))
> >  		return -EINVAL;
> >  
> > -	ret = xfs_reflink_remap_range(file_in, pos_in, file_out, pos_out,
> > +	return xfs_reflink_remap_range(file_in, pos_in, file_out, pos_out,
> >  			len, remap_flags);
> > -	return ret < 0 ? ret : len;
> >  }
> >  
> >  STATIC int
> > diff --git a/fs/xfs/xfs_reflink.c b/fs/xfs/xfs_reflink.c
> > index e1592e751cc2..12a1fe92454e 100644
> > --- a/fs/xfs/xfs_reflink.c
> > +++ b/fs/xfs/xfs_reflink.c
> > @@ -1123,6 +1123,7 @@ xfs_reflink_remap_blocks(
> >  	struct xfs_inode	*dest,
> >  	xfs_fileoff_t		destoff,
> >  	xfs_filblks_t		len,
> > +	xfs_filblks_t		*remapped,
> >  	xfs_off_t		new_isize)
> >  {
> >  	struct xfs_bmbt_irec	imap;
> > @@ -1130,6 +1131,7 @@ xfs_reflink_remap_blocks(
> >  	int			error = 0;
> >  	xfs_filblks_t		range_len;
> >  
> > +	*remapped = 0;
> >  	/* drange = (destoff, destoff + len); srange = (srcoff, srcoff + len) */
> >  	while (len) {
> >  		uint		lock_mode;
> > @@ -1168,6 +1170,7 @@ xfs_reflink_remap_blocks(
> >  		srcoff += range_len;
> >  		destoff += range_len;
> >  		len -= range_len;
> > +		*remapped += range_len;
> >  	}
> 
> So "remapped" is a block count? Can we call this something like
> remap_len so it's obvious what it is tracking?

Ok.

> > @@ -1424,11 +1427,17 @@ xfs_reflink_remap_range(
> >  
> >  	trace_xfs_reflink_remap_range(src, pos_in, len, dest, pos_out);
> >  
> > +	if (len == 0) {
> > +		ret = 0;
> > +		goto out_unlock;
> > +	}
> > +
> >  	dfsbno = XFS_B_TO_FSBT(mp, pos_out);
> >  	sfsbno = XFS_B_TO_FSBT(mp, pos_in);
> >  	fsblen = XFS_B_TO_FSB(mp, len);
> >  	ret = xfs_reflink_remap_blocks(src, sfsbno, dest, dfsbno, fsblen,
> > -			pos_out + len);
> > +			&remapped, pos_out + len);
> > +	remapped = min_t(int64_t, len, XFS_FSB_TO_B(mp, remapped));
> 
> So remapped is returned as a block count, then immediately converted
> to a byte count? Can we return it as byte count so that we don't
> have this weird unit conversion?

But then we'd have a function whose inputs are in units of blocks but
whose return value is in units of bytes.

Maybe I'll just do this to make it more explicit:

xfs_filblks_t	remapped_blocks = 0;
loff_t		remapped_bytes = 0;

ret = xfs_reflink_remap_blocks(..., &remapped_blocks...);
remapped_bytes = min_t(int64_t, len, XFS_FSB_TO_B(mp, remapped_blocks));

...

return remapped_bytes > 0 ? remapped_bytes : ret;

--D

> Cheers,
> 
> Dave.
> -- 
> Dave Chinner
> david@fromorbit.com

WARNING: multiple messages have this Message-ID (diff)
From: Darrick J. Wong <darrick.wong@oracle.com>
To: Dave Chinner <david@fromorbit.com>
Cc: sandeen@redhat.com, linux-nfs@vger.kernel.org,
	linux-cifs@vger.kernel.org, linux-unionfs@vger.kernel.org,
	linux-xfs@vger.kernel.org, linux-mm@kvack.org,
	linux-btrfs@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	ocfs2-devel@oss.oracle.com
Subject: [Ocfs2-devel] [PATCH 24/25] xfs: support returning partial reflink results
Date: Fri, 12 Oct 2018 09:06:30 -0700	[thread overview]
Message-ID: <20181012160630.GE28243@magnolia> (raw)
In-Reply-To: <20181012012226.GT6311@dastard>

On Fri, Oct 12, 2018 at 12:22:26PM +1100, Dave Chinner wrote:
> On Wed, Oct 10, 2018 at 09:15:19PM -0700, Darrick J. Wong wrote:
> > From: Darrick J. Wong <darrick.wong@oracle.com>
> > 
> > Back when the XFS reflink code only supported clone_file_range, we were
> > only able to return zero or negative error codes to userspace.  However,
> > now that copy_file_range (which returns bytes copied) can use XFS'
> > clone_file_range, we have the opportunity to return partial results.
> > For example, if userspace sends a 1GB clone request and we run out of
> > space halfway through, we at least can tell userspace that we completed
> > 512M of that request like a regular write.
> > 
> > Signed-off-by: Darrick J. Wong <darrick.wong@oracle.com>
> > ---
> >  fs/xfs/xfs_file.c    |    5 +----
> >  fs/xfs/xfs_reflink.c |   19 ++++++++++++++-----
> >  fs/xfs/xfs_reflink.h |    2 +-
> >  3 files changed, 16 insertions(+), 10 deletions(-)
> > 
> > 
> > diff --git a/fs/xfs/xfs_file.c b/fs/xfs/xfs_file.c
> > index bc9e94bcb7a3..b2b15b8dc4a1 100644
> > --- a/fs/xfs/xfs_file.c
> > +++ b/fs/xfs/xfs_file.c
> > @@ -928,14 +928,11 @@ xfs_file_remap_range(
> >  	loff_t		len,
> >  	unsigned int	remap_flags)
> >  {
> > -	int		ret;
> > -
> >  	if (!remap_check_flags(remap_flags, RFR_SAME_DATA))
> >  		return -EINVAL;
> >  
> > -	ret = xfs_reflink_remap_range(file_in, pos_in, file_out, pos_out,
> > +	return xfs_reflink_remap_range(file_in, pos_in, file_out, pos_out,
> >  			len, remap_flags);
> > -	return ret < 0 ? ret : len;
> >  }
> >  
> >  STATIC int
> > diff --git a/fs/xfs/xfs_reflink.c b/fs/xfs/xfs_reflink.c
> > index e1592e751cc2..12a1fe92454e 100644
> > --- a/fs/xfs/xfs_reflink.c
> > +++ b/fs/xfs/xfs_reflink.c
> > @@ -1123,6 +1123,7 @@ xfs_reflink_remap_blocks(
> >  	struct xfs_inode	*dest,
> >  	xfs_fileoff_t		destoff,
> >  	xfs_filblks_t		len,
> > +	xfs_filblks_t		*remapped,
> >  	xfs_off_t		new_isize)
> >  {
> >  	struct xfs_bmbt_irec	imap;
> > @@ -1130,6 +1131,7 @@ xfs_reflink_remap_blocks(
> >  	int			error = 0;
> >  	xfs_filblks_t		range_len;
> >  
> > +	*remapped = 0;
> >  	/* drange = (destoff, destoff + len); srange = (srcoff, srcoff + len) */
> >  	while (len) {
> >  		uint		lock_mode;
> > @@ -1168,6 +1170,7 @@ xfs_reflink_remap_blocks(
> >  		srcoff += range_len;
> >  		destoff += range_len;
> >  		len -= range_len;
> > +		*remapped += range_len;
> >  	}
> 
> So "remapped" is a block count? Can we call this something like
> remap_len so it's obvious what it is tracking?

Ok.

> > @@ -1424,11 +1427,17 @@ xfs_reflink_remap_range(
> >  
> >  	trace_xfs_reflink_remap_range(src, pos_in, len, dest, pos_out);
> >  
> > +	if (len == 0) {
> > +		ret = 0;
> > +		goto out_unlock;
> > +	}
> > +
> >  	dfsbno = XFS_B_TO_FSBT(mp, pos_out);
> >  	sfsbno = XFS_B_TO_FSBT(mp, pos_in);
> >  	fsblen = XFS_B_TO_FSB(mp, len);
> >  	ret = xfs_reflink_remap_blocks(src, sfsbno, dest, dfsbno, fsblen,
> > -			pos_out + len);
> > +			&remapped, pos_out + len);
> > +	remapped = min_t(int64_t, len, XFS_FSB_TO_B(mp, remapped));
> 
> So remapped is returned as a block count, then immediately converted
> to a byte count? Can we return it as byte count so that we don't
> have this weird unit conversion?

But then we'd have a function whose inputs are in units of blocks but
whose return value is in units of bytes.

Maybe I'll just do this to make it more explicit:

xfs_filblks_t	remapped_blocks = 0;
loff_t		remapped_bytes = 0;

ret = xfs_reflink_remap_blocks(..., &remapped_blocks...);
remapped_bytes = min_t(int64_t, len, XFS_FSB_TO_B(mp, remapped_blocks));

...

return remapped_bytes > 0 ? remapped_bytes : ret;

--D

> Cheers,
> 
> Dave.
> -- 
> Dave Chinner
> david at fromorbit.com

  reply	other threads:[~2018-10-12 16:06 UTC|newest]

Thread overview: 98+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-11  4:12 [PATCH v3 00/25] fs: fixes for serious clone/dedupe problems Darrick J. Wong
2018-10-11  4:12 ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:12 ` [PATCH 01/25] xfs: add a per-xfs trace_printk macro Darrick J. Wong
2018-10-11  4:12   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11 13:39   ` Christoph Hellwig
2018-10-11 13:39     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-11 23:34     ` Darrick J. Wong
2018-10-11 23:34       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:12 ` [PATCH 02/25] vfs: vfs_clone_file_prep_inodes should return EINVAL for a clone from beyond EOF Darrick J. Wong
2018-10-11  4:12   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11 13:40   ` Christoph Hellwig
2018-10-11 13:40     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-11  4:12 ` [PATCH 03/25] vfs: check file ranges before cloning files Darrick J. Wong
2018-10-11  4:12   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11 13:42   ` Christoph Hellwig
2018-10-11 13:42     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-11 14:13     ` Amir Goldstein
2018-10-11  4:12 ` [PATCH 04/25] vfs: strengthen checking of file range inputs to generic_remap_checks Darrick J. Wong
2018-10-11  4:12   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11 13:43   ` Christoph Hellwig
2018-10-11 13:43     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-11  4:12 ` [PATCH 05/25] vfs: avoid problematic remapping requests into partial EOF block Darrick J. Wong
2018-10-11  4:12   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-12  0:16   ` Dave Chinner
2018-10-12  0:16     ` [Ocfs2-devel] " Dave Chinner
2018-10-12 16:07     ` Darrick J. Wong
2018-10-12 16:07       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-12 20:22   ` Filipe Manana
2018-10-12 20:22     ` Filipe Manana
2018-10-15  0:31     ` Dave Chinner
2018-10-15  0:31       ` [Ocfs2-devel] " Dave Chinner
2018-11-02 12:04       ` Filipe Manana
2018-11-02 12:04         ` Filipe Manana
2018-11-02 17:42         ` Darrick J. Wong
2018-11-02 17:42           ` Darrick J. Wong
2018-11-02 17:42           ` [Ocfs2-devel] " Darrick J. Wong
2018-11-02 18:18           ` Filipe Manana
2018-11-02 19:05             ` Filipe Manana
2018-10-11  4:13 ` [PATCH 06/25] vfs: skip zero-length dedupe requests Darrick J. Wong
2018-10-11  4:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:13 ` [PATCH 07/25] vfs: combine the clone and dedupe into a single remap_file_range Darrick J. Wong
2018-10-11  4:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:13 ` [PATCH 08/25] vfs: rename vfs_clone_file_prep to be more descriptive Darrick J. Wong
2018-10-11  4:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:13 ` [PATCH 09/25] vfs: rename clone_verify_area to remap_verify_area Darrick J. Wong
2018-10-11  4:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:13 ` [PATCH 10/25] vfs: create generic_remap_file_range_touch to update inode metadata Darrick J. Wong
2018-10-11  4:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:13 ` [PATCH 11/25] vfs: pass remap flags to generic_remap_file_range_prep Darrick J. Wong
2018-10-11  4:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:13 ` [PATCH 12/25] vfs: pass remap flags to generic_remap_checks Darrick J. Wong
2018-10-11  4:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:13 ` [PATCH 13/25] vfs: make remap_file_range functions take and return bytes completed Darrick J. Wong
2018-10-11  4:13   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:14 ` [PATCH 14/25] vfs: plumb RFR_* remap flags through the vfs clone functions Darrick J. Wong
2018-10-11  4:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:14 ` [PATCH 15/25] vfs: plumb RFR_* remap flags through the vfs dedupe functions Darrick J. Wong
2018-10-11  4:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:14 ` [PATCH 16/25] vfs: make remapping to source file eof more explicit Darrick J. Wong
2018-10-11  4:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:14 ` [PATCH 17/25] vfs: enable remap callers that can handle short operations Darrick J. Wong
2018-10-11  4:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  5:15   ` Amir Goldstein
2018-10-11 16:04     ` Darrick J. Wong
2018-10-11 16:04       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11 16:05   ` [PATCH v2 " Darrick J. Wong
2018-10-11 16:05     ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:14 ` [PATCH 18/25] vfs: hide file range comparison function Darrick J. Wong
2018-10-11  4:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:14 ` [PATCH 19/25] vfs: implement opportunistic short dedupe Darrick J. Wong
2018-10-11  4:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:14 ` [PATCH 20/25] ocfs2: truncate page cache for clone destination file before remapping Darrick J. Wong
2018-10-11  4:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:14 ` [PATCH 21/25] ocfs2: fix pagecache truncation prior to reflink Darrick J. Wong
2018-10-11  4:14   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:15 ` [PATCH 22/25] ocfs2: support partial clone range and dedupe range Darrick J. Wong
2018-10-11  4:15   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-11  4:15 ` [PATCH 23/25] xfs: fix pagecache truncation prior to reflink Darrick J. Wong
2018-10-11  4:15   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-12  1:15   ` Dave Chinner
2018-10-12  1:15     ` [Ocfs2-devel] " Dave Chinner
2018-10-11  4:15 ` [PATCH 24/25] xfs: support returning partial reflink results Darrick J. Wong
2018-10-11  4:15   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-12  1:22   ` Dave Chinner
2018-10-12  1:22     ` [Ocfs2-devel] " Dave Chinner
2018-10-12 16:06     ` Darrick J. Wong [this message]
2018-10-12 16:06       ` Darrick J. Wong
2018-10-11  4:15 ` [PATCH 25/25] xfs: remove redundant remap partial EOF block checks Darrick J. Wong
2018-10-11  4:15   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-12  1:22   ` Dave Chinner
2018-10-12  1:22     ` [Ocfs2-devel] " Dave Chinner
2018-10-11  8:33 ` [PATCH v3 00/25] fs: fixes for serious clone/dedupe problems Amir Goldstein
2018-10-11 15:55   ` Darrick J. Wong
2018-10-11 15:55     ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:05 [PATCH v4 " Darrick J. Wong
2018-10-13  0:08 ` [PATCH 24/25] xfs: support returning partial reflink results Darrick J. Wong
2018-10-14 17:35   ` Christoph Hellwig
2018-10-14 23:05     ` Dave Chinner
2018-10-15 15:49       ` Darrick J. Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181012160630.GE28243@magnolia \
    --to=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=linux-btrfs@vger.kernel.org \
    --cc=linux-cifs@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-nfs@vger.kernel.org \
    --cc=linux-unionfs@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=ocfs2-devel@oss.oracle.com \
    --cc=sandeen@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.