All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mark Rutland <mark.rutland@arm.com>
To: Pavel Tatashin <pasha.tatashin@soleen.com>
Cc: jmorris@namei.org, sashal@kernel.org, ebiederm@xmission.com,
	kexec@lists.infradead.org, linux-kernel@vger.kernel.org,
	corbet@lwn.net, catalin.marinas@arm.com, will@kernel.org,
	linux-arm-kernel@lists.infradead.org, marc.zyngier@arm.com,
	james.morse@arm.com, vladimir.murzin@arm.com,
	matthias.bgg@gmail.com, bhsharma@redhat.com, linux-mm@kvack.org
Subject: Re: [PATCH v2 02/14] arm64, hibernate: create_safe_exec_page cleanup
Date: Mon, 19 Aug 2019 16:50:14 +0100	[thread overview]
Message-ID: <20190819155014.GD9927@lakrids.cambridge.arm.com> (raw)
In-Reply-To: <20190817024629.26611-3-pasha.tatashin@soleen.com>

On Fri, Aug 16, 2019 at 10:46:17PM -0400, Pavel Tatashin wrote:
> create_safe_exec_page() is going to be split into two parts in preparation
> of moving page table handling code out of hibernate.c
> 
> Remove allocator parameter, and rename dst to page. Also, remove the
> goto's, as we can return directly without cleanups.

It would be nice if you could do the goto/allocator/rename changes as
separate patches, since it's vastly easier to verify each change in
isolation that way.

What's the point of the rename? It's inconsistent with the phys_dst_addr
that you leave as-is, so I'm not sure that's worthwhile.

> 
> Signed-off-by: Pavel Tatashin <pasha.tatashin@soleen.com>
> ---
>  arch/arm64/kernel/hibernate.c | 60 +++++++++++++++--------------------
>  1 file changed, 26 insertions(+), 34 deletions(-)
> 
> diff --git a/arch/arm64/kernel/hibernate.c b/arch/arm64/kernel/hibernate.c
> index 9341fcc6e809..96b6f8da7e49 100644
> --- a/arch/arm64/kernel/hibernate.c
> +++ b/arch/arm64/kernel/hibernate.c
> @@ -196,57 +196,51 @@ EXPORT_SYMBOL(arch_hibernation_header_restore);
>   */
>  static int create_safe_exec_page(void *src_start, size_t length,
>  				 unsigned long dst_addr,
> -				 phys_addr_t *phys_dst_addr,
> -				 void *(*allocator)(gfp_t mask),
> -				 gfp_t mask)
> +				 phys_addr_t *phys_dst_addr)
>  {
> -	int rc = 0;
> +	void *page = (void *)get_safe_page(GFP_ATOMIC);
> +	pgd_t *trans_table;

The addition of this trans_table variable wasn't mentioned in the commit
message...

> +	trans_table = (void *)get_safe_page(GFP_ATOMIC);
> +	if (!trans_table)
> +		return -ENOMEM;
>  
> -	pgdp = pgd_offset_raw(allocator(mask), dst_addr);
> +	pgdp = pgd_offset_raw(trans_table, dst_addr);

> -	write_sysreg(phys_to_ttbr(virt_to_phys(pgdp)), ttbr0_el1);
> +	write_sysreg(phys_to_ttbr(virt_to_phys(trans_table)), ttbr0_el1);


... and I guess you're trying to ensure that we program the TTBR with
the correct base address, without the offset of whatever pgd entry we
happen to have plumbed in?

I think that's a fix, and should come before any other cleanup or
rework.

If you can respin that specific change with s/trans_table/pgdir/, that
would make sense to me.

Thanks,
Mark.

WARNING: multiple messages have this Message-ID (diff)
From: Mark Rutland <mark.rutland@arm.com>
To: Pavel Tatashin <pasha.tatashin@soleen.com>
Cc: sashal@kernel.org, vladimir.murzin@arm.com, corbet@lwn.net,
	marc.zyngier@arm.com, catalin.marinas@arm.com,
	bhsharma@redhat.com, kexec@lists.infradead.org,
	linux-kernel@vger.kernel.org, jmorris@namei.org,
	linux-mm@kvack.org, james.morse@arm.com, ebiederm@xmission.com,
	matthias.bgg@gmail.com, will@kernel.org,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v2 02/14] arm64, hibernate: create_safe_exec_page cleanup
Date: Mon, 19 Aug 2019 16:50:14 +0100	[thread overview]
Message-ID: <20190819155014.GD9927@lakrids.cambridge.arm.com> (raw)
In-Reply-To: <20190817024629.26611-3-pasha.tatashin@soleen.com>

On Fri, Aug 16, 2019 at 10:46:17PM -0400, Pavel Tatashin wrote:
> create_safe_exec_page() is going to be split into two parts in preparation
> of moving page table handling code out of hibernate.c
> 
> Remove allocator parameter, and rename dst to page. Also, remove the
> goto's, as we can return directly without cleanups.

It would be nice if you could do the goto/allocator/rename changes as
separate patches, since it's vastly easier to verify each change in
isolation that way.

What's the point of the rename? It's inconsistent with the phys_dst_addr
that you leave as-is, so I'm not sure that's worthwhile.

> 
> Signed-off-by: Pavel Tatashin <pasha.tatashin@soleen.com>
> ---
>  arch/arm64/kernel/hibernate.c | 60 +++++++++++++++--------------------
>  1 file changed, 26 insertions(+), 34 deletions(-)
> 
> diff --git a/arch/arm64/kernel/hibernate.c b/arch/arm64/kernel/hibernate.c
> index 9341fcc6e809..96b6f8da7e49 100644
> --- a/arch/arm64/kernel/hibernate.c
> +++ b/arch/arm64/kernel/hibernate.c
> @@ -196,57 +196,51 @@ EXPORT_SYMBOL(arch_hibernation_header_restore);
>   */
>  static int create_safe_exec_page(void *src_start, size_t length,
>  				 unsigned long dst_addr,
> -				 phys_addr_t *phys_dst_addr,
> -				 void *(*allocator)(gfp_t mask),
> -				 gfp_t mask)
> +				 phys_addr_t *phys_dst_addr)
>  {
> -	int rc = 0;
> +	void *page = (void *)get_safe_page(GFP_ATOMIC);
> +	pgd_t *trans_table;

The addition of this trans_table variable wasn't mentioned in the commit
message...

> +	trans_table = (void *)get_safe_page(GFP_ATOMIC);
> +	if (!trans_table)
> +		return -ENOMEM;
>  
> -	pgdp = pgd_offset_raw(allocator(mask), dst_addr);
> +	pgdp = pgd_offset_raw(trans_table, dst_addr);

> -	write_sysreg(phys_to_ttbr(virt_to_phys(pgdp)), ttbr0_el1);
> +	write_sysreg(phys_to_ttbr(virt_to_phys(trans_table)), ttbr0_el1);


... and I guess you're trying to ensure that we program the TTBR with
the correct base address, without the offset of whatever pgd entry we
happen to have plumbed in?

I think that's a fix, and should come before any other cleanup or
rework.

If you can respin that specific change with s/trans_table/pgdir/, that
would make sense to me.

Thanks,
Mark.

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

WARNING: multiple messages have this Message-ID (diff)
From: Mark Rutland <mark.rutland@arm.com>
To: Pavel Tatashin <pasha.tatashin@soleen.com>
Cc: sashal@kernel.org, vladimir.murzin@arm.com, corbet@lwn.net,
	marc.zyngier@arm.com, catalin.marinas@arm.com,
	bhsharma@redhat.com, kexec@lists.infradead.org,
	linux-kernel@vger.kernel.org, jmorris@namei.org,
	linux-mm@kvack.org, james.morse@arm.com, ebiederm@xmission.com,
	matthias.bgg@gmail.com, will@kernel.org,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v2 02/14] arm64, hibernate: create_safe_exec_page cleanup
Date: Mon, 19 Aug 2019 16:50:14 +0100	[thread overview]
Message-ID: <20190819155014.GD9927@lakrids.cambridge.arm.com> (raw)
In-Reply-To: <20190817024629.26611-3-pasha.tatashin@soleen.com>

On Fri, Aug 16, 2019 at 10:46:17PM -0400, Pavel Tatashin wrote:
> create_safe_exec_page() is going to be split into two parts in preparation
> of moving page table handling code out of hibernate.c
> 
> Remove allocator parameter, and rename dst to page. Also, remove the
> goto's, as we can return directly without cleanups.

It would be nice if you could do the goto/allocator/rename changes as
separate patches, since it's vastly easier to verify each change in
isolation that way.

What's the point of the rename? It's inconsistent with the phys_dst_addr
that you leave as-is, so I'm not sure that's worthwhile.

> 
> Signed-off-by: Pavel Tatashin <pasha.tatashin@soleen.com>
> ---
>  arch/arm64/kernel/hibernate.c | 60 +++++++++++++++--------------------
>  1 file changed, 26 insertions(+), 34 deletions(-)
> 
> diff --git a/arch/arm64/kernel/hibernate.c b/arch/arm64/kernel/hibernate.c
> index 9341fcc6e809..96b6f8da7e49 100644
> --- a/arch/arm64/kernel/hibernate.c
> +++ b/arch/arm64/kernel/hibernate.c
> @@ -196,57 +196,51 @@ EXPORT_SYMBOL(arch_hibernation_header_restore);
>   */
>  static int create_safe_exec_page(void *src_start, size_t length,
>  				 unsigned long dst_addr,
> -				 phys_addr_t *phys_dst_addr,
> -				 void *(*allocator)(gfp_t mask),
> -				 gfp_t mask)
> +				 phys_addr_t *phys_dst_addr)
>  {
> -	int rc = 0;
> +	void *page = (void *)get_safe_page(GFP_ATOMIC);
> +	pgd_t *trans_table;

The addition of this trans_table variable wasn't mentioned in the commit
message...

> +	trans_table = (void *)get_safe_page(GFP_ATOMIC);
> +	if (!trans_table)
> +		return -ENOMEM;
>  
> -	pgdp = pgd_offset_raw(allocator(mask), dst_addr);
> +	pgdp = pgd_offset_raw(trans_table, dst_addr);

> -	write_sysreg(phys_to_ttbr(virt_to_phys(pgdp)), ttbr0_el1);
> +	write_sysreg(phys_to_ttbr(virt_to_phys(trans_table)), ttbr0_el1);


... and I guess you're trying to ensure that we program the TTBR with
the correct base address, without the offset of whatever pgd entry we
happen to have plumbed in?

I think that's a fix, and should come before any other cleanup or
rework.

If you can respin that specific change with s/trans_table/pgdir/, that
would make sense to me.

Thanks,
Mark.

_______________________________________________
kexec mailing list
kexec@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/kexec

  reply	other threads:[~2019-08-19 15:50 UTC|newest]

Thread overview: 66+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-17  2:46 [PATCH v2 00/14] arm64: MMU enabled kexec relocation Pavel Tatashin
2019-08-17  2:46 ` Pavel Tatashin
2019-08-17  2:46 ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 01/14] kexec: quiet down kexec reboot Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 02/14] arm64, hibernate: create_safe_exec_page cleanup Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-19 15:50   ` Mark Rutland [this message]
2019-08-19 15:50     ` Mark Rutland
2019-08-19 15:50     ` Mark Rutland
2019-08-19 16:25     ` Pavel Tatashin
2019-08-19 16:25       ` Pavel Tatashin
2019-08-19 16:25       ` Pavel Tatashin
2019-08-19 16:25       ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 03/14] arm64, hibernate: add trans_table public functions Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-19 15:58   ` Mark Rutland
2019-08-19 15:58     ` Mark Rutland
2019-08-19 15:58     ` Mark Rutland
2019-08-19 16:33     ` Pavel Tatashin
2019-08-19 16:33       ` Pavel Tatashin
2019-08-19 16:33       ` Pavel Tatashin
2019-08-19 16:33       ` Pavel Tatashin
2019-08-20 11:30       ` Mark Rutland
2019-08-20 11:30         ` Mark Rutland
2019-08-20 11:30         ` Mark Rutland
2019-08-20 11:41         ` Pavel Tatashin
2019-08-20 11:41           ` Pavel Tatashin
2019-08-20 11:41           ` Pavel Tatashin
2019-08-20 11:41           ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 04/14] arm64, hibernate: move page handling function to new trans_table.c Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 05/14] arm64, trans_table: make trans_table_map_page generic Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 06/14] arm64, trans_table: add trans_table_create_empty Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 07/14] arm64, trans_table: adjust trans_table_create_copy interface Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 08/14] arm64, trans_table: add PUD_SECT_RDONLY Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 09/14] arm64, trans_table: complete generalization of trans_tables Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 10/14] kexec: add machine_kexec_post_load() Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 11/14] arm64, kexec: move relocation function setup and clean up Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 12/14] arm64, kexec: add expandable argument to relocation function Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 13/14] arm64, kexec: configure transitional page table for kexec Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46 ` [PATCH v2 14/14] arm64, kexec: enable MMU during kexec relocation Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin
2019-08-17  2:46   ` Pavel Tatashin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190819155014.GD9927@lakrids.cambridge.arm.com \
    --to=mark.rutland@arm.com \
    --cc=bhsharma@redhat.com \
    --cc=catalin.marinas@arm.com \
    --cc=corbet@lwn.net \
    --cc=ebiederm@xmission.com \
    --cc=james.morse@arm.com \
    --cc=jmorris@namei.org \
    --cc=kexec@lists.infradead.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=marc.zyngier@arm.com \
    --cc=matthias.bgg@gmail.com \
    --cc=pasha.tatashin@soleen.com \
    --cc=sashal@kernel.org \
    --cc=vladimir.murzin@arm.com \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.