All of lore.kernel.org
 help / color / mirror / Atom feed
From: Masami Hiramatsu <mhiramat@kernel.org>
To: Christoph Hellwig <hch@lst.de>
Cc: x86@kernel.org, Alexei Starovoitov <ast@kernel.org>,
	Daniel Borkmann <daniel@iogearbox.net>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	linux-parisc@vger.kernel.org, linux-um@lists.infradead.org,
	netdev@vger.kernel.org, bpf@vger.kernel.org, linux-mm@kvack.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 13/20] maccess: always use strict semantics for probe_kernel_read
Date: Wed, 20 May 2020 20:11:26 +0900	[thread overview]
Message-ID: <20200520201126.f37d3b1e46355199216404e2@kernel.org> (raw)
In-Reply-To: <20200519134449.1466624-14-hch@lst.de>

On Tue, 19 May 2020 15:44:42 +0200
Christoph Hellwig <hch@lst.de> wrote:

> diff --git a/kernel/trace/trace_kprobe.c b/kernel/trace/trace_kprobe.c
> index 2f6737cc53e6c..82da20e712507 100644
> --- a/kernel/trace/trace_kprobe.c
> +++ b/kernel/trace/trace_kprobe.c
> @@ -1208,7 +1208,13 @@ fetch_store_strlen(unsigned long addr)
>  	u8 c;
>  
>  	do {
> -		ret = probe_kernel_read(&c, (u8 *)addr + len, 1);
> +		if (IS_ENABLED(CONFIG_ARCH_HAS_NON_OVERLAPPING_ADDRESS_SPACE) &&
> +		    (unsigned long)addr < TASK_SIZE) {
> +			ret = probe_user_read(&c,
> +				(__force u8 __user *)addr + len, 1);
> +		} else {
> +			ret = probe_kernel_read(&c, (u8 *)addr + len, 1);
> +		}
>  		len++;
>  	} while (c && ret == 0 && len < MAX_STRING_SIZE);

To avoid redundant check in the loop, we can use strnlen_user_nofault() out of
the loop. Something like below.

...
	u8 c;

	if (IS_ENABLED(CONFIG_ARCH_HAS_NON_OVERLAPPING_ADDRESS_SPACE) &&
	    (unsigned long)addr < TASK_SIZE) {
		return strnlen_user_nofault((__force u8 __user *)addr, MAX_STRING_SIZE);

	do {
		ret = probe_kernel_read(&c, (u8 *)addr + len, 1);
		len++;
	} while (c && ret == 0 && len < MAX_STRING_SIZE);
...

This must work because we must not have a string that continues across
kernel space and user space.

Thank you,


-- 
Masami Hiramatsu <mhiramat@kernel.org>

WARNING: multiple messages have this Message-ID (diff)
From: Masami Hiramatsu <mhiramat@kernel.org>
To: Christoph Hellwig <hch@lst.de>
Cc: linux-parisc@vger.kernel.org,
	Daniel Borkmann <daniel@iogearbox.net>,
	netdev@vger.kernel.org, x86@kernel.org,
	linux-um@lists.infradead.org, Alexei Starovoitov <ast@kernel.org>,
	linux-kernel@vger.kernel.org, linux-mm@kvack.org,
	Andrew Morton <akpm@linux-foundation.org>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	bpf@vger.kernel.org
Subject: Re: [PATCH 13/20] maccess: always use strict semantics for probe_kernel_read
Date: Wed, 20 May 2020 20:11:26 +0900	[thread overview]
Message-ID: <20200520201126.f37d3b1e46355199216404e2@kernel.org> (raw)
In-Reply-To: <20200519134449.1466624-14-hch@lst.de>

On Tue, 19 May 2020 15:44:42 +0200
Christoph Hellwig <hch@lst.de> wrote:

> diff --git a/kernel/trace/trace_kprobe.c b/kernel/trace/trace_kprobe.c
> index 2f6737cc53e6c..82da20e712507 100644
> --- a/kernel/trace/trace_kprobe.c
> +++ b/kernel/trace/trace_kprobe.c
> @@ -1208,7 +1208,13 @@ fetch_store_strlen(unsigned long addr)
>  	u8 c;
>  
>  	do {
> -		ret = probe_kernel_read(&c, (u8 *)addr + len, 1);
> +		if (IS_ENABLED(CONFIG_ARCH_HAS_NON_OVERLAPPING_ADDRESS_SPACE) &&
> +		    (unsigned long)addr < TASK_SIZE) {
> +			ret = probe_user_read(&c,
> +				(__force u8 __user *)addr + len, 1);
> +		} else {
> +			ret = probe_kernel_read(&c, (u8 *)addr + len, 1);
> +		}
>  		len++;
>  	} while (c && ret == 0 && len < MAX_STRING_SIZE);

To avoid redundant check in the loop, we can use strnlen_user_nofault() out of
the loop. Something like below.

...
	u8 c;

	if (IS_ENABLED(CONFIG_ARCH_HAS_NON_OVERLAPPING_ADDRESS_SPACE) &&
	    (unsigned long)addr < TASK_SIZE) {
		return strnlen_user_nofault((__force u8 __user *)addr, MAX_STRING_SIZE);

	do {
		ret = probe_kernel_read(&c, (u8 *)addr + len, 1);
		len++;
	} while (c && ret == 0 && len < MAX_STRING_SIZE);
...

This must work because we must not have a string that continues across
kernel space and user space.

Thank you,


-- 
Masami Hiramatsu <mhiramat@kernel.org>

_______________________________________________
linux-um mailing list
linux-um@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-um

  parent reply	other threads:[~2020-05-20 11:11 UTC|newest]

Thread overview: 72+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-19 13:44 clean up and streamline probe_kernel_* and friends v3 Christoph Hellwig
2020-05-19 13:44 ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 01/20] maccess: unexport probe_kernel_write and probe_user_write Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 02/20] maccess: remove various unused weak aliases Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 03/20] maccess: remove duplicate kerneldoc comments Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 04/20] maccess: clarify " Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 05/20] maccess: update the top of file comment Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 06/20] maccess: rename strncpy_from_unsafe_user to strncpy_from_user_nofault Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 07/20] maccess: rename strncpy_from_unsafe_strict to strncpy_from_kernel_nofault Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 08/20] maccess: rename strnlen_unsafe_user to strnlen_user_nofault Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 09/20] maccess: remove probe_read_common and probe_write_common Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 10/20] maccess: unify the probe kernel arch hooks Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 11/20] bpf: factor out a bpf_trace_copy_string helper Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 16:07   ` Linus Torvalds
2020-05-19 16:07     ` Linus Torvalds
2020-05-19 16:07     ` Linus Torvalds
2020-05-19 16:14     ` Christoph Hellwig
2020-05-19 16:14       ` Christoph Hellwig
2020-05-19 16:36       ` Linus Torvalds
2020-05-19 16:36         ` Linus Torvalds
2020-05-19 16:36         ` Linus Torvalds
2020-05-19 13:44 ` [PATCH 12/20] maccess: remove strncpy_from_unsafe Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 16:25   ` Linus Torvalds
2020-05-19 16:25     ` Linus Torvalds
2020-05-19 16:25     ` Linus Torvalds
2020-05-19 16:41     ` Christoph Hellwig
2020-05-19 16:41       ` Christoph Hellwig
2020-05-19 16:46       ` Linus Torvalds
2020-05-19 16:46         ` Linus Torvalds
2020-05-19 16:46         ` Linus Torvalds
2020-05-19 13:44 ` [PATCH 13/20] maccess: always use strict semantics for probe_kernel_read Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 16:33   ` Linus Torvalds
2020-05-19 16:33     ` Linus Torvalds
2020-05-19 16:33     ` Linus Torvalds
2020-05-20 11:11   ` Masami Hiramatsu [this message]
2020-05-20 11:11     ` Masami Hiramatsu
2020-05-20 11:13     ` Christoph Hellwig
2020-05-20 11:13       ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 14/20] maccess: move user access routines together Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 15/20] maccess: allow architectures to provide kernel probing directly Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 16/20] x86: use non-set_fs based maccess routines Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 17/20] maccess: rename probe_kernel_{read,write} to copy_{from,to}_kernel_nofault Christoph Hellwig
2020-05-19 13:44   ` [PATCH 17/20] maccess: rename probe_kernel_{read, write} to copy_{from, to}_kernel_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 18/20] maccess: rename probe_user_{read,write} to copy_{from,to}_user_nofault Christoph Hellwig
2020-05-19 13:44   ` [PATCH 18/20] maccess: rename probe_user_{read, write} to copy_{from, to}_user_nofault Christoph Hellwig
2020-05-19 13:44 ` [PATCH 19/20] maccess: rename probe_kernel_address to get_kernel_nofault Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-19 13:44 ` [PATCH 20/20] maccess: return -ERANGE when copy_from_kernel_nofault_allowed fails Christoph Hellwig
2020-05-19 13:44   ` Christoph Hellwig
2020-05-20 11:02   ` Masami Hiramatsu
2020-05-20 11:02     ` Masami Hiramatsu
2020-05-20 16:16     ` Christoph Hellwig
2020-05-20 16:16       ` Christoph Hellwig
2020-05-19 16:34 ` clean up and streamline probe_kernel_* and friends v3 Linus Torvalds
2020-05-19 16:34   ` Linus Torvalds
2020-05-19 16:34   ` Linus Torvalds

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200520201126.f37d3b1e46355199216404e2@kernel.org \
    --to=mhiramat@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=ast@kernel.org \
    --cc=bpf@vger.kernel.org \
    --cc=daniel@iogearbox.net \
    --cc=hch@lst.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linux-um@lists.infradead.org \
    --cc=netdev@vger.kernel.org \
    --cc=torvalds@linux-foundation.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.