All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jonathan Cameron <jic23@kernel.org>
To: Lee Jones <lee.jones@linaro.org>
Cc: knaack.h@gmx.de, lars@metafoo.de, pmeerw@pmeerw.net,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org, linux-iio@vger.kernel.org,
	Josef Gajdusek <atx@atx.name>
Subject: Re: [PATCH 04/30] iio: magnetometer: hmc5843: 'hmc5843_pm_ops' is unused in 1 of 3 files including hmc5843_core.h
Date: Sat, 18 Jul 2020 16:34:58 +0100	[thread overview]
Message-ID: <20200718163458.458ea23d@archlinux> (raw)
In-Reply-To: <20200717165538.3275050-5-lee.jones@linaro.org>

On Fri, 17 Jul 2020 17:55:12 +0100
Lee Jones <lee.jones@linaro.org> wrote:

> We know that it's okay for 'hmc5843_pm_ops' to be unused here.
> 
> Fixes the following W=1 kernel build warning(s):
> 
>  In file included from include/linux/device.h:25,
>  from include/linux/iio/iio.h:10,
>  from drivers/iio/magnetometer/hmc5843_core.c:16:
>  drivers/iio/magnetometer/hmc5843.h:55:26: warning: ‘hmc5843_pm_ops’ defined but not used [-Wunused-const-variable=]
>  55 | static SIMPLE_DEV_PM_OPS(hmc5843_pm_ops,
>  | ^~~~~~~~~~~~~~
>  include/linux/pm.h:354:25: note: in definition of macro ‘SIMPLE_DEV_PM_OPS’
>  354 | const struct dev_pm_ops name = { | ^~~~
> 
> Cc: Josef Gajdusek <atx@atx.name>
> Signed-off-by: Lee Jones <lee.jones@linaro.org>
Seems like a sensible solution to me.

Applied to the togreg branch of iio.git an pushed out as testing to see if
we missed anything.

Thanks,

Jonathan

> ---
>  drivers/iio/magnetometer/hmc5843.h | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/iio/magnetometer/hmc5843.h b/drivers/iio/magnetometer/hmc5843.h
> index b0dee87a8b20e..3f6c0b6629415 100644
> --- a/drivers/iio/magnetometer/hmc5843.h
> +++ b/drivers/iio/magnetometer/hmc5843.h
> @@ -52,9 +52,9 @@ int hmc5843_common_suspend(struct device *dev);
>  int hmc5843_common_resume(struct device *dev);
>  
>  #ifdef CONFIG_PM_SLEEP
> -static SIMPLE_DEV_PM_OPS(hmc5843_pm_ops,
> -		hmc5843_common_suspend,
> -		hmc5843_common_resume);
> +static __maybe_unused SIMPLE_DEV_PM_OPS(hmc5843_pm_ops,
> +					hmc5843_common_suspend,
> +					hmc5843_common_resume);
>  #define HMC5843_PM_OPS (&hmc5843_pm_ops)
>  #else
>  #define HMC5843_PM_OPS NULL


WARNING: multiple messages have this Message-ID (diff)
From: Jonathan Cameron <jic23@kernel.org>
To: Lee Jones <lee.jones@linaro.org>
Cc: lars@metafoo.de, Josef Gajdusek <atx@atx.name>,
	linux-iio@vger.kernel.org, linux-kernel@vger.kernel.org,
	pmeerw@pmeerw.net, knaack.h@gmx.de,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH 04/30] iio: magnetometer: hmc5843: 'hmc5843_pm_ops' is unused in 1 of 3 files including hmc5843_core.h
Date: Sat, 18 Jul 2020 16:34:58 +0100	[thread overview]
Message-ID: <20200718163458.458ea23d@archlinux> (raw)
In-Reply-To: <20200717165538.3275050-5-lee.jones@linaro.org>

On Fri, 17 Jul 2020 17:55:12 +0100
Lee Jones <lee.jones@linaro.org> wrote:

> We know that it's okay for 'hmc5843_pm_ops' to be unused here.
> 
> Fixes the following W=1 kernel build warning(s):
> 
>  In file included from include/linux/device.h:25,
>  from include/linux/iio/iio.h:10,
>  from drivers/iio/magnetometer/hmc5843_core.c:16:
>  drivers/iio/magnetometer/hmc5843.h:55:26: warning: ‘hmc5843_pm_ops’ defined but not used [-Wunused-const-variable=]
>  55 | static SIMPLE_DEV_PM_OPS(hmc5843_pm_ops,
>  | ^~~~~~~~~~~~~~
>  include/linux/pm.h:354:25: note: in definition of macro ‘SIMPLE_DEV_PM_OPS’
>  354 | const struct dev_pm_ops name = { | ^~~~
> 
> Cc: Josef Gajdusek <atx@atx.name>
> Signed-off-by: Lee Jones <lee.jones@linaro.org>
Seems like a sensible solution to me.

Applied to the togreg branch of iio.git an pushed out as testing to see if
we missed anything.

Thanks,

Jonathan

> ---
>  drivers/iio/magnetometer/hmc5843.h | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/iio/magnetometer/hmc5843.h b/drivers/iio/magnetometer/hmc5843.h
> index b0dee87a8b20e..3f6c0b6629415 100644
> --- a/drivers/iio/magnetometer/hmc5843.h
> +++ b/drivers/iio/magnetometer/hmc5843.h
> @@ -52,9 +52,9 @@ int hmc5843_common_suspend(struct device *dev);
>  int hmc5843_common_resume(struct device *dev);
>  
>  #ifdef CONFIG_PM_SLEEP
> -static SIMPLE_DEV_PM_OPS(hmc5843_pm_ops,
> -		hmc5843_common_suspend,
> -		hmc5843_common_resume);
> +static __maybe_unused SIMPLE_DEV_PM_OPS(hmc5843_pm_ops,
> +					hmc5843_common_suspend,
> +					hmc5843_common_resume);
>  #define HMC5843_PM_OPS (&hmc5843_pm_ops)
>  #else
>  #define HMC5843_PM_OPS NULL


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2020-07-18 15:35 UTC|newest]

Thread overview: 131+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-17 16:55 [PATCH 00/30] Second batch of W=1 fixes for IIO Lee Jones
2020-07-17 16:55 ` Lee Jones
2020-07-17 16:55 ` [PATCH 01/30] iio: adc: ti_am335x_adc: Remove a couple of unused 'read' variables Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:30   ` Jonathan Cameron
2020-07-18 15:30     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 02/30] iio: adc: twl4030-madc: Remove set but unused variables 'len' Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:32   ` Jonathan Cameron
2020-07-18 15:32     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 03/30] iio: adc: twl4030-madc: Fix misnamed struct attribute Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:33   ` Jonathan Cameron
2020-07-18 15:33     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 04/30] iio: magnetometer: hmc5843: 'hmc5843_pm_ops' is unused in 1 of 3 files including hmc5843_core.h Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:34   ` Jonathan Cameron [this message]
2020-07-18 15:34     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 05/30] iio: adc: twl6030-gpadc: Fix some misdocumentation and formatting issues Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:38   ` Jonathan Cameron
2020-07-18 15:38     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 06/30] iio: dac: ltc2632: Fix formatting in kerneldoc struct header Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:39   ` Jonathan Cameron
2020-07-18 15:39     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 07/30] iio: light: si1145: Demote obvious misuse of kerneldoc to standard comment blocks Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:40   ` Jonathan Cameron
2020-07-18 15:40     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 08/30] iio: resolver: ad2s1200: Change ordering of compiler attribute macro Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:41   ` Jonathan Cameron
2020-07-18 15:41     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 09/30] iio: temperature: mlx90632: Function parameter descriptions must match exactly Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-17 19:48   ` Crt Mori
2020-07-17 19:48     ` Crt Mori
2020-07-18 15:42     ` Jonathan Cameron
2020-07-18 15:42       ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 10/30] iio: light: us5182d: Fix formatting in kerneldoc function block Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:44   ` Jonathan Cameron
2020-07-18 15:44     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 11/30] iio: adc: ad799x: Demote seemingly unintentional kerneldoc header Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:47   ` Jonathan Cameron
2020-07-18 15:47     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 12/30] iio: dac: ad5504: Fix formatting errors and demote non-compliant kerneldoc Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:48   ` Jonathan Cameron
2020-07-18 15:48     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 13/30] iio: adc: at91_adc: Fix 'bad line' warning Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:48   ` Jonathan Cameron
2020-07-18 15:48     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 14/30] iio: adc: at91-sama5d2_adc: Struct kerneldoc titles need to start with 'struct ' Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:49   ` Jonathan Cameron
2020-07-18 15:49     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 15/30] iio: adc: cpcap-adc: Demote seemingly unintentional kerneldoc header Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:50   ` Jonathan Cameron
2020-07-18 15:50     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 16/30] iio: accel: sca3000: Fix 2 misspellings and demote nonconforming kerneldocs Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:51   ` Jonathan Cameron
2020-07-18 15:51     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 17/30] iio: gyro: adxrs450: Change ordering of compiler attribute macro Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:52   ` Jonathan Cameron
2020-07-18 15:52     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 18/30] iio: gyro: fxas21002c: Move 'fxas21002c_reg_fields' to the only file its used Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:54   ` Jonathan Cameron
2020-07-18 15:54     ` Jonathan Cameron
2020-07-22 20:20   ` Rui Miguel Silva
2020-07-22 20:20     ` Rui Miguel Silva
2020-07-17 16:55 ` [PATCH 19/30] iio: imu: st_lsm6dsx: st_lsm6dsx: Reorder 'inline' declaration Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:54   ` Jonathan Cameron
2020-07-18 15:54     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 20/30] iio: adc: max1363: Fix kerneldoc attribute formatting for 'lock' Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:56   ` Jonathan Cameron
2020-07-18 15:56     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 21/30] iio: adc: max9611: Demote obvious misuse of kerneldoc to standard comment blocks Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 15:59   ` Jonathan Cameron
2020-07-18 15:59     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 22/30] iio: adc: mcp320x: Change ordering of compiler attribute macro Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 16:00   ` Jonathan Cameron
2020-07-18 16:00     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 23/30] iio: adc: palmas_gpadc: Demote non-conforming kerneldoc header Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 16:01   ` Jonathan Cameron
2020-07-18 16:01     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 24/30] iio: imu: inv_mpu6050: inv_mpu_core: Demote obvious misuse of kerneldoc to standard comment blocks Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 16:02   ` Jonathan Cameron
2020-07-18 16:02     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 25/30] iio: imu: inv_mpu6050: inv_mpu_ring: Demote seemingly unintentional kerneldoc header Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 16:03   ` Jonathan Cameron
2020-07-18 16:03     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 26/30] iio: adc: qcom-pm8xxx-xoadc: Demote standard comment block and supply missing description Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-17 20:15   ` Bjorn Andersson
2020-07-17 20:15     ` Bjorn Andersson
2020-07-18 16:06     ` Jonathan Cameron
2020-07-18 16:06       ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 27/30] iio: magnetometer: ak8974: Add description for ak8974's 'scan' attribute Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 16:08   ` Jonathan Cameron
2020-07-18 16:08     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 28/30] iio: imu: st_lsm6dsx: st_lsm6dsx_shub: Demote obvious misuse of kerneldoc to standard comment blocks Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 16:13   ` Jonathan Cameron
2020-07-18 16:13     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 29/30] iio: imu: st_lsm6dsx: st_lsm6dsx: Mark 'st_lsm6dsx_accel_ext_info' as __maybe_unused Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-18 16:14   ` Jonathan Cameron
2020-07-18 16:14     ` Jonathan Cameron
2020-07-17 16:55 ` [PATCH 30/30] iio: adc: rockchip_saradc: Demote Demote seemingly unintentional kerneldoc header Lee Jones
2020-07-17 16:55   ` Lee Jones
2020-07-17 19:10   ` Heiko Stübner
2020-07-17 19:10     ` Heiko Stübner
2020-07-17 19:10     ` Heiko Stübner
2020-07-18 16:15     ` Jonathan Cameron
2020-07-18 16:15       ` Jonathan Cameron

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200718163458.458ea23d@archlinux \
    --to=jic23@kernel.org \
    --cc=atx@atx.name \
    --cc=knaack.h@gmx.de \
    --cc=lars@metafoo.de \
    --cc=lee.jones@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pmeerw@pmeerw.net \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.