All of lore.kernel.org
 help / color / mirror / Atom feed
From: Krzysztof Kozlowski <krzk@kernel.org>
To: Tomasz Duszynski <tomasz.duszynski@octakon.com>
Cc: Jonathan Cameron <jic23@kernel.org>,
	Hartmut Knaack <knaack.h@gmx.de>,
	Lars-Peter Clausen <lars@metafoo.de>,
	Peter Meerwald-Stadler <pmeerw@pmeerw.net>,
	Peter Rosin <peda@axentia.se>, Kukjin Kim <kgene@kernel.org>,
	Michael Hennerich <Michael.Hennerich@analog.com>,
	Kevin Hilman <khilman@baylibre.com>,
	Neil Armstrong <narmstrong@baylibre.com>,
	Jerome Brunet <jbrunet@baylibre.com>,
	Martin Blumenstingl <martin.blumenstingl@googlemail.com>,
	Marek Vasut <marek.vasut@gmail.com>,
	Maxime Coquelin <mcoquelin.stm32@gmail.com>,
	Alexandre Torgue <alexandre.torgue@st.com>,
	Beniamin Bia <beniamin.bia@analog.com>,
	Linus Walleij <linus.walleij@linaro.org>,
	Jonathan Bakker <xc-racer2@live.ca>,
	Alexandru Ardelean <alexandru.ardelean@analog.com>,
	linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,
	linux-samsung-soc@vger.kernel.org,
	linux-amlogic@lists.infradead.org,
	linux-stm32@st-md-mailman.stormreply.com
Subject: Re: [PATCH 11/16] iio: chemical: scd30: Simplify with dev_err_probe()
Date: Wed, 26 Aug 2020 17:57:23 +0200	[thread overview]
Message-ID: <20200826155723.GA31748@kozik-lap> (raw)
In-Reply-To: <20200826153434.GA7468@arch>

On Wed, Aug 26, 2020 at 05:34:34PM +0200, Tomasz Duszynski wrote:
> On Wed, Aug 26, 2020 at 04:51:48PM +0200, Krzysztof Kozlowski wrote:
> > Common pattern of handling deferred probe can be simplified with
> > dev_err_probe().  Less code and also it prints the error value.
> >
> > Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> > ---
> >  drivers/iio/chemical/scd30_core.c | 10 +++-------
> >  1 file changed, 3 insertions(+), 7 deletions(-)
> >
> > diff --git a/drivers/iio/chemical/scd30_core.c b/drivers/iio/chemical/scd30_core.c
> > index eac76972f83e..92358797796d 100644
> > --- a/drivers/iio/chemical/scd30_core.c
> > +++ b/drivers/iio/chemical/scd30_core.c
> > @@ -705,13 +705,9 @@ int scd30_probe(struct device *dev, int irq, const char *name, void *priv,
> >  	indio_dev->available_scan_masks = scd30_scan_masks;
> >
> >  	state->vdd = devm_regulator_get(dev, "vdd");
> > -	if (IS_ERR(state->vdd)) {
> > -		if (PTR_ERR(state->vdd) == -EPROBE_DEFER)
> > -			return -EPROBE_DEFER;
> > -
> > -		dev_err(dev, "failed to get regulator\n");
> > -		return PTR_ERR(state->vdd);
> > -	}
> > +	if (IS_ERR(state->vdd))
> > +		return dev_err_probe(dev, PTR_ERR(state->vdd),
> > +				     "failed to get regulator\n");
> 
> I'd say that removing like break would slightly improve readability.
> Besides, staying within 100 columns seems socially acceptable now.
> Otherwise,
> 
> Acked-by: Tomasz Duszynski <tomasz.duszynski@octakon.com>

Indeed. Although 80 is still mentioned as preferred (in commit bdc48fa11
and in coding style) but here having longer line would be better.

I guess this could be fixed up easily when applying but if resend is
wanted, let me know.

Best regards,
Krzysztof

WARNING: multiple messages have this Message-ID (diff)
From: Krzysztof Kozlowski <krzk@kernel.org>
To: Tomasz Duszynski <tomasz.duszynski@octakon.com>
Cc: Neil Armstrong <narmstrong@baylibre.com>,
	Jonathan Bakker <xc-racer2@live.ca>,
	Peter Meerwald-Stadler <pmeerw@pmeerw.net>,
	linux-stm32@st-md-mailman.stormreply.com,
	Jerome Brunet <jbrunet@baylibre.com>,
	linux-samsung-soc@vger.kernel.org,
	Kevin Hilman <khilman@baylibre.com>,
	Marek Vasut <marek.vasut@gmail.com>,
	Kukjin Kim <kgene@kernel.org>,
	Alexandru Ardelean <alexandru.ardelean@analog.com>,
	Linus Walleij <linus.walleij@linaro.org>,
	Alexandre Torgue <alexandre.torgue@st.com>,
	Michael Hennerich <Michael.Hennerich@analog.com>,
	Martin Blumenstingl <martin.blumenstingl@googlemail.com>,
	Lars-Peter Clausen <lars@metafoo.de>,
	linux-amlogic@lists.infradead.org,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org,
	Beniamin Bia <beniamin.bia@analog.com>,
	Maxime Coquelin <mcoquelin.stm32@gmail.com>,
	Hartmut Knaack <knaack.h@gmx.de>, Peter Rosin <peda@axentia.se>,
	Jonathan Cameron <jic23@kernel.org>
Subject: Re: [PATCH 11/16] iio: chemical: scd30: Simplify with dev_err_probe()
Date: Wed, 26 Aug 2020 17:57:23 +0200	[thread overview]
Message-ID: <20200826155723.GA31748@kozik-lap> (raw)
In-Reply-To: <20200826153434.GA7468@arch>

On Wed, Aug 26, 2020 at 05:34:34PM +0200, Tomasz Duszynski wrote:
> On Wed, Aug 26, 2020 at 04:51:48PM +0200, Krzysztof Kozlowski wrote:
> > Common pattern of handling deferred probe can be simplified with
> > dev_err_probe().  Less code and also it prints the error value.
> >
> > Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> > ---
> >  drivers/iio/chemical/scd30_core.c | 10 +++-------
> >  1 file changed, 3 insertions(+), 7 deletions(-)
> >
> > diff --git a/drivers/iio/chemical/scd30_core.c b/drivers/iio/chemical/scd30_core.c
> > index eac76972f83e..92358797796d 100644
> > --- a/drivers/iio/chemical/scd30_core.c
> > +++ b/drivers/iio/chemical/scd30_core.c
> > @@ -705,13 +705,9 @@ int scd30_probe(struct device *dev, int irq, const char *name, void *priv,
> >  	indio_dev->available_scan_masks = scd30_scan_masks;
> >
> >  	state->vdd = devm_regulator_get(dev, "vdd");
> > -	if (IS_ERR(state->vdd)) {
> > -		if (PTR_ERR(state->vdd) == -EPROBE_DEFER)
> > -			return -EPROBE_DEFER;
> > -
> > -		dev_err(dev, "failed to get regulator\n");
> > -		return PTR_ERR(state->vdd);
> > -	}
> > +	if (IS_ERR(state->vdd))
> > +		return dev_err_probe(dev, PTR_ERR(state->vdd),
> > +				     "failed to get regulator\n");
> 
> I'd say that removing like break would slightly improve readability.
> Besides, staying within 100 columns seems socially acceptable now.
> Otherwise,
> 
> Acked-by: Tomasz Duszynski <tomasz.duszynski@octakon.com>

Indeed. Although 80 is still mentioned as preferred (in commit bdc48fa11
and in coding style) but here having longer line would be better.

I guess this could be fixed up easily when applying but if resend is
wanted, let me know.

Best regards,
Krzysztof

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

WARNING: multiple messages have this Message-ID (diff)
From: Krzysztof Kozlowski <krzk@kernel.org>
To: Tomasz Duszynski <tomasz.duszynski@octakon.com>
Cc: Neil Armstrong <narmstrong@baylibre.com>,
	Jonathan Bakker <xc-racer2@live.ca>,
	Peter Meerwald-Stadler <pmeerw@pmeerw.net>,
	linux-stm32@st-md-mailman.stormreply.com,
	Jerome Brunet <jbrunet@baylibre.com>,
	linux-samsung-soc@vger.kernel.org,
	Kevin Hilman <khilman@baylibre.com>,
	Marek Vasut <marek.vasut@gmail.com>,
	Kukjin Kim <kgene@kernel.org>,
	Alexandru Ardelean <alexandru.ardelean@analog.com>,
	Linus Walleij <linus.walleij@linaro.org>,
	Alexandre Torgue <alexandre.torgue@st.com>,
	Michael Hennerich <Michael.Hennerich@analog.com>,
	Martin Blumenstingl <martin.blumenstingl@googlemail.com>,
	Lars-Peter Clausen <lars@metafoo.de>,
	linux-amlogic@lists.infradead.org,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org,
	Beniamin Bia <beniamin.bia@analog.com>,
	Maxime Coquelin <mcoquelin.stm32@gmail.com>,
	Hartmut Knaack <knaack.h@gmx.de>, Peter Rosin <peda@axentia.se>,
	Jonathan Cameron <jic23@kernel.org>
Subject: Re: [PATCH 11/16] iio: chemical: scd30: Simplify with dev_err_probe()
Date: Wed, 26 Aug 2020 17:57:23 +0200	[thread overview]
Message-ID: <20200826155723.GA31748@kozik-lap> (raw)
In-Reply-To: <20200826153434.GA7468@arch>

On Wed, Aug 26, 2020 at 05:34:34PM +0200, Tomasz Duszynski wrote:
> On Wed, Aug 26, 2020 at 04:51:48PM +0200, Krzysztof Kozlowski wrote:
> > Common pattern of handling deferred probe can be simplified with
> > dev_err_probe().  Less code and also it prints the error value.
> >
> > Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
> > ---
> >  drivers/iio/chemical/scd30_core.c | 10 +++-------
> >  1 file changed, 3 insertions(+), 7 deletions(-)
> >
> > diff --git a/drivers/iio/chemical/scd30_core.c b/drivers/iio/chemical/scd30_core.c
> > index eac76972f83e..92358797796d 100644
> > --- a/drivers/iio/chemical/scd30_core.c
> > +++ b/drivers/iio/chemical/scd30_core.c
> > @@ -705,13 +705,9 @@ int scd30_probe(struct device *dev, int irq, const char *name, void *priv,
> >  	indio_dev->available_scan_masks = scd30_scan_masks;
> >
> >  	state->vdd = devm_regulator_get(dev, "vdd");
> > -	if (IS_ERR(state->vdd)) {
> > -		if (PTR_ERR(state->vdd) == -EPROBE_DEFER)
> > -			return -EPROBE_DEFER;
> > -
> > -		dev_err(dev, "failed to get regulator\n");
> > -		return PTR_ERR(state->vdd);
> > -	}
> > +	if (IS_ERR(state->vdd))
> > +		return dev_err_probe(dev, PTR_ERR(state->vdd),
> > +				     "failed to get regulator\n");
> 
> I'd say that removing like break would slightly improve readability.
> Besides, staying within 100 columns seems socially acceptable now.
> Otherwise,
> 
> Acked-by: Tomasz Duszynski <tomasz.duszynski@octakon.com>

Indeed. Although 80 is still mentioned as preferred (in commit bdc48fa11
and in coding style) but here having longer line would be better.

I guess this could be fixed up easily when applying but if resend is
wanted, let me know.

Best regards,
Krzysztof

_______________________________________________
linux-amlogic mailing list
linux-amlogic@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-amlogic

  reply	other threads:[~2020-08-26 15:57 UTC|newest]

Thread overview: 66+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-08-26 14:51 [PATCH 01/16] iio: accel: bma180: Simplify with dev_err_probe() Krzysztof Kozlowski
2020-08-26 14:51 ` Krzysztof Kozlowski
2020-08-26 14:51 ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 02/16] iio: accel: mma8452: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 03/16] iio: adc: envelope-detector: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 04/16] iio: adc: exynos_adc: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 05/16] iio: adc: ltc2497: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 06/16] iio: adc: meson_saradc: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 07/16] iio: adc: rcar-gyroadc: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 08/16] iio: adc: stm32: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 16:17   ` Krzysztof Kozlowski
2020-08-26 16:17     ` Krzysztof Kozlowski
2020-08-26 16:17     ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 09/16] iio: afe: iio-rescale: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 10/16] iio: amplifiers: hmc425a: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 11/16] iio: chemical: scd30: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 15:34   ` Tomasz Duszynski
2020-08-26 15:34     ` Tomasz Duszynski
2020-08-26 15:34     ` Tomasz Duszynski
2020-08-26 15:57     ` Krzysztof Kozlowski [this message]
2020-08-26 15:57       ` Krzysztof Kozlowski
2020-08-26 15:57       ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 12/16] iio: dac: dpot-dac: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 13/16] iio: imu: inv_mpu6050: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 14/16] iio: light: isl29018: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 15/16] iio: light: tsl2772: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51 ` [PATCH 16/16] iio: magnetometer: ak8974: " Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-26 14:51   ` Krzysztof Kozlowski
2020-08-28 13:03   ` Linus Walleij
2020-08-28 13:03     ` Linus Walleij
2020-08-28 13:03     ` Linus Walleij
2020-08-27 11:26 ` [PATCH 01/16] iio: accel: bma180: " Jonathan Cameron
2020-08-27 11:26   ` Jonathan Cameron
2020-08-27 11:26   ` Jonathan Cameron
2020-08-27 11:28   ` Krzysztof Kozlowski
2020-08-27 11:28     ` Krzysztof Kozlowski
2020-08-27 11:28     ` Krzysztof Kozlowski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200826155723.GA31748@kozik-lap \
    --to=krzk@kernel.org \
    --cc=Michael.Hennerich@analog.com \
    --cc=alexandre.torgue@st.com \
    --cc=alexandru.ardelean@analog.com \
    --cc=beniamin.bia@analog.com \
    --cc=jbrunet@baylibre.com \
    --cc=jic23@kernel.org \
    --cc=kgene@kernel.org \
    --cc=khilman@baylibre.com \
    --cc=knaack.h@gmx.de \
    --cc=lars@metafoo.de \
    --cc=linus.walleij@linaro.org \
    --cc=linux-amlogic@lists.infradead.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-samsung-soc@vger.kernel.org \
    --cc=linux-stm32@st-md-mailman.stormreply.com \
    --cc=marek.vasut@gmail.com \
    --cc=martin.blumenstingl@googlemail.com \
    --cc=mcoquelin.stm32@gmail.com \
    --cc=narmstrong@baylibre.com \
    --cc=peda@axentia.se \
    --cc=pmeerw@pmeerw.net \
    --cc=tomasz.duszynski@octakon.com \
    --cc=xc-racer2@live.ca \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.