All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
To: Lee Jones <lee.jones@linaro.org>
Cc: linux-kernel@vger.kernel.org,
	Henrik Rydberg <rydberg@bitmath.org>,
	James Hilliard <james.hilliard1@gmail.com>,
	Daniel Ritz <daniel.ritz@gmx.ch>,
	linux-input@vger.kernel.org
Subject: Re: [PATCH 07/15] input: touchscreen: usbtouchscreen: Remove unused variable 'ret'
Date: Thu, 19 Nov 2020 19:09:55 -0800	[thread overview]
Message-ID: <20201120030955.GK2034289@dtor-ws> (raw)
In-Reply-To: <20201113075631.GI2787115@dell>

On Fri, Nov 13, 2020 at 07:56:31AM +0000, Lee Jones wrote:
> On Thu, 12 Nov 2020, Dmitry Torokhov wrote:
> 
> > On Thu, Nov 12, 2020 at 11:01:56AM +0000, Lee Jones wrote:
> > > Fixes the following W=1 kernel build warning(s):
> > > 
> > >  drivers/input/touchscreen/usbtouchscreen.c: In function ‘nexio_read_data’:
> > >  drivers/input/touchscreen/usbtouchscreen.c:1052:50: warning: variable ‘ret’ set but not used [-Wunused-but-set-variable]
> > > 
> > > Cc: Dmitry Torokhov <dmitry.torokhov@gmail.com>
> > > Cc: Henrik Rydberg <rydberg@bitmath.org>
> > > Cc: James Hilliard <james.hilliard1@gmail.com>
> > > Cc: Daniel Ritz <daniel.ritz@gmx.ch>
> > > Cc: linux-input@vger.kernel.org
> > > Signed-off-by: Lee Jones <lee.jones@linaro.org>
> > > ---
> > >  drivers/input/touchscreen/usbtouchscreen.c | 4 ++--
> > >  1 file changed, 2 insertions(+), 2 deletions(-)
> > > 
> > > diff --git a/drivers/input/touchscreen/usbtouchscreen.c b/drivers/input/touchscreen/usbtouchscreen.c
> > > index 397cb1d3f481b..c3b7130cd9033 100644
> > > --- a/drivers/input/touchscreen/usbtouchscreen.c
> > > +++ b/drivers/input/touchscreen/usbtouchscreen.c
> > > @@ -1049,7 +1049,7 @@ static int nexio_read_data(struct usbtouch_usb *usbtouch, unsigned char *pkt)
> > >  	unsigned int data_len = be16_to_cpu(packet->data_len);
> > >  	unsigned int x_len = be16_to_cpu(packet->x_len);
> > >  	unsigned int y_len = be16_to_cpu(packet->y_len);
> > > -	int x, y, begin_x, begin_y, end_x, end_y, w, h, ret;
> > > +	int x, y, begin_x, begin_y, end_x, end_y, w, h;
> > >  
> > >  	/* got touch data? */
> > >  	if ((pkt[0] & 0xe0) != 0xe0)
> > > @@ -1061,7 +1061,7 @@ static int nexio_read_data(struct usbtouch_usb *usbtouch, unsigned char *pkt)
> > >  		x_len -= 0x80;
> > >  
> > >  	/* send ACK */
> > > -	ret = usb_submit_urb(priv->ack, GFP_ATOMIC);
> > > +	usb_submit_urb(priv->ack, GFP_ATOMIC);
> > 
> > I wonder if we should handle potential errors instead.
> 
> Your call.  I'll do whatever you decide.

OK, please add error handling here.

Thank you.

-- 
Dmitry

  reply	other threads:[~2020-11-20  3:10 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-12 11:01 [PATCH 00/15] [Set 2/2] Rid W=1 issues from Input Lee Jones
2020-11-12 11:01 ` [PATCH 01/15] input: joystick: xpad: Demote non-conformant kernel-doc header Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 02/15] input: keyboard: samsung-keypad: Remove set but unused variable 'var' Lee Jones
2020-11-13  7:37   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 03/15] input: misc: mc13783-pwrbutton: File headers are not good candidates for kernel-doc Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 04/15] input: touchscreen: goodix: Provide some missing function parameter descriptions Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 05/15] input: touchscreen: imx6ul_tsc: Remove set but unused variable 'value' Lee Jones
2020-11-12 12:20   ` Bough Chen
2020-11-13  7:37   ` Dmitry Torokhov
2020-11-19  9:12     ` Lee Jones
2020-11-12 11:01 ` [PATCH 06/15] input: touchscreen: melfas_mip4: Remove a bunch of unused variables Lee Jones
2020-11-13  7:42   ` Dmitry Torokhov
2020-11-13  7:55     ` Lee Jones
2020-11-20  3:09       ` Dmitry Torokhov
2020-11-20  7:45         ` Lee Jones
2020-11-12 11:01 ` [PATCH 07/15] input: touchscreen: usbtouchscreen: Remove unused variable 'ret' Lee Jones
2020-11-13  7:36   ` Dmitry Torokhov
2020-11-13  7:56     ` Lee Jones
2020-11-20  3:09       ` Dmitry Torokhov [this message]
2020-11-12 11:01 ` [PATCH 08/15] input: touchscreen: surface3_spi: Remove set but unused variable 'timestamp' Lee Jones
2020-11-13  7:40   ` Dmitry Torokhov
2020-11-13  7:42     ` Benjamin Tissoires
2020-11-15 22:02       ` Peter Hutterer
2020-11-12 11:01 ` [PATCH 09/15] input: misc: wm831x-on: Source file headers are not good candidates for kernel-doc Lee Jones
2020-11-12 11:20   ` Richard Fitzgerald
2020-11-20  3:17   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 10/15] input: touchscreen: surface3_spi: Fix naming issue with 'surface3_spi_get_gpio_config's header Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 11/15] input: touchscreen: wm97xx-core: Provide missing description for 'status' Lee Jones
2020-11-12 11:22   ` Richard Fitzgerald
2020-11-20  3:17   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 12/15] input: mouse: synaptics: Demote non-conformant kernel-doc header Lee Jones
2020-11-20  3:18   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 13/15] input: touchscreen: goodix: Fix misspelling of 'ctx' Lee Jones
2020-11-20  3:20   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 14/15] input: keyboard: applespi: Provide missing struct 'message' descriptions Lee Jones
2020-11-20  3:21   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 15/15] input: mouse: vmmouse: Demote obvious abuse of kernel-doc header Lee Jones
2020-11-20  3:21   ` Dmitry Torokhov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201120030955.GK2034289@dtor-ws \
    --to=dmitry.torokhov@gmail.com \
    --cc=daniel.ritz@gmx.ch \
    --cc=james.hilliard1@gmail.com \
    --cc=lee.jones@linaro.org \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rydberg@bitmath.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.