All of lore.kernel.org
 help / color / mirror / Atom feed
From: Lakshmi Ramasubramanian <nramas@linux.microsoft.com>
To: zohar@linux.ibm.com, bauerman@linux.ibm.com, robh@kernel.org,
	takahiro.akashi@linaro.org, gregkh@linuxfoundation.org,
	will@kernel.org, joe@perches.com, catalin.marinas@arm.com,
	mpe@ellerman.id.au
Cc: james.morse@arm.com, sashal@kernel.org, benh@kernel.crashing.org,
	paulus@samba.org, frowand.list@gmail.com,
	vincenzo.frascino@arm.com, mark.rutland@arm.com,
	dmitry.kasatkin@gmail.com, jmorris@namei.org, serge@hallyn.com,
	pasha.tatashin@soleen.com, allison@lohutok.net,
	masahiroy@kernel.org, mbrugger@suse.com, hsinyi@chromium.org,
	tao.li@vivo.com, christophe.leroy@c-s.fr,
	prsriva@linux.microsoft.com, balajib@linux.microsoft.com,
	linux-integrity@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org, devicetree@vger.kernel.org,
	linuxppc-dev@lists.ozlabs.org
Subject: [PATCH v18 01/11] powerpc: Rename kexec elfcorehdr_addr to elf_load_addr
Date: Sat, 13 Feb 2021 08:10:39 -0800	[thread overview]
Message-ID: <20210213161049.6190-2-nramas@linux.microsoft.com> (raw)
In-Reply-To: <20210213161049.6190-1-nramas@linux.microsoft.com>

From: Rob Herring <robh@kernel.org>

The architecture specific field, elfcorehdr_addr in struct kimage_arch,
that holds the address of the buffer in memory for ELF core header for
powerpc has a different name than the one used for x86_64.  This makes
it hard to have a common code for setting up the device tree for
kexec system call.

Rename elfcorehdr_addr to elf_load_addr to align with x86_64 name so
common code can use it.

Signed-off-by: Rob Herring <robh@kernel.org>
Reviewed-by: Lakshmi Ramasubramanian <nramas@linux.microsoft.com>
---
 arch/powerpc/include/asm/kexec.h  | 2 +-
 arch/powerpc/kexec/file_load.c    | 4 ++--
 arch/powerpc/kexec/file_load_64.c | 4 ++--
 3 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/arch/powerpc/include/asm/kexec.h b/arch/powerpc/include/asm/kexec.h
index 55d6ede30c19..4d9b250cf1e6 100644
--- a/arch/powerpc/include/asm/kexec.h
+++ b/arch/powerpc/include/asm/kexec.h
@@ -108,7 +108,7 @@ struct kimage_arch {
 	unsigned long backup_start;
 	void *backup_buf;
 
-	unsigned long elfcorehdr_addr;
+	unsigned long elf_load_addr;
 	unsigned long elf_headers_sz;
 	void *elf_headers;
 
diff --git a/arch/powerpc/kexec/file_load.c b/arch/powerpc/kexec/file_load.c
index 9a232bc36c8f..f7c31daf8a2e 100644
--- a/arch/powerpc/kexec/file_load.c
+++ b/arch/powerpc/kexec/file_load.c
@@ -45,7 +45,7 @@ char *setup_kdump_cmdline(struct kimage *image, char *cmdline,
 		return NULL;
 
 	elfcorehdr_strlen = sprintf(cmdline_ptr, "elfcorehdr=0x%lx ",
-				    image->arch.elfcorehdr_addr);
+				    image->arch.elf_load_addr);
 
 	if (elfcorehdr_strlen + cmdline_len > COMMAND_LINE_SIZE) {
 		pr_err("Appending elfcorehdr=<addr> exceeds cmdline size\n");
@@ -263,7 +263,7 @@ int setup_new_fdt(const struct kimage *image, void *fdt,
 		 * Avoid elfcorehdr from being stomped on in kdump kernel by
 		 * setting up memory reserve map.
 		 */
-		ret = fdt_add_mem_rsv(fdt, image->arch.elfcorehdr_addr,
+		ret = fdt_add_mem_rsv(fdt, image->arch.elf_load_addr,
 				      image->arch.elf_headers_sz);
 		if (ret) {
 			pr_err("Error reserving elfcorehdr memory: %s\n",
diff --git a/arch/powerpc/kexec/file_load_64.c b/arch/powerpc/kexec/file_load_64.c
index c69bcf9b547a..e539b7d401a2 100644
--- a/arch/powerpc/kexec/file_load_64.c
+++ b/arch/powerpc/kexec/file_load_64.c
@@ -815,7 +815,7 @@ static int load_elfcorehdr_segment(struct kimage *image, struct kexec_buf *kbuf)
 		goto out;
 	}
 
-	image->arch.elfcorehdr_addr = kbuf->mem;
+	image->arch.elf_load_addr = kbuf->mem;
 	image->arch.elf_headers_sz = headers_sz;
 	image->arch.elf_headers = headers;
 out:
@@ -851,7 +851,7 @@ int load_crashdump_segments_ppc64(struct kimage *image,
 		return ret;
 	}
 	pr_debug("Loaded elf core header at 0x%lx, bufsz=0x%lx memsz=0x%lx\n",
-		 image->arch.elfcorehdr_addr, kbuf->bufsz, kbuf->memsz);
+		 image->arch.elf_load_addr, kbuf->bufsz, kbuf->memsz);
 
 	return 0;
 }
-- 
2.30.0


WARNING: multiple messages have this Message-ID (diff)
From: Lakshmi Ramasubramanian <nramas@linux.microsoft.com>
To: zohar@linux.ibm.com, bauerman@linux.ibm.com, robh@kernel.org,
	takahiro.akashi@linaro.org, gregkh@linuxfoundation.org,
	will@kernel.org, joe@perches.com, catalin.marinas@arm.com,
	mpe@ellerman.id.au
Cc: mark.rutland@arm.com, tao.li@vivo.com, paulus@samba.org,
	vincenzo.frascino@arm.com, frowand.list@gmail.com,
	sashal@kernel.org, masahiroy@kernel.org, jmorris@namei.org,
	allison@lohutok.net, serge@hallyn.com,
	devicetree@vger.kernel.org, pasha.tatashin@soleen.com,
	prsriva@linux.microsoft.com, hsinyi@chromium.org,
	linux-arm-kernel@lists.infradead.org, christophe.leroy@c-s.fr,
	mbrugger@suse.com, balajib@linux.microsoft.com,
	dmitry.kasatkin@gmail.com, linux-kernel@vger.kernel.org,
	james.morse@arm.com, linux-integrity@vger.kernel.org,
	linuxppc-dev@lists.ozlabs.org
Subject: [PATCH v18 01/11] powerpc: Rename kexec elfcorehdr_addr to elf_load_addr
Date: Sat, 13 Feb 2021 08:10:39 -0800	[thread overview]
Message-ID: <20210213161049.6190-2-nramas@linux.microsoft.com> (raw)
In-Reply-To: <20210213161049.6190-1-nramas@linux.microsoft.com>

From: Rob Herring <robh@kernel.org>

The architecture specific field, elfcorehdr_addr in struct kimage_arch,
that holds the address of the buffer in memory for ELF core header for
powerpc has a different name than the one used for x86_64.  This makes
it hard to have a common code for setting up the device tree for
kexec system call.

Rename elfcorehdr_addr to elf_load_addr to align with x86_64 name so
common code can use it.

Signed-off-by: Rob Herring <robh@kernel.org>
Reviewed-by: Lakshmi Ramasubramanian <nramas@linux.microsoft.com>
---
 arch/powerpc/include/asm/kexec.h  | 2 +-
 arch/powerpc/kexec/file_load.c    | 4 ++--
 arch/powerpc/kexec/file_load_64.c | 4 ++--
 3 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/arch/powerpc/include/asm/kexec.h b/arch/powerpc/include/asm/kexec.h
index 55d6ede30c19..4d9b250cf1e6 100644
--- a/arch/powerpc/include/asm/kexec.h
+++ b/arch/powerpc/include/asm/kexec.h
@@ -108,7 +108,7 @@ struct kimage_arch {
 	unsigned long backup_start;
 	void *backup_buf;
 
-	unsigned long elfcorehdr_addr;
+	unsigned long elf_load_addr;
 	unsigned long elf_headers_sz;
 	void *elf_headers;
 
diff --git a/arch/powerpc/kexec/file_load.c b/arch/powerpc/kexec/file_load.c
index 9a232bc36c8f..f7c31daf8a2e 100644
--- a/arch/powerpc/kexec/file_load.c
+++ b/arch/powerpc/kexec/file_load.c
@@ -45,7 +45,7 @@ char *setup_kdump_cmdline(struct kimage *image, char *cmdline,
 		return NULL;
 
 	elfcorehdr_strlen = sprintf(cmdline_ptr, "elfcorehdr=0x%lx ",
-				    image->arch.elfcorehdr_addr);
+				    image->arch.elf_load_addr);
 
 	if (elfcorehdr_strlen + cmdline_len > COMMAND_LINE_SIZE) {
 		pr_err("Appending elfcorehdr=<addr> exceeds cmdline size\n");
@@ -263,7 +263,7 @@ int setup_new_fdt(const struct kimage *image, void *fdt,
 		 * Avoid elfcorehdr from being stomped on in kdump kernel by
 		 * setting up memory reserve map.
 		 */
-		ret = fdt_add_mem_rsv(fdt, image->arch.elfcorehdr_addr,
+		ret = fdt_add_mem_rsv(fdt, image->arch.elf_load_addr,
 				      image->arch.elf_headers_sz);
 		if (ret) {
 			pr_err("Error reserving elfcorehdr memory: %s\n",
diff --git a/arch/powerpc/kexec/file_load_64.c b/arch/powerpc/kexec/file_load_64.c
index c69bcf9b547a..e539b7d401a2 100644
--- a/arch/powerpc/kexec/file_load_64.c
+++ b/arch/powerpc/kexec/file_load_64.c
@@ -815,7 +815,7 @@ static int load_elfcorehdr_segment(struct kimage *image, struct kexec_buf *kbuf)
 		goto out;
 	}
 
-	image->arch.elfcorehdr_addr = kbuf->mem;
+	image->arch.elf_load_addr = kbuf->mem;
 	image->arch.elf_headers_sz = headers_sz;
 	image->arch.elf_headers = headers;
 out:
@@ -851,7 +851,7 @@ int load_crashdump_segments_ppc64(struct kimage *image,
 		return ret;
 	}
 	pr_debug("Loaded elf core header at 0x%lx, bufsz=0x%lx memsz=0x%lx\n",
-		 image->arch.elfcorehdr_addr, kbuf->bufsz, kbuf->memsz);
+		 image->arch.elf_load_addr, kbuf->bufsz, kbuf->memsz);
 
 	return 0;
 }
-- 
2.30.0


WARNING: multiple messages have this Message-ID (diff)
From: Lakshmi Ramasubramanian <nramas@linux.microsoft.com>
To: zohar@linux.ibm.com, bauerman@linux.ibm.com, robh@kernel.org,
	takahiro.akashi@linaro.org, gregkh@linuxfoundation.org,
	will@kernel.org, joe@perches.com, catalin.marinas@arm.com,
	mpe@ellerman.id.au
Cc: mark.rutland@arm.com, benh@kernel.crashing.org, tao.li@vivo.com,
	paulus@samba.org, vincenzo.frascino@arm.com,
	frowand.list@gmail.com, sashal@kernel.org, masahiroy@kernel.org,
	jmorris@namei.org, allison@lohutok.net, serge@hallyn.com,
	devicetree@vger.kernel.org, pasha.tatashin@soleen.com,
	prsriva@linux.microsoft.com, hsinyi@chromium.org,
	linux-arm-kernel@lists.infradead.org, christophe.leroy@c-s.fr,
	mbrugger@suse.com, balajib@linux.microsoft.com,
	dmitry.kasatkin@gmail.com, linux-kernel@vger.kernel.org,
	james.morse@arm.com, linux-integrity@vger.kernel.org,
	linuxppc-dev@lists.ozlabs.org
Subject: [PATCH v18 01/11] powerpc: Rename kexec elfcorehdr_addr to elf_load_addr
Date: Sat, 13 Feb 2021 08:10:39 -0800	[thread overview]
Message-ID: <20210213161049.6190-2-nramas@linux.microsoft.com> (raw)
In-Reply-To: <20210213161049.6190-1-nramas@linux.microsoft.com>

From: Rob Herring <robh@kernel.org>

The architecture specific field, elfcorehdr_addr in struct kimage_arch,
that holds the address of the buffer in memory for ELF core header for
powerpc has a different name than the one used for x86_64.  This makes
it hard to have a common code for setting up the device tree for
kexec system call.

Rename elfcorehdr_addr to elf_load_addr to align with x86_64 name so
common code can use it.

Signed-off-by: Rob Herring <robh@kernel.org>
Reviewed-by: Lakshmi Ramasubramanian <nramas@linux.microsoft.com>
---
 arch/powerpc/include/asm/kexec.h  | 2 +-
 arch/powerpc/kexec/file_load.c    | 4 ++--
 arch/powerpc/kexec/file_load_64.c | 4 ++--
 3 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/arch/powerpc/include/asm/kexec.h b/arch/powerpc/include/asm/kexec.h
index 55d6ede30c19..4d9b250cf1e6 100644
--- a/arch/powerpc/include/asm/kexec.h
+++ b/arch/powerpc/include/asm/kexec.h
@@ -108,7 +108,7 @@ struct kimage_arch {
 	unsigned long backup_start;
 	void *backup_buf;
 
-	unsigned long elfcorehdr_addr;
+	unsigned long elf_load_addr;
 	unsigned long elf_headers_sz;
 	void *elf_headers;
 
diff --git a/arch/powerpc/kexec/file_load.c b/arch/powerpc/kexec/file_load.c
index 9a232bc36c8f..f7c31daf8a2e 100644
--- a/arch/powerpc/kexec/file_load.c
+++ b/arch/powerpc/kexec/file_load.c
@@ -45,7 +45,7 @@ char *setup_kdump_cmdline(struct kimage *image, char *cmdline,
 		return NULL;
 
 	elfcorehdr_strlen = sprintf(cmdline_ptr, "elfcorehdr=0x%lx ",
-				    image->arch.elfcorehdr_addr);
+				    image->arch.elf_load_addr);
 
 	if (elfcorehdr_strlen + cmdline_len > COMMAND_LINE_SIZE) {
 		pr_err("Appending elfcorehdr=<addr> exceeds cmdline size\n");
@@ -263,7 +263,7 @@ int setup_new_fdt(const struct kimage *image, void *fdt,
 		 * Avoid elfcorehdr from being stomped on in kdump kernel by
 		 * setting up memory reserve map.
 		 */
-		ret = fdt_add_mem_rsv(fdt, image->arch.elfcorehdr_addr,
+		ret = fdt_add_mem_rsv(fdt, image->arch.elf_load_addr,
 				      image->arch.elf_headers_sz);
 		if (ret) {
 			pr_err("Error reserving elfcorehdr memory: %s\n",
diff --git a/arch/powerpc/kexec/file_load_64.c b/arch/powerpc/kexec/file_load_64.c
index c69bcf9b547a..e539b7d401a2 100644
--- a/arch/powerpc/kexec/file_load_64.c
+++ b/arch/powerpc/kexec/file_load_64.c
@@ -815,7 +815,7 @@ static int load_elfcorehdr_segment(struct kimage *image, struct kexec_buf *kbuf)
 		goto out;
 	}
 
-	image->arch.elfcorehdr_addr = kbuf->mem;
+	image->arch.elf_load_addr = kbuf->mem;
 	image->arch.elf_headers_sz = headers_sz;
 	image->arch.elf_headers = headers;
 out:
@@ -851,7 +851,7 @@ int load_crashdump_segments_ppc64(struct kimage *image,
 		return ret;
 	}
 	pr_debug("Loaded elf core header at 0x%lx, bufsz=0x%lx memsz=0x%lx\n",
-		 image->arch.elfcorehdr_addr, kbuf->bufsz, kbuf->memsz);
+		 image->arch.elf_load_addr, kbuf->bufsz, kbuf->memsz);
 
 	return 0;
 }
-- 
2.30.0


_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2021-02-13 16:12 UTC|newest]

Thread overview: 63+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-02-13 16:10 [PATCH v18 00/10] Carry forward IMA measurement log on kexec on ARM64 Lakshmi Ramasubramanian
2021-02-13 16:10 ` Lakshmi Ramasubramanian
2021-02-13 16:10 ` Lakshmi Ramasubramanian
2021-02-13 16:10 ` Lakshmi Ramasubramanian [this message]
2021-02-13 16:10   ` [PATCH v18 01/11] powerpc: Rename kexec elfcorehdr_addr to elf_load_addr Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-15 21:31   ` Thiago Jung Bauermann
2021-02-15 21:31     ` Thiago Jung Bauermann
2021-02-15 21:31     ` Thiago Jung Bauermann
2021-02-13 16:10 ` [PATCH v18 02/11] arm64: Rename kexec elf_headers_mem " Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-15 21:34   ` Thiago Jung Bauermann
2021-02-15 21:34     ` Thiago Jung Bauermann
2021-02-15 21:34     ` Thiago Jung Bauermann
2021-02-13 16:10 ` [PATCH v18 03/11] of: Add a common kexec FDT setup function Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-15 21:41   ` Thiago Jung Bauermann
2021-02-15 21:41     ` Thiago Jung Bauermann
2021-02-15 21:41     ` Thiago Jung Bauermann
2021-02-22  1:32   ` Guenter Roeck
2021-02-22  1:32     ` Guenter Roeck
2021-02-22  1:32     ` Guenter Roeck
2021-02-22  1:35     ` Lakshmi Ramasubramanian
2021-02-22  1:35       ` Lakshmi Ramasubramanian
2021-02-22  1:35       ` Lakshmi Ramasubramanian
2021-02-13 16:10 ` [PATCH v18 04/11] arm64: Use common of_kexec_alloc_and_setup_fdt() Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-15 21:46   ` Thiago Jung Bauermann
2021-02-15 21:46     ` Thiago Jung Bauermann
2021-02-15 21:46     ` Thiago Jung Bauermann
2021-02-13 16:10 ` [PATCH v18 05/11] powerpc: " Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-15 21:50   ` Thiago Jung Bauermann
2021-02-15 21:50     ` Thiago Jung Bauermann
2021-02-15 21:50     ` Thiago Jung Bauermann
2021-02-13 16:10 ` [PATCH v18 06/11] powerpc: Move ima buffer fields to struct kimage Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-15 21:58   ` Thiago Jung Bauermann
2021-02-15 21:58     ` Thiago Jung Bauermann
2021-02-15 21:58     ` Thiago Jung Bauermann
2021-02-13 16:10 ` [PATCH v18 07/11] powerpc: Enable passing IMA log to next kernel on kexec Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10 ` [PATCH v18 08/11] powerpc: Move arch independent ima kexec functions to drivers/of/kexec.c Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10 ` [PATCH v18 09/11] kexec: Use fdt_appendprop_addrrange() to add ima buffer to FDT Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10 ` [PATCH v18 10/11] powerpc: Delete unused function delete_fdt_mem_rsv() Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10 ` [PATCH v18 11/11] arm64: Enable passing IMA log to next kernel on kexec Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-13 16:10   ` Lakshmi Ramasubramanian
2021-02-18  1:25 ` [PATCH v18 00/10] Carry forward IMA measurement log on kexec on ARM64 Rob Herring
2021-02-18  1:25   ` Rob Herring
2021-02-18  1:25   ` Rob Herring

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210213161049.6190-2-nramas@linux.microsoft.com \
    --to=nramas@linux.microsoft.com \
    --cc=allison@lohutok.net \
    --cc=balajib@linux.microsoft.com \
    --cc=bauerman@linux.ibm.com \
    --cc=benh@kernel.crashing.org \
    --cc=catalin.marinas@arm.com \
    --cc=christophe.leroy@c-s.fr \
    --cc=devicetree@vger.kernel.org \
    --cc=dmitry.kasatkin@gmail.com \
    --cc=frowand.list@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=hsinyi@chromium.org \
    --cc=james.morse@arm.com \
    --cc=jmorris@namei.org \
    --cc=joe@perches.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-integrity@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mark.rutland@arm.com \
    --cc=masahiroy@kernel.org \
    --cc=mbrugger@suse.com \
    --cc=mpe@ellerman.id.au \
    --cc=pasha.tatashin@soleen.com \
    --cc=paulus@samba.org \
    --cc=prsriva@linux.microsoft.com \
    --cc=robh@kernel.org \
    --cc=sashal@kernel.org \
    --cc=serge@hallyn.com \
    --cc=takahiro.akashi@linaro.org \
    --cc=tao.li@vivo.com \
    --cc=vincenzo.frascino@arm.com \
    --cc=will@kernel.org \
    --cc=zohar@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.