All of lore.kernel.org
 help / color / mirror / Atom feed
From: Andrew Morton <akpm@linux-foundation.org>
To: Kefeng Wang <wangkefeng.wang@huawei.com>
Cc: Catalin Marinas <catalin.marinas@arm.com>,
	Will Deacon <will@kernel.org>,
	<linux-arm-kernel@lists.infradead.org>,
	<linux-kernel@vger.kernel.org>, <linux-mm@kvack.org>
Subject: Re: [PATCH 2/4] mm: ioremap: Add arch_ioremap/iounmap_check()
Date: Wed, 27 Apr 2022 10:04:11 -0700	[thread overview]
Message-ID: <20220427100411.8eaf54c51767c3e2b0b070a5@linux-foundation.org> (raw)
In-Reply-To: <20220427121413.168468-3-wangkefeng.wang@huawei.com>

On Wed, 27 Apr 2022 20:14:11 +0800 Kefeng Wang <wangkefeng.wang@huawei.com> wrote:

> Add special check hook for architecture to verify addr, size
> or prot when ioremap() or iounmap(), which will make the generic
> ioremap more useful.
> 
> ...
>
> --- a/include/asm-generic/io.h
> +++ b/include/asm-generic/io.h
> @@ -964,6 +964,9 @@ static inline void iounmap(volatile void __iomem *addr)
>  #elif defined(CONFIG_GENERIC_IOREMAP)
>  #include <linux/pgtable.h>
>  
> +bool arch_ioremap_check(phys_addr_t addr, size_t size, unsigned long prot);
> +bool arch_iounmap_check(void __iomem *addr);

Pet peeve.  The word "check" is a poor one.  I gives no sense of what
the function is checking and it gives no sense of how the function's
return value relates to the thing which it checks.

Maybe it returns 0 on success and -EINVAL on failure.  Don't know!

Don't you think that better names would be io_remap_ok(),
io_remap_valid(), io_remap_allowed(), etc?


Other than that, 

Acked-by: Andrew Morton <akpm@linux-foundation.org>

WARNING: multiple messages have this Message-ID (diff)
From: Andrew Morton <akpm@linux-foundation.org>
To: Kefeng Wang <wangkefeng.wang@huawei.com>
Cc: Catalin Marinas <catalin.marinas@arm.com>,
	Will Deacon <will@kernel.org>,
	<linux-arm-kernel@lists.infradead.org>,
	<linux-kernel@vger.kernel.org>, <linux-mm@kvack.org>
Subject: Re: [PATCH 2/4] mm: ioremap: Add arch_ioremap/iounmap_check()
Date: Wed, 27 Apr 2022 10:04:11 -0700	[thread overview]
Message-ID: <20220427100411.8eaf54c51767c3e2b0b070a5@linux-foundation.org> (raw)
In-Reply-To: <20220427121413.168468-3-wangkefeng.wang@huawei.com>

On Wed, 27 Apr 2022 20:14:11 +0800 Kefeng Wang <wangkefeng.wang@huawei.com> wrote:

> Add special check hook for architecture to verify addr, size
> or prot when ioremap() or iounmap(), which will make the generic
> ioremap more useful.
> 
> ...
>
> --- a/include/asm-generic/io.h
> +++ b/include/asm-generic/io.h
> @@ -964,6 +964,9 @@ static inline void iounmap(volatile void __iomem *addr)
>  #elif defined(CONFIG_GENERIC_IOREMAP)
>  #include <linux/pgtable.h>
>  
> +bool arch_ioremap_check(phys_addr_t addr, size_t size, unsigned long prot);
> +bool arch_iounmap_check(void __iomem *addr);

Pet peeve.  The word "check" is a poor one.  I gives no sense of what
the function is checking and it gives no sense of how the function's
return value relates to the thing which it checks.

Maybe it returns 0 on success and -EINVAL on failure.  Don't know!

Don't you think that better names would be io_remap_ok(),
io_remap_valid(), io_remap_allowed(), etc?


Other than that, 

Acked-by: Andrew Morton <akpm@linux-foundation.org>

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2022-04-27 17:04 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-04-27 12:14 [PATCH 0/4] arm64: Cleanup ioremap() and support ioremap_prot() Kefeng Wang
2022-04-27 12:14 ` Kefeng Wang
2022-04-27 12:14 ` [PATCH 1/4] mm: ioremap: Setup phys_addr of struct vm_struct Kefeng Wang
2022-04-27 12:14   ` Kefeng Wang
2022-04-27 17:10   ` Andrew Morton
2022-04-27 17:10     ` Andrew Morton
2022-04-28  1:40     ` Kefeng Wang
2022-04-28  1:40       ` Kefeng Wang
2022-04-28 15:41   ` Christoph Hellwig
2022-04-28 15:41     ` Christoph Hellwig
2022-04-27 12:14 ` [PATCH 2/4] mm: ioremap: Add arch_ioremap/iounmap_check() Kefeng Wang
2022-04-27 12:14   ` Kefeng Wang
2022-04-27 17:04   ` Andrew Morton [this message]
2022-04-27 17:04     ` Andrew Morton
2022-04-28  6:16     ` Kefeng Wang
2022-04-28  6:16       ` Kefeng Wang
2022-04-28 15:46       ` Christoph Hellwig
2022-04-28 15:46         ` Christoph Hellwig
2022-04-27 18:20   ` Arnd Bergmann
2022-04-27 18:20     ` Arnd Bergmann
2022-04-27 18:25     ` Andrew Morton
2022-04-27 18:25       ` Andrew Morton
2022-04-27 20:46       ` Arnd Bergmann
2022-04-27 20:46         ` Arnd Bergmann
2022-04-28  6:20     ` Kefeng Wang
2022-04-28  6:20       ` Kefeng Wang
2022-04-28  6:47       ` Arnd Bergmann
2022-04-28  6:47         ` Arnd Bergmann
2022-04-27 12:14 ` [PATCH 3/4] arm64: mm: Convert to GENERIC_IOREMAP Kefeng Wang
2022-04-27 12:14   ` Kefeng Wang
2022-04-27 17:11   ` Andrew Morton
2022-04-27 17:11     ` Andrew Morton
2022-04-27 12:14 ` [PATCH 4/4] arm64: Add HAVE_IOREMAP_PROT support Kefeng Wang
2022-04-27 12:14   ` Kefeng Wang
2022-04-28 10:46 ` [PATCH 0/4] arm64: Cleanup ioremap() and support ioremap_prot() Will Deacon
2022-04-28 10:46   ` Will Deacon
2022-04-28 11:48   ` Kefeng Wang
2022-04-28 11:48     ` Kefeng Wang
2022-04-28 15:48   ` Christoph Hellwig
2022-04-28 15:48     ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220427100411.8eaf54c51767c3e2b0b070a5@linux-foundation.org \
    --to=akpm@linux-foundation.org \
    --cc=catalin.marinas@arm.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=wangkefeng.wang@huawei.com \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.