All of lore.kernel.org
 help / color / mirror / Atom feed
From: SeongJae Park <sj@kernel.org>
To: Matthew Wilcox <willy@infradead.org>
Cc: Kefeng Wang <wangkefeng.wang@huawei.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	SeongJae Park <sj@kernel.org>,
	damon@lists.linux.dev, linux-mm@kvack.org,
	vishal.moola@gmail.com, david@redhat.com
Subject: Re: [PATCH -next v3 2/7] mm/damon: introduce damon_get_folio()
Date: Wed, 28 Dec 2022 23:14:17 +0000	[thread overview]
Message-ID: <20221228231417.150148-1-sj@kernel.org> (raw)
In-Reply-To: <Y6zE5DsGU1CRpWS2@casper.infradead.org>

Hi Matthew,

On Wed, 28 Dec 2022 22:36:20 +0000 Matthew Wilcox <willy@infradead.org> wrote:

> On Wed, Dec 28, 2022 at 07:34:08PM +0800, Kefeng Wang wrote:
> > +static inline struct page *damon_get_page(unsigned long pfn)
> > +{
> > +	struct folio *folio = damon_get_folio(pfn);
> > +
> > +	/* when folio is NULL, return &(0->page) mean return NULL */
> > +	return &folio->page;
> 
> I really don't think this comment is needed.  This is the standard idiom
> for converting from a folio to its head page.

Well, I think some of DAMON code readers (at least me) might not yet that
familiar with Folio, as it has not been a while since DAMON started using
Folio.  Also, maybe I overlooked some comments or documents, but I was unable
to sure if the offset of 'page' in 'folio' is intended to be never changed with
any future changes, or not.  So I thought adding one more line of explanation
here could be helpful for someone.

I also show some code using 'folio_page(folio, 0)', so I might not be the only
one who at least sometimes forget the idiom.  For helping people remember this
idiom easier, what do you think about having a new macro or static inline
function, say, 'folio_head_page()' and comment why passing NULL is ok on the
function?  IMHO, that would be easier to read.


Thanks,
SJ

  reply	other threads:[~2022-12-28 23:14 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-12-28 11:34 [PATCH -next v3 0/7] mm: convert page_idle/damon to use folios Kefeng Wang
2022-12-28 11:34 ` [PATCH -next v3 1/7] mm: page_idle: convert page idle " Kefeng Wang
2022-12-28 17:46   ` SeongJae Park
2022-12-28 11:34 ` [PATCH -next v3 2/7] mm/damon: introduce damon_get_folio() Kefeng Wang
2022-12-28 22:36   ` Matthew Wilcox
2022-12-28 23:14     ` SeongJae Park [this message]
2022-12-28 11:34 ` [PATCH -next v3 3/7] mm/damon: convert damon_ptep/pmdp_mkold() to use folios Kefeng Wang
2022-12-28 11:34 ` [PATCH -next v3 4/7] mm/damon/paddr: convert damon_pa_*() " Kefeng Wang
2022-12-29 20:36   ` Matthew Wilcox
2022-12-30  6:40     ` Kefeng Wang
2022-12-28 11:34 ` [PATCH -next v3 5/7] mm/damon/vaddr: convert damon_young_pmd_entry() to use folio Kefeng Wang
2022-12-29 21:06   ` Matthew Wilcox
2022-12-29 21:31     ` SeongJae Park
2022-12-28 11:34 ` [PATCH -next v3 6/7] mm/damon: remove unneed damon_get_page() Kefeng Wang
2022-12-28 17:49   ` SeongJae Park
2022-12-28 11:34 ` [PATCH -next v3 7/7] mm/damon/vaddr: convert hugetlb related function to use folios Kefeng Wang
2022-12-28 17:51   ` SeongJae Park
2022-12-28 17:55 ` [PATCH -next v3 0/7] mm: convert page_idle/damon " SeongJae Park
2022-12-29  2:16   ` Kefeng Wang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20221228231417.150148-1-sj@kernel.org \
    --to=sj@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=damon@lists.linux.dev \
    --cc=david@redhat.com \
    --cc=linux-mm@kvack.org \
    --cc=vishal.moola@gmail.com \
    --cc=wangkefeng.wang@huawei.com \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.