All of lore.kernel.org
 help / color / mirror / Atom feed
From: Al Viro <viro@zeniv.linux.org.uk>
To: Yangtao Li <frank.li@vivo.com>
Cc: xiang@kernel.org, chao@kernel.org, huyue2@coolpad.com,
	jefflexu@linux.alibaba.com, tytso@mit.edu,
	adilger.kernel@dilger.ca, rpeterso@redhat.com,
	agruenba@redhat.com, mark@fasheh.com, jlbec@evilplan.org,
	joseph.qi@linux.alibaba.com, brauner@kernel.org,
	linux-erofs@lists.ozlabs.org, linux-kernel@vger.kernel.org,
	linux-ext4@vger.kernel.org, cluster-devel@redhat.com,
	ocfs2-devel@oss.oracle.com, linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH v3 4/6] ext4: convert to use i_blockmask()
Date: Fri, 10 Mar 2023 03:32:13 +0000	[thread overview]
Message-ID: <20230310033213.GG3390869@ZenIV> (raw)
In-Reply-To: <20230310031940.GE3390869@ZenIV>

On Fri, Mar 10, 2023 at 03:19:40AM +0000, Al Viro wrote:
> On Thu, Mar 09, 2023 at 11:21:25PM +0800, Yangtao Li wrote:
> > Use i_blockmask() to simplify code.
> > 
> > Signed-off-by: Yangtao Li <frank.li@vivo.com>
> > ---
> > v3:
> > -none
> > v2:
> > -convert to i_blockmask()
> >  fs/ext4/inode.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/fs/ext4/inode.c b/fs/ext4/inode.c
> > index d251d705c276..eec36520e5e9 100644
> > --- a/fs/ext4/inode.c
> > +++ b/fs/ext4/inode.c
> > @@ -2218,7 +2218,7 @@ static int mpage_process_page_bufs(struct mpage_da_data *mpd,
> >  {
> >  	struct inode *inode = mpd->inode;
> >  	int err;
> > -	ext4_lblk_t blocks = (i_size_read(inode) + i_blocksize(inode) - 1)
> > +	ext4_lblk_t blocks = (i_size_read(inode) + i_blockmask(inode))
> >  							>> inode->i_blkbits;
> 
> Umm...  That actually asks for DIV_ROUND_UP(i_size_read_inode(), i_blocksize(inode)) -
> compiler should bloody well be able to figure out that division by (1 << n) is
> shift down by n and it's easier to follow that way...

BTW, here the fact that you are adding the mask is misleading - it's true,
but we are not using it as a mask - it's straight arithmetics.

One can do an equivalent code where it would've been used as a mask, but that
would be harder to read -
	(((i_size_read(inode) - 1) | i_blockmask(inode)) + 1) >> inode->i_blkbits
and I doubt anyone wants that kind of puzzles to stumble upon.

WARNING: multiple messages have this Message-ID (diff)
From: Al Viro via Ocfs2-devel <ocfs2-devel@oss.oracle.com>
To: Yangtao Li <frank.li@vivo.com>
Cc: brauner@kernel.org, tytso@mit.edu, agruenba@redhat.com,
	chao@kernel.org, linux-kernel@vger.kernel.org,
	cluster-devel@redhat.com, rpeterso@redhat.com,
	huyue2@coolpad.com, adilger.kernel@dilger.ca,
	jefflexu@linux.alibaba.com, linux-fsdevel@vger.kernel.org,
	xiang@kernel.org, linux-ext4@vger.kernel.org,
	linux-erofs@lists.ozlabs.org, ocfs2-devel@oss.oracle.com
Subject: Re: [Ocfs2-devel] [PATCH v3 4/6] ext4: convert to use i_blockmask()
Date: Fri, 10 Mar 2023 03:32:13 +0000	[thread overview]
Message-ID: <20230310033213.GG3390869@ZenIV> (raw)
In-Reply-To: <20230310031940.GE3390869@ZenIV>

On Fri, Mar 10, 2023 at 03:19:40AM +0000, Al Viro wrote:
> On Thu, Mar 09, 2023 at 11:21:25PM +0800, Yangtao Li wrote:
> > Use i_blockmask() to simplify code.
> > 
> > Signed-off-by: Yangtao Li <frank.li@vivo.com>
> > ---
> > v3:
> > -none
> > v2:
> > -convert to i_blockmask()
> >  fs/ext4/inode.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/fs/ext4/inode.c b/fs/ext4/inode.c
> > index d251d705c276..eec36520e5e9 100644
> > --- a/fs/ext4/inode.c
> > +++ b/fs/ext4/inode.c
> > @@ -2218,7 +2218,7 @@ static int mpage_process_page_bufs(struct mpage_da_data *mpd,
> >  {
> >  	struct inode *inode = mpd->inode;
> >  	int err;
> > -	ext4_lblk_t blocks = (i_size_read(inode) + i_blocksize(inode) - 1)
> > +	ext4_lblk_t blocks = (i_size_read(inode) + i_blockmask(inode))
> >  							>> inode->i_blkbits;
> 
> Umm...  That actually asks for DIV_ROUND_UP(i_size_read_inode(), i_blocksize(inode)) -
> compiler should bloody well be able to figure out that division by (1 << n) is
> shift down by n and it's easier to follow that way...

BTW, here the fact that you are adding the mask is misleading - it's true,
but we are not using it as a mask - it's straight arithmetics.

One can do an equivalent code where it would've been used as a mask, but that
would be harder to read -
	(((i_size_read(inode) - 1) | i_blockmask(inode)) + 1) >> inode->i_blkbits
and I doubt anyone wants that kind of puzzles to stumble upon.

_______________________________________________
Ocfs2-devel mailing list
Ocfs2-devel@oss.oracle.com
https://oss.oracle.com/mailman/listinfo/ocfs2-devel

WARNING: multiple messages have this Message-ID (diff)
From: Al Viro <viro@zeniv.linux.org.uk>
To: Yangtao Li <frank.li@vivo.com>
Cc: brauner@kernel.org, tytso@mit.edu, agruenba@redhat.com,
	joseph.qi@linux.alibaba.com, mark@fasheh.com,
	linux-kernel@vger.kernel.org, cluster-devel@redhat.com,
	rpeterso@redhat.com, huyue2@coolpad.com,
	adilger.kernel@dilger.ca, jlbec@evilplan.org,
	linux-fsdevel@vger.kernel.org, linux-ext4@vger.kernel.org,
	linux-erofs@lists.ozlabs.org, ocfs2-devel@oss.oracle.com
Subject: Re: [PATCH v3 4/6] ext4: convert to use i_blockmask()
Date: Fri, 10 Mar 2023 03:32:13 +0000	[thread overview]
Message-ID: <20230310033213.GG3390869@ZenIV> (raw)
In-Reply-To: <20230310031940.GE3390869@ZenIV>

On Fri, Mar 10, 2023 at 03:19:40AM +0000, Al Viro wrote:
> On Thu, Mar 09, 2023 at 11:21:25PM +0800, Yangtao Li wrote:
> > Use i_blockmask() to simplify code.
> > 
> > Signed-off-by: Yangtao Li <frank.li@vivo.com>
> > ---
> > v3:
> > -none
> > v2:
> > -convert to i_blockmask()
> >  fs/ext4/inode.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/fs/ext4/inode.c b/fs/ext4/inode.c
> > index d251d705c276..eec36520e5e9 100644
> > --- a/fs/ext4/inode.c
> > +++ b/fs/ext4/inode.c
> > @@ -2218,7 +2218,7 @@ static int mpage_process_page_bufs(struct mpage_da_data *mpd,
> >  {
> >  	struct inode *inode = mpd->inode;
> >  	int err;
> > -	ext4_lblk_t blocks = (i_size_read(inode) + i_blocksize(inode) - 1)
> > +	ext4_lblk_t blocks = (i_size_read(inode) + i_blockmask(inode))
> >  							>> inode->i_blkbits;
> 
> Umm...  That actually asks for DIV_ROUND_UP(i_size_read_inode(), i_blocksize(inode)) -
> compiler should bloody well be able to figure out that division by (1 << n) is
> shift down by n and it's easier to follow that way...

BTW, here the fact that you are adding the mask is misleading - it's true,
but we are not using it as a mask - it's straight arithmetics.

One can do an equivalent code where it would've been used as a mask, but that
would be harder to read -
	(((i_size_read(inode) - 1) | i_blockmask(inode)) + 1) >> inode->i_blkbits
and I doubt anyone wants that kind of puzzles to stumble upon.

WARNING: multiple messages have this Message-ID (diff)
From: Al Viro <viro@zeniv.linux.org.uk>
To: cluster-devel.redhat.com
Subject: [Cluster-devel] [PATCH v3 4/6] ext4: convert to use i_blockmask()
Date: Fri, 10 Mar 2023 03:32:13 +0000	[thread overview]
Message-ID: <20230310033213.GG3390869@ZenIV> (raw)
In-Reply-To: <20230310031940.GE3390869@ZenIV>

On Fri, Mar 10, 2023 at 03:19:40AM +0000, Al Viro wrote:
> On Thu, Mar 09, 2023 at 11:21:25PM +0800, Yangtao Li wrote:
> > Use i_blockmask() to simplify code.
> > 
> > Signed-off-by: Yangtao Li <frank.li@vivo.com>
> > ---
> > v3:
> > -none
> > v2:
> > -convert to i_blockmask()
> >  fs/ext4/inode.c | 2 +-
> >  1 file changed, 1 insertion(+), 1 deletion(-)
> > 
> > diff --git a/fs/ext4/inode.c b/fs/ext4/inode.c
> > index d251d705c276..eec36520e5e9 100644
> > --- a/fs/ext4/inode.c
> > +++ b/fs/ext4/inode.c
> > @@ -2218,7 +2218,7 @@ static int mpage_process_page_bufs(struct mpage_da_data *mpd,
> >  {
> >  	struct inode *inode = mpd->inode;
> >  	int err;
> > -	ext4_lblk_t blocks = (i_size_read(inode) + i_blocksize(inode) - 1)
> > +	ext4_lblk_t blocks = (i_size_read(inode) + i_blockmask(inode))
> >  							>> inode->i_blkbits;
> 
> Umm...  That actually asks for DIV_ROUND_UP(i_size_read_inode(), i_blocksize(inode)) -
> compiler should bloody well be able to figure out that division by (1 << n) is
> shift down by n and it's easier to follow that way...

BTW, here the fact that you are adding the mask is misleading - it's true,
but we are not using it as a mask - it's straight arithmetics.

One can do an equivalent code where it would've been used as a mask, but that
would be harder to read -
	(((i_size_read(inode) - 1) | i_blockmask(inode)) + 1) >> inode->i_blkbits
and I doubt anyone wants that kind of puzzles to stumble upon.


  reply	other threads:[~2023-03-10  3:32 UTC|newest]

Thread overview: 60+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-03-09 15:21 [PATCH v3 1/6] fs: add i_blockmask() Yangtao Li
2023-03-09 15:21 ` [Cluster-devel] " Yangtao Li
2023-03-09 15:21 ` [Ocfs2-devel] " Yangtao Li via Ocfs2-devel
2023-03-09 15:21 ` Yangtao Li
2023-03-09 15:21 ` [PATCH v3 2/6] erofs: convert to use i_blockmask() Yangtao Li
2023-03-09 15:21   ` [Cluster-devel] " Yangtao Li
2023-03-09 15:21   ` [Ocfs2-devel] " Yangtao Li via Ocfs2-devel
2023-03-09 15:21   ` Yangtao Li
2023-03-10  3:15   ` Al Viro
2023-03-10  3:15     ` [Cluster-devel] " Al Viro
2023-03-10  3:15     ` Al Viro
2023-03-10  3:15     ` [Ocfs2-devel] " Al Viro via Ocfs2-devel
2023-03-10  3:42     ` Gao Xiang
2023-03-10  3:42       ` [Cluster-devel] " Gao Xiang
2023-03-10  3:42       ` [Ocfs2-devel] " Gao Xiang via Ocfs2-devel
2023-03-10  3:42       ` Gao Xiang
2023-03-10  3:47       ` Gao Xiang
2023-03-10  3:47         ` [Cluster-devel] " Gao Xiang
2023-03-10  3:47         ` [Ocfs2-devel] " Gao Xiang via Ocfs2-devel
2023-03-10  3:47         ` Gao Xiang
2023-03-10  3:51     ` Yangtao Li
2023-03-10  3:51       ` [Cluster-devel] " Yangtao Li
2023-03-10  3:51       ` [Ocfs2-devel] " Yangtao Li via Ocfs2-devel
2023-03-10  3:51       ` Yangtao Li
2023-03-10  4:05       ` Al Viro
2023-03-10  4:05         ` [Cluster-devel] " Al Viro
2023-03-10  4:05         ` Al Viro
2023-03-10  4:05         ` [Ocfs2-devel] " Al Viro via Ocfs2-devel
2023-03-10  6:50         ` Yangtao Li
2023-03-10  6:50           ` [Cluster-devel] " Yangtao Li
2023-03-10  6:50           ` [Ocfs2-devel] " Yangtao Li via Ocfs2-devel
2023-03-10  6:50           ` Yangtao Li
2023-03-09 15:21 ` [PATCH v3 3/6] gfs2: " Yangtao Li
2023-03-09 15:21   ` [Cluster-devel] " Yangtao Li
2023-03-09 15:21   ` [Ocfs2-devel] " Yangtao Li via Ocfs2-devel
2023-03-09 15:21   ` Yangtao Li
2023-03-09 15:21 ` [PATCH v3 4/6] ext4: " Yangtao Li
2023-03-09 15:21   ` [Cluster-devel] " Yangtao Li
2023-03-09 15:21   ` [Ocfs2-devel] " Yangtao Li via Ocfs2-devel
2023-03-09 15:21   ` Yangtao Li
2023-03-10  3:19   ` Al Viro
2023-03-10  3:19     ` [Cluster-devel] " Al Viro
2023-03-10  3:19     ` Al Viro
2023-03-10  3:19     ` [Ocfs2-devel] " Al Viro via Ocfs2-devel
2023-03-10  3:32     ` Al Viro [this message]
2023-03-10  3:32       ` [Cluster-devel] " Al Viro
2023-03-10  3:32       ` Al Viro
2023-03-10  3:32       ` [Ocfs2-devel] " Al Viro via Ocfs2-devel
2023-03-09 15:21 ` [PATCH v3 5/6] ocfs2: " Yangtao Li
2023-03-09 15:21   ` [Cluster-devel] " Yangtao Li
2023-03-09 15:21   ` [Ocfs2-devel] " Yangtao Li via Ocfs2-devel
2023-03-09 15:21   ` Yangtao Li
2023-03-10  3:26   ` Al Viro
2023-03-10  3:26     ` [Cluster-devel] " Al Viro
2023-03-10  3:26     ` Al Viro
2023-03-10  3:26     ` [Ocfs2-devel] " Al Viro via Ocfs2-devel
2023-03-09 15:21 ` [PATCH v3 6/6] fs/remap_range: " Yangtao Li
2023-03-09 15:21   ` [Cluster-devel] " Yangtao Li
2023-03-09 15:21   ` [Ocfs2-devel] " Yangtao Li via Ocfs2-devel
2023-03-09 15:21   ` Yangtao Li

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20230310033213.GG3390869@ZenIV \
    --to=viro@zeniv.linux.org.uk \
    --cc=adilger.kernel@dilger.ca \
    --cc=agruenba@redhat.com \
    --cc=brauner@kernel.org \
    --cc=chao@kernel.org \
    --cc=cluster-devel@redhat.com \
    --cc=frank.li@vivo.com \
    --cc=huyue2@coolpad.com \
    --cc=jefflexu@linux.alibaba.com \
    --cc=jlbec@evilplan.org \
    --cc=joseph.qi@linux.alibaba.com \
    --cc=linux-erofs@lists.ozlabs.org \
    --cc=linux-ext4@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark@fasheh.com \
    --cc=ocfs2-devel@oss.oracle.com \
    --cc=rpeterso@redhat.com \
    --cc=tytso@mit.edu \
    --cc=xiang@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.