All of lore.kernel.org
 help / color / mirror / Atom feed
From: Arnd Bergmann <arnd@arndb.de>
To: Catalin Marinas <catalin.marinas@arm.com>
Cc: Andrew Pinski <pinskia@gmail.com>,
	"Joseph S. Myers" <joseph@codesourcery.com>,
	"Kapoor, Prasun" <Prasun.Kapoor@caviumnetworks.com>,
	broonie@kernel.org, Nathan Lynch <Nathan_Lynch@mentor.com>,
	LKML <linux-kernel@vger.kernel.org>,
	Alexander Graf <agraf@suse.de>,
	Alexey Klimov <klimov.linux@gmail.com>,
	Yury Norov <ynorov@caviumnetworks.com>,
	Jan Dakinevich <jan.dakinevich@gmail.com>,
	Andrew Pinski <apinski@cavium.com>,
	David Daney <ddaney.cavm@gmail.com>,
	Andreas Schwab <schwab@suse.de>,
	"Zhangjian (Bamvor)" <bamvor.zhangjian@huawei.com>,
	Philipp Tomsich <philipp.tomsich@theobroma-systems.com>,
	"linux-arm-kernel@lists.infradead.org" 
	<linux-arm-kernel@lists.infradead.org>,
	christoph.muellner@theobroma-systems.com,
	Marcus Shawcroft <Marcus.Shawcroft@arm.com>
Subject: Re: [PATCH v6 12/20] arm64:ilp32: add sys_ilp32.c and a separate table (in entry.S) to use it
Date: Fri, 18 Dec 2015 13:47:55 +0100	[thread overview]
Message-ID: <2334903.IjsQ1BK3JF@wuerfel> (raw)
In-Reply-To: <20151218114219.GA2830@mbp>

On Friday 18 December 2015 11:42:19 Catalin Marinas wrote:
> On Thu, Dec 17, 2015 at 12:14:20PM -0800, Andrew Pinski wrote:
> > Well (just like LP64 on AARCH64), when passing a 32bit value to a
> > function, the upper 32bits are undefined.  I ran into this when I was
> > debugging the GCC go library on ILP32 (though reproduced with pure C
> > code) and the assembly functions inside glibc where pointers are
> > passed with the upper 32bits as undefined.
> > So we have an issue if called with syscall function or using pure
> > assembly to create the syscall functions (which glibc does).
> 
> I think the ILP32 syscall ABI should follow the PCS convention where the
> top 32-bit of a register is not guaranteed 0 when the size of the
> argument is 32-bit. So take the read(2) syscall:
> 
>         ssize_t read(int fd, void *buf, size_t count);
> 
> From the ILP32 code perspective, void * and size_t are both 32-bit. It
> would call into the kernel leaving the top 32-bit as undefined (if we
> follow the PCS). Normally, calling a function with the same size
> arguments is not a problem since the compiler generates the callee code
> accordingly. However, we route the syscall directly into the native
> sys_read() where void * and size_t are 64-bit with the top 32-bit left
> undefined.
> 
> We have three options here:
> 
> 1. Always follow PCS convention across user/kernel call and add wrappers
>    in the kernel (preferred)

Yes, I also think this is best.

> 2. Follow the PCS up to glibc and get glibc to zero the top part (not
>    always safe with hand-written assembly, though we already do this for
>    AArch32 where the PCS only specifies 4 arguments in registers, the
>    rest go on the stack)

I assume this needs special handling for syscalls with 64-bit arguments
in both glibc and kernel.

> 3. Follow the PCS up to glibc but always pass syscall arguments in W
>    registers, like AArch32 compat support (the least preferred option,
>    the only advantage is a single wrapper for all syscalls but it would
>    be doing unnecessary zeroing even for syscalls where it isn't needed)

This would mean we cannot pass 64-bit arguments in registers, right?
 
> My preference, as stated above, is (1). You can write the wrappers in C
> directly and let the compiler upgrade the types when calling the native
> syscall. But any other option would be fine (take some inspiration from
> other architectures). Unfortunately we don't have COMPAT_SYSCALL_DEFINE
> for all functions that we need to wrap, it would have been easier (so we
> need to add them but probably in the arch/arm64 code).

It would be nice to have that code architecture-independent, so we can
share it with s390 and only need to update one place when new syscalls
get added.

	Arnd

WARNING: multiple messages have this Message-ID (diff)
From: arnd@arndb.de (Arnd Bergmann)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v6 12/20] arm64:ilp32: add sys_ilp32.c and a separate table (in entry.S) to use it
Date: Fri, 18 Dec 2015 13:47:55 +0100	[thread overview]
Message-ID: <2334903.IjsQ1BK3JF@wuerfel> (raw)
In-Reply-To: <20151218114219.GA2830@mbp>

On Friday 18 December 2015 11:42:19 Catalin Marinas wrote:
> On Thu, Dec 17, 2015 at 12:14:20PM -0800, Andrew Pinski wrote:
> > Well (just like LP64 on AARCH64), when passing a 32bit value to a
> > function, the upper 32bits are undefined.  I ran into this when I was
> > debugging the GCC go library on ILP32 (though reproduced with pure C
> > code) and the assembly functions inside glibc where pointers are
> > passed with the upper 32bits as undefined.
> > So we have an issue if called with syscall function or using pure
> > assembly to create the syscall functions (which glibc does).
> 
> I think the ILP32 syscall ABI should follow the PCS convention where the
> top 32-bit of a register is not guaranteed 0 when the size of the
> argument is 32-bit. So take the read(2) syscall:
> 
>         ssize_t read(int fd, void *buf, size_t count);
> 
> From the ILP32 code perspective, void * and size_t are both 32-bit. It
> would call into the kernel leaving the top 32-bit as undefined (if we
> follow the PCS). Normally, calling a function with the same size
> arguments is not a problem since the compiler generates the callee code
> accordingly. However, we route the syscall directly into the native
> sys_read() where void * and size_t are 64-bit with the top 32-bit left
> undefined.
> 
> We have three options here:
> 
> 1. Always follow PCS convention across user/kernel call and add wrappers
>    in the kernel (preferred)

Yes, I also think this is best.

> 2. Follow the PCS up to glibc and get glibc to zero the top part (not
>    always safe with hand-written assembly, though we already do this for
>    AArch32 where the PCS only specifies 4 arguments in registers, the
>    rest go on the stack)

I assume this needs special handling for syscalls with 64-bit arguments
in both glibc and kernel.

> 3. Follow the PCS up to glibc but always pass syscall arguments in W
>    registers, like AArch32 compat support (the least preferred option,
>    the only advantage is a single wrapper for all syscalls but it would
>    be doing unnecessary zeroing even for syscalls where it isn't needed)

This would mean we cannot pass 64-bit arguments in registers, right?
 
> My preference, as stated above, is (1). You can write the wrappers in C
> directly and let the compiler upgrade the types when calling the native
> syscall. But any other option would be fine (take some inspiration from
> other architectures). Unfortunately we don't have COMPAT_SYSCALL_DEFINE
> for all functions that we need to wrap, it would have been easier (so we
> need to add them but probably in the arch/arm64 code).

It would be nice to have that code architecture-independent, so we can
share it with s390 and only need to update one place when new syscalls
get added.

	Arnd

  reply	other threads:[~2015-12-18 12:54 UTC|newest]

Thread overview: 156+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-12-15 21:42 [RFC3 PATCH v6 00/20] ILP32 for ARM64 Yury Norov
2015-12-15 21:42 ` Yury Norov
2015-12-15 21:42 ` [PATCH v6 01/20] arm64: ilp32: add documentation on the ILP32 ABI " Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-15 21:42 ` [PATCH v6 02/20] arm64: ensure the kernel is compiled for LP64 Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-15 21:42 ` [PATCH v6 03/20] arm64: rename COMPAT to AARCH32_EL0 in Kconfig Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-17 11:23   ` Catalin Marinas
2015-12-17 11:23     ` Catalin Marinas
2015-12-15 21:42 ` [PATCH v6 04/20] arm64: change some CONFIG_COMPAT over to use CONFIG_AARCH32_EL0 instead Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-23 14:15   ` Yury Norov
2015-12-23 14:15     ` Yury Norov
2015-12-28  8:43   ` > diff --git a/arch/arm64/kernel/Makefile b/arch/arm64/kernel/Makefile Bamvor Jian Zhang
2015-12-28  8:43     ` Bamvor Jian Zhang
2015-12-28  9:01     ` [PATCH v6 04/20] arm64: change some CONFIG_COMPAT over to use CONFIG_AARCH32_EL0 instead Zhangjian (Bamvor)
2015-12-28  9:01       ` Zhangjian (Bamvor)
2015-12-29 12:27       ` Yury Norov
2015-12-29 12:27         ` Yury Norov
2015-12-29 14:59         ` [PATCH] arm64: compat: fix wrong dependency Bamvor Jian Zhang
2015-12-29 14:59           ` Bamvor Jian Zhang
2015-12-29 13:12       ` [PATCH v6 04/20] arm64: change some CONFIG_COMPAT over to use CONFIG_AARCH32_EL0 instead Yury Norov
2015-12-29 13:12         ` Yury Norov
2015-12-15 21:42 ` [PATCH v6 05/20] arm64:uapi: set __BITS_PER_LONG correctly for ILP32 and LP64 Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-15 21:42 ` [PATCH v6 06/20] thread: move thread bits accessors to separated file Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-15 21:42 ` [PATCH v6 07/20] arm64: introduce is_a32_task and is_a32_thread (for AArch32 compat) Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-17 11:38   ` Catalin Marinas
2015-12-17 11:38     ` Catalin Marinas
2015-12-15 21:42 ` [PATCH v6 08/20] arm64: ilp32: add is_ilp32_compat_{task,thread} and TIF_32BIT_AARCH64 Yury Norov
2015-12-15 21:42   ` [PATCH v6 08/20] arm64: ilp32: add is_ilp32_compat_{task, thread} " Yury Norov
2015-12-17 11:41   ` Catalin Marinas
2015-12-17 11:41     ` Catalin Marinas
2015-12-18 14:11     ` Yury Norov
2015-12-18 14:11       ` Yury Norov
2015-12-18 14:44       ` Yury Norov
2015-12-18 14:44         ` Yury Norov
2015-12-21 17:42         ` Catalin Marinas
2015-12-21 17:42           ` Catalin Marinas
2015-12-15 21:42 ` [PATCH v6 09/20] arm64:ilp32: share HWCAP between LP64 and ILP32 Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-16 15:54   ` Arnd Bergmann
2015-12-16 15:54     ` Arnd Bergmann
2015-12-16 16:58     ` Catalin Marinas
2015-12-16 16:58       ` Catalin Marinas
2015-12-16 17:19       ` Catalin Marinas
2015-12-16 17:19         ` Catalin Marinas
2015-12-16 19:17         ` Arnd Bergmann
2015-12-16 19:17           ` Arnd Bergmann
2015-12-17 10:54           ` Catalin Marinas
2015-12-17 10:54             ` Catalin Marinas
2015-12-17 13:56             ` Arnd Bergmann
2015-12-17 13:56               ` Arnd Bergmann
2015-12-15 21:42 ` [PATCH v6 10/20] arm64:ilp32 use the native LP64 'start_thread' for ILP32 threads Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-16 15:50   ` Arnd Bergmann
2015-12-16 15:50     ` Arnd Bergmann
2015-12-18 13:57     ` Yury Norov
2015-12-18 13:57       ` Yury Norov
2015-12-15 21:42 ` [PATCH v6 11/20] arm64:ilp32: support core dump generation for ILP32 Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-17 14:05   ` Catalin Marinas
2015-12-17 14:05     ` Catalin Marinas
2015-12-15 21:42 ` [PATCH v6 12/20] arm64:ilp32: add sys_ilp32.c and a separate table (in entry.S) to use it Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-16 16:07   ` Arnd Bergmann
2015-12-16 16:07     ` Arnd Bergmann
2015-12-17 18:27   ` Catalin Marinas
2015-12-17 18:27     ` Catalin Marinas
2015-12-17 20:10     ` Arnd Bergmann
2015-12-17 20:10       ` Arnd Bergmann
2015-12-17 20:14       ` Andrew Pinski
2015-12-17 20:14         ` Andrew Pinski
2015-12-17 20:50         ` Arnd Bergmann
2015-12-17 20:50           ` Arnd Bergmann
2016-01-05 15:26           ` Yury Norov
2016-01-05 15:26             ` Yury Norov
2016-01-05 21:12             ` Arnd Bergmann
2016-01-05 21:12               ` Arnd Bergmann
2016-01-06 17:10               ` Catalin Marinas
2016-01-06 17:10                 ` Catalin Marinas
2016-01-07 14:13                 ` Arnd Bergmann
2016-01-07 14:13                   ` Arnd Bergmann
2016-01-07 15:42                   ` Yury Norov
2016-01-07 15:42                     ` Yury Norov
2016-01-07 17:23                   ` Catalin Marinas
2016-01-07 17:23                     ` Catalin Marinas
2015-12-18 11:42         ` Catalin Marinas
2015-12-18 11:42           ` Catalin Marinas
2015-12-18 12:47           ` Arnd Bergmann [this message]
2015-12-18 12:47             ` Arnd Bergmann
2015-12-21 18:31             ` Catalin Marinas
2015-12-21 18:31               ` Catalin Marinas
2015-12-21 22:19               ` Arnd Bergmann
2015-12-21 22:19                 ` Arnd Bergmann
2015-12-21 18:39             ` Dr. Philipp Tomsich
2015-12-21 18:39               ` Dr. Philipp Tomsich
2015-12-21 22:13               ` Arnd Bergmann
2015-12-21 22:13                 ` Arnd Bergmann
2015-12-21 22:31   ` Arnd Bergmann
2015-12-21 22:31     ` Arnd Bergmann
2015-12-23 18:31     ` Yury Norov
2015-12-23 18:31       ` Yury Norov
2015-12-23 21:48       ` Arnd Bergmann
2015-12-23 21:48         ` Arnd Bergmann
2015-12-15 21:42 ` [PATCH v6 13/20] arm64: ilp32: share aarch32 syscall wrappers to ilp32 Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-17 14:38   ` Andreas Schwab
2015-12-17 14:38     ` Andreas Schwab
2015-12-18 13:49     ` Yury Norov
2015-12-18 13:49       ` Yury Norov
2015-12-22 12:25   ` Catalin Marinas
2015-12-22 12:25     ` Catalin Marinas
2015-12-22 21:44     ` Arnd Bergmann
2015-12-22 21:44       ` Arnd Bergmann
2015-12-23 13:37       ` Catalin Marinas
2015-12-23 13:37         ` Catalin Marinas
2015-12-23 20:41         ` Arnd Bergmann
2015-12-23 20:41           ` Arnd Bergmann
2015-12-30 17:29           ` Yury Norov
2015-12-30 17:29             ` Yury Norov
2015-12-30 22:36             ` Arnd Bergmann
2015-12-30 22:36               ` Arnd Bergmann
2015-12-23  4:21     ` Yury Norov
2015-12-23  4:21       ` Yury Norov
2015-12-15 21:42 ` [PATCH v6 14/20] arm64: signal: wrap struct ucontext, fp and lr with struct sigframe Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-15 21:42 ` [PATCH v6 15/20] arm64: signal: move ilp32 and lp64 common code to separated file Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-16 16:08   ` Arnd Bergmann
2015-12-16 16:08     ` Arnd Bergmann
2015-12-18 13:48     ` Yury Norov
2015-12-18 13:48       ` Yury Norov
2015-12-18 14:09       ` Arnd Bergmann
2015-12-18 14:09         ` Arnd Bergmann
2015-12-22 17:11   ` Catalin Marinas
2015-12-22 17:11     ` Catalin Marinas
2015-12-15 21:42 ` [PATCH v6 16/20] arm64: signal32: move ilp32 and aarch32 " Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-22 14:29   ` Catalin Marinas
2015-12-22 14:29     ` Catalin Marinas
2015-12-15 21:42 ` [PATCH v6 17/20] arm64: ilp32: introduce ilp32-specific handlers for sigframe Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-22 17:08   ` Catalin Marinas
2015-12-22 17:08     ` Catalin Marinas
2015-12-15 21:42 ` [PATCH v6 18/20] arm64:ilp32: add vdso-ilp32 and use for signal return Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-15 21:42 ` [PATCH v6 19/20] arm64:ilp32: change COMPAT_ELF_PLATFORM to report a a subplatform for ILP32 Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-15 21:42 ` [PATCH v6 20/20] arm64:ilp32: add ARM64_ILP32 to Kconfig Yury Norov
2015-12-15 21:42   ` Yury Norov
2015-12-16 16:24 ` [RFC3 PATCH v6 00/20] ILP32 for ARM64 Arnd Bergmann
2015-12-16 16:24   ` Arnd Bergmann

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2334903.IjsQ1BK3JF@wuerfel \
    --to=arnd@arndb.de \
    --cc=Marcus.Shawcroft@arm.com \
    --cc=Nathan_Lynch@mentor.com \
    --cc=Prasun.Kapoor@caviumnetworks.com \
    --cc=agraf@suse.de \
    --cc=apinski@cavium.com \
    --cc=bamvor.zhangjian@huawei.com \
    --cc=broonie@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=christoph.muellner@theobroma-systems.com \
    --cc=ddaney.cavm@gmail.com \
    --cc=jan.dakinevich@gmail.com \
    --cc=joseph@codesourcery.com \
    --cc=klimov.linux@gmail.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=philipp.tomsich@theobroma-systems.com \
    --cc=pinskia@gmail.com \
    --cc=schwab@suse.de \
    --cc=ynorov@caviumnetworks.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.