All of lore.kernel.org
 help / color / mirror / Atom feed
From: Johannes Thumshirn <jthumshirn@suse.de>
To: Sagi Grimberg <sagi@grimberg.me>,
	linux-block@vger.kernel.org, linux-nvme@lists.infradead.org,
	linux-rdma@vger.kernel.org, target-devel@vger.kernel.org
Subject: Re: [PATCH rfc 04/10] block: Add a non-selective polling interface
Date: Thu, 9 Mar 2017 14:44:48 +0100	[thread overview]
Message-ID: <83713ef7-168d-e1f6-8220-b7d6264ea29a@suse.de> (raw)
In-Reply-To: <1489065402-14757-5-git-send-email-sagi@grimberg.me>

On 03/09/2017 02:16 PM, Sagi Grimberg wrote:
> For a server/target appliance mode where we don't
> necessarily care about specific IOs but rather want
> to poll opportunisticly, it is useful to have a
> non-selective polling interface.
> 
> Expose a blk_poll_batch for a batched blkdev polling
> interface so our nvme target (and others) can use.
> 
> Signed-off-by: Sagi Grimberg <sagi@grimberg.me>
> ---
>  block/blk-mq.c         | 14 ++++++++++++++
>  include/linux/blk-mq.h |  2 ++
>  include/linux/blkdev.h |  1 +
>  3 files changed, 17 insertions(+)
> 
> diff --git a/block/blk-mq.c b/block/blk-mq.c
> index b2fd175e84d7..1962785b571a 100644
> --- a/block/blk-mq.c
> +++ b/block/blk-mq.c
> @@ -2911,6 +2911,20 @@ bool blk_mq_poll(struct request_queue *q, blk_qc_t cookie)
>  }
>  EXPORT_SYMBOL_GPL(blk_mq_poll);
>  
> +int blk_mq_poll_batch(struct request_queue *q, unsigned int batch)
> +{
> +	struct blk_mq_hw_ctx *hctx;
> +
> +	if (!q->mq_ops || !q->mq_ops->poll_batch)
> +		return 0;
> +
> +	hctx = blk_mq_map_queue(q, smp_processor_id());
> +	return q->mq_ops->poll_batch(hctx, batch);
> +}
> +EXPORT_SYMBOL_GPL(blk_mq_poll_batch);
> +
> +
> +

Quite some additional newlines and I'm not really fond of the
->poll_batch() name. It's a bit confusing with ->poll() and we also have
irq_poll(). But the only thing that would come to my mind is
complete_batch() which "races" with ->complete().

Otherwise looks OK,
Reviewed-by: Johannes Thumshirn <jthumshirn@suse.de>

-- 
Johannes Thumshirn                                          Storage
jthumshirn@suse.de                                +49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 N�rnberg
GF: Felix Imend�rffer, Jane Smithard, Graham Norton
HRB 21284 (AG N�rnberg)
Key fingerprint = EC38 9CAB C2C4 F25D 8600 D0D0 0393 969D 2D76 0850

WARNING: multiple messages have this Message-ID (diff)
From: Johannes Thumshirn <jthumshirn@suse.de>
To: Sagi Grimberg <sagi@grimberg.me>,
	linux-block@vger.kernel.org, linux-nvme@lists.infradead.org,
	linux-rdma@vger.kernel.org, target-devel@vger.kernel.org
Subject: Re: [PATCH rfc 04/10] block: Add a non-selective polling interface
Date: Thu, 9 Mar 2017 14:44:48 +0100	[thread overview]
Message-ID: <83713ef7-168d-e1f6-8220-b7d6264ea29a@suse.de> (raw)
In-Reply-To: <1489065402-14757-5-git-send-email-sagi@grimberg.me>

On 03/09/2017 02:16 PM, Sagi Grimberg wrote:
> For a server/target appliance mode where we don't
> necessarily care about specific IOs but rather want
> to poll opportunisticly, it is useful to have a
> non-selective polling interface.
> 
> Expose a blk_poll_batch for a batched blkdev polling
> interface so our nvme target (and others) can use.
> 
> Signed-off-by: Sagi Grimberg <sagi@grimberg.me>
> ---
>  block/blk-mq.c         | 14 ++++++++++++++
>  include/linux/blk-mq.h |  2 ++
>  include/linux/blkdev.h |  1 +
>  3 files changed, 17 insertions(+)
> 
> diff --git a/block/blk-mq.c b/block/blk-mq.c
> index b2fd175e84d7..1962785b571a 100644
> --- a/block/blk-mq.c
> +++ b/block/blk-mq.c
> @@ -2911,6 +2911,20 @@ bool blk_mq_poll(struct request_queue *q, blk_qc_t cookie)
>  }
>  EXPORT_SYMBOL_GPL(blk_mq_poll);
>  
> +int blk_mq_poll_batch(struct request_queue *q, unsigned int batch)
> +{
> +	struct blk_mq_hw_ctx *hctx;
> +
> +	if (!q->mq_ops || !q->mq_ops->poll_batch)
> +		return 0;
> +
> +	hctx = blk_mq_map_queue(q, smp_processor_id());
> +	return q->mq_ops->poll_batch(hctx, batch);
> +}
> +EXPORT_SYMBOL_GPL(blk_mq_poll_batch);
> +
> +
> +

Quite some additional newlines and I'm not really fond of the
->poll_batch() name. It's a bit confusing with ->poll() and we also have
irq_poll(). But the only thing that would come to my mind is
complete_batch() which "races" with ->complete().

Otherwise looks OK,
Reviewed-by: Johannes Thumshirn <jthumshirn@suse.de>

-- 
Johannes Thumshirn                                          Storage
jthumshirn@suse.de                                +49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: Felix Imendörffer, Jane Smithard, Graham Norton
HRB 21284 (AG Nürnberg)
Key fingerprint = EC38 9CAB C2C4 F25D 8600 D0D0 0393 969D 2D76 0850

WARNING: multiple messages have this Message-ID (diff)
From: jthumshirn@suse.de (Johannes Thumshirn)
Subject: [PATCH rfc 04/10] block: Add a non-selective polling interface
Date: Thu, 9 Mar 2017 14:44:48 +0100	[thread overview]
Message-ID: <83713ef7-168d-e1f6-8220-b7d6264ea29a@suse.de> (raw)
In-Reply-To: <1489065402-14757-5-git-send-email-sagi@grimberg.me>

On 03/09/2017 02:16 PM, Sagi Grimberg wrote:
> For a server/target appliance mode where we don't
> necessarily care about specific IOs but rather want
> to poll opportunisticly, it is useful to have a
> non-selective polling interface.
> 
> Expose a blk_poll_batch for a batched blkdev polling
> interface so our nvme target (and others) can use.
> 
> Signed-off-by: Sagi Grimberg <sagi at grimberg.me>
> ---
>  block/blk-mq.c         | 14 ++++++++++++++
>  include/linux/blk-mq.h |  2 ++
>  include/linux/blkdev.h |  1 +
>  3 files changed, 17 insertions(+)
> 
> diff --git a/block/blk-mq.c b/block/blk-mq.c
> index b2fd175e84d7..1962785b571a 100644
> --- a/block/blk-mq.c
> +++ b/block/blk-mq.c
> @@ -2911,6 +2911,20 @@ bool blk_mq_poll(struct request_queue *q, blk_qc_t cookie)
>  }
>  EXPORT_SYMBOL_GPL(blk_mq_poll);
>  
> +int blk_mq_poll_batch(struct request_queue *q, unsigned int batch)
> +{
> +	struct blk_mq_hw_ctx *hctx;
> +
> +	if (!q->mq_ops || !q->mq_ops->poll_batch)
> +		return 0;
> +
> +	hctx = blk_mq_map_queue(q, smp_processor_id());
> +	return q->mq_ops->poll_batch(hctx, batch);
> +}
> +EXPORT_SYMBOL_GPL(blk_mq_poll_batch);
> +
> +
> +

Quite some additional newlines and I'm not really fond of the
->poll_batch() name. It's a bit confusing with ->poll() and we also have
irq_poll(). But the only thing that would come to my mind is
complete_batch() which "races" with ->complete().

Otherwise looks OK,
Reviewed-by: Johannes Thumshirn <jthumshirn at suse.de>

-- 
Johannes Thumshirn                                          Storage
jthumshirn at suse.de                                +49 911 74053 689
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 N?rnberg
GF: Felix Imend?rffer, Jane Smithard, Graham Norton
HRB 21284 (AG N?rnberg)
Key fingerprint = EC38 9CAB C2C4 F25D 8600 D0D0 0393 969D 2D76 0850

  reply	other threads:[~2017-03-09 13:44 UTC|newest]

Thread overview: 85+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-03-09 13:16 [PATCH rfc 00/10] non selective polling block interface Sagi Grimberg
2017-03-09 13:16 ` Sagi Grimberg
2017-03-09 13:16 ` Sagi Grimberg
2017-03-09 13:16 ` [PATCH rfc 01/10] nvme-pci: Split __nvme_process_cq to poll and handle Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:57   ` Johannes Thumshirn
2017-03-09 13:57     ` Johannes Thumshirn
2017-03-09 13:57     ` Johannes Thumshirn
2017-03-22 19:07   ` Christoph Hellwig
2017-03-22 19:07     ` Christoph Hellwig
2017-03-22 19:07     ` Christoph Hellwig
2017-03-09 13:16 ` [PATCH rfc 02/10] nvme-pci: Add budget to __nvme_process_cq Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:46   ` Johannes Thumshirn
2017-03-09 13:46     ` Johannes Thumshirn
2017-03-09 13:46     ` Johannes Thumshirn
2017-03-22 19:08   ` Christoph Hellwig
2017-03-22 19:08     ` Christoph Hellwig
2017-03-09 13:16 ` [PATCH rfc 03/10] nvme-pci: open-code polling logic in nvme_poll Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:56   ` Johannes Thumshirn
2017-03-09 13:56     ` Johannes Thumshirn
2017-03-09 13:56     ` Johannes Thumshirn
2017-03-22 19:09   ` Christoph Hellwig
2017-03-22 19:09     ` Christoph Hellwig
2017-03-22 19:09     ` Christoph Hellwig
2017-03-09 13:16 ` [PATCH rfc 04/10] block: Add a non-selective polling interface Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:44   ` Johannes Thumshirn [this message]
2017-03-09 13:44     ` Johannes Thumshirn
2017-03-09 13:44     ` Johannes Thumshirn
2017-03-10  3:04     ` Damien Le Moal
2017-03-10  3:04       ` Damien Le Moal
2017-03-13  8:26       ` Sagi Grimberg
2017-03-13  8:26         ` Sagi Grimberg
2017-03-09 16:25   ` Bart Van Assche
2017-03-09 16:25     ` Bart Van Assche
2017-03-09 16:25     ` Bart Van Assche
2017-03-13  8:15     ` Sagi Grimberg
2017-03-13  8:15       ` Sagi Grimberg
2017-03-14 21:21       ` Bart Van Assche
2017-03-14 21:21         ` Bart Van Assche
2017-03-14 21:21         ` Bart Van Assche
2017-03-09 13:16 ` [PATCH rfc 05/10] nvme-pci: Support blk_poll_batch Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16 ` [PATCH rfc 06/10] IB/cq: Don't force IB_POLL_DIRECT poll context for ib_process_cq_direct Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 16:30   ` Bart Van Assche
2017-03-09 16:30     ` Bart Van Assche
2017-03-09 16:30     ` Bart Van Assche
2017-03-13  8:24     ` Sagi Grimberg
2017-03-13  8:24       ` Sagi Grimberg
2017-03-14 21:32       ` Bart Van Assche
2017-03-14 21:32         ` Bart Van Assche
2017-03-14 21:32         ` Bart Van Assche
2017-03-09 13:16 ` [PATCH rfc 07/10] nvme-rdma: Don't rearm the CQ when polling directly Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:52   ` Johannes Thumshirn
2017-03-09 13:52     ` Johannes Thumshirn
2017-03-09 13:52     ` Johannes Thumshirn
2017-03-09 13:16 ` [PATCH rfc 08/10] nvme-rdma: Support blk_poll_batch Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16 ` [PATCH rfc 09/10] nvmet: Use non-selective polling Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:54   ` Johannes Thumshirn
2017-03-09 13:54     ` Johannes Thumshirn
2017-03-09 13:54     ` Johannes Thumshirn
2017-03-09 13:16 ` [PATCH rfc 10/10] target: " Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-09 13:16   ` Sagi Grimberg
2017-03-18 23:58   ` Nicholas A. Bellinger
2017-03-18 23:58     ` Nicholas A. Bellinger
2017-03-18 23:58     ` Nicholas A. Bellinger
2017-03-21 11:35     ` Sagi Grimberg
2017-03-21 11:35       ` Sagi Grimberg
2017-03-21 11:35       ` Sagi Grimberg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=83713ef7-168d-e1f6-8220-b7d6264ea29a@suse.de \
    --to=jthumshirn@suse.de \
    --cc=linux-block@vger.kernel.org \
    --cc=linux-nvme@lists.infradead.org \
    --cc=linux-rdma@vger.kernel.org \
    --cc=sagi@grimberg.me \
    --cc=target-devel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.