All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Philippe Mathieu-Daudé" <philmd@redhat.com>
To: Klaus Jensen <its@irrelevant.dk>, qemu-block@nongnu.org
Cc: Kevin Wolf <kwolf@redhat.com>,
	Beata Michalska <beata.michalska@linaro.org>,
	Klaus Jensen <k.jensen@samsung.com>,
	qemu-devel@nongnu.org, Max Reitz <mreitz@redhat.com>,
	Keith Busch <kbusch@kernel.org>,
	Javier Gonzalez <javier.gonz@samsung.com>,
	Maxim Levitsky <mlevitsk@redhat.com>
Subject: Re: [PATCH 02/16] nvme: rename trace events to nvme_dev
Date: Wed, 15 Apr 2020 13:36:18 +0200	[thread overview]
Message-ID: <83edb49b-56b5-4504-8794-f7fcdf74fd67@redhat.com> (raw)
In-Reply-To: <20200415102445.564803-3-its@irrelevant.dk>

On 4/15/20 12:24 PM, Klaus Jensen wrote:
> From: Klaus Jensen <k.jensen@samsung.com>
> 
> Change the prefix of all nvme device related trace events to 'nvme_dev'

Another option is 'pci_nvme'. None of them make me happy but I can't 
find a better name.

> to not clash with trace events from the nvme block driver.
> 
> Signed-off-by: Klaus Jensen <k.jensen@samsung.com>
> Acked-by: Keith Busch <kbusch@kernel.org>
> Reviewed-by: Maxim Levitsky <mlevitsk@redhat.com>
> ---
>   hw/block/nvme.c       | 190 +++++++++++++++++++++---------------------
>   hw/block/trace-events | 172 +++++++++++++++++++-------------------
>   2 files changed, 180 insertions(+), 182 deletions(-)
> 
> diff --git a/hw/block/nvme.c b/hw/block/nvme.c
> index 77f9c151a665..316cfc4d36e0 100644
> --- a/hw/block/nvme.c
> +++ b/hw/block/nvme.c
> @@ -112,16 +112,16 @@ static void nvme_irq_assert(NvmeCtrl *n, NvmeCQueue *cq)
>   {
>       if (cq->irq_enabled) {
>           if (msix_enabled(&(n->parent_obj))) {
> -            trace_nvme_irq_msix(cq->vector);
> +            trace_nvme_dev_irq_msix(cq->vector);
>               msix_notify(&(n->parent_obj), cq->vector);
>           } else {
> -            trace_nvme_irq_pin();
> +            trace_nvme_dev_irq_pin();
>               assert(cq->cqid < 64);
>               n->irq_status |= 1 << cq->cqid;
>               nvme_irq_check(n);
>           }
>       } else {
> -        trace_nvme_irq_masked();
> +        trace_nvme_dev_irq_masked();
>       }
>   }
[...]



  reply	other threads:[~2020-04-15 11:37 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-15 10:24 [PATCH 00/16] nvme: refactoring and cleanups Klaus Jensen
2020-04-15 10:24 ` [PATCH 01/16] nvme: fix pci doorbell size calculation Klaus Jensen
2020-04-15 11:34   ` Philippe Mathieu-Daudé
2020-04-15 10:24 ` [PATCH 02/16] nvme: rename trace events to nvme_dev Klaus Jensen
2020-04-15 11:36   ` Philippe Mathieu-Daudé [this message]
2020-04-15 10:24 ` [PATCH 03/16] nvme: remove superfluous breaks Klaus Jensen
2020-04-15 10:24 ` [PATCH 04/16] nvme: move device parameters to separate struct Klaus Jensen
2020-04-15 10:24 ` [PATCH 05/16] nvme: use constants in identify Klaus Jensen
2020-04-15 10:24 ` [PATCH 06/16] nvme: refactor nvme_addr_read Klaus Jensen
2020-04-15 10:24 ` [PATCH 07/16] nvme: add max_ioqpairs device parameter Klaus Jensen
2020-04-15 11:02   ` Philippe Mathieu-Daudé
2020-04-15 10:24 ` [PATCH 08/16] nvme: remove redundant cmbloc/cmbsz members Klaus Jensen
2020-04-15 10:24 ` [PATCH 09/16] nvme: factor out property/constraint checks Klaus Jensen
2020-04-15 10:56   ` Philippe Mathieu-Daudé
2020-04-15 10:24 ` [PATCH 10/16] nvme: factor out device state setup Klaus Jensen
2020-04-15 10:54   ` Philippe Mathieu-Daudé
2020-04-15 10:24 ` [PATCH 11/16] nvme: factor out block backend setup Klaus Jensen
2020-04-15 10:52   ` Philippe Mathieu-Daudé
2020-04-15 11:02     ` Klaus Birkelund Jensen
2020-04-15 11:21       ` Klaus Birkelund Jensen
2020-04-15 10:24 ` [PATCH 12/16] nvme: add namespace helpers Klaus Jensen
2020-04-15 10:36   ` Philippe Mathieu-Daudé
2020-04-15 10:24 ` [PATCH 13/16] nvme: factor out namespace setup Klaus Jensen
2020-04-15 10:38   ` Philippe Mathieu-Daudé
2020-04-15 10:53     ` Klaus Birkelund Jensen
2020-04-15 10:59       ` Klaus Birkelund Jensen
2020-04-15 10:24 ` [PATCH 14/16] nvme: factor out pci setup Klaus Jensen
2020-04-15 10:43   ` Philippe Mathieu-Daudé
2020-04-15 10:24 ` [PATCH 15/16] nvme: factor out cmb setup Klaus Jensen
2020-04-15 10:45   ` Philippe Mathieu-Daudé
2020-04-15 10:24 ` [PATCH 16/16] nvme: factor out controller identify setup Klaus Jensen
2020-04-15 11:07   ` Philippe Mathieu-Daudé
2020-04-15 13:35 ` [PATCH 00/16] nvme: refactoring and cleanups no-reply

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=83edb49b-56b5-4504-8794-f7fcdf74fd67@redhat.com \
    --to=philmd@redhat.com \
    --cc=beata.michalska@linaro.org \
    --cc=its@irrelevant.dk \
    --cc=javier.gonz@samsung.com \
    --cc=k.jensen@samsung.com \
    --cc=kbusch@kernel.org \
    --cc=kwolf@redhat.com \
    --cc=mlevitsk@redhat.com \
    --cc=mreitz@redhat.com \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.