All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Julian Veenstra <davidjulianveenstra@gmail.com>
To: Jonathan Cameron <jic23@kernel.org>
Cc: devel@driverdev.osuosl.org, devicetree@vger.kernel.org,
	lars@metafoo.de, Michael.Hennerich@analog.com,
	linux-iio@vger.kernel.org, robh+dt@kernel.org, pmeerw@pmeerw.net,
	knaack.h@gmx.de, daniel.baluta@nxp.com
Subject: Re: [PATCH v2 06/13] staging: iio: ad2s1200: Introduce variable for repeated value
Date: Sun, 22 Apr 2018 16:29:47 +0200	[thread overview]
Message-ID: <87o9ibmi04.fsf@gmail.com> (raw)
In-Reply-To: <20180421175051.05f7e1b1@archlinux>


On 21, April 2018 18:50, Jonathan Cameron wrote:

> On Fri, 20 Apr 2018 21:30:19 +0200
> David Veenstra <davidjulianveenstra@gmail.com> wrote:
>
>> Add variable to hold &spi->dev in ad2s1200_probe. This value is repeatedly
>> used in ad2s1200_probe.
>> 
>> Signed-off-by: David Veenstra <davidjulianveenstra@gmail.com>
> No significant gain in readability.   Perhaps even a slight lost I'm
> going to say no to this one.

We discussed this in [1]. But after removal of platform data it will
be even less worth it. I'll remove this patch in v3.

Best regards,
David Veenstra

[1] https://marc.info/?l=linux-iio&m=152190029808229&w=2

>
> Jonathan
>
>> ---
>>  drivers/staging/iio/resolver/ad2s1200.c | 13 ++++++++-----
>>  1 file changed, 8 insertions(+), 5 deletions(-)
>> 
>> diff --git a/drivers/staging/iio/resolver/ad2s1200.c b/drivers/staging/iio/resolver/ad2s1200.c
>> index f07aab7e7a35..0a5fc9917e32 100644
>> --- a/drivers/staging/iio/resolver/ad2s1200.c
>> +++ b/drivers/staging/iio/resolver/ad2s1200.c
>> @@ -117,19 +117,22 @@ static int ad2s1200_probe(struct spi_device *spi)
>>  	unsigned short *pins = spi->dev.platform_data;
>>  	struct ad2s1200_state *st;
>>  	struct iio_dev *indio_dev;
>> +	struct device *dev;
>>  	int pn, ret = 0;
>>  
>> +	dev = &spi->dev;
>> +
>>  	for (pn = 0; pn < AD2S1200_PN; pn++) {
>> -		ret = devm_gpio_request_one(&spi->dev, pins[pn], GPIOF_DIR_OUT,
>> +		ret = devm_gpio_request_one(dev, pins[pn], GPIOF_DIR_OUT,
>>  					    DRV_NAME);
>>  		if (ret) {
>> -			dev_err(&spi->dev, "request gpio pin %d failed\n",
>> +			dev_err(dev, "request gpio pin %d failed\n",
>>  				pins[pn]);
>>  			return ret;
>>  		}
>>  	}
>>  
>> -	indio_dev = devm_iio_device_alloc(&spi->dev, sizeof(*st));
>> +	indio_dev = devm_iio_device_alloc(dev, sizeof(*st));
>>  	if (!indio_dev)
>>  		return -ENOMEM;
>>  
>> @@ -140,14 +143,14 @@ static int ad2s1200_probe(struct spi_device *spi)
>>  	st->sample = pins[0];
>>  	st->rdvel = pins[1];
>>  
>> -	indio_dev->dev.parent = &spi->dev;
>> +	indio_dev->dev.parent = dev;
>>  	indio_dev->info = &ad2s1200_info;
>>  	indio_dev->modes = INDIO_DIRECT_MODE;
>>  	indio_dev->channels = ad2s1200_channels;
>>  	indio_dev->num_channels = ARRAY_SIZE(ad2s1200_channels);
>>  	indio_dev->name = spi_get_device_id(spi)->name;
>>  
>> -	ret = devm_iio_device_register(&spi->dev, indio_dev);
>> +	ret = devm_iio_device_register(dev, indio_dev);
>>  	if (ret)
>>  		return ret;
>>  

WARNING: multiple messages have this Message-ID (diff)
From: David Julian Veenstra <davidjulianveenstra@gmail.com>
To: Jonathan Cameron <jic23@kernel.org>
Cc: lars@metafoo.de, pmeerw@pmeerw.net, robh+dt@kernel.org,
	Michael.Hennerich@analog.com, knaack.h@gmx.de,
	daniel.baluta@nxp.com, linux-iio@vger.kernel.org,
	devel@driverdev.osuosl.org, devicetree@vger.kernel.org
Subject: Re: [PATCH v2 06/13] staging: iio: ad2s1200: Introduce variable for repeated value
Date: Sun, 22 Apr 2018 16:29:47 +0200	[thread overview]
Message-ID: <87o9ibmi04.fsf@gmail.com> (raw)
In-Reply-To: <20180421175051.05f7e1b1@archlinux>


On 21, April 2018 18:50, Jonathan Cameron wrote:

> On Fri, 20 Apr 2018 21:30:19 +0200
> David Veenstra <davidjulianveenstra@gmail.com> wrote:
>
>> Add variable to hold &spi->dev in ad2s1200_probe. This value is repeatedly
>> used in ad2s1200_probe.
>> 
>> Signed-off-by: David Veenstra <davidjulianveenstra@gmail.com>
> No significant gain in readability.   Perhaps even a slight lost I'm
> going to say no to this one.

We discussed this in [1]. But after removal of platform data it will
be even less worth it. I'll remove this patch in v3.

Best regards,
David Veenstra

[1] https://marc.info/?l=linux-iio&m=152190029808229&w=2

>
> Jonathan
>
>> ---
>>  drivers/staging/iio/resolver/ad2s1200.c | 13 ++++++++-----
>>  1 file changed, 8 insertions(+), 5 deletions(-)
>> 
>> diff --git a/drivers/staging/iio/resolver/ad2s1200.c b/drivers/staging/iio/resolver/ad2s1200.c
>> index f07aab7e7a35..0a5fc9917e32 100644
>> --- a/drivers/staging/iio/resolver/ad2s1200.c
>> +++ b/drivers/staging/iio/resolver/ad2s1200.c
>> @@ -117,19 +117,22 @@ static int ad2s1200_probe(struct spi_device *spi)
>>  	unsigned short *pins = spi->dev.platform_data;
>>  	struct ad2s1200_state *st;
>>  	struct iio_dev *indio_dev;
>> +	struct device *dev;
>>  	int pn, ret = 0;
>>  
>> +	dev = &spi->dev;
>> +
>>  	for (pn = 0; pn < AD2S1200_PN; pn++) {
>> -		ret = devm_gpio_request_one(&spi->dev, pins[pn], GPIOF_DIR_OUT,
>> +		ret = devm_gpio_request_one(dev, pins[pn], GPIOF_DIR_OUT,
>>  					    DRV_NAME);
>>  		if (ret) {
>> -			dev_err(&spi->dev, "request gpio pin %d failed\n",
>> +			dev_err(dev, "request gpio pin %d failed\n",
>>  				pins[pn]);
>>  			return ret;
>>  		}
>>  	}
>>  
>> -	indio_dev = devm_iio_device_alloc(&spi->dev, sizeof(*st));
>> +	indio_dev = devm_iio_device_alloc(dev, sizeof(*st));
>>  	if (!indio_dev)
>>  		return -ENOMEM;
>>  
>> @@ -140,14 +143,14 @@ static int ad2s1200_probe(struct spi_device *spi)
>>  	st->sample = pins[0];
>>  	st->rdvel = pins[1];
>>  
>> -	indio_dev->dev.parent = &spi->dev;
>> +	indio_dev->dev.parent = dev;
>>  	indio_dev->info = &ad2s1200_info;
>>  	indio_dev->modes = INDIO_DIRECT_MODE;
>>  	indio_dev->channels = ad2s1200_channels;
>>  	indio_dev->num_channels = ARRAY_SIZE(ad2s1200_channels);
>>  	indio_dev->name = spi_get_device_id(spi)->name;
>>  
>> -	ret = devm_iio_device_register(&spi->dev, indio_dev);
>> +	ret = devm_iio_device_register(dev, indio_dev);
>>  	if (ret)
>>  		return ret;
>>  


  reply	other threads:[~2018-04-22 14:29 UTC|newest]

Thread overview: 66+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-20 19:28 [PATCH v2 00/13] staging: iio: ad2s1200: Driver clean up David Veenstra
2018-04-20 19:28 ` David Veenstra
2018-04-20 19:28 ` [PATCH v2 01/13] staging: iio: ad2s1200: Remove unneeded include David Veenstra
2018-04-20 19:28   ` David Veenstra
2018-04-21 16:45   ` Jonathan Cameron
2018-04-21 16:45     ` Jonathan Cameron
2018-04-20 19:28 ` [PATCH v2 02/13] staging: iio: ad2s1200: Sort includes alphabetically David Veenstra
2018-04-20 19:28   ` David Veenstra
2018-04-21 16:46   ` Jonathan Cameron
2018-04-21 16:46     ` Jonathan Cameron
2018-04-20 19:29 ` [PATCH v2 03/13] staging: iio: ad2s1200: Reverse Christmas tree ordering David Veenstra
2018-04-20 19:29   ` David Veenstra
2018-04-21 16:46   ` Jonathan Cameron
2018-04-21 16:46     ` Jonathan Cameron
2018-04-20 19:29 ` [PATCH v2 04/13] staging: iio: ad2s1200: Add blank lines David Veenstra
2018-04-20 19:29   ` David Veenstra
2018-04-21 16:47   ` Jonathan Cameron
2018-04-21 16:47     ` Jonathan Cameron
2018-04-20 19:30 ` [PATCH v2 05/13] staging: iio: ad2s1200: Add kernel docs to driver state David Veenstra
2018-04-20 19:30   ` David Veenstra
2018-04-21 16:49   ` Jonathan Cameron
2018-04-21 16:49     ` Jonathan Cameron
2018-04-22 14:26     ` David Julian Veenstra
2018-04-22 14:26       ` David Julian Veenstra
2018-04-20 19:30 ` [PATCH v2 06/13] staging: iio: ad2s1200: Introduce variable for repeated value David Veenstra
2018-04-20 19:30   ` David Veenstra
2018-04-21 16:50   ` Jonathan Cameron
2018-04-21 16:50     ` Jonathan Cameron
2018-04-22 14:29     ` David Julian Veenstra [this message]
2018-04-22 14:29       ` David Julian Veenstra
2018-04-20 19:30 ` [PATCH v2 07/13] staging: iio: ad2s1200: Improve readability with be16_to_cpup David Veenstra
2018-04-20 19:30   ` David Veenstra
2018-04-21 16:55   ` Jonathan Cameron
2018-04-21 16:55     ` Jonathan Cameron
2018-04-22 14:31     ` David Julian Veenstra
2018-04-22 14:31       ` David Julian Veenstra
2018-04-20 19:30 ` [PATCH v2 08/13] staging: iio: ad2s1200: Replace legacy gpio API with modern API David Veenstra
2018-04-20 19:30   ` David Veenstra
2018-04-21 16:58   ` Jonathan Cameron
2018-04-21 16:58     ` Jonathan Cameron
2018-04-22 14:32     ` David Julian Veenstra
2018-04-22 14:32       ` David Julian Veenstra
2018-04-20 19:30 ` [PATCH v2 09/13] staging: iio: ad2s1200: Add documentation for device tree binding David Veenstra
2018-04-20 19:30   ` David Veenstra
2018-04-21 17:03   ` Jonathan Cameron
2018-04-21 17:03     ` Jonathan Cameron
2018-04-20 19:31 ` [PATCH v2 10/13] staging: iio: ad2s1200: Add scaling factor for angular velocity channel David Veenstra
2018-04-20 19:31   ` David Veenstra
2018-04-21 17:07   ` Jonathan Cameron
2018-04-21 17:07     ` Jonathan Cameron
2018-04-22 14:37     ` David Julian Veenstra
2018-04-22 14:37       ` David Julian Veenstra
2018-04-20 19:31 ` [PATCH v2 11/13] staging: iio: Documentation: Add missing sysfs docs for angle channel David Veenstra
2018-04-20 19:31   ` David Veenstra
2018-04-21 17:08   ` Jonathan Cameron
2018-04-21 17:08     ` Jonathan Cameron
2018-04-22 14:41     ` David Julian Veenstra
2018-04-22 14:41       ` David Julian Veenstra
2018-04-20 19:31 ` [PATCH v2 12/13] staging: iio: ad2s1200: Add scaling factor " David Veenstra
2018-04-20 19:31   ` David Veenstra
2018-04-21 17:10   ` Jonathan Cameron
2018-04-21 17:10     ` Jonathan Cameron
2018-04-20 19:32 ` [PATCH v2 13/13] staging: iio: ad2s1200: Move driver out of staging David Veenstra
2018-04-20 19:32   ` David Veenstra
2018-04-21 17:11   ` Jonathan Cameron
2018-04-21 17:11     ` Jonathan Cameron

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87o9ibmi04.fsf@gmail.com \
    --to=davidjulianveenstra@gmail.com \
    --cc=Michael.Hennerich@analog.com \
    --cc=daniel.baluta@nxp.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=devicetree@vger.kernel.org \
    --cc=jic23@kernel.org \
    --cc=knaack.h@gmx.de \
    --cc=lars@metafoo.de \
    --cc=linux-iio@vger.kernel.org \
    --cc=pmeerw@pmeerw.net \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.