All of lore.kernel.org
 help / color / mirror / Atom feed
From: Felipe Contreras <felipe.contreras@gmail.com>
To: "Kanigeri, Hari" <h-kanigeri2@ti.com>
Cc: "linux-omap@vger.kernel.org" <linux-omap@vger.kernel.org>,
	Hiroshi DOYU <Hiroshi.DOYU@nokia.com>,
	"ameya.palande@nokia.com" <ameya.palande@nokia.com>
Subject: Re: [PATCH v2 3/4] dsp-bridge: cleanup and remove HW_MBOX_IsFull
Date: Tue, 24 Feb 2009 00:22:45 +0200	[thread overview]
Message-ID: <94a0d4530902231422y6b044cb2qe686c7e106ff2e5e@mail.gmail.com> (raw)
In-Reply-To: <8F7AF80515AF0D4D93307E594F3CB40E211807CE@dlee03.ent.ti.com>

On Tue, Feb 24, 2009 at 12:06 AM, Kanigeri, Hari <h-kanigeri2@ti.com> wrote:
> Hi Felipe,
>
>> HW_MBOX_IsFull has many convoluted macros and is used only once. Clean
>> it up so it's easier to see what it's actually doing.
>
> -- Is this the reason you added a new function that checks if fifo is full or is there any issue with the existing function ?

fifo_full should do exactly the same as HW_MBOX_IsFulll, I just
removed all the macros and used __raw_readl instead. I could have
removed the fifo_full function and do the __raw_readl directly, but I
thought this way it was more readable.

The main reason I cleaned the function was for performance reasons;
remove unnecessary checks, extra steps, and the function call (now
inline).

-- 
Felipe Contreras

  reply	other threads:[~2009-02-23 22:22 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-02-20 23:04 [PATCH] dspbridge: wait less and check the mailbox more Felipe Contreras
2009-02-22  5:21 ` Hiroshi DOYU
2009-02-22  6:46   ` Felipe Contreras
2009-02-22  9:32     ` [PATCH v2 1/4] dsp-bridge: remove unnecessary comments in util.h Felipe Contreras
2009-02-22  9:32       ` [PATCH v2 2/4] dsp-bridge: remove UTIL_Wait wrapper Felipe Contreras
2009-02-22  9:32         ` [PATCH v2 3/4] dsp-bridge: cleanup and remove HW_MBOX_IsFull Felipe Contreras
2009-02-22  9:32           ` [PATCH v2 4/4] dsp-bridge: wait less and check the mailbox more Felipe Contreras
2009-02-23 22:06           ` [PATCH v2 3/4] dsp-bridge: cleanup and remove HW_MBOX_IsFull Kanigeri, Hari
2009-02-23 22:22             ` Felipe Contreras [this message]
2009-02-23 22:22         ` [PATCH v2 2/4] dsp-bridge: remove UTIL_Wait wrapper Kanigeri, Hari
2009-02-22 11:35       ` [PATCH v2 1/4] dsp-bridge: remove unnecessary comments in util.h Hiroshi DOYU

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=94a0d4530902231422y6b044cb2qe686c7e106ff2e5e@mail.gmail.com \
    --to=felipe.contreras@gmail.com \
    --cc=Hiroshi.DOYU@nokia.com \
    --cc=ameya.palande@nokia.com \
    --cc=h-kanigeri2@ti.com \
    --cc=linux-omap@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.