All of lore.kernel.org
 help / color / mirror / Atom feed
From: Fuad Tabba <tabba@google.com>
To: Will Deacon <will@kernel.org>
Cc: kvmarm@lists.cs.columbia.edu, maz@kernel.org,
	james.morse@arm.com, alexandru.elisei@arm.com,
	suzuki.poulose@arm.com, mark.rutland@arm.com,
	christoffer.dall@arm.com, pbonzini@redhat.com,
	drjones@redhat.com, qperret@google.com, kvm@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org, kernel-team@android.com
Subject: Re: [PATCH v2 03/13] KVM: arm64: Fix names of config register fields
Date: Thu, 1 Jul 2021 14:44:50 +0100	[thread overview]
Message-ID: <CA+EHjTxmmLtGgSm6XOe9PL7S5hkjuzeW6VSzQbhR1wT5RWi7WQ@mail.gmail.com> (raw)
In-Reply-To: <20210701130149.GC9757@willie-the-truck>

Hi Will,

On Thu, Jul 1, 2021 at 2:01 PM Will Deacon <will@kernel.org> wrote:
>
> On Tue, Jun 15, 2021 at 02:39:40PM +0100, Fuad Tabba wrote:
> > Change the names of hcr_el2 register fields to match the Arm
> > Architecture Reference Manual. Easier for cross-referencing and
> > for grepping.
> >
> > Also, change the name of CPTR_EL2_RES1 to CPTR_NVHE_EL2_RES1,
> > because res1 bits are different for VHE.
> >
> > No functional change intended.
> >
> > Signed-off-by: Fuad Tabba <tabba@google.com>
> > ---
> >  arch/arm64/include/asm/kvm_arm.h | 12 ++++++------
> >  1 file changed, 6 insertions(+), 6 deletions(-)
> >
> > diff --git a/arch/arm64/include/asm/kvm_arm.h b/arch/arm64/include/asm/kvm_arm.h
> > index 25d8a61888e4..bee1ba6773fb 100644
> > --- a/arch/arm64/include/asm/kvm_arm.h
> > +++ b/arch/arm64/include/asm/kvm_arm.h
> > @@ -31,9 +31,9 @@
> >  #define HCR_TVM              (UL(1) << 26)
> >  #define HCR_TTLB     (UL(1) << 25)
> >  #define HCR_TPU              (UL(1) << 24)
> > -#define HCR_TPC              (UL(1) << 23)
> > +#define HCR_TPCP     (UL(1) << 23)
>
> This one is a bit weird: the field is called TPCP if the CPU supports
> FEAT_DPB but is called TPC otherwise! So I don't think renaming it like
> this really makes anything better. Perhaps add a comment:
>
>   #define HCR_TPC       (UL(1) << 23)   /* TPCP if FEAT_DPB */

I missed that. That's why it's referred to as Bit[23] in the diagram.
I'll add the comment and revert its name.

Thanks,
/fuad

> ?
>
> Rest of the patch looks good:
>
> Acked-by: Will Deacon <will@kernel.org>
>
> Will

WARNING: multiple messages have this Message-ID (diff)
From: Fuad Tabba <tabba@google.com>
To: Will Deacon <will@kernel.org>
Cc: kernel-team@android.com, kvm@vger.kernel.org, maz@kernel.org,
	pbonzini@redhat.com, kvmarm@lists.cs.columbia.edu,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v2 03/13] KVM: arm64: Fix names of config register fields
Date: Thu, 1 Jul 2021 14:44:50 +0100	[thread overview]
Message-ID: <CA+EHjTxmmLtGgSm6XOe9PL7S5hkjuzeW6VSzQbhR1wT5RWi7WQ@mail.gmail.com> (raw)
In-Reply-To: <20210701130149.GC9757@willie-the-truck>

Hi Will,

On Thu, Jul 1, 2021 at 2:01 PM Will Deacon <will@kernel.org> wrote:
>
> On Tue, Jun 15, 2021 at 02:39:40PM +0100, Fuad Tabba wrote:
> > Change the names of hcr_el2 register fields to match the Arm
> > Architecture Reference Manual. Easier for cross-referencing and
> > for grepping.
> >
> > Also, change the name of CPTR_EL2_RES1 to CPTR_NVHE_EL2_RES1,
> > because res1 bits are different for VHE.
> >
> > No functional change intended.
> >
> > Signed-off-by: Fuad Tabba <tabba@google.com>
> > ---
> >  arch/arm64/include/asm/kvm_arm.h | 12 ++++++------
> >  1 file changed, 6 insertions(+), 6 deletions(-)
> >
> > diff --git a/arch/arm64/include/asm/kvm_arm.h b/arch/arm64/include/asm/kvm_arm.h
> > index 25d8a61888e4..bee1ba6773fb 100644
> > --- a/arch/arm64/include/asm/kvm_arm.h
> > +++ b/arch/arm64/include/asm/kvm_arm.h
> > @@ -31,9 +31,9 @@
> >  #define HCR_TVM              (UL(1) << 26)
> >  #define HCR_TTLB     (UL(1) << 25)
> >  #define HCR_TPU              (UL(1) << 24)
> > -#define HCR_TPC              (UL(1) << 23)
> > +#define HCR_TPCP     (UL(1) << 23)
>
> This one is a bit weird: the field is called TPCP if the CPU supports
> FEAT_DPB but is called TPC otherwise! So I don't think renaming it like
> this really makes anything better. Perhaps add a comment:
>
>   #define HCR_TPC       (UL(1) << 23)   /* TPCP if FEAT_DPB */

I missed that. That's why it's referred to as Bit[23] in the diagram.
I'll add the comment and revert its name.

Thanks,
/fuad

> ?
>
> Rest of the patch looks good:
>
> Acked-by: Will Deacon <will@kernel.org>
>
> Will
_______________________________________________
kvmarm mailing list
kvmarm@lists.cs.columbia.edu
https://lists.cs.columbia.edu/mailman/listinfo/kvmarm

WARNING: multiple messages have this Message-ID (diff)
From: Fuad Tabba <tabba@google.com>
To: Will Deacon <will@kernel.org>
Cc: kvmarm@lists.cs.columbia.edu, maz@kernel.org,
	james.morse@arm.com,  alexandru.elisei@arm.com,
	suzuki.poulose@arm.com, mark.rutland@arm.com,
	 christoffer.dall@arm.com, pbonzini@redhat.com,
	drjones@redhat.com,  qperret@google.com, kvm@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org,  kernel-team@android.com
Subject: Re: [PATCH v2 03/13] KVM: arm64: Fix names of config register fields
Date: Thu, 1 Jul 2021 14:44:50 +0100	[thread overview]
Message-ID: <CA+EHjTxmmLtGgSm6XOe9PL7S5hkjuzeW6VSzQbhR1wT5RWi7WQ@mail.gmail.com> (raw)
In-Reply-To: <20210701130149.GC9757@willie-the-truck>

Hi Will,

On Thu, Jul 1, 2021 at 2:01 PM Will Deacon <will@kernel.org> wrote:
>
> On Tue, Jun 15, 2021 at 02:39:40PM +0100, Fuad Tabba wrote:
> > Change the names of hcr_el2 register fields to match the Arm
> > Architecture Reference Manual. Easier for cross-referencing and
> > for grepping.
> >
> > Also, change the name of CPTR_EL2_RES1 to CPTR_NVHE_EL2_RES1,
> > because res1 bits are different for VHE.
> >
> > No functional change intended.
> >
> > Signed-off-by: Fuad Tabba <tabba@google.com>
> > ---
> >  arch/arm64/include/asm/kvm_arm.h | 12 ++++++------
> >  1 file changed, 6 insertions(+), 6 deletions(-)
> >
> > diff --git a/arch/arm64/include/asm/kvm_arm.h b/arch/arm64/include/asm/kvm_arm.h
> > index 25d8a61888e4..bee1ba6773fb 100644
> > --- a/arch/arm64/include/asm/kvm_arm.h
> > +++ b/arch/arm64/include/asm/kvm_arm.h
> > @@ -31,9 +31,9 @@
> >  #define HCR_TVM              (UL(1) << 26)
> >  #define HCR_TTLB     (UL(1) << 25)
> >  #define HCR_TPU              (UL(1) << 24)
> > -#define HCR_TPC              (UL(1) << 23)
> > +#define HCR_TPCP     (UL(1) << 23)
>
> This one is a bit weird: the field is called TPCP if the CPU supports
> FEAT_DPB but is called TPC otherwise! So I don't think renaming it like
> this really makes anything better. Perhaps add a comment:
>
>   #define HCR_TPC       (UL(1) << 23)   /* TPCP if FEAT_DPB */

I missed that. That's why it's referred to as Bit[23] in the diagram.
I'll add the comment and revert its name.

Thanks,
/fuad

> ?
>
> Rest of the patch looks good:
>
> Acked-by: Will Deacon <will@kernel.org>
>
> Will

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

  reply	other threads:[~2021-07-01 13:45 UTC|newest]

Thread overview: 96+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-06-15 13:39 [PATCH v2 00/13] KVM: arm64: Fixed features for protected VMs Fuad Tabba
2021-06-15 13:39 ` Fuad Tabba
2021-06-15 13:39 ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 01/13] KVM: arm64: Remove trailing whitespace in comments Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-07-01 12:55   ` Will Deacon
2021-07-01 12:55     ` Will Deacon
2021-07-01 12:55     ` Will Deacon
2021-07-01 13:24     ` Fuad Tabba
2021-07-01 13:24       ` Fuad Tabba
2021-07-01 13:24       ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 02/13] KVM: arm64: MDCR_EL2 is a 64-bit register Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-07-01 12:53   ` Will Deacon
2021-07-01 12:53     ` Will Deacon
2021-07-01 12:53     ` Will Deacon
2021-07-01 13:24     ` Fuad Tabba
2021-07-01 13:24       ` Fuad Tabba
2021-07-01 13:24       ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 03/13] KVM: arm64: Fix names of config register fields Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-07-01 13:01   ` Will Deacon
2021-07-01 13:01     ` Will Deacon
2021-07-01 13:01     ` Will Deacon
2021-07-01 13:44     ` Fuad Tabba [this message]
2021-07-01 13:44       ` Fuad Tabba
2021-07-01 13:44       ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 04/13] KVM: arm64: Refactor sys_regs.h,c for nVHE reuse Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-07-01 13:09   ` Will Deacon
2021-07-01 13:09     ` [PATCH v2 04/13] KVM: arm64: Refactor sys_regs.h, c " Will Deacon
2021-07-01 13:09     ` Will Deacon
2021-07-01 14:04     ` [PATCH v2 04/13] KVM: arm64: Refactor sys_regs.h,c " Fuad Tabba
2021-07-01 14:04       ` [PATCH v2 04/13] KVM: arm64: Refactor sys_regs.h, c " Fuad Tabba
2021-07-01 14:04       ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 05/13] KVM: arm64: Restore mdcr_el2 from vcpu Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-07-01 13:17   ` Will Deacon
2021-07-01 13:17     ` Will Deacon
2021-07-01 13:17     ` Will Deacon
2021-07-01 14:05     ` Fuad Tabba
2021-07-01 14:05       ` Fuad Tabba
2021-07-01 14:05       ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 06/13] KVM: arm64: Add feature register flag definitions Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-07-01 13:22   ` Will Deacon
2021-07-01 13:22     ` Will Deacon
2021-07-01 13:22     ` Will Deacon
2021-07-01 14:31     ` Fuad Tabba
2021-07-01 14:31       ` Fuad Tabba
2021-07-01 14:31       ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 07/13] KVM: arm64: Add config register bit definitions Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-07-01 13:33   ` Will Deacon
2021-07-01 13:33     ` Will Deacon
2021-07-01 13:33     ` Will Deacon
2021-07-01 14:52     ` Fuad Tabba
2021-07-01 14:52       ` Fuad Tabba
2021-07-01 14:52       ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 08/13] KVM: arm64: Guest exit handlers for nVHE hyp Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-07-01 13:48   ` Will Deacon
2021-07-01 13:48     ` Will Deacon
2021-07-01 13:48     ` Will Deacon
2021-07-01 14:58     ` Fuad Tabba
2021-07-01 14:58       ` Fuad Tabba
2021-07-01 14:58       ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 09/13] KVM: arm64: Add trap handlers for protected VMs Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-07-01 14:08   ` Will Deacon
2021-07-01 14:08     ` Will Deacon
2021-07-01 14:08     ` Will Deacon
2021-07-14 20:01     ` Andrew Jones
2021-07-14 20:01       ` Andrew Jones
2021-07-14 20:01       ` Andrew Jones
2021-06-15 13:39 ` [PATCH v2 10/13] KVM: arm64: Move sanitized copies of CPU features Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 11/13] KVM: arm64: Trap access to pVM restricted features Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 12/13] KVM: arm64: Handle protected guests at 32 bits Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39 ` [PATCH v2 13/13] KVM: arm64: Check vcpu features at pVM creation Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba
2021-06-15 13:39   ` Fuad Tabba

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CA+EHjTxmmLtGgSm6XOe9PL7S5hkjuzeW6VSzQbhR1wT5RWi7WQ@mail.gmail.com \
    --to=tabba@google.com \
    --cc=alexandru.elisei@arm.com \
    --cc=christoffer.dall@arm.com \
    --cc=drjones@redhat.com \
    --cc=james.morse@arm.com \
    --cc=kernel-team@android.com \
    --cc=kvm@vger.kernel.org \
    --cc=kvmarm@lists.cs.columbia.edu \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=mark.rutland@arm.com \
    --cc=maz@kernel.org \
    --cc=pbonzini@redhat.com \
    --cc=qperret@google.com \
    --cc=suzuki.poulose@arm.com \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.