All of lore.kernel.org
 help / color / mirror / Atom feed
From: Shengjiu Wang <shengjiu.wang@gmail.com>
To: Nicolin Chen <nicoleotsuka@gmail.com>
Cc: Shengjiu Wang <shengjiu.wang@nxp.com>,
	Mark Rutland <mark.rutland@arm.com>,
	"open list:OPEN FIRMWARE AND FLATTENED DEVICE TREE BINDINGS" 
	<devicetree@vger.kernel.org>,
	Linux-ALSA <alsa-devel@alsa-project.org>,
	Timur Tabi <timur@kernel.org>, Xiubo Li <Xiubo.Lee@gmail.com>,
	linuxppc-dev@lists.ozlabs.org, Takashi Iwai <tiwai@suse.com>,
	Liam Girdwood <lgirdwood@gmail.com>,
	Rob Herring <robh+dt@kernel.org>, Mark Brown <broonie@kernel.org>,
	Fabio Estevam <festevam@gmail.com>,
	linux-kernel <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v6 5/7] ASoC: fsl_asrc: Move common definition to fsl_asrc_common
Date: Mon, 13 Apr 2020 15:19:08 +0800	[thread overview]
Message-ID: <CAA+D8ANUDAfLVJ6NQvtHSV27G4RUoQYEnA3Ym0wH28YCA6bZMg@mail.gmail.com> (raw)
In-Reply-To: <20200413043143.GA9116@Asurada>

On Mon, Apr 13, 2020 at 12:31 PM Nicolin Chen <nicoleotsuka@gmail.com> wrote:
>
> On Mon, Apr 13, 2020 at 11:16:31AM +0800, Shengjiu Wang wrote:
> > On Sun, Apr 12, 2020 at 10:08 AM Nicolin Chen <nicoleotsuka@gmail.com> wrote:
> > >
> > > On Sat, Apr 11, 2020 at 01:49:43PM +0800, Shengjiu Wang wrote:
> > >
> > > > > > diff --git a/sound/soc/fsl/fsl_asrc_dma.c b/sound/soc/fsl/fsl_asrc_dma.c
> > > > > > index b15946e03380..5cf0468ce6e3 100644
> > > > > > --- a/sound/soc/fsl/fsl_asrc_dma.c
> > > > > > +++ b/sound/soc/fsl/fsl_asrc_dma.c
> > > > >
> > > > > > @@ -311,11 +311,12 @@ static int fsl_asrc_dma_startup(struct snd_soc_component *component,
> > > > > >               return ret;
> > > > > >       }
> > > > > >
> > > > > > -     pair = kzalloc(sizeof(struct fsl_asrc_pair), GFP_KERNEL);
> > > > > > +     pair = kzalloc(sizeof(struct fsl_asrc_pair) + PAIR_PRIVAT_SIZE, GFP_KERNEL);
> > > > >
> > > > > If we only use the PAIR_PRIVATE_SIZE here, maybe we can put the
> > > > > define in this file too, rather than in the header file.
> > > > >
> > > > > And could fit 80 characters:
> > > > >
> > > > > +       pair = kzalloc(sizeof(*pair) + PAIR_PRIVAT_SIZE, GFP_KERNEL);
> > >
> > > > I will use a function pointer
> > > >     int (*get_pair_priv_size)(void)
> > >
> > > Since it's the size of pair or cts structure, could be just a
> > > size_t variable?
> >
> > Yes, should be "size_t (*get_pair_priv_size)(void)"
>
> Does it have to be a function? -- how about this:
>
> struct pair {
>         ...
>         size_t private_size;
>         void *private;
> };
>
> probe/or-somewhere() {
>         ...
>         pair->private = pair_priv;

we need to know the size of pair_priv before allocate memory.

>         pair->private_size = sizeof(*pair_priv);
>         ...
> }

In fsl_asrc_dma_startup, we need to allocate memory for pair and
pair->private,but we don't know the object, so we don't know the
size of private, so function pointer is better.

best regards
wang shengjiu

WARNING: multiple messages have this Message-ID (diff)
From: Shengjiu Wang <shengjiu.wang@gmail.com>
To: Nicolin Chen <nicoleotsuka@gmail.com>
Cc: Mark Rutland <mark.rutland@arm.com>,
	"open list:OPEN FIRMWARE AND FLATTENED DEVICE TREE BINDINGS"
	<devicetree@vger.kernel.org>,
	Linux-ALSA <alsa-devel@alsa-project.org>,
	Timur Tabi <timur@kernel.org>, Xiubo Li <Xiubo.Lee@gmail.com>,
	Fabio Estevam <festevam@gmail.com>,
	Shengjiu Wang <shengjiu.wang@nxp.com>,
	Takashi Iwai <tiwai@suse.com>,
	Liam Girdwood <lgirdwood@gmail.com>,
	Rob Herring <robh+dt@kernel.org>, Mark Brown <broonie@kernel.org>,
	linuxppc-dev@lists.ozlabs.org,
	linux-kernel <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v6 5/7] ASoC: fsl_asrc: Move common definition to fsl_asrc_common
Date: Mon, 13 Apr 2020 15:19:08 +0800	[thread overview]
Message-ID: <CAA+D8ANUDAfLVJ6NQvtHSV27G4RUoQYEnA3Ym0wH28YCA6bZMg@mail.gmail.com> (raw)
In-Reply-To: <20200413043143.GA9116@Asurada>

On Mon, Apr 13, 2020 at 12:31 PM Nicolin Chen <nicoleotsuka@gmail.com> wrote:
>
> On Mon, Apr 13, 2020 at 11:16:31AM +0800, Shengjiu Wang wrote:
> > On Sun, Apr 12, 2020 at 10:08 AM Nicolin Chen <nicoleotsuka@gmail.com> wrote:
> > >
> > > On Sat, Apr 11, 2020 at 01:49:43PM +0800, Shengjiu Wang wrote:
> > >
> > > > > > diff --git a/sound/soc/fsl/fsl_asrc_dma.c b/sound/soc/fsl/fsl_asrc_dma.c
> > > > > > index b15946e03380..5cf0468ce6e3 100644
> > > > > > --- a/sound/soc/fsl/fsl_asrc_dma.c
> > > > > > +++ b/sound/soc/fsl/fsl_asrc_dma.c
> > > > >
> > > > > > @@ -311,11 +311,12 @@ static int fsl_asrc_dma_startup(struct snd_soc_component *component,
> > > > > >               return ret;
> > > > > >       }
> > > > > >
> > > > > > -     pair = kzalloc(sizeof(struct fsl_asrc_pair), GFP_KERNEL);
> > > > > > +     pair = kzalloc(sizeof(struct fsl_asrc_pair) + PAIR_PRIVAT_SIZE, GFP_KERNEL);
> > > > >
> > > > > If we only use the PAIR_PRIVATE_SIZE here, maybe we can put the
> > > > > define in this file too, rather than in the header file.
> > > > >
> > > > > And could fit 80 characters:
> > > > >
> > > > > +       pair = kzalloc(sizeof(*pair) + PAIR_PRIVAT_SIZE, GFP_KERNEL);
> > >
> > > > I will use a function pointer
> > > >     int (*get_pair_priv_size)(void)
> > >
> > > Since it's the size of pair or cts structure, could be just a
> > > size_t variable?
> >
> > Yes, should be "size_t (*get_pair_priv_size)(void)"
>
> Does it have to be a function? -- how about this:
>
> struct pair {
>         ...
>         size_t private_size;
>         void *private;
> };
>
> probe/or-somewhere() {
>         ...
>         pair->private = pair_priv;

we need to know the size of pair_priv before allocate memory.

>         pair->private_size = sizeof(*pair_priv);
>         ...
> }

In fsl_asrc_dma_startup, we need to allocate memory for pair and
pair->private,but we don't know the object, so we don't know the
size of private, so function pointer is better.

best regards
wang shengjiu

  reply	other threads:[~2020-04-13  7:19 UTC|newest]

Thread overview: 48+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-01  8:45 [PATCH v6 0/7] ASoC: Add new module driver for new ASRC Shengjiu Wang
2020-04-01  8:45 ` [PATCH v6 1/7] ASoC: fsl_asrc: rename asrc_priv to asrc Shengjiu Wang
2020-04-01  9:00   ` Nicolin Chen
2020-04-01  9:00     ` Nicolin Chen
2020-04-01  9:00     ` Nicolin Chen
2020-04-01  8:45 ` [PATCH v6 2/7] ASoC: dt-bindings: fsl_asrc: Add new property fsl,asrc-format Shengjiu Wang
2020-04-01  8:45   ` [PATCH v6 2/7] ASoC: dt-bindings: fsl_asrc: Add new property fsl, asrc-format Shengjiu Wang
2020-04-06 22:43   ` [PATCH v6 2/7] ASoC: dt-bindings: fsl_asrc: Add new property fsl,asrc-format Nicolin Chen
2020-04-06 22:43     ` Nicolin Chen
2020-04-06 22:43     ` Nicolin Chen
2020-04-14 15:23   ` Rob Herring
2020-04-14 15:23     ` Rob Herring
2020-04-14 15:23     ` Rob Herring
2020-04-01  8:45 ` [PATCH v6 3/7] ASoC: fsl-asoc-card: Support " Shengjiu Wang
2020-04-01  8:45   ` [PATCH v6 3/7] ASoC: fsl-asoc-card: Support new property fsl, asrc-format Shengjiu Wang
2020-04-06 22:59   ` [PATCH v6 3/7] ASoC: fsl-asoc-card: Support new property fsl,asrc-format Nicolin Chen
2020-04-06 22:59     ` Nicolin Chen
2020-04-06 22:59     ` Nicolin Chen
2020-04-01  8:45 ` [PATCH v6 4/7] ASoC: fsl_asrc: " Shengjiu Wang
2020-04-06 23:19   ` Nicolin Chen
2020-04-06 23:19     ` Nicolin Chen
2020-04-06 23:19     ` Nicolin Chen
2020-04-01  8:45 ` [PATCH v6 5/7] ASoC: fsl_asrc: Move common definition to fsl_asrc_common Shengjiu Wang
2020-04-06 23:48   ` Nicolin Chen
2020-04-06 23:48     ` Nicolin Chen
2020-04-06 23:48     ` Nicolin Chen
2020-04-11  5:49     ` Shengjiu Wang
2020-04-11  5:49       ` Shengjiu Wang
2020-04-12  2:08       ` Nicolin Chen
2020-04-12  2:08         ` Nicolin Chen
2020-04-13  3:16         ` Shengjiu Wang
2020-04-13  3:16           ` Shengjiu Wang
2020-04-13  4:31           ` Nicolin Chen
2020-04-13  4:31             ` Nicolin Chen
2020-04-13  7:19             ` Shengjiu Wang [this message]
2020-04-13  7:19               ` Shengjiu Wang
2020-04-01  8:45 ` [PATCH v6 6/7] ASoC: dt-bindings: fsl_easrc: Add document for EASRC Shengjiu Wang
2020-04-14 15:46   ` Rob Herring
2020-04-14 15:46     ` Rob Herring
2020-04-14 15:46     ` Rob Herring
2020-04-15  2:55     ` Shengjiu Wang
2020-04-15  2:55       ` Shengjiu Wang
2020-04-15 14:11       ` Rob Herring
2020-04-15 14:11         ` Rob Herring
2020-04-01  8:45 ` [PATCH v6 7/7] ASoC: fsl_easrc: Add EASRC ASoC CPU DAI drivers Shengjiu Wang
2020-04-07  0:29   ` Nicolin Chen
2020-04-07  0:29     ` Nicolin Chen
2020-04-07  0:29     ` Nicolin Chen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAA+D8ANUDAfLVJ6NQvtHSV27G4RUoQYEnA3Ym0wH28YCA6bZMg@mail.gmail.com \
    --to=shengjiu.wang@gmail.com \
    --cc=Xiubo.Lee@gmail.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=broonie@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=festevam@gmail.com \
    --cc=lgirdwood@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mark.rutland@arm.com \
    --cc=nicoleotsuka@gmail.com \
    --cc=robh+dt@kernel.org \
    --cc=shengjiu.wang@nxp.com \
    --cc=timur@kernel.org \
    --cc=tiwai@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.