All of lore.kernel.org
 help / color / mirror / Atom feed
From: John Stultz <john.stultz@linaro.org>
To: "Andrew F. Davis" <afd@ti.com>
Cc: lkml <linux-kernel@vger.kernel.org>,
	Laura Abbott <labbott@redhat.com>,
	Benjamin Gaignard <benjamin.gaignard@linaro.org>,
	Sumit Semwal <sumit.semwal@linaro.org>,
	Liam Mark <lmark@codeaurora.org>,
	Pratik Patel <pratikp@codeaurora.org>,
	Brian Starkey <Brian.Starkey@arm.com>,
	Vincent Donnefort <Vincent.Donnefort@arm.com>,
	Sudipto Paul <Sudipto.Paul@arm.com>,
	Christoph Hellwig <hch@infradead.org>,
	Chenbo Feng <fengc@google.com>,
	Alistair Strachan <astrachan@google.com>,
	Hridya Valsaraju <hridya@google.com>,
	Sandeep Patil <sspatil@google.com>,
	Hillf Danton <hdanton@sina.com>, Dave Airlie <airlied@gmail.com>,
	dri-devel <dri-devel@lists.freedesktop.org>
Subject: Re: [RESEND][PATCH v16 1/5] dma-buf: Add dma-buf heaps framework
Date: Thu, 12 Dec 2019 10:33:36 -0800	[thread overview]
Message-ID: <CALAqxLV5XwrJU2psx_ALFK1q9ZTaLTGRD9dgQhGQ5v=ojfyE+w@mail.gmail.com> (raw)
In-Reply-To: <b3e979ab-0c95-4e16-6399-9bed09e08a7b@ti.com>

On Thu, Dec 12, 2019 at 8:52 AM Andrew F. Davis <afd@ti.com> wrote:
> On 12/3/19 12:26 PM, John Stultz wrote:
> > +#define DMA_HEAP_IOC_MAGIC           'H'
> > +
> > +/**
> > + * DOC: DMA_HEAP_IOC_ALLOC - allocate memory from pool
> > + *
> > + * Takes a dma_heap_allocation_data struct and returns it with the fd field
> > + * populated with the dmabuf handle of the allocation.
> > + */
> > +#define DMA_HEAP_IOC_ALLOC   _IOWR(DMA_HEAP_IOC_MAGIC, 0x0,\
> > +                                   struct dma_heap_allocation_data)
> > +
>
> <subsytem>_IOC_
>
> Seems more common for the internal numberings and such, what the user
> calls is more often (espesially in DRM and DMA_BUF):
>
> <subsytem>_IOCTL_<function>
>
> This is really just another naming nit but becouse this one really *is*
> ABI then getting our prefrence right is a must, up to you here.

So yea, Sumit has already pulled these into drm-misc-next, so this
feedback is just a few days too late.

But it's not a bad suggestion, so if you want to submit a tack-on
patch to drm-misc-next I suspect we can, try to pull it in.

thanks
-john

WARNING: multiple messages have this Message-ID (diff)
From: John Stultz <john.stultz@linaro.org>
To: "Andrew F. Davis" <afd@ti.com>
Cc: Hillf Danton <hdanton@sina.com>,
	Sudipto Paul <Sudipto.Paul@arm.com>,
	Sandeep Patil <sspatil@google.com>,
	Vincent Donnefort <Vincent.Donnefort@arm.com>,
	Chenbo Feng <fengc@google.com>,
	lkml <linux-kernel@vger.kernel.org>,
	Liam Mark <lmark@codeaurora.org>,
	Christoph Hellwig <hch@infradead.org>,
	Alistair Strachan <astrachan@google.com>,
	dri-devel <dri-devel@lists.freedesktop.org>,
	Hridya Valsaraju <hridya@google.com>,
	Pratik Patel <pratikp@codeaurora.org>
Subject: Re: [RESEND][PATCH v16 1/5] dma-buf: Add dma-buf heaps framework
Date: Thu, 12 Dec 2019 10:33:36 -0800	[thread overview]
Message-ID: <CALAqxLV5XwrJU2psx_ALFK1q9ZTaLTGRD9dgQhGQ5v=ojfyE+w@mail.gmail.com> (raw)
In-Reply-To: <b3e979ab-0c95-4e16-6399-9bed09e08a7b@ti.com>

On Thu, Dec 12, 2019 at 8:52 AM Andrew F. Davis <afd@ti.com> wrote:
> On 12/3/19 12:26 PM, John Stultz wrote:
> > +#define DMA_HEAP_IOC_MAGIC           'H'
> > +
> > +/**
> > + * DOC: DMA_HEAP_IOC_ALLOC - allocate memory from pool
> > + *
> > + * Takes a dma_heap_allocation_data struct and returns it with the fd field
> > + * populated with the dmabuf handle of the allocation.
> > + */
> > +#define DMA_HEAP_IOC_ALLOC   _IOWR(DMA_HEAP_IOC_MAGIC, 0x0,\
> > +                                   struct dma_heap_allocation_data)
> > +
>
> <subsytem>_IOC_
>
> Seems more common for the internal numberings and such, what the user
> calls is more often (espesially in DRM and DMA_BUF):
>
> <subsytem>_IOCTL_<function>
>
> This is really just another naming nit but becouse this one really *is*
> ABI then getting our prefrence right is a must, up to you here.

So yea, Sumit has already pulled these into drm-misc-next, so this
feedback is just a few days too late.

But it's not a bad suggestion, so if you want to submit a tack-on
patch to drm-misc-next I suspect we can, try to pull it in.

thanks
-john
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

  reply	other threads:[~2019-12-12 18:33 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-12-03 17:26 [RESEND][PATCH v16 0/5] DMA-BUF Heaps (destaging ION) John Stultz
2019-12-03 17:26 ` John Stultz
2019-12-03 17:26 ` [RESEND][PATCH v16 1/5] dma-buf: Add dma-buf heaps framework John Stultz
2019-12-03 17:26   ` John Stultz
2019-12-12 16:52   ` Andrew F. Davis
2019-12-12 16:52     ` Andrew F. Davis
2019-12-12 18:33     ` John Stultz [this message]
2019-12-12 18:33       ` John Stultz
2019-12-03 17:26 ` [RESEND][PATCH v16 2/5] dma-buf: heaps: Add heap helpers John Stultz
2019-12-03 17:26   ` John Stultz
2019-12-03 17:26 ` [RESEND][PATCH v16 3/5] dma-buf: heaps: Add system heap to dmabuf heaps John Stultz
2019-12-03 17:26   ` John Stultz
2019-12-12 16:20   ` Andrew F. Davis
2019-12-12 16:20     ` Andrew F. Davis
2019-12-12 18:37     ` John Stultz
2019-12-12 18:37       ` John Stultz
2019-12-03 17:26 ` [RESEND][PATCH v16 4/5] dma-buf: heaps: Add CMA " John Stultz
2019-12-03 17:26   ` John Stultz
2019-12-03 17:26 ` [RESEND][PATCH v16 5/5] kselftests: Add dma-heap test John Stultz
2019-12-03 17:26   ` John Stultz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CALAqxLV5XwrJU2psx_ALFK1q9ZTaLTGRD9dgQhGQ5v=ojfyE+w@mail.gmail.com' \
    --to=john.stultz@linaro.org \
    --cc=Brian.Starkey@arm.com \
    --cc=Sudipto.Paul@arm.com \
    --cc=Vincent.Donnefort@arm.com \
    --cc=afd@ti.com \
    --cc=airlied@gmail.com \
    --cc=astrachan@google.com \
    --cc=benjamin.gaignard@linaro.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=fengc@google.com \
    --cc=hch@infradead.org \
    --cc=hdanton@sina.com \
    --cc=hridya@google.com \
    --cc=labbott@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lmark@codeaurora.org \
    --cc=pratikp@codeaurora.org \
    --cc=sspatil@google.com \
    --cc=sumit.semwal@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.