All of lore.kernel.org
 help / color / mirror / Atom feed
From: Gilad Ben-Yossef <gilad@benyossef.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: devel@driverdev.osuosl.org,
	driverdev-devel@linuxdriverproject.org,
	linux-crypto@vger.kernel.org, Ofir Drang <ofir.drang@arm.com>,
	Linux kernel mailing list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 04/12] staging: ccree: cleanup lli access macro
Date: Mon, 29 May 2017 20:32:30 +0300	[thread overview]
Message-ID: <CAOtvUMcT3rh5rHy9hrwD-JqmT7EfKdW1pQ+n2V6RsAbuq-OGiw@mail.gmail.com> (raw)
In-Reply-To: <20170529144114.GC12428@kroah.com>

On Mon, May 29, 2017 at 5:41 PM, Greg Kroah-Hartman
<gregkh@linuxfoundation.org> wrote:
> On Sun, May 28, 2017 at 05:40:29PM +0300, Gilad Ben-Yossef wrote:
>> The Linked List Item descriptors were being accessed via
>> a baroque set of defines and macro. Re-factor for structs
>> and inline function for readability and sanity.
>>
>> Signed-off-by: Gilad Ben-Yossef <gilad@benyossef.com>
>> ---
>>  drivers/staging/ccree/cc_lli_defs.h    | 65 +++++++++++++++++++---------------
>>  drivers/staging/ccree/ssi_buffer_mgr.c | 45 +++++------------------
>>  2 files changed, 44 insertions(+), 66 deletions(-)
>>
>> diff --git a/drivers/staging/ccree/cc_lli_defs.h b/drivers/staging/ccree/cc_lli_defs.h
>> index 857b94f..c6b2917 100644
>> --- a/drivers/staging/ccree/cc_lli_defs.h
>> +++ b/drivers/staging/ccree/cc_lli_defs.h
>> @@ -28,36 +28,43 @@
>>
>>  #define CC_MAX_MLLI_ENTRY_SIZE 0x10000
>>
>> -#define LLI_SET_ADDR(__lli_p, __addr) do {                           \
>> -             u32 *lli_p = (u32 *)__lli_p;                            \
>> -             typeof(__addr) addr = __addr;                           \
>> -                                                                     \
>> -             BITFIELD_SET(lli_p[LLI_WORD0_OFFSET],                   \
>> -                     LLI_LADDR_BIT_OFFSET,                           \
>> -                     LLI_LADDR_BIT_SIZE, (addr & U32_MAX));          \
>> -                                                                     \
>> -             BITFIELD_SET(lli_p[LLI_WORD1_OFFSET],                   \
>> -                     LLI_HADDR_BIT_OFFSET,                           \
>> -                     LLI_HADDR_BIT_SIZE, MSB64(addr));               \
>> -     } while (0)
>> -
>> -#define LLI_SET_SIZE(lli_p, size)                                    \
>> -             BITFIELD_SET(((u32 *)(lli_p))[LLI_WORD1_OFFSET],        \
>> -             LLI_SIZE_BIT_OFFSET, LLI_SIZE_BIT_SIZE, size)
>> +#define LLI_MAX_NUM_OF_DATA_ENTRIES 128
>> +#define LLI_MAX_NUM_OF_ASSOC_DATA_ENTRIES 4
>> +#define MLLI_TABLE_MIN_ALIGNMENT 4 /* 32 bit alignment */
>> +#define MAX_NUM_OF_BUFFERS_IN_MLLI 4
>> +#define MAX_NUM_OF_TOTAL_MLLI_ENTRIES (2 * LLI_MAX_NUM_OF_DATA_ENTRIES + \
>> +                                    LLI_MAX_NUM_OF_ASSOC_DATA_ENTRIES)
>> +
>> +struct cc_lli_entry {
>> +#ifndef __LITTLE_ENDIAN__
>> +     u32 addr_lsb;
>> +     u16 size;
>> +     u16 addr_msb;
>> +#else /* __BIG_ENDIAN__ */
>> +     u16 addr_msb;
>> +     u16 size;
>> +     u32 addr_lsb;
>> +#endif
>
> How is the bits within the different variables also not affected by the
> endian issues?  Just moving them around in the 64bits seems really
> strange.

I actually did not overlook this issue. My reasoning was that the new code
is doing exactly what the old code was doing. Either the callers was doing
the right thing, or the HW is magically taking care of it[1] or the
new code is as
broken as the old in a bug to bug compatibility sort of way.

And if it's broken, fixing it in this patch would actually break the
"do one thing"
rule... :-)

[1] I know this sounds strange but the control register description has language
that sounds like it does automagicall swabbing under certain circumstances I am
yet to understand and since I don't have a big endian test system at
my disposable
I chose to leave it as is for now.

>
> Why not just use the "normal" ways to address data in an endian-neutral
> way instead of making your own macros up here?  (i.e. shift and mask.)
>

I personally find it more readable it this way and there are other
example in the
kernel source of doing this) but I will gladly switch if you think it
is preferred.

Thanks,
Gilad

> thanks,
>
> greg k-h



-- 
Gilad Ben-Yossef
Chief Coffee Drinker

"If you take a class in large-scale robotics, can you end up in a
situation where the homework eats your dog?"
 -- Jean-Baptiste Queru

WARNING: multiple messages have this Message-ID (diff)
From: Gilad Ben-Yossef <gilad@benyossef.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: linux-crypto@vger.kernel.org, devel@driverdev.osuosl.org,
	driverdev-devel@linuxdriverproject.org,
	Linux kernel mailing list <linux-kernel@vger.kernel.org>,
	Ofir Drang <ofir.drang@arm.com>
Subject: Re: [PATCH 04/12] staging: ccree: cleanup lli access macro
Date: Mon, 29 May 2017 20:32:30 +0300	[thread overview]
Message-ID: <CAOtvUMcT3rh5rHy9hrwD-JqmT7EfKdW1pQ+n2V6RsAbuq-OGiw@mail.gmail.com> (raw)
In-Reply-To: <20170529144114.GC12428@kroah.com>

On Mon, May 29, 2017 at 5:41 PM, Greg Kroah-Hartman
<gregkh@linuxfoundation.org> wrote:
> On Sun, May 28, 2017 at 05:40:29PM +0300, Gilad Ben-Yossef wrote:
>> The Linked List Item descriptors were being accessed via
>> a baroque set of defines and macro. Re-factor for structs
>> and inline function for readability and sanity.
>>
>> Signed-off-by: Gilad Ben-Yossef <gilad@benyossef.com>
>> ---
>>  drivers/staging/ccree/cc_lli_defs.h    | 65 +++++++++++++++++++---------------
>>  drivers/staging/ccree/ssi_buffer_mgr.c | 45 +++++------------------
>>  2 files changed, 44 insertions(+), 66 deletions(-)
>>
>> diff --git a/drivers/staging/ccree/cc_lli_defs.h b/drivers/staging/ccree/cc_lli_defs.h
>> index 857b94f..c6b2917 100644
>> --- a/drivers/staging/ccree/cc_lli_defs.h
>> +++ b/drivers/staging/ccree/cc_lli_defs.h
>> @@ -28,36 +28,43 @@
>>
>>  #define CC_MAX_MLLI_ENTRY_SIZE 0x10000
>>
>> -#define LLI_SET_ADDR(__lli_p, __addr) do {                           \
>> -             u32 *lli_p = (u32 *)__lli_p;                            \
>> -             typeof(__addr) addr = __addr;                           \
>> -                                                                     \
>> -             BITFIELD_SET(lli_p[LLI_WORD0_OFFSET],                   \
>> -                     LLI_LADDR_BIT_OFFSET,                           \
>> -                     LLI_LADDR_BIT_SIZE, (addr & U32_MAX));          \
>> -                                                                     \
>> -             BITFIELD_SET(lli_p[LLI_WORD1_OFFSET],                   \
>> -                     LLI_HADDR_BIT_OFFSET,                           \
>> -                     LLI_HADDR_BIT_SIZE, MSB64(addr));               \
>> -     } while (0)
>> -
>> -#define LLI_SET_SIZE(lli_p, size)                                    \
>> -             BITFIELD_SET(((u32 *)(lli_p))[LLI_WORD1_OFFSET],        \
>> -             LLI_SIZE_BIT_OFFSET, LLI_SIZE_BIT_SIZE, size)
>> +#define LLI_MAX_NUM_OF_DATA_ENTRIES 128
>> +#define LLI_MAX_NUM_OF_ASSOC_DATA_ENTRIES 4
>> +#define MLLI_TABLE_MIN_ALIGNMENT 4 /* 32 bit alignment */
>> +#define MAX_NUM_OF_BUFFERS_IN_MLLI 4
>> +#define MAX_NUM_OF_TOTAL_MLLI_ENTRIES (2 * LLI_MAX_NUM_OF_DATA_ENTRIES + \
>> +                                    LLI_MAX_NUM_OF_ASSOC_DATA_ENTRIES)
>> +
>> +struct cc_lli_entry {
>> +#ifndef __LITTLE_ENDIAN__
>> +     u32 addr_lsb;
>> +     u16 size;
>> +     u16 addr_msb;
>> +#else /* __BIG_ENDIAN__ */
>> +     u16 addr_msb;
>> +     u16 size;
>> +     u32 addr_lsb;
>> +#endif
>
> How is the bits within the different variables also not affected by the
> endian issues?  Just moving them around in the 64bits seems really
> strange.

I actually did not overlook this issue. My reasoning was that the new code
is doing exactly what the old code was doing. Either the callers was doing
the right thing, or the HW is magically taking care of it[1] or the
new code is as
broken as the old in a bug to bug compatibility sort of way.

And if it's broken, fixing it in this patch would actually break the
"do one thing"
rule... :-)

[1] I know this sounds strange but the control register description has language
that sounds like it does automagicall swabbing under certain circumstances I am
yet to understand and since I don't have a big endian test system at
my disposable
I chose to leave it as is for now.

>
> Why not just use the "normal" ways to address data in an endian-neutral
> way instead of making your own macros up here?  (i.e. shift and mask.)
>

I personally find it more readable it this way and there are other
example in the
kernel source of doing this) but I will gladly switch if you think it
is preferred.

Thanks,
Gilad

> thanks,
>
> greg k-h



-- 
Gilad Ben-Yossef
Chief Coffee Drinker

"If you take a class in large-scale robotics, can you end up in a
situation where the homework eats your dog?"
 -- Jean-Baptiste Queru

  reply	other threads:[~2017-05-29 17:32 UTC|newest]

Thread overview: 48+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-05-28 14:40 [PATCH 00/12] staging: ccree: addtional driver cleanups Gilad Ben-Yossef
2017-05-28 14:40 ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 01/12] staging: ccree: correct coding style violations Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-29 14:37   ` Greg Kroah-Hartman
2017-05-29 14:37     ` Greg Kroah-Hartman
2017-05-29 14:37     ` Greg Kroah-Hartman
2017-05-29 16:57     ` Joe Perches
2017-05-29 17:11       ` Gilad Ben-Yossef
2017-05-29 17:11         ` Gilad Ben-Yossef
2017-05-29 17:36         ` Joe Perches
2017-05-29 17:36           ` Joe Perches
2017-05-29 17:51           ` Gilad Ben-Yossef
2017-05-29 17:51             ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 02/12] staging: ccree: move to kernel bitfields/bitops Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-29 14:38   ` Greg Kroah-Hartman
2017-05-29 14:38     ` Greg Kroah-Hartman
2017-05-29 14:38     ` Greg Kroah-Hartman
2017-05-29 17:23     ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 03/12] staging: ccree: remove 48 bit dma addr sim Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 04/12] staging: ccree: cleanup lli access macro Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-29 14:41   ` Greg Kroah-Hartman
2017-05-29 14:41     ` Greg Kroah-Hartman
2017-05-29 14:41     ` Greg Kroah-Hartman
2017-05-29 17:32     ` Gilad Ben-Yossef [this message]
2017-05-29 17:32       ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 05/12] staging: ccree: remove cycle count debug support Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 06/12] staging: ccree: move request_mgr to generic bitfield ops Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 07/12] staging: ccree remove custom bitfield macros Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 08/12] staging: ccree: remove unused struct Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 09/12] staging: ccree: use snake_case for hash enums Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 10/12] staging: ccree: drop no longer used macro Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 11/12] staging: ccree: remove dead code Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef
2017-05-28 14:40 ` [PATCH 12/12] staging: ccree: whitespace fixes Gilad Ben-Yossef
2017-05-28 14:40   ` Gilad Ben-Yossef

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAOtvUMcT3rh5rHy9hrwD-JqmT7EfKdW1pQ+n2V6RsAbuq-OGiw@mail.gmail.com \
    --to=gilad@benyossef.com \
    --cc=devel@driverdev.osuosl.org \
    --cc=driverdev-devel@linuxdriverproject.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-crypto@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=ofir.drang@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.