All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dan Williams <dan.j.williams@intel.com>
To: Jerry Hoemann <jerry.hoemann@hpe.com>
Cc: "linux-nvdimm@lists.01.org" <linux-nvdimm@lists.01.org>
Subject: Re: [RFC v9 3/5] Subject: [PATCH v8 07/10] tools/testing/nvdimm: 'call_dsm' support
Date: Mon, 18 Apr 2016 19:22:00 -0700	[thread overview]
Message-ID: <CAPcyv4hC2f0Ekf6sk4Xg3Wyqwg9N6yj8NZ4y_coSSLOPE3E-2Q@mail.gmail.com> (raw)
In-Reply-To: <e069fdba64643ab83458bfc2b88711dc1974e6a8.1460936121.git.jerry.hoemann@hpe.com>

On Sun, Apr 17, 2016 at 4:38 PM, Jerry Hoemann <jerry.hoemann@hpe.com> wrote:
> Enable nfit_test to use the generic 'call_dsm' envelope.
>
> Signed-off-by: Dan Williams <dan.j.williams@intel.com>
> ---
>  tools/testing/nvdimm/test/nfit.c | 13 +++++++++++--
>  1 file changed, 11 insertions(+), 2 deletions(-)
>
> diff --git a/tools/testing/nvdimm/test/nfit.c b/tools/testing/nvdimm/test/nfit.c
> index 1d3b8ce..5afc3d3 100644
> --- a/tools/testing/nvdimm/test/nfit.c
> +++ b/tools/testing/nvdimm/test/nfit.c
> @@ -336,12 +336,21 @@ static int nfit_test_ctl(struct nvdimm_bus_descriptor *nd_desc,
>  {
>         struct acpi_nfit_desc *acpi_desc = to_acpi_desc(nd_desc);
>         struct nfit_test *t = container_of(acpi_desc, typeof(*t), acpi_desc);
> +       unsigned int func = cmd;
>         int i, rc = 0, __cmd_rc;
>
>         if (!cmd_rc)
>                 cmd_rc = &__cmd_rc;
>         *cmd_rc = 0;
>
> +       if (cmd == ND_CMD_CALL) {
> +               struct nd_cmd_pkg *call_dsm = buf;
> +
> +               buf_len = call_dsm->nd_size_in + call_dsm->nd_size_out;
> +               buf = (void *) call_dsm->nd_payload;
> +               func = call_dsm->nd_command;

Same comment as patch1, now that we've switched from call_dsm to
nd_cmd_pkg, let's use 'pkg' as the local variable name.

> +       }
> +
>         if (nvdimm) {
>                 struct nfit_mem *nfit_mem = nvdimm_provider_data(nvdimm);
>
> @@ -356,7 +365,7 @@ static int nfit_test_ctl(struct nvdimm_bus_descriptor *nd_desc,
>                 if (i >= ARRAY_SIZE(handle))
>                         return -ENXIO;
>
> -               switch (cmd) {
> +               switch (func) {
>                 case ND_CMD_GET_CONFIG_SIZE:
>                         rc = nfit_test_cmd_get_config_size(buf, buf_len);
>                         break;
> @@ -377,7 +386,7 @@ static int nfit_test_ctl(struct nvdimm_bus_descriptor *nd_desc,
>                 if (!nd_desc || !test_bit(cmd, &nd_desc->cmd_mask))
>                         return -ENOTTY;
>
> -               switch (cmd) {
> +               switch (func) {
>                 case ND_CMD_ARS_CAP:
>                         rc = nfit_test_cmd_ars_cap(buf, buf_len);
>                         break;

This patch is missing setting the ND_CMD_CALL bit in
'dimm_dsm_force_en' at the bottom of nfit_test0_setup().  That field
should also be renamed to 'dimm_cmd_force_en' similar to the dsm_mask
=> cmd_mask rename..
_______________________________________________
Linux-nvdimm mailing list
Linux-nvdimm@lists.01.org
https://lists.01.org/mailman/listinfo/linux-nvdimm

  parent reply	other threads:[~2016-04-19  2:22 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-04-17 23:38 [RFC v9 0/5] nvdimm: Add an IOCTL pass thru for DSM calls Jerry Hoemann
2016-04-17 23:38 ` [RFC v9 1/5] nvdimm: Add IOCTL pass thru functions Jerry Hoemann
2016-04-18  8:07   ` Johannes Thumshirn
2016-04-19  2:15   ` Dan Williams
2016-04-20 16:46     ` Jerry Hoemann
2016-04-20 20:08       ` Dan Williams
2016-04-20 22:55         ` Jerry Hoemann
2016-04-21  1:29           ` Dan Williams
2016-04-21 11:39             ` Dan Williams
2016-04-17 23:38 ` [RFC v9 2/5] libnvdimm: nvdimm_bus_descriptor field name change Jerry Hoemann
2016-04-18  8:08   ` Johannes Thumshirn
2016-04-17 23:38 ` [RFC v9 3/5] Subject: [PATCH v8 07/10] tools/testing/nvdimm: 'call_dsm' support Jerry Hoemann
2016-04-18  8:08   ` Johannes Thumshirn
2016-04-19  2:22   ` Dan Williams [this message]
2016-04-20 16:50     ` Jerry Hoemann
2016-04-17 23:38 ` [RFC v9 4/5] nvdimm: Add concept of cmd mask Jerry Hoemann
2016-04-18  8:09   ` Johannes Thumshirn
2016-04-19  3:03   ` Dan Williams
2016-04-21 17:28     ` Jerry Hoemann
2016-04-21 18:25       ` Dan Williams
2016-04-22 17:55         ` Jerry Hoemann
2016-04-22 18:16           ` Dan Williams
2016-04-17 23:38 ` [RFC v9 5/5] nvdimm: Add ioctl to return command mask Jerry Hoemann
2016-04-18  8:09   ` Johannes Thumshirn
2016-04-19 17:45   ` Dan Williams
2016-04-20 17:41     ` Jerry Hoemann
2016-04-21 11:52       ` Dan Williams
2016-04-21 16:52         ` Jerry Hoemann
2016-04-21 18:18           ` Dan Williams
2016-04-22 23:15             ` Jerry Hoemann
2016-04-22 23:33               ` Dan Williams

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAPcyv4hC2f0Ekf6sk4Xg3Wyqwg9N6yj8NZ4y_coSSLOPE3E-2Q@mail.gmail.com \
    --to=dan.j.williams@intel.com \
    --cc=jerry.hoemann@hpe.com \
    --cc=linux-nvdimm@lists.01.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.