All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dan Williams <dan.j.williams@intel.com>
To: Andy Shevchenko <andy.shevchenko@gmail.com>
Cc: Arnd Bergmann <arnd@arndb.de>, Ingo Molnar <mingo@redhat.com>,
	Borislav Petkov <bp@alien8.de>, "H. Peter Anvin" <hpa@zytor.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ross Zwisler <ross.zwisler@linux.intel.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Juergen Gross <jgross@suse.com>,
	"x86@kernel.org" <x86@kernel.org>,
	"Kani, Toshimitsu" <toshi.kani@hp.com>,
	"linux-nvdimm@lists.01.org" <linux-nvdimm@lists.01.org>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Luis Rodriguez <mcgrof@suse.com>,
	Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Stefan Bader <stefan.bader@canonical.com>,
	Andy Lutomirski <luto@amacapital.net>,
	linux-mm@kvack.org, Geert Uytterhoeven <geert@linux-m68k.org>,
	Ralf Baechle <ralf@linux-mips.org>,
	Henrique de Moraes Holschuh <hmh@hmh.eng.br>,
	mpe@ellerman.id.au, Tejun Heo <tj@kernel.org>,
	Paul Mackerras <paulus@samba.org>, Christoph Hellwig <hch@lst.de>
Subject: Re: [PATCH v3 5/6] arch: introduce memremap_cache() and memremap_wt()
Date: Mon, 8 Jun 2015 12:39:33 -0700	[thread overview]
Message-ID: <CAPcyv4hi9tEdRborvfV19MhRPM-pch=mCaLD0To1N_sZejJZ2g@mail.gmail.com> (raw)
In-Reply-To: <CAHp75VdW5Pd-h1qvOm+sTT6xoAbYRY9aBR8aTMF7QQ8sT05FZw@mail.gmail.com>

On Mon, Jun 8, 2015 at 12:04 PM, Andy Shevchenko
<andy.shevchenko@gmail.com> wrote:
> On Mon, Jun 8, 2015 at 9:25 PM, Dan Williams <dan.j.williams@intel.com> wrote:
>
>>>> +       if (region_is_ram(offset, size) != 0) {
>>>> +               WARN_ONCE(1, "memremap attempted on ram %pa size: %zd\n",
>>>
>>> %zu
>>
>> Sure, thanks for taking a look Andy!
>
> One more thing, can we do
> WARN_ONCE(region_is_ram(offset, size), …); ?
>

We still want to return false in this case so it would become
"if(WARN_ONCE(...)) return false;".  Neil once made the argument to me
that we should be able to compile all of the asserts out of the
kernel, also "if (WARN_ONCE(...))" is a bit harder to read as you need
to go check the macro to make sure it returns the right status, and
more than once.

--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org.  For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>

WARNING: multiple messages have this Message-ID (diff)
From: Dan Williams <dan.j.williams@intel.com>
To: Andy Shevchenko <andy.shevchenko@gmail.com>
Cc: Arnd Bergmann <arnd@arndb.de>, Ingo Molnar <mingo@redhat.com>,
	Borislav Petkov <bp@alien8.de>, "H. Peter Anvin" <hpa@zytor.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ross Zwisler <ross.zwisler@linux.intel.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Juergen Gross <jgross@suse.com>,
	"x86@kernel.org" <x86@kernel.org>,
	"Kani, Toshimitsu" <toshi.kani@hp.com>,
	"linux-nvdimm@lists.01.org" <linux-nvdimm@ml01.01.org>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Luis Rodriguez <mcgrof@suse.com>,
	Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Stefan Bader <stefan.bader@canonical.com>,
	Andy Lutomirski <luto@amacapital.net>,
	linux-mm@kvack.org, Geert Uytterhoeven <geert@linux-m68k.org>,
	Ralf Baechle <ralf@linux-mips.org>,
	Henrique de Moraes Holschuh <hmh@hmh.eng.br>,
	mpe@ellerman.id.au, Tejun Heo <tj@kernel.org>,
	Paul Mackerras <paulus@samba.org>, Christoph Hellwig <hch@lst.de>
Subject: Re: [PATCH v3 5/6] arch: introduce memremap_cache() and memremap_wt()
Date: Mon, 8 Jun 2015 12:39:33 -0700	[thread overview]
Message-ID: <CAPcyv4hi9tEdRborvfV19MhRPM-pch=mCaLD0To1N_sZejJZ2g@mail.gmail.com> (raw)
In-Reply-To: <CAHp75VdW5Pd-h1qvOm+sTT6xoAbYRY9aBR8aTMF7QQ8sT05FZw@mail.gmail.com>

On Mon, Jun 8, 2015 at 12:04 PM, Andy Shevchenko
<andy.shevchenko@gmail.com> wrote:
> On Mon, Jun 8, 2015 at 9:25 PM, Dan Williams <dan.j.williams@intel.com> wrote:
>
>>>> +       if (region_is_ram(offset, size) != 0) {
>>>> +               WARN_ONCE(1, "memremap attempted on ram %pa size: %zd\n",
>>>
>>> %zu
>>
>> Sure, thanks for taking a look Andy!
>
> One more thing, can we do
> WARN_ONCE(region_is_ram(offset, size), …); ?
>

We still want to return false in this case so it would become
"if(WARN_ONCE(...)) return false;".  Neil once made the argument to me
that we should be able to compile all of the asserts out of the
kernel, also "if (WARN_ONCE(...))" is a bit harder to read as you need
to go check the macro to make sure it returns the right status, and
more than once.

  reply	other threads:[~2015-06-08 19:39 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-06-03 21:34 [PATCH v3 0/6] pmem api, generic ioremap_cache, and memremap Dan Williams
2015-06-03 21:34 ` Dan Williams
2015-06-03 21:34 ` [PATCH v3 1/6] arch: unify ioremap prototypes and macro aliases Dan Williams
2015-06-03 21:34   ` Dan Williams
2015-06-03 21:34 ` [PATCH v3 2/6] cleanup IORESOURCE_CACHEABLE vs ioremap() Dan Williams
2015-06-03 21:34   ` Dan Williams
2015-06-03 23:58   ` Dan Williams
2015-06-03 23:58     ` Dan Williams
2015-06-03 21:34 ` [PATCH v3 3/6] arch/*/asm/io.h: add ioremap_cache() to all architectures Dan Williams
2015-06-03 21:34   ` Dan Williams
2015-06-03 21:34 ` [PATCH v3 4/6] devm: fix ioremap_cache() usage Dan Williams
2015-06-03 21:34   ` Dan Williams
2015-06-03 21:34 ` [PATCH v3 5/6] arch: introduce memremap_cache() and memremap_wt() Dan Williams
2015-06-03 21:34   ` Dan Williams
2015-06-08 16:27   ` Andy Shevchenko
2015-06-08 16:27     ` Andy Shevchenko
2015-06-08 18:25     ` Dan Williams
2015-06-08 18:25       ` Dan Williams
2015-06-08 19:04       ` Andy Shevchenko
2015-06-08 19:04         ` Andy Shevchenko
2015-06-08 19:39         ` Dan Williams [this message]
2015-06-08 19:39           ` Dan Williams
2015-06-03 21:34 ` [PATCH v3 6/6] arch, x86: pmem api for ensuring durability of persistent memory updates Dan Williams
2015-06-03 21:34   ` Dan Williams
2015-06-03 21:38 ` [PATCH v3 0/6] pmem api, generic ioremap_cache, and memremap Dan Williams
2015-06-03 21:38   ` Dan Williams

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAPcyv4hi9tEdRborvfV19MhRPM-pch=mCaLD0To1N_sZejJZ2g@mail.gmail.com' \
    --to=dan.j.williams@intel.com \
    --cc=akpm@linux-foundation.org \
    --cc=andy.shevchenko@gmail.com \
    --cc=arnd@arndb.de \
    --cc=benh@kernel.crashing.org \
    --cc=bp@alien8.de \
    --cc=geert@linux-m68k.org \
    --cc=hch@lst.de \
    --cc=hmh@hmh.eng.br \
    --cc=hpa@zytor.com \
    --cc=jgross@suse.com \
    --cc=konrad.wilk@oracle.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-nvdimm@lists.01.org \
    --cc=luto@amacapital.net \
    --cc=mcgrof@suse.com \
    --cc=mingo@redhat.com \
    --cc=mpe@ellerman.id.au \
    --cc=paulus@samba.org \
    --cc=ralf@linux-mips.org \
    --cc=ross.zwisler@linux.intel.com \
    --cc=stefan.bader@canonical.com \
    --cc=tglx@linutronix.de \
    --cc=tj@kernel.org \
    --cc=toshi.kani@hp.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.