All of lore.kernel.org
 help / color / mirror / Atom feed
From: Chris Brandt <Chris.Brandt@renesas.com>
To: Geert Uytterhoeven <geert@linux-m68k.org>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Rob Herring <robh+dt@kernel.org>,
	Mark Rutland <mark.rutland@arm.com>,
	Simon Horman <horms@verge.net.au>,
	USB list <linux-usb@vger.kernel.org>,
	Linux-Renesas <linux-renesas-soc@vger.kernel.org>,
	"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
	Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
Subject: RE: [PATCH v2 1/3] usb: renesas_usbhs: Add support for RZ/A1
Date: Fri, 5 Jan 2018 20:26:06 +0000	[thread overview]
Message-ID: <SG2PR06MB116564859278F511BD5CD4208A1C0@SG2PR06MB1165.apcprd06.prod.outlook.com> (raw)
In-Reply-To: <CAMuHMdV5KcRAJDw2eTMET2rpJoGD47YTfSXq-CEH_j+44Z+Byw@mail.gmail.com>

Hi Geert,

On Friday, January 05, 2018, Geert Uytterhoeven wrote:
> > +       {
> > +               .compatible = "renesas,usbhs-r7s72100",
> > +               .data = (void *)USBHS_TYPE_RZA1,
> > +       },
> 
> I think it suffices to drop the part above...
> 
> >         {
> >                 .compatible = "renesas,rcar-gen2-usbhs",
> >                 .data = (void *)USBHS_TYPE_RCAR_GEN2,
> > @@ -488,6 +493,10 @@ static const struct of_device_id usbhs_of_match[] =
> {
> >                 .compatible = "renesas,rcar-gen3-usbhs",
> >                 .data = (void *)USBHS_TYPE_RCAR_GEN3,
> >         },
> > +       {
> > +               .compatible = "renesas,rza1-usbhs",
> > +               .data = (void *)USBHS_TYPE_RZA1,
> > +       },
> 
> ... and just let the driver match against the generic compatible value.
> But then you have to add "renesas,rza1-usbhs" to the DTS, too.

OK. I can do that.

I keep forgetting all the new/old DT rules.
I thought there was something about you always need a generic name and
also a device specific name.

I'm happy with just "renesas,rza1-usbhs".


> > --- /dev/null
> > +++ b/drivers/usb/renesas_usbhs/rza.c
> > @@ -0,0 +1,52 @@
> > +// SPDX-License-Identifier: GPL-1.0+
> 
> Not GPL-2.0?

Oops. Copy/paste error.


I'll submit a V3 of the series.


Thanks!

Chris


WARNING: multiple messages have this Message-ID (diff)
From: Chris Brandt <chris.brandt@renesas.com>
To: Geert Uytterhoeven <geert@linux-m68k.org>
Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Rob Herring <robh+dt@kernel.org>,
	Mark Rutland <mark.rutland@arm.com>,
	Simon Horman <horms@verge.net.au>,
	USB list <linux-usb@vger.kernel.org>,
	Linux-Renesas <linux-renesas-soc@vger.kernel.org>,
	"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
	Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>
Subject: [v2,1/3] usb: renesas_usbhs: Add support for RZ/A1
Date: Fri, 5 Jan 2018 20:26:06 +0000	[thread overview]
Message-ID: <SG2PR06MB116564859278F511BD5CD4208A1C0@SG2PR06MB1165.apcprd06.prod.outlook.com> (raw)

Hi Geert,

On Friday, January 05, 2018, Geert Uytterhoeven wrote:
> > +       {
> > +               .compatible = "renesas,usbhs-r7s72100",
> > +               .data = (void *)USBHS_TYPE_RZA1,
> > +       },
> 
> I think it suffices to drop the part above...
> 
> >         {
> >                 .compatible = "renesas,rcar-gen2-usbhs",
> >                 .data = (void *)USBHS_TYPE_RCAR_GEN2,
> > @@ -488,6 +493,10 @@ static const struct of_device_id usbhs_of_match[] =
> {
> >                 .compatible = "renesas,rcar-gen3-usbhs",
> >                 .data = (void *)USBHS_TYPE_RCAR_GEN3,
> >         },
> > +       {
> > +               .compatible = "renesas,rza1-usbhs",
> > +               .data = (void *)USBHS_TYPE_RZA1,
> > +       },
> 
> ... and just let the driver match against the generic compatible value.
> But then you have to add "renesas,rza1-usbhs" to the DTS, too.

OK. I can do that.

I keep forgetting all the new/old DT rules.
I thought there was something about you always need a generic name and
also a device specific name.

I'm happy with just "renesas,rza1-usbhs".


> > --- /dev/null
> > +++ b/drivers/usb/renesas_usbhs/rza.c
> > @@ -0,0 +1,52 @@
> > +// SPDX-License-Identifier: GPL-1.0+
> 
> Not GPL-2.0?

Oops. Copy/paste error.


I'll submit a V3 of the series.


Thanks!

Chris

  reply	other threads:[~2018-01-05 20:26 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-01-05 18:46 [PATCH v2 0/3] usb: renesas_usbhs: Add RZ/A1 support Chris Brandt
2018-01-05 18:46 ` Chris Brandt
     [not found] ` <20180105184609.24106-1-chris.brandt-zM6kxYcvzFBBDgjK7y7TUQ@public.gmane.org>
2018-01-05 18:46   ` [PATCH v2 1/3] usb: renesas_usbhs: Add support for RZ/A1 Chris Brandt
2018-01-05 18:46     ` [v2,1/3] " Chris Brandt
2018-01-05 18:46     ` [PATCH v2 1/3] " Chris Brandt
     [not found]     ` <20180105184609.24106-2-chris.brandt-zM6kxYcvzFBBDgjK7y7TUQ@public.gmane.org>
2018-01-05 20:18       ` Geert Uytterhoeven
2018-01-05 20:18         ` [v2,1/3] " Geert Uytterhoeven
2018-01-05 20:18         ` [PATCH v2 1/3] " Geert Uytterhoeven
2018-01-05 20:26         ` Chris Brandt [this message]
2018-01-05 20:26           ` [v2,1/3] " Chris Brandt
2018-01-05 18:46   ` [PATCH v2 2/3] dt-bindings: " Chris Brandt
2018-01-05 18:46     ` [v2,2/3] " Chris Brandt
2018-01-05 18:46     ` [PATCH v2 2/3] " Chris Brandt
2018-01-05 18:46   ` [PATCH v2 3/3] ARM: dts: r7s72100: add USB device to device tree Chris Brandt
2018-01-05 18:46     ` [v2,3/3] " Chris Brandt
2018-01-05 18:46     ` [PATCH v2 3/3] " Chris Brandt
     [not found]     ` <20180105184609.24106-4-chris.brandt-zM6kxYcvzFBBDgjK7y7TUQ@public.gmane.org>
2018-01-05 20:17       ` Geert Uytterhoeven
2018-01-05 20:17         ` [v2,3/3] " Geert Uytterhoeven
2018-01-05 20:17         ` [PATCH v2 3/3] " Geert Uytterhoeven

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=SG2PR06MB116564859278F511BD5CD4208A1C0@SG2PR06MB1165.apcprd06.prod.outlook.com \
    --to=chris.brandt@renesas.com \
    --cc=devicetree@vger.kernel.org \
    --cc=geert@linux-m68k.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=horms@verge.net.au \
    --cc=linux-renesas-soc@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=robh+dt@kernel.org \
    --cc=sergei.shtylyov@cogentembedded.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.