All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH v2] i2c: cadence: fixup of wait_for_completion_timeout return handling
@ 2015-02-09 15:03 ` Nicholas Mc Guire
  0 siblings, 0 replies; 10+ messages in thread
From: Nicholas Mc Guire @ 2015-02-09 15:03 UTC (permalink / raw)
  To: Michal Simek
  Cc: Soren Brinkmann, Wolfram Sang, linux-arm-kernel, linux-i2c,
	linux-kernel, Nicholas Mc Guire

return type of wait_for_completion_timeout is unsigned long not int. The
return variable is renamed to reflect its use and the type adjusted to
unsigned long.

Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org>
---

v2: int ret is an idiom not only a declaration - thus rather than just
    changing the type, rename the variable, as suggested by Wolfram Sang 
    <wsa@the-dreams.de>. 

Patch was only compile tested with multi_v7_defconfig
(implies CONFIG_I2C_CADENCE=y)

Patch is against 3.19.0-rc7 (localversion-next is -next-20150209)

 drivers/i2c/busses/i2c-cadence.c |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/i2c/busses/i2c-cadence.c b/drivers/i2c/busses/i2c-cadence.c
index 7d7a14c..8f92732f 100644
--- a/drivers/i2c/busses/i2c-cadence.c
+++ b/drivers/i2c/busses/i2c-cadence.c
@@ -475,7 +475,7 @@ static void cdns_i2c_master_reset(struct i2c_adapter *adap)
 static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
 		struct i2c_adapter *adap)
 {
-	int ret;
+	unsigned long timeout;
 	u32 reg;
 
 	id->p_msg = msg;
@@ -501,8 +501,8 @@ static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
 		cdns_i2c_msend(id);
 
 	/* Wait for the signal of completion */
-	ret = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
-	if (!ret) {
+	timeout = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
+	if (!timeout) {
 		cdns_i2c_master_reset(adap);
 		dev_err(id->adap.dev.parent,
 				"timeout waiting on completion\n");
-- 
1.7.10.4


^ permalink raw reply related	[flat|nested] 10+ messages in thread

* [PATCH v2] i2c: cadence: fixup of wait_for_completion_timeout return handling
@ 2015-02-09 15:03 ` Nicholas Mc Guire
  0 siblings, 0 replies; 10+ messages in thread
From: Nicholas Mc Guire @ 2015-02-09 15:03 UTC (permalink / raw)
  To: linux-arm-kernel

return type of wait_for_completion_timeout is unsigned long not int. The
return variable is renamed to reflect its use and the type adjusted to
unsigned long.

Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org>
---

v2: int ret is an idiom not only a declaration - thus rather than just
    changing the type, rename the variable, as suggested by Wolfram Sang 
    <wsa@the-dreams.de>. 

Patch was only compile tested with multi_v7_defconfig
(implies CONFIG_I2C_CADENCE=y)

Patch is against 3.19.0-rc7 (localversion-next is -next-20150209)

 drivers/i2c/busses/i2c-cadence.c |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/i2c/busses/i2c-cadence.c b/drivers/i2c/busses/i2c-cadence.c
index 7d7a14c..8f92732f 100644
--- a/drivers/i2c/busses/i2c-cadence.c
+++ b/drivers/i2c/busses/i2c-cadence.c
@@ -475,7 +475,7 @@ static void cdns_i2c_master_reset(struct i2c_adapter *adap)
 static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
 		struct i2c_adapter *adap)
 {
-	int ret;
+	unsigned long timeout;
 	u32 reg;
 
 	id->p_msg = msg;
@@ -501,8 +501,8 @@ static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
 		cdns_i2c_msend(id);
 
 	/* Wait for the signal of completion */
-	ret = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
-	if (!ret) {
+	timeout = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
+	if (!timeout) {
 		cdns_i2c_master_reset(adap);
 		dev_err(id->adap.dev.parent,
 				"timeout waiting on completion\n");
-- 
1.7.10.4

^ permalink raw reply related	[flat|nested] 10+ messages in thread

* Re: [PATCH v2] i2c: cadence: fixup of wait_for_completion_timeout return handling
  2015-02-09 15:03 ` Nicholas Mc Guire
  (?)
@ 2015-02-09 16:15   ` Sören Brinkmann
  -1 siblings, 0 replies; 10+ messages in thread
From: Sören Brinkmann @ 2015-02-09 16:15 UTC (permalink / raw)
  To: Nicholas Mc Guire
  Cc: Michal Simek, Wolfram Sang, linux-arm-kernel, linux-i2c, linux-kernel

On Mon, 2015-02-09 at 10:03AM -0500, Nicholas Mc Guire wrote:
> return type of wait_for_completion_timeout is unsigned long not int. The
> return variable is renamed to reflect its use and the type adjusted to
> unsigned long.
> 
> Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org>
Reviewed-by: Soren Brinkmann <soren.brinkmann@xilinx.com>

	Soren

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH v2] i2c: cadence: fixup of wait_for_completion_timeout return handling
@ 2015-02-09 16:15   ` Sören Brinkmann
  0 siblings, 0 replies; 10+ messages in thread
From: Sören Brinkmann @ 2015-02-09 16:15 UTC (permalink / raw)
  To: Nicholas Mc Guire
  Cc: Michal Simek, Wolfram Sang, linux-arm-kernel, linux-i2c, linux-kernel

On Mon, 2015-02-09 at 10:03AM -0500, Nicholas Mc Guire wrote:
> return type of wait_for_completion_timeout is unsigned long not int. The
> return variable is renamed to reflect its use and the type adjusted to
> unsigned long.
> 
> Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org>
Reviewed-by: Soren Brinkmann <soren.brinkmann@xilinx.com>

	Soren

^ permalink raw reply	[flat|nested] 10+ messages in thread

* [PATCH v2] i2c: cadence: fixup of wait_for_completion_timeout return handling
@ 2015-02-09 16:15   ` Sören Brinkmann
  0 siblings, 0 replies; 10+ messages in thread
From: Sören Brinkmann @ 2015-02-09 16:15 UTC (permalink / raw)
  To: linux-arm-kernel

On Mon, 2015-02-09 at 10:03AM -0500, Nicholas Mc Guire wrote:
> return type of wait_for_completion_timeout is unsigned long not int. The
> return variable is renamed to reflect its use and the type adjusted to
> unsigned long.
> 
> Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org>
Reviewed-by: Soren Brinkmann <soren.brinkmann@xilinx.com>

	Soren

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH v2] i2c: cadence: fixup of wait_for_completion_timeout return handling
  2015-02-09 15:03 ` Nicholas Mc Guire
@ 2015-02-10 14:17   ` Sergei Shtylyov
  -1 siblings, 0 replies; 10+ messages in thread
From: Sergei Shtylyov @ 2015-02-10 14:17 UTC (permalink / raw)
  To: Nicholas Mc Guire, Michal Simek
  Cc: Soren Brinkmann, Wolfram Sang, linux-kernel, linux-i2c, linux-arm-kernel

Hello.

On 2/9/2015 6:03 PM, Nicholas Mc Guire wrote:

> return type of wait_for_completion_timeout is unsigned long not int. The
> return variable is renamed to reflect its use and the type adjusted to
> unsigned long.

> Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org>
> ---

> v2: int ret is an idiom not only a declaration - thus rather than just
>      changing the type, rename the variable, as suggested by Wolfram Sang
>      <wsa@the-dreams.de>.

> Patch was only compile tested with multi_v7_defconfig
> (implies CONFIG_I2C_CADENCE=y)

> Patch is against 3.19.0-rc7 (localversion-next is -next-20150209)

>   drivers/i2c/busses/i2c-cadence.c |    6 +++---
>   1 file changed, 3 insertions(+), 3 deletions(-)

> diff --git a/drivers/i2c/busses/i2c-cadence.c b/drivers/i2c/busses/i2c-cadence.c
> index 7d7a14c..8f92732f 100644
> --- a/drivers/i2c/busses/i2c-cadence.c
> +++ b/drivers/i2c/busses/i2c-cadence.c
> @@ -475,7 +475,7 @@ static void cdns_i2c_master_reset(struct i2c_adapter *adap)
>   static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
>   		struct i2c_adapter *adap)
>   {
> -	int ret;
> +	unsigned long timeout;
>   	u32 reg;
>
>   	id->p_msg = msg;
> @@ -501,8 +501,8 @@ static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
>   		cdns_i2c_msend(id);
>
>   	/* Wait for the signal of completion */
> -	ret = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
> -	if (!ret) {
> +	timeout = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
> +	if (!timeout) {

    Which means that timeout *did* expire, contrary to what one may think. I 
don't think this is a good name for the variable, I'd suggest something like 
'time_left' instead...

>   		cdns_i2c_master_reset(adap);
>   		dev_err(id->adap.dev.parent,
>   				"timeout waiting on completion\n");

WBR, Sergei


^ permalink raw reply	[flat|nested] 10+ messages in thread

* [PATCH v2] i2c: cadence: fixup of wait_for_completion_timeout return handling
@ 2015-02-10 14:17   ` Sergei Shtylyov
  0 siblings, 0 replies; 10+ messages in thread
From: Sergei Shtylyov @ 2015-02-10 14:17 UTC (permalink / raw)
  To: linux-arm-kernel

Hello.

On 2/9/2015 6:03 PM, Nicholas Mc Guire wrote:

> return type of wait_for_completion_timeout is unsigned long not int. The
> return variable is renamed to reflect its use and the type adjusted to
> unsigned long.

> Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org>
> ---

> v2: int ret is an idiom not only a declaration - thus rather than just
>      changing the type, rename the variable, as suggested by Wolfram Sang
>      <wsa@the-dreams.de>.

> Patch was only compile tested with multi_v7_defconfig
> (implies CONFIG_I2C_CADENCE=y)

> Patch is against 3.19.0-rc7 (localversion-next is -next-20150209)

>   drivers/i2c/busses/i2c-cadence.c |    6 +++---
>   1 file changed, 3 insertions(+), 3 deletions(-)

> diff --git a/drivers/i2c/busses/i2c-cadence.c b/drivers/i2c/busses/i2c-cadence.c
> index 7d7a14c..8f92732f 100644
> --- a/drivers/i2c/busses/i2c-cadence.c
> +++ b/drivers/i2c/busses/i2c-cadence.c
> @@ -475,7 +475,7 @@ static void cdns_i2c_master_reset(struct i2c_adapter *adap)
>   static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
>   		struct i2c_adapter *adap)
>   {
> -	int ret;
> +	unsigned long timeout;
>   	u32 reg;
>
>   	id->p_msg = msg;
> @@ -501,8 +501,8 @@ static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
>   		cdns_i2c_msend(id);
>
>   	/* Wait for the signal of completion */
> -	ret = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
> -	if (!ret) {
> +	timeout = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
> +	if (!timeout) {

    Which means that timeout *did* expire, contrary to what one may think. I 
don't think this is a good name for the variable, I'd suggest something like 
'time_left' instead...

>   		cdns_i2c_master_reset(adap);
>   		dev_err(id->adap.dev.parent,
>   				"timeout waiting on completion\n");

WBR, Sergei

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH v2] i2c: cadence: fixup of wait_for_completion_timeout return handling
@ 2015-02-10 14:55     ` Nicholas Mc Guire
  0 siblings, 0 replies; 10+ messages in thread
From: Nicholas Mc Guire @ 2015-02-10 14:55 UTC (permalink / raw)
  To: Sergei Shtylyov
  Cc: Nicholas Mc Guire, Michal Simek, Soren Brinkmann, Wolfram Sang,
	linux-kernel, linux-i2c, linux-arm-kernel

On Tue, 10 Feb 2015, Sergei Shtylyov wrote:

> Hello.
>
> On 2/9/2015 6:03 PM, Nicholas Mc Guire wrote:
>
>> return type of wait_for_completion_timeout is unsigned long not int. The
>> return variable is renamed to reflect its use and the type adjusted to
>> unsigned long.
>
>> Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org>
>> ---
>
>> v2: int ret is an idiom not only a declaration - thus rather than just
>>      changing the type, rename the variable, as suggested by Wolfram Sang
>>      <wsa@the-dreams.de>.
>
>> Patch was only compile tested with multi_v7_defconfig
>> (implies CONFIG_I2C_CADENCE=y)
>
>> Patch is against 3.19.0-rc7 (localversion-next is -next-20150209)
>
>>   drivers/i2c/busses/i2c-cadence.c |    6 +++---
>>   1 file changed, 3 insertions(+), 3 deletions(-)
>
>> diff --git a/drivers/i2c/busses/i2c-cadence.c b/drivers/i2c/busses/i2c-cadence.c
>> index 7d7a14c..8f92732f 100644
>> --- a/drivers/i2c/busses/i2c-cadence.c
>> +++ b/drivers/i2c/busses/i2c-cadence.c
>> @@ -475,7 +475,7 @@ static void cdns_i2c_master_reset(struct i2c_adapter *adap)
>>   static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
>>   		struct i2c_adapter *adap)
>>   {
>> -	int ret;
>> +	unsigned long timeout;
>>   	u32 reg;
>>
>>   	id->p_msg = msg;
>> @@ -501,8 +501,8 @@ static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
>>   		cdns_i2c_msend(id);
>>
>>   	/* Wait for the signal of completion */
>> -	ret = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
>> -	if (!ret) {
>> +	timeout = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
>> +	if (!timeout) {
>
>    Which means that timeout *did* expire, contrary to what one may think. 
> I don't think this is a good name for the variable, I'd suggest something 
> like 'time_left' instead...
>

thanks for that review - yes it (time_left == 0) would clearly read as
timeout.

Will fix that up and repost.

thx!
hofrat

^ permalink raw reply	[flat|nested] 10+ messages in thread

* Re: [PATCH v2] i2c: cadence: fixup of wait_for_completion_timeout return handling
@ 2015-02-10 14:55     ` Nicholas Mc Guire
  0 siblings, 0 replies; 10+ messages in thread
From: Nicholas Mc Guire @ 2015-02-10 14:55 UTC (permalink / raw)
  To: Sergei Shtylyov
  Cc: Nicholas Mc Guire, Michal Simek, Soren Brinkmann, Wolfram Sang,
	linux-kernel-u79uwXL29TY76Z2rM5mHXA,
	linux-i2c-u79uwXL29TY76Z2rM5mHXA,
	linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r

On Tue, 10 Feb 2015, Sergei Shtylyov wrote:

> Hello.
>
> On 2/9/2015 6:03 PM, Nicholas Mc Guire wrote:
>
>> return type of wait_for_completion_timeout is unsigned long not int. The
>> return variable is renamed to reflect its use and the type adjusted to
>> unsigned long.
>
>> Signed-off-by: Nicholas Mc Guire <hofrat-Q945KHDl0DbYtjvyW6yDsg@public.gmane.org>
>> ---
>
>> v2: int ret is an idiom not only a declaration - thus rather than just
>>      changing the type, rename the variable, as suggested by Wolfram Sang
>>      <wsa-z923LK4zBo2bacvFa/9K2g@public.gmane.org>.
>
>> Patch was only compile tested with multi_v7_defconfig
>> (implies CONFIG_I2C_CADENCE=y)
>
>> Patch is against 3.19.0-rc7 (localversion-next is -next-20150209)
>
>>   drivers/i2c/busses/i2c-cadence.c |    6 +++---
>>   1 file changed, 3 insertions(+), 3 deletions(-)
>
>> diff --git a/drivers/i2c/busses/i2c-cadence.c b/drivers/i2c/busses/i2c-cadence.c
>> index 7d7a14c..8f92732f 100644
>> --- a/drivers/i2c/busses/i2c-cadence.c
>> +++ b/drivers/i2c/busses/i2c-cadence.c
>> @@ -475,7 +475,7 @@ static void cdns_i2c_master_reset(struct i2c_adapter *adap)
>>   static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
>>   		struct i2c_adapter *adap)
>>   {
>> -	int ret;
>> +	unsigned long timeout;
>>   	u32 reg;
>>
>>   	id->p_msg = msg;
>> @@ -501,8 +501,8 @@ static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
>>   		cdns_i2c_msend(id);
>>
>>   	/* Wait for the signal of completion */
>> -	ret = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
>> -	if (!ret) {
>> +	timeout = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
>> +	if (!timeout) {
>
>    Which means that timeout *did* expire, contrary to what one may think. 
> I don't think this is a good name for the variable, I'd suggest something 
> like 'time_left' instead...
>

thanks for that review - yes it (time_left == 0) would clearly read as
timeout.

Will fix that up and repost.

thx!
hofrat

^ permalink raw reply	[flat|nested] 10+ messages in thread

* [PATCH v2] i2c: cadence: fixup of wait_for_completion_timeout return handling
@ 2015-02-10 14:55     ` Nicholas Mc Guire
  0 siblings, 0 replies; 10+ messages in thread
From: Nicholas Mc Guire @ 2015-02-10 14:55 UTC (permalink / raw)
  To: linux-arm-kernel

On Tue, 10 Feb 2015, Sergei Shtylyov wrote:

> Hello.
>
> On 2/9/2015 6:03 PM, Nicholas Mc Guire wrote:
>
>> return type of wait_for_completion_timeout is unsigned long not int. The
>> return variable is renamed to reflect its use and the type adjusted to
>> unsigned long.
>
>> Signed-off-by: Nicholas Mc Guire <hofrat@osadl.org>
>> ---
>
>> v2: int ret is an idiom not only a declaration - thus rather than just
>>      changing the type, rename the variable, as suggested by Wolfram Sang
>>      <wsa@the-dreams.de>.
>
>> Patch was only compile tested with multi_v7_defconfig
>> (implies CONFIG_I2C_CADENCE=y)
>
>> Patch is against 3.19.0-rc7 (localversion-next is -next-20150209)
>
>>   drivers/i2c/busses/i2c-cadence.c |    6 +++---
>>   1 file changed, 3 insertions(+), 3 deletions(-)
>
>> diff --git a/drivers/i2c/busses/i2c-cadence.c b/drivers/i2c/busses/i2c-cadence.c
>> index 7d7a14c..8f92732f 100644
>> --- a/drivers/i2c/busses/i2c-cadence.c
>> +++ b/drivers/i2c/busses/i2c-cadence.c
>> @@ -475,7 +475,7 @@ static void cdns_i2c_master_reset(struct i2c_adapter *adap)
>>   static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
>>   		struct i2c_adapter *adap)
>>   {
>> -	int ret;
>> +	unsigned long timeout;
>>   	u32 reg;
>>
>>   	id->p_msg = msg;
>> @@ -501,8 +501,8 @@ static int cdns_i2c_process_msg(struct cdns_i2c *id, struct i2c_msg *msg,
>>   		cdns_i2c_msend(id);
>>
>>   	/* Wait for the signal of completion */
>> -	ret = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
>> -	if (!ret) {
>> +	timeout = wait_for_completion_timeout(&id->xfer_done, adap->timeout);
>> +	if (!timeout) {
>
>    Which means that timeout *did* expire, contrary to what one may think. 
> I don't think this is a good name for the variable, I'd suggest something 
> like 'time_left' instead...
>

thanks for that review - yes it (time_left == 0) would clearly read as
timeout.

Will fix that up and repost.

thx!
hofrat

^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2015-02-10 14:55 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-02-09 15:03 [PATCH v2] i2c: cadence: fixup of wait_for_completion_timeout return handling Nicholas Mc Guire
2015-02-09 15:03 ` Nicholas Mc Guire
2015-02-09 16:15 ` Sören Brinkmann
2015-02-09 16:15   ` Sören Brinkmann
2015-02-09 16:15   ` Sören Brinkmann
2015-02-10 14:17 ` Sergei Shtylyov
2015-02-10 14:17   ` Sergei Shtylyov
2015-02-10 14:55   ` Nicholas Mc Guire
2015-02-10 14:55     ` Nicholas Mc Guire
2015-02-10 14:55     ` Nicholas Mc Guire

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.