All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/1] busybox: more nails in the coffin
@ 2015-09-05  2:18 Joe Slater
  2015-09-05  5:32 ` Richard Purdie
  0 siblings, 1 reply; 3+ messages in thread
From: Joe Slater @ 2015-09-05  2:18 UTC (permalink / raw)
  To: openembedded-core

Create packagegroup-busybox and modify packagegroup-core-boot
to conditionally use it.

Signed-off-by: Joe Slater <jslater@windriver.com>
---
 .../packagegroups/packagegroup-busybox.bb          |   23 ++++++++++++++++++++
 .../packagegroups/packagegroup-core-boot.bb        |   17 ++++++++-------
 2 files changed, 32 insertions(+), 8 deletions(-)
 create mode 100644 meta/recipes-core/packagegroups/packagegroup-busybox.bb

diff --git a/meta/recipes-core/packagegroups/packagegroup-busybox.bb b/meta/recipes-core/packagegroups/packagegroup-busybox.bb
new file mode 100644
index 0000000..acf0791
--- /dev/null
+++ b/meta/recipes-core/packagegroups/packagegroup-busybox.bb
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2015 Wind River Inc.
+#
+
+SUMMARY = "Busybox related information"
+DESCRIPTION = "Busybox packages and variables"
+LICENSE = "MIT"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+# Do not ever, ever override LOCAL variables.
+#
+LOCAL_sysvinit = " \
+                   ${@bb.utils.contains('MACHINE_FEATURES', 'rtc', 'busybox-hwclock', '', d)} \
+                   "
+
+RDEPENDS_${PN} = "\
+    busybox \
+    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "${LOCAL_sysvinit}", "", d)} \
+    "
+
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
index 09f5373..b2d0775 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
@@ -17,14 +17,17 @@ inherit packagegroup
 MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
 MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
 
-# Distro can override the following VIRTUAL-RUNTIME providers:
+# These can be overridden in any .conf file.
+#
 VIRTUAL-RUNTIME_dev_manager ?= "udev"
-VIRTUAL-RUNTIME_login_manager ?= "busybox"
-VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
 VIRTUAL-RUNTIME_initscripts ?= "initscripts"
 VIRTUAL-RUNTIME_keymaps ?= "keymaps"
+VIRTUAL-RUNTIME_busybox ?= "packagegroup-busybox"
 
-SYSVINIT_SCRIPTS = "${@bb.utils.contains('MACHINE_FEATURES', 'rtc', 'busybox-hwclock', '', d)} \
+# Do not ever, ever override LOCAL variables.
+#
+LOCAL_sysvinit = " \
+                    sysvinit \
                     modutils-initscripts \
                     init-ifupdown \
                     ${VIRTUAL-RUNTIME_initscripts} \
@@ -33,12 +36,10 @@ SYSVINIT_SCRIPTS = "${@bb.utils.contains('MACHINE_FEATURES', 'rtc', 'busybox-hwc
 RDEPENDS_${PN} = "\
     base-files \
     base-passwd \
-    busybox \
-    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "${SYSVINIT_SCRIPTS}", "", d)} \
+    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "${LOCAL_sysvinit}", "", d)} \
     ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
     netbase \
-    ${VIRTUAL-RUNTIME_login_manager} \
-    ${VIRTUAL-RUNTIME_init_manager} \
+    ${VIRTUAL-RUNTIME_busybox} \
     ${VIRTUAL-RUNTIME_dev_manager} \
     ${VIRTUAL-RUNTIME_update-alternatives} \
     ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS}"
-- 
1.7.9.5



^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH 1/1] busybox: more nails in the coffin
  2015-09-05  2:18 [PATCH 1/1] busybox: more nails in the coffin Joe Slater
@ 2015-09-05  5:32 ` Richard Purdie
  2015-09-08  0:55   ` Slater, Joseph
  0 siblings, 1 reply; 3+ messages in thread
From: Richard Purdie @ 2015-09-05  5:32 UTC (permalink / raw)
  To: Joe Slater; +Cc: openembedded-core

On Fri, 2015-09-04 at 19:18 -0700, Joe Slater wrote:
> Create packagegroup-busybox and modify packagegroup-core-boot
> to conditionally use it.

This says what it goes but not why. I'm also less than keen on the
subject line :/.

> Signed-off-by: Joe Slater <jslater@windriver.com>
> ---
>  .../packagegroups/packagegroup-busybox.bb          |   23 ++++++++++++++++++++
>  .../packagegroups/packagegroup-core-boot.bb        |   17 ++++++++-------
>  2 files changed, 32 insertions(+), 8 deletions(-)
>  create mode 100644 meta/recipes-core/packagegroups/packagegroup-busybox.bb
> 
> diff --git a/meta/recipes-core/packagegroups/packagegroup-busybox.bb b/meta/recipes-core/packagegroups/packagegroup-busybox.bb
> new file mode 100644
> index 0000000..acf0791
> --- /dev/null
> +++ b/meta/recipes-core/packagegroups/packagegroup-busybox.bb
> @@ -0,0 +1,23 @@
> +#
> +# Copyright (C) 2015 Wind River Inc.
> +#
> +
> +SUMMARY = "Busybox related information"
> +DESCRIPTION = "Busybox packages and variables"
> +LICENSE = "MIT"
> +
> +PACKAGE_ARCH = "${MACHINE_ARCH}"
> +
> +inherit packagegroup
> +
> +# Do not ever, ever override LOCAL variables.
> +#

Why?

> +LOCAL_sysvinit = " \
> +                   ${@bb.utils.contains('MACHINE_FEATURES', 'rtc', 'busybox-hwclock', '', d)} \
> +                   "
> +
> +RDEPENDS_${PN} = "\
> +    busybox \
> +    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "${LOCAL_sysvinit}", "", d)} \
> +    "
> +
> diff --git a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
> index 09f5373..b2d0775 100644
> --- a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
> +++ b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
> @@ -17,14 +17,17 @@ inherit packagegroup
>  MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
>  MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
>  
> -# Distro can override the following VIRTUAL-RUNTIME providers:
> +# These can be overridden in any .conf file.
> +#
>  VIRTUAL-RUNTIME_dev_manager ?= "udev"
> -VIRTUAL-RUNTIME_login_manager ?= "busybox"
> -VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
>  VIRTUAL-RUNTIME_initscripts ?= "initscripts"
>  VIRTUAL-RUNTIME_keymaps ?= "keymaps"
> +VIRTUAL-RUNTIME_busybox ?= "packagegroup-busybox"

What about anyone who actually use these existing VIRTUAL-RUNTIME
variables?

Cheers,

Richard




^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH 1/1] busybox: more nails in the coffin
  2015-09-05  5:32 ` Richard Purdie
@ 2015-09-08  0:55   ` Slater, Joseph
  0 siblings, 0 replies; 3+ messages in thread
From: Slater, Joseph @ 2015-09-08  0:55 UTC (permalink / raw)
  To: Richard Purdie; +Cc: openembedded-core



> -----Original Message-----
> From: Richard Purdie [mailto:richard.purdie@linuxfoundation.org]
> Sent: Friday, September 04, 2015 10:33 PM
> To: Slater, Joseph
> Cc: openembedded-core@lists.openembedded.org
> Subject: Re: [OE-core] [oe-core][PATCH 1/1] busybox: more nails in the coffin
> 
> On Fri, 2015-09-04 at 19:18 -0700, Joe Slater wrote:
> > Create packagegroup-busybox and modify packagegroup-core-boot
> > to conditionally use it.
> 
> This says what it goes but not why. I'm also less than keen on the
> subject line :/.

Yes, the why should be there.  I kind of like the subject line, but
it won't be the same when I re-submit this.

> 
> > Signed-off-by: Joe Slater <jslater@windriver.com>
> > ---
> >  .../packagegroups/packagegroup-busybox.bb          |   23 ++++++++++++++++++++
> >  .../packagegroups/packagegroup-core-boot.bb        |   17 ++++++++-------
> >  2 files changed, 32 insertions(+), 8 deletions(-)
> >  create mode 100644 meta/recipes-core/packagegroups/packagegroup-busybox.bb
> >
> > diff --git a/meta/recipes-core/packagegroups/packagegroup-busybox.bb b/meta/recipes-
> core/packagegroups/packagegroup-busybox.bb
> > new file mode 100644
> > index 0000000..acf0791
> > --- /dev/null
> > +++ b/meta/recipes-core/packagegroups/packagegroup-busybox.bb
> > @@ -0,0 +1,23 @@
> > +#
> > +# Copyright (C) 2015 Wind River Inc.
> > +#
> > +
> > +SUMMARY = "Busybox related information"
> > +DESCRIPTION = "Busybox packages and variables"
> > +LICENSE = "MIT"
> > +
> > +PACKAGE_ARCH = "${MACHINE_ARCH}"
> > +
> > +inherit packagegroup
> > +
> > +# Do not ever, ever override LOCAL variables.
> > +#
> 
> Why?

The comment should not be there.  I'll remove it.  Maybe there is
a naming convention, but I'd like recipes to have truly local variables.

> 
> > +LOCAL_sysvinit = " \
> > +                   ${@bb.utils.contains('MACHINE_FEATURES', 'rtc', 'busybox-hwclock',
> '', d)} \
> > +                   "
> > +
> > +RDEPENDS_${PN} = "\
> > +    busybox \
> > +    ${@bb.utils.contains("DISTRO_FEATURES", "sysvinit", "${LOCAL_sysvinit}", "", d)} \
> > +    "
> > +
> > diff --git a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb b/meta/recipes-
> core/packagegroups/packagegroup-core-boot.bb
> > index 09f5373..b2d0775 100644
> > --- a/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
> > +++ b/meta/recipes-core/packagegroups/packagegroup-core-boot.bb
> > @@ -17,14 +17,17 @@ inherit packagegroup
> >  MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
> >  MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
> >
> > -# Distro can override the following VIRTUAL-RUNTIME providers:
> > +# These can be overridden in any .conf file.
> > +#
> >  VIRTUAL-RUNTIME_dev_manager ?= "udev"
> > -VIRTUAL-RUNTIME_login_manager ?= "busybox"
> > -VIRTUAL-RUNTIME_init_manager ?= "sysvinit"
> >  VIRTUAL-RUNTIME_initscripts ?= "initscripts"
> >  VIRTUAL-RUNTIME_keymaps ?= "keymaps"
> > +VIRTUAL-RUNTIME_busybox ?= "packagegroup-busybox"
> 
> What about anyone who actually use these existing VIRTUAL-RUNTIME
> variables?

This could break things, but maybe not in a bad way.  VIRTUAL-RUNTIME_init_manager
seems to conflict with the DISTRO_FEATURES sysvinit/systemd.  Maybe _busybox could
be eliminated and _login_manager be preserved and set to packagegroup-busybox.

Joe

> 
> Cheers,
> 
> Richard
> 


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2015-09-08  0:55 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-09-05  2:18 [PATCH 1/1] busybox: more nails in the coffin Joe Slater
2015-09-05  5:32 ` Richard Purdie
2015-09-08  0:55   ` Slater, Joseph

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.