All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0071/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-02 10:38 Baole Ni
  2016-08-03 15:47   ` David Laight
  0 siblings, 1 reply; 3+ messages in thread
From: Baole Ni @ 2016-08-02 10:38 UTC (permalink / raw)
  To: 3chas3, tj, lenb, x86, hpa
  Cc: linux-atm-general, netdev, linux-kernel, chuansheng.liu, baolex.ni

I find that the developers often just specified the numeric value
when calling a macro which is defined with a parameter for access permission.
As we know, these numeric value for access permission have had the corresponding macro,
and that using macro can improve the robustness and readability of the code,
thus, I suggest replacing the numeric parameter with the macro.

Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
Signed-off-by: Baole Ni <baolex.ni@intel.com>
---
 drivers/atm/idt77252.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/atm/idt77252.c b/drivers/atm/idt77252.c
index 074616b..7d6e420 100644
--- a/drivers/atm/idt77252.c
+++ b/drivers/atm/idt77252.c
@@ -3796,7 +3796,7 @@ MODULE_LICENSE("GPL");
 module_param(vpibits, uint, 0);
 MODULE_PARM_DESC(vpibits, "number of VPI bits supported (0, 1, or 2)");
 #ifdef CONFIG_ATM_IDT77252_DEBUG
-module_param(debug, ulong, 0644);
+module_param(debug, ulong, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
 MODULE_PARM_DESC(debug,   "debug bitmap, see drivers/atm/idt77252.h");
 #endif
 
-- 
2.9.2

^ permalink raw reply related	[flat|nested] 3+ messages in thread

* RE: [PATCH 0071/1285] Replace numeric parameter like 0444 with macro
  2016-08-02 10:38 [PATCH 0071/1285] Replace numeric parameter like 0444 with macro Baole Ni
@ 2016-08-03 15:47   ` David Laight
  0 siblings, 0 replies; 3+ messages in thread
From: David Laight @ 2016-08-03 15:47 UTC (permalink / raw)
  To: 'Baole Ni', 3chas3, tj, lenb, x86, hpa
  Cc: linux-atm-general, netdev, linux-kernel, chuansheng.liu

From: Baole Ni
> Sent: 02 August 2016 11:39
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
...
> -module_param(debug, ulong, 0644);
> +module_param(debug, ulong, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
...

If you're as old as I am the octal constant is easier to read!

	David

^ permalink raw reply	[flat|nested] 3+ messages in thread

* RE: [PATCH 0071/1285] Replace numeric parameter like 0444 with macro
@ 2016-08-03 15:47   ` David Laight
  0 siblings, 0 replies; 3+ messages in thread
From: David Laight @ 2016-08-03 15:47 UTC (permalink / raw)
  To: 'Baole Ni', 3chas3, tj, lenb, x86, hpa
  Cc: linux-atm-general, netdev, linux-kernel, chuansheng.liu

From: Baole Ni
> Sent: 02 August 2016 11:39
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
...
> -module_param(debug, ulong, 0644);
> +module_param(debug, ulong, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
...

If you're as old as I am the octal constant is easier to read!

	David

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2016-08-03 15:49 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-08-02 10:38 [PATCH 0071/1285] Replace numeric parameter like 0444 with macro Baole Ni
2016-08-03 15:47 ` David Laight
2016-08-03 15:47   ` David Laight

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.