All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] arm: mx6: module_fuse: fix build failure due to wrong argument name
@ 2023-04-06 16:17 Giulio Benetti
  2023-04-07  1:52 ` Peng Fan
                   ` (2 more replies)
  0 siblings, 3 replies; 5+ messages in thread
From: Giulio Benetti @ 2023-04-06 16:17 UTC (permalink / raw)
  To: Stefano Babic, Fabio Estevam; +Cc: NXP i.MX U-Boot Team, Giulio Benetti, u-boot

nodeoff variable should be variable off returned by fdt_path_offset() so
let's rename it to off.

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
---
 arch/arm/mach-imx/mx6/module_fuse.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/arm/mach-imx/mx6/module_fuse.c b/arch/arm/mach-imx/mx6/module_fuse.c
index 0f4565e311..b58f11c1e5 100644
--- a/arch/arm/mach-imx/mx6/module_fuse.c
+++ b/arch/arm/mach-imx/mx6/module_fuse.c
@@ -206,7 +206,7 @@ int ft_system_setup(void *blob, struct bd_info *bd)
 			if (off < 0)
 				continue; /* Not found, skip it */
 add_status:
-			rc = fdt_setprop(blob, nodeoff, "status", status,
+			rc = fdt_setprop(blob, off, "status", status,
 					 strlen(status) + 1);
 			if (rc) {
 				if (rc == -FDT_ERR_NOSPACE) {
-- 
2.34.1


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] arm: mx6: module_fuse: fix build failure due to wrong argument name
  2023-04-06 16:17 [PATCH] arm: mx6: module_fuse: fix build failure due to wrong argument name Giulio Benetti
@ 2023-04-07  1:52 ` Peng Fan
  2023-06-15 13:14   ` Giulio Benetti
  2023-06-15 13:37 ` Fabio Estevam
  2023-07-11 19:45 ` sbabic
  2 siblings, 1 reply; 5+ messages in thread
From: Peng Fan @ 2023-04-07  1:52 UTC (permalink / raw)
  To: Giulio Benetti, Stefano Babic, Fabio Estevam; +Cc: NXP i.MX U-Boot Team, u-boot



On 4/7/2023 12:17 AM, Giulio Benetti wrote:
> nodeoff variable should be variable off returned by fdt_path_offset() so
> let's rename it to off.
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>

Reviewed-by: Peng Fan <peng.fan@nxp.com>

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] arm: mx6: module_fuse: fix build failure due to wrong argument name
  2023-04-07  1:52 ` Peng Fan
@ 2023-06-15 13:14   ` Giulio Benetti
  0 siblings, 0 replies; 5+ messages in thread
From: Giulio Benetti @ 2023-06-15 13:14 UTC (permalink / raw)
  To: Peng Fan, Stefano Babic, Fabio Estevam; +Cc: NXP i.MX U-Boot Team, u-boot

Hello All,

On 07/04/23 03:52, Peng Fan wrote:
> 
> 
> On 4/7/2023 12:17 AM, Giulio Benetti wrote:
>> nodeoff variable should be variable off returned by fdt_path_offset() so
>> let's rename it to off.
>>
>> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
> 
> Reviewed-by: Peng Fan <peng.fan@nxp.com>

I kindly ping

Best regards
-- 
CEO/CTO@Benetti Engineering sas

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] arm: mx6: module_fuse: fix build failure due to wrong argument name
  2023-04-06 16:17 [PATCH] arm: mx6: module_fuse: fix build failure due to wrong argument name Giulio Benetti
  2023-04-07  1:52 ` Peng Fan
@ 2023-06-15 13:37 ` Fabio Estevam
  2023-07-11 19:45 ` sbabic
  2 siblings, 0 replies; 5+ messages in thread
From: Fabio Estevam @ 2023-06-15 13:37 UTC (permalink / raw)
  To: Giulio Benetti; +Cc: Stefano Babic, NXP i.MX U-Boot Team, u-boot

On Thu, Apr 6, 2023 at 1:17 PM Giulio Benetti
<giulio.benetti@benettiengineering.com> wrote:
>
> nodeoff variable should be variable off returned by fdt_path_offset() so
> let's rename it to off.
>
> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>

Reviewed-by: Fabio Estevam <festevam@denx.de>

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [PATCH] arm: mx6: module_fuse: fix build failure due to wrong argument name
  2023-04-06 16:17 [PATCH] arm: mx6: module_fuse: fix build failure due to wrong argument name Giulio Benetti
  2023-04-07  1:52 ` Peng Fan
  2023-06-15 13:37 ` Fabio Estevam
@ 2023-07-11 19:45 ` sbabic
  2 siblings, 0 replies; 5+ messages in thread
From: sbabic @ 2023-07-11 19:45 UTC (permalink / raw)
  To: Giulio Benetti, u-boot

> nodeoff variable should be variable off returned by fdt_path_offset() so
> let's rename it to off.
> Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
> Reviewed-by: Peng Fan <peng.fan@nxp.com>
> Reviewed-by: Fabio Estevam <festevam@denx.de>
Applied to u-boot-imx, master, thanks !

Best regards,
Stefano Babic

-- 
=====================================================================
DENX Software Engineering GmbH,        Managing Director: Erika Unter  
HRB 165235 Munich,   Office: Kirchenstr.5, 82194 Groebenzell, Germany
Phone: +49-8142-66989-53 Fax: +49-8142-66989-80 Email: sbabic@denx.de
=====================================================================

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2023-07-11 19:52 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-04-06 16:17 [PATCH] arm: mx6: module_fuse: fix build failure due to wrong argument name Giulio Benetti
2023-04-07  1:52 ` Peng Fan
2023-06-15 13:14   ` Giulio Benetti
2023-06-15 13:37 ` Fabio Estevam
2023-07-11 19:45 ` sbabic

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.