All of lore.kernel.org
 help / color / mirror / Atom feed
From: "Pandiyan, Dhinakaran" <dhinakaran.pandiyan@intel.com>
To: "igt-dev@lists.freedesktop.org" <igt-dev@lists.freedesktop.org>,
	"Souza, Jose" <jose.souza@intel.com>
Subject: Re: [igt-dev] [PATCH i-g-t 3/3] test/kms_fbcon_fbt: Give a explicit parameter name to functions that expect debugfs fd
Date: Tue, 18 Sep 2018 22:52:24 +0000	[thread overview]
Message-ID: <0f7da9ecb8fee45822bb9b973071292aa35fb3de.camel@intel.com> (raw)
In-Reply-To: <20180918221531.18233-3-jose.souza@intel.com>

On Tue, 2018-09-18 at 15:15 -0700, José Roberto de Souza wrote:
> Let's rename to debugfs_fd all the parameters of the functions that
> expect debugfs fd to avoid call one those functions with the wrong
> file descriptor.
> 
Series Reviewed-by: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com>


> Cc: Dhinakaran Pandiyan <dhinakaran.pandiyan@intel.com>
> Signed-off-by: José Roberto de Souza <jose.souza@intel.com>
> ---
>  tests/kms_fbcon_fbt.c | 22 +++++++++++-----------
>  1 file changed, 11 insertions(+), 11 deletions(-)
> 
> diff --git a/tests/kms_fbcon_fbt.c b/tests/kms_fbcon_fbt.c
> index 138eda9b..9869aa14 100644
> --- a/tests/kms_fbcon_fbt.c
> +++ b/tests/kms_fbcon_fbt.c
> @@ -203,34 +203,34 @@ static bool psr_is_enabled(int debugfs_fd)
>  	return strstr(buf, "\nHW Enabled & Active bit: yes\n");
>  }
>  
> -static bool psr_wait_until_enabled(int fd)
> +static bool psr_wait_until_enabled(int debugfs_fd)
>  {
> -	bool r = igt_wait(psr_is_enabled(fd), 5000, 1);
> -	psr_print_status(fd);
> +	bool r = igt_wait(psr_is_enabled(debugfs_fd), 5000, 1);
> +	psr_print_status(debugfs_fd);
>  	return r;
>  }
>  
> -static void disable_features(int fd)
> +static void disable_features(int debugfs_fd)
>  {
>  	igt_set_module_param_int("enable_fbc", 0);
> -	psr_disable(fd);
> +	psr_disable(debugfs_fd);
>  }
>  
> -static inline void fbc_modparam_enable(int fd)
> +static inline void fbc_modparam_enable(int debugfs_fd)
>  {
>  	igt_set_module_param_int("enable_fbc", 1);
>  }
>  
> -static inline void psr_debugfs_enable(int fd)
> +static inline void psr_debugfs_enable(int debugfs_fd)
>  {
> -	psr_enable(fd);
> +	psr_enable(debugfs_fd);
>  }
>  
>  struct feature {
> -	bool (*supported_on_chipset)(int fd);
> -	bool (*wait_until_enabled)(int fd);
> +	bool (*supported_on_chipset)(int debugfs_fd);
> +	bool (*wait_until_enabled)(int debugfs_fd);
>  	bool (*connector_possible_fn)(drmModeConnectorPtr
> connector);
> -	void (*enable)(int fd);
> +	void (*enable)(int debugfs_fd);
>  } fbc = {
>  	.supported_on_chipset = fbc_supported_on_chipset,
>  	.wait_until_enabled = fbc_wait_until_enabled,
_______________________________________________
igt-dev mailing list
igt-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/igt-dev

  reply	other threads:[~2018-09-18 22:52 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-09-18 22:15 [igt-dev] [PATCH i-g-t 1/3] tests/kms_frontbuffer_tracking: Pass the debugfs fd to psr_wait_entry() José Roberto de Souza
2018-09-18 22:15 ` [igt-dev] [PATCH i-g-t 2/3] lib/igt_psr: Give a explicit parameter name to functions that expect debugfs fd José Roberto de Souza
2018-09-18 22:15 ` [igt-dev] [PATCH i-g-t 3/3] test/kms_fbcon_fbt: " José Roberto de Souza
2018-09-18 22:52   ` Pandiyan, Dhinakaran [this message]
2018-09-20  4:59   ` Pandiyan, Dhinakaran
2018-09-20 17:59     ` Souza, Jose
2018-09-20 18:43       ` Pandiyan, Dhinakaran
2018-09-19 10:11 ` [igt-dev] ✓ Fi.CI.BAT: success for series starting with [i-g-t,1/3] tests/kms_frontbuffer_tracking: Pass the debugfs fd to psr_wait_entry() Patchwork
2018-09-19 12:42 ` [igt-dev] ✓ Fi.CI.IGT: " Patchwork

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0f7da9ecb8fee45822bb9b973071292aa35fb3de.camel@intel.com \
    --to=dhinakaran.pandiyan@intel.com \
    --cc=igt-dev@lists.freedesktop.org \
    --cc=jose.souza@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.