All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations
@ 2010-04-09  7:45 Tay Ray Chuan
  2010-04-09 11:55 ` Michael J Gruber
  2010-04-09 12:38 ` [PATCH v2] " Tay Ray Chuan
  0 siblings, 2 replies; 6+ messages in thread
From: Tay Ray Chuan @ 2010-04-09  7:45 UTC (permalink / raw)
  To: Git Mailing List

In 5f856dd (fix reflog entries for "git-branch"), it is mentioned that
'git branch -f' is intended to be equivalent to 'git reset'. Since we
usually say "reset to <commit>" in the git-reset Documentation and
elsewhere, it would make sense to say "Reset to" here as well.

Signed-off-by: Tay Ray Chuan <rctay89@gmail.com>
---

  I happened to be perusing my branch's reflog when I spotted this.

 branch.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/branch.c b/branch.c
index 9e1f63e..2ab42aa 100644
--- a/branch.c
+++ b/branch.c
@@ -198,7 +198,7 @@ void create_branch(const char *head,
 		log_all_ref_updates = 1;

 	if (forcing)
-		snprintf(msg, sizeof msg, "branch: Reset from %s",
+		snprintf(msg, sizeof msg, "branch: Reset to %s",
 			 start_name);
 	else if (!dont_change_ref)
 		snprintf(msg, sizeof msg, "branch: Created from %s",
--
1.7.1.rc0.240.gba75f

^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations
  2010-04-09  7:45 [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations Tay Ray Chuan
@ 2010-04-09 11:55 ` Michael J Gruber
  2010-04-09 12:03   ` Matthieu Moy
  2010-04-09 12:18   ` Tay Ray Chuan
  2010-04-09 12:38 ` [PATCH v2] " Tay Ray Chuan
  1 sibling, 2 replies; 6+ messages in thread
From: Michael J Gruber @ 2010-04-09 11:55 UTC (permalink / raw)
  To: Tay Ray Chuan; +Cc: Git Mailing List

Tay Ray Chuan venit, vidit, dixit 09.04.2010 15:45:
> In 5f856dd (fix reflog entries for "git-branch"), it is mentioned that
> 'git branch -f' is intended to be equivalent to 'git reset'. Since we
> usually say "reset to <commit>" in the git-reset Documentation and
> elsewhere, it would make sense to say "Reset to" here as well.
> 

I know the patch is not large, but one really has to read it after
wondering: Huh? What is branch -f doing now before the patch? To me it
sounded as if it didn't write to the reflog at all. So, how about

elsewhere, it would make sense to say "Reset to" here as well rather
than "Rest from".

But I also have a functional question: Is "start_from" really the ref
*to* which the branch is reset? I hope reset does it right.

> Signed-off-by: Tay Ray Chuan <rctay89@gmail.com>
> ---
> 
>   I happened to be perusing my branch's reflog when I spotted this.
> 
>  branch.c |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/branch.c b/branch.c
> index 9e1f63e..2ab42aa 100644
> --- a/branch.c
> +++ b/branch.c
> @@ -198,7 +198,7 @@ void create_branch(const char *head,
>  		log_all_ref_updates = 1;
> 
>  	if (forcing)
> -		snprintf(msg, sizeof msg, "branch: Reset from %s",
> +		snprintf(msg, sizeof msg, "branch: Reset to %s",
>  			 start_name);
>  	else if (!dont_change_ref)
>  		snprintf(msg, sizeof msg, "branch: Created from %s",
> --
> 1.7.1.rc0.240.gba75f
> 

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations
  2010-04-09 11:55 ` Michael J Gruber
@ 2010-04-09 12:03   ` Matthieu Moy
  2010-04-09 12:20     ` Johannes Sixt
  2010-04-09 12:18   ` Tay Ray Chuan
  1 sibling, 1 reply; 6+ messages in thread
From: Matthieu Moy @ 2010-04-09 12:03 UTC (permalink / raw)
  To: Michael J Gruber; +Cc: Tay Ray Chuan, Git Mailing List

Michael J Gruber <git@drmicha.warpmail.net> writes:

> But I also have a functional question: Is "start_from" really the ref
> *to* which the branch is reset? I hope reset does it right.

I don't know which is which, but if start_from is the destination of
the ref, then it should be renamed. I don't think we want to have this

		snprintf(msg, sizeof msg, "branch: Reset to %s",
                                                         ^^
 			 start_name);
                         ^^^^^

in the code.

-- 
Matthieu Moy
http://www-verimag.imag.fr/~moy/

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] branch: say "Reset to" in reflog entries for 'git branch  -f' operations
  2010-04-09 11:55 ` Michael J Gruber
  2010-04-09 12:03   ` Matthieu Moy
@ 2010-04-09 12:18   ` Tay Ray Chuan
  1 sibling, 0 replies; 6+ messages in thread
From: Tay Ray Chuan @ 2010-04-09 12:18 UTC (permalink / raw)
  To: Michael J Gruber; +Cc: Git Mailing List

Hi,

On Fri, Apr 9, 2010 at 7:55 PM, Michael J Gruber
<git@drmicha.warpmail.net> wrote:
> I know the patch is not large, but one really has to read it after
> wondering: Huh? What is branch -f doing now before the patch? To me it
> sounded as if it didn't write to the reflog at all. So, how about
>
> elsewhere, it would make sense to say "Reset to" here as well rather
> than "Rest from".

Sounds good.

> But I also have a functional question: Is "start_from" really the ref
> *to* which the branch is reset? I hope reset does it right.

(I think you mean "start_name" instead of "start_from".)

Well, "start_name" determines where the branch/ref points to. I don't
think any branch can "start", except that it can diverge.

But that's outside the scope of this patch.

-- 
Cheers,
Ray Chuan

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations
  2010-04-09 12:03   ` Matthieu Moy
@ 2010-04-09 12:20     ` Johannes Sixt
  0 siblings, 0 replies; 6+ messages in thread
From: Johannes Sixt @ 2010-04-09 12:20 UTC (permalink / raw)
  To: Matthieu Moy; +Cc: Michael J Gruber, Tay Ray Chuan, Git Mailing List

Am 4/9/2010 14:03, schrieb Matthieu Moy:
> Michael J Gruber <git@drmicha.warpmail.net> writes:
> 
>> But I also have a functional question: Is "start_from" really the ref
>> *to* which the branch is reset? I hope reset does it right.
> 
> I don't know which is which, but if start_from is the destination of
> the ref, then it should be renamed. I don't think we want to have this
> 
> 		snprintf(msg, sizeof msg, "branch: Reset to %s",
>                                                          ^^
>  			 start_name);
>                          ^^^^^
> 
> in the code.

I think the patch is right.

The "start" part refers to where the branch forks off of existing history.

In the case were an existing branch is pointed to a new commit, the "Reset
to" is indeed correct. IIUC, the "start_name" is what was given on the
command line as fork point (or HEAD if not given). For example, after

   git branch -f thebranch master~23

the reflog of 'thebranch' would now read as "Reset to master~23".

-- Hannes

^ permalink raw reply	[flat|nested] 6+ messages in thread

* [PATCH v2] branch: say "Reset to" in reflog entries for 'git branch -f' operations
  2010-04-09  7:45 [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations Tay Ray Chuan
  2010-04-09 11:55 ` Michael J Gruber
@ 2010-04-09 12:38 ` Tay Ray Chuan
  1 sibling, 0 replies; 6+ messages in thread
From: Tay Ray Chuan @ 2010-04-09 12:38 UTC (permalink / raw)
  To: Git Mailing List; +Cc: Michael J Gruber, Matthieu Moy, Johannes Sixt

In 5f856dd (fix reflog entries for "git-branch"), it is mentioned that
'git branch -f' is intended to be equivalent to 'git reset'. Since we
usually say "reset to <commit>" in the git-reset Documentation and
elsewhere, it would make sense to say "Reset to" here as well, instead
of "Reset from" previously.

Signed-off-by: Tay Ray Chuan <rctay89@gmail.com>
---

Changed from v1:
 - Mention old reflog message in patch message, as suggested by
   Michael J Gruber.

 branch.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/branch.c b/branch.c
index 9e1f63e..2ab42aa 100644
--- a/branch.c
+++ b/branch.c
@@ -198,7 +198,7 @@ void create_branch(const char *head,
 		log_all_ref_updates = 1;

 	if (forcing)
-		snprintf(msg, sizeof msg, "branch: Reset from %s",
+		snprintf(msg, sizeof msg, "branch: Reset to %s",
 			 start_name);
 	else if (!dont_change_ref)
 		snprintf(msg, sizeof msg, "branch: Created from %s",
--
1.7.1.rc0.240.gba75f

^ permalink raw reply related	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2010-04-09 12:38 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-04-09  7:45 [PATCH] branch: say "Reset to" in reflog entries for 'git branch -f' operations Tay Ray Chuan
2010-04-09 11:55 ` Michael J Gruber
2010-04-09 12:03   ` Matthieu Moy
2010-04-09 12:20     ` Johannes Sixt
2010-04-09 12:18   ` Tay Ray Chuan
2010-04-09 12:38 ` [PATCH v2] " Tay Ray Chuan

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.