All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 2/3] Replace hci_recv_fragment calls
@ 2010-06-01  6:54 GLOBAL/suraj
  0 siblings, 0 replies; 7+ messages in thread
From: GLOBAL/suraj @ 2010-06-01  6:54 UTC (permalink / raw)
  To: linux-bluetooth; +Cc: marcel, Luis.Rodriguez, Jothikumar.Mothilal


Replace all usages of hci_recv_fragment calls with hci_recv_packet_fragment

Signed-off-by: suraj <suraj@Atheros.com>
---
 drivers/bluetooth/btusb.c |    6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
index 5d9cc53..50aa8d1 100644
--- a/drivers/bluetooth/btusb.c
+++ b/drivers/bluetooth/btusb.c
@@ -211,7 +211,7 @@ static void btusb_intr_complete(struct urb *urb)
 	if (urb->status == 0) {
 		hdev->stat.byte_rx += urb->actual_length;
 
-		if (hci_recv_fragment(hdev, HCI_EVENT_PKT,
+		if (hci_recv_packet_fragment(hdev, HCI_EVENT_PKT,
 						urb->transfer_buffer,
 						urb->actual_length) < 0) {
 			BT_ERR("%s corrupted event packet", hdev->name);
@@ -295,7 +295,7 @@ static void btusb_bulk_complete(struct urb *urb)
 	if (urb->status == 0) {
 		hdev->stat.byte_rx += urb->actual_length;
 
-		if (hci_recv_fragment(hdev, HCI_ACLDATA_PKT,
+		if (hci_recv_packet_fragment(hdev, HCI_ACLDATA_PKT,
 						urb->transfer_buffer,
 						urb->actual_length) < 0) {
 			BT_ERR("%s corrupted ACL packet", hdev->name);
@@ -384,7 +384,7 @@ static void btusb_isoc_complete(struct urb *urb)
 
 			hdev->stat.byte_rx += length;
 
-			if (hci_recv_fragment(hdev, HCI_SCODATA_PKT,
+			if (hci_recv_packet_fragment(hdev, HCI_SCODATA_PKT,
 						urb->transfer_buffer + offset,
 								length) < 0) {
 				BT_ERR("%s corrupted SCO packet", hdev->name);
-- 
1.7.0

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH 2/3] Replace hci_recv_fragment calls
  2010-06-01 21:59         ` Marcel Holtmann
@ 2010-06-02  4:11           ` Suraj Sumangala
  0 siblings, 0 replies; 7+ messages in thread
From: Suraj Sumangala @ 2010-06-02  4:11 UTC (permalink / raw)
  To: Marcel Holtmann
  Cc: Luis Rodriguez, Suraj Sumangala, linux-bluetooth, Jothikumar Mothilal

Hi Marcel,

On 6/2/2010 3:29 AM, Marcel Holtmann wrote:
> Hi Luis,
>
>>>> You want to unify patches 1 and 2. Patches upstream should be atomic so that if  you apply it, it should make everything still work. Your first patch removes hci_recv_fragment() and then this one fixes the places that call it, you want to do both in one shot.
>>>
>>> actually I prefer to leave these two patches out for now. Since the
>>> renaming could be done easily later. The important part is actually the
>>> other implementation.
>>
>> Won't that break compilation on the first patch since all existing
>> code users no longer have the exported symbol available?
>
> no. The important change here is for the H4 specific stream fragment
> handling. The rest is just a renaming. So 3/3 is the important patch and
> 1/2 and 2/2 are just cosmetic changes.
>
> Regards
>
> Marcel
>
>

I will send 3/3 as a separate patch for you to verify.

Regards
Suraj

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH 2/3] Replace hci_recv_fragment calls
  2010-06-01 20:51       ` Luis R. Rodriguez
@ 2010-06-01 21:59         ` Marcel Holtmann
  2010-06-02  4:11           ` Suraj Sumangala
  0 siblings, 1 reply; 7+ messages in thread
From: Marcel Holtmann @ 2010-06-01 21:59 UTC (permalink / raw)
  To: Luis R. Rodriguez
  Cc: Luis Rodriguez, Suraj Sumangala, linux-bluetooth, Jothikumar Mothilal

Hi Luis,

> > > You want to unify patches 1 and 2. Patches upstream should be atomic so that if  you apply it, it should make everything still work. Your first patch removes hci_recv_fragment() and then this one fixes the places that call it, you want to do both in one shot.
> > 
> > actually I prefer to leave these two patches out for now. Since the
> > renaming could be done easily later. The important part is actually the
> > other implementation.
> 
> Won't that break compilation on the first patch since all existing
> code users no longer have the exported symbol available?

no. The important change here is for the H4 specific stream fragment
handling. The rest is just a renaming. So 3/3 is the important patch and
1/2 and 2/2 are just cosmetic changes.

Regards

Marcel



^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH 2/3] Replace hci_recv_fragment calls
  2010-06-01 19:59     ` Marcel Holtmann
@ 2010-06-01 20:51       ` Luis R. Rodriguez
  2010-06-01 21:59         ` Marcel Holtmann
  0 siblings, 1 reply; 7+ messages in thread
From: Luis R. Rodriguez @ 2010-06-01 20:51 UTC (permalink / raw)
  To: Marcel Holtmann
  Cc: Luis Rodriguez, Suraj Sumangala, linux-bluetooth, Jothikumar Mothilal

On Tue, Jun 01, 2010 at 12:59:13PM -0700, Marcel Holtmann wrote:
> Hi Luis,
> 
> > You want to unify patches 1 and 2. Patches upstream should be atomic so that if  you apply it, it should make everything still work. Your first patch removes hci_recv_fragment() and then this one fixes the places that call it, you want to do both in one shot.
> 
> actually I prefer to leave these two patches out for now. Since the
> renaming could be done easily later. The important part is actually the
> other implementation.

Won't that break compilation on the first patch since all existing
code users no longer have the exported symbol available?

  Luis

^ permalink raw reply	[flat|nested] 7+ messages in thread

* RE: [PATCH 2/3] Replace hci_recv_fragment calls
  2010-06-01 14:29   ` Luis Rodriguez
@ 2010-06-01 19:59     ` Marcel Holtmann
  2010-06-01 20:51       ` Luis R. Rodriguez
  0 siblings, 1 reply; 7+ messages in thread
From: Marcel Holtmann @ 2010-06-01 19:59 UTC (permalink / raw)
  To: Luis Rodriguez; +Cc: Suraj Sumangala, linux-bluetooth, Jothikumar Mothilal

Hi Luis,

> You want to unify patches 1 and 2. Patches upstream should be atomic so that if  you apply it, it should make everything still work. Your first patch removes hci_recv_fragment() and then this one fixes the places that call it, you want to do both in one shot.

actually I prefer to leave these two patches out for now. Since the
renaming could be done easily later. The important part is actually the
other implementation.

Regards

Marcel



^ permalink raw reply	[flat|nested] 7+ messages in thread

* RE: [PATCH 2/3] Replace hci_recv_fragment calls
  2010-06-01  8:08 ` [PATCH 2/3] Replace hci_recv_fragment calls suraj
@ 2010-06-01 14:29   ` Luis Rodriguez
  2010-06-01 19:59     ` Marcel Holtmann
  0 siblings, 1 reply; 7+ messages in thread
From: Luis Rodriguez @ 2010-06-01 14:29 UTC (permalink / raw)
  To: Suraj Sumangala, linux-bluetooth; +Cc: marcel, Jothikumar Mothilal


You want to unify patches 1 and 2. Patches upstream should be atomic so tha=
t if  you apply it, it should make everything still work. Your first patch =
removes hci_recv_fragment() and then this one fixes the places that call it=
, you want to do both in one shot.

  Luis
________________________________________
From: Suraj Sumangala
Sent: Tuesday, June 01, 2010 1:08 AM
To: linux-bluetooth@vger.kernel.org
Cc: marcel@holtmann.org; Luis Rodriguez; Jothikumar Mothilal
Subject: [PATCH 2/3] Replace hci_recv_fragment calls

Replace all usages of hci_recv_fragment calls with
hci_recv_packet_fragment


Signed-off-by: suraj <suraj@Atheros.com>
---
 drivers/bluetooth/btusb.c |    6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
index 5d9cc53..50aa8d1 100644
--- a/drivers/bluetooth/btusb.c
+++ b/drivers/bluetooth/btusb.c
@@ -211,7 +211,7 @@ static void btusb_intr_complete(struct urb *urb)
        if (urb->status =3D=3D 0) {
                hdev->stat.byte_rx +=3D urb->actual_length;

-               if (hci_recv_fragment(hdev, HCI_EVENT_PKT,
+               if (hci_recv_packet_fragment(hdev, HCI_EVENT_PKT,
                                                urb->transfer_buffer,
                                                urb->actual_length) < 0) {
                        BT_ERR("%s corrupted event packet", hdev->name);
@@ -295,7 +295,7 @@ static void btusb_bulk_complete(struct urb *urb)
        if (urb->status =3D=3D 0) {
                hdev->stat.byte_rx +=3D urb->actual_length;

-               if (hci_recv_fragment(hdev, HCI_ACLDATA_PKT,
+               if (hci_recv_packet_fragment(hdev, HCI_ACLDATA_PKT,
                                                urb->transfer_buffer,
                                                urb->actual_length) < 0) {
                        BT_ERR("%s corrupted ACL packet", hdev->name);
@@ -384,7 +384,7 @@ static void btusb_isoc_complete(struct urb *urb)

                        hdev->stat.byte_rx +=3D length;

-                       if (hci_recv_fragment(hdev, HCI_SCODATA_PKT,
+                       if (hci_recv_packet_fragment(hdev, HCI_SCODATA_PKT,
                                                urb->transfer_buffer + offs=
et,
                                                                length) < 0=
) {
                                BT_ERR("%s corrupted SCO packet", hdev->nam=
e);
--
1.7.0

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* [PATCH 2/3] Replace hci_recv_fragment calls
  2010-06-01  8:04 [PATCH 1/3] Rename hci_recv_fragment to hci_recv_packet_fragment suraj
@ 2010-06-01  8:08 ` suraj
  2010-06-01 14:29   ` Luis Rodriguez
  0 siblings, 1 reply; 7+ messages in thread
From: suraj @ 2010-06-01  8:08 UTC (permalink / raw)
  To: linux-bluetooth; +Cc: marcel, Luis.Rodriguez, Jothikumar.Mothilal

Replace all usages of hci_recv_fragment calls with
hci_recv_packet_fragment


Signed-off-by: suraj <suraj@Atheros.com>
---
 drivers/bluetooth/btusb.c |    6 +++---
 1 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/bluetooth/btusb.c b/drivers/bluetooth/btusb.c
index 5d9cc53..50aa8d1 100644
--- a/drivers/bluetooth/btusb.c
+++ b/drivers/bluetooth/btusb.c
@@ -211,7 +211,7 @@ static void btusb_intr_complete(struct urb *urb)
 	if (urb->status == 0) {
 		hdev->stat.byte_rx += urb->actual_length;
 
-		if (hci_recv_fragment(hdev, HCI_EVENT_PKT,
+		if (hci_recv_packet_fragment(hdev, HCI_EVENT_PKT,
 						urb->transfer_buffer,
 						urb->actual_length) < 0) {
 			BT_ERR("%s corrupted event packet", hdev->name);
@@ -295,7 +295,7 @@ static void btusb_bulk_complete(struct urb *urb)
 	if (urb->status == 0) {
 		hdev->stat.byte_rx += urb->actual_length;
 
-		if (hci_recv_fragment(hdev, HCI_ACLDATA_PKT,
+		if (hci_recv_packet_fragment(hdev, HCI_ACLDATA_PKT,
 						urb->transfer_buffer,
 						urb->actual_length) < 0) {
 			BT_ERR("%s corrupted ACL packet", hdev->name);
@@ -384,7 +384,7 @@ static void btusb_isoc_complete(struct urb *urb)
 
 			hdev->stat.byte_rx += length;
 
-			if (hci_recv_fragment(hdev, HCI_SCODATA_PKT,
+			if (hci_recv_packet_fragment(hdev, HCI_SCODATA_PKT,
 						urb->transfer_buffer + offset,
 								length) < 0) {
 				BT_ERR("%s corrupted SCO packet", hdev->name);
-- 
1.7.0

^ permalink raw reply related	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2010-06-02  4:11 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-06-01  6:54 [PATCH 2/3] Replace hci_recv_fragment calls GLOBAL/suraj
2010-06-01  8:04 [PATCH 1/3] Rename hci_recv_fragment to hci_recv_packet_fragment suraj
2010-06-01  8:08 ` [PATCH 2/3] Replace hci_recv_fragment calls suraj
2010-06-01 14:29   ` Luis Rodriguez
2010-06-01 19:59     ` Marcel Holtmann
2010-06-01 20:51       ` Luis R. Rodriguez
2010-06-01 21:59         ` Marcel Holtmann
2010-06-02  4:11           ` Suraj Sumangala

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.