All of lore.kernel.org
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH v2] Move filedescriptor parsing code from net.c into qemu_parse_fd()
@ 2011-09-28 10:41 Stefan Berger
  2011-11-01 22:19 ` Anthony Liguori
  0 siblings, 1 reply; 2+ messages in thread
From: Stefan Berger @ 2011-09-28 10:41 UTC (permalink / raw)
  To: qemu-devel; +Cc: stefanha, mst

Move the parsing of a filedescriptor into a common function
qemu_parse_fd() so others can use it as well. Have net.c call this
function.

v2:
 - moving qemu_parse_fd into cutils.c

Signed-off-by: Stefan Berger <stefanb@linux.vnet.ibm.com>

---
 cutils.c      |   12 ++++++++++++
 net.c         |    7 +------
 qemu-common.h |    1 +
 3 files changed, 14 insertions(+), 6 deletions(-)

Index: qemu-git.pt/net.c
===================================================================
--- qemu-git.pt.orig/net.c
+++ qemu-git.pt/net.c
@@ -733,12 +733,7 @@ int net_handle_fd_param(Monitor *mon, co
             return -1;
         }
     } else {
-        char *endptr = NULL;
-
-        fd = strtol(param, &endptr, 10);
-        if (*endptr || (fd == 0 && param == endptr)) {
-            return -1;
-        }
+        fd = qemu_parse_fd(param);
     }
 
     return fd;
Index: qemu-git.pt/qemu-common.h
===================================================================
--- qemu-git.pt.orig/qemu-common.h
+++ qemu-git.pt/qemu-common.h
@@ -143,6 +143,7 @@ time_t mktimegm(struct tm *tm);
 int qemu_fls(int i);
 int qemu_fdatasync(int fd);
 int fcntl_setfl(int fd, int flag);
+int qemu_parse_fd(const char *param);
 
 /*
  * strtosz() suffixes used to specify the default treatment of an
Index: qemu-git.pt/cutils.c
===================================================================
--- qemu-git.pt.orig/cutils.c
+++ qemu-git.pt/cutils.c
@@ -415,3 +415,15 @@ int64_t strtosz(const char *nptr, char *
 {
     return strtosz_suffix(nptr, end, STRTOSZ_DEFSUFFIX_MB);
 }
+
+int qemu_parse_fd(const char *param)
+{
+    int fd;
+    char *endptr = NULL;
+
+    fd = strtol(param, &endptr, 10);
+    if (*endptr || (fd == 0 && param == endptr)) {
+        return -1;
+    }
+    return fd;
+}

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [Qemu-devel] [PATCH v2] Move filedescriptor parsing code from net.c into qemu_parse_fd()
  2011-09-28 10:41 [Qemu-devel] [PATCH v2] Move filedescriptor parsing code from net.c into qemu_parse_fd() Stefan Berger
@ 2011-11-01 22:19 ` Anthony Liguori
  0 siblings, 0 replies; 2+ messages in thread
From: Anthony Liguori @ 2011-11-01 22:19 UTC (permalink / raw)
  To: Stefan Berger; +Cc: stefanha, qemu-devel, mst

On 09/28/2011 05:41 AM, Stefan Berger wrote:
> Move the parsing of a filedescriptor into a common function
> qemu_parse_fd() so others can use it as well. Have net.c call this
> function.
>
> v2:
>   - moving qemu_parse_fd into cutils.c
>
> Signed-off-by: Stefan Berger<stefanb@linux.vnet.ibm.com>

Applied.  Thanks.

Regards,

Anthony Liguori

>
> ---
>   cutils.c      |   12 ++++++++++++
>   net.c         |    7 +------
>   qemu-common.h |    1 +
>   3 files changed, 14 insertions(+), 6 deletions(-)
>
> Index: qemu-git.pt/net.c
> ===================================================================
> --- qemu-git.pt.orig/net.c
> +++ qemu-git.pt/net.c
> @@ -733,12 +733,7 @@ int net_handle_fd_param(Monitor *mon, co
>               return -1;
>           }
>       } else {
> -        char *endptr = NULL;
> -
> -        fd = strtol(param,&endptr, 10);
> -        if (*endptr || (fd == 0&&  param == endptr)) {
> -            return -1;
> -        }
> +        fd = qemu_parse_fd(param);
>       }
>
>       return fd;
> Index: qemu-git.pt/qemu-common.h
> ===================================================================
> --- qemu-git.pt.orig/qemu-common.h
> +++ qemu-git.pt/qemu-common.h
> @@ -143,6 +143,7 @@ time_t mktimegm(struct tm *tm);
>   int qemu_fls(int i);
>   int qemu_fdatasync(int fd);
>   int fcntl_setfl(int fd, int flag);
> +int qemu_parse_fd(const char *param);
>
>   /*
>    * strtosz() suffixes used to specify the default treatment of an
> Index: qemu-git.pt/cutils.c
> ===================================================================
> --- qemu-git.pt.orig/cutils.c
> +++ qemu-git.pt/cutils.c
> @@ -415,3 +415,15 @@ int64_t strtosz(const char *nptr, char *
>   {
>       return strtosz_suffix(nptr, end, STRTOSZ_DEFSUFFIX_MB);
>   }
> +
> +int qemu_parse_fd(const char *param)
> +{
> +    int fd;
> +    char *endptr = NULL;
> +
> +    fd = strtol(param,&endptr, 10);
> +    if (*endptr || (fd == 0&&  param == endptr)) {
> +        return -1;
> +    }
> +    return fd;
> +}
>
>
>

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2011-11-01 22:19 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2011-09-28 10:41 [Qemu-devel] [PATCH v2] Move filedescriptor parsing code from net.c into qemu_parse_fd() Stefan Berger
2011-11-01 22:19 ` Anthony Liguori

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.