All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] Fix build failure on cygwin.
@ 2012-04-02 14:05 Andrej Krutak
  2012-04-02 21:31 ` Michal Marek
  0 siblings, 1 reply; 7+ messages in thread
From: Andrej Krutak @ 2012-04-02 14:05 UTC (permalink / raw)
  To: Michal Marek; +Cc: linux-kbuild, Andrej Krutak

The _B macro is defined by cygwin in ctype.h.
Move the inclusion to avoid build failure.

Signed-off-by: Andrej Krutak <andree@andree.sk>
---
 scripts/dtc/dtc.h |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/scripts/dtc/dtc.h b/scripts/dtc/dtc.h
index f37c97e..7aa3cc6 100644
--- a/scripts/dtc/dtc.h
+++ b/scripts/dtc/dtc.h
@@ -27,13 +27,13 @@
 #include <stdint.h>
 #include <stdarg.h>
 #include <assert.h>
-#include <ctype.h>
 #include <errno.h>
 #include <unistd.h>
 
 #include <libfdt_env.h>
 #include <fdt.h>
 
+#include <ctype.h>
 #include "util.h"
 
 #ifdef DEBUG
-- 
1.7.4.1


^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH] Fix build failure on cygwin.
  2012-04-02 14:05 [PATCH] Fix build failure on cygwin Andrej Krutak
@ 2012-04-02 21:31 ` Michal Marek
  2012-04-02 22:22   ` Jon Loeliger
  0 siblings, 1 reply; 7+ messages in thread
From: Michal Marek @ 2012-04-02 21:31 UTC (permalink / raw)
  To: Andrej Krutak; +Cc: linux-kbuild, Jon Loeliger

Adding Jon Loeliger (dtc maintainer) to CC.


Dne 2.4.2012 16:05, Andrej Krutak napsal(a):
> The _B macro is defined by cygwin in ctype.h.
> Move the inclusion to avoid build failure.

But nothing prevents the other system headers from including <ctype.h>
earlier :-(. A more robust fix would be to rename the macro to something
that does not clash (fdt_b??). But that's up to Jon.

Michal

> 
> Signed-off-by: Andrej Krutak <andree@andree.sk>
> ---
>  scripts/dtc/dtc.h |    2 +-
>  1 files changed, 1 insertions(+), 1 deletions(-)
> 
> diff --git a/scripts/dtc/dtc.h b/scripts/dtc/dtc.h
> index f37c97e..7aa3cc6 100644
> --- a/scripts/dtc/dtc.h
> +++ b/scripts/dtc/dtc.h
> @@ -27,13 +27,13 @@
>  #include <stdint.h>
>  #include <stdarg.h>
>  #include <assert.h>
> -#include <ctype.h>
>  #include <errno.h>
>  #include <unistd.h>
>  
>  #include <libfdt_env.h>
>  #include <fdt.h>
>  
> +#include <ctype.h>
>  #include "util.h"
>  
>  #ifdef DEBUG


^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] Fix build failure on cygwin.
  2012-04-02 21:31 ` Michal Marek
@ 2012-04-02 22:22   ` Jon Loeliger
  2012-04-03  6:35     ` [PATCH] Rename _B to _XBYTE in libfdt_env.h Andrej Krutak
  0 siblings, 1 reply; 7+ messages in thread
From: Jon Loeliger @ 2012-04-02 22:22 UTC (permalink / raw)
  To: Michal Marek; +Cc: Andrej Krutak, linux-kbuild

> Adding Jon Loeliger (dtc maintainer) to CC.
> 
> Dne 2.4.2012 16:05, Andrej Krutak napsal(a):
> > The _B macro is defined by cygwin in ctype.h.
> > Move the inclusion to avoid build failure.
> 
> But nothing prevents the other system headers from including <ctype.h>
> earlier :-(. A more robust fix would be to rename the macro to something
> that does not clash (fdt_b??). But that's up to Jon.
> 
> Michal

Folks,

I'll happily accept a patch to rename _B() to something better
or eliminate it entirely.  Patch to devtree-discuss@lists.ozlabs.org
and CC:'ed to jdl@jdl.com, please.

Thanks,
jdl

^ permalink raw reply	[flat|nested] 7+ messages in thread

* [PATCH] Rename _B to _XBYTE in libfdt_env.h.
  2012-04-02 22:22   ` Jon Loeliger
@ 2012-04-03  6:35     ` Andrej Krutak
  2012-04-09 13:49       ` Jon Loeliger
  0 siblings, 1 reply; 7+ messages in thread
From: Andrej Krutak @ 2012-04-03  6:35 UTC (permalink / raw)
  To: Jon Loeliger; +Cc: devtree-discuss, Michal Marek, linux-kbuild, Andrej Krutak

The _B macro is also defined by cygwin in ctype.h.
Rename _B to _XBYTE to better avoid name collisions.

Signed-off-by: Andrej Krutak <andree@andree.sk>
---
 scripts/dtc/libfdt/libfdt_env.h |   11 ++++++-----
 1 files changed, 6 insertions(+), 5 deletions(-)

diff --git a/scripts/dtc/libfdt/libfdt_env.h b/scripts/dtc/libfdt/libfdt_env.h
index 449bf60..4ec8565 100644
--- a/scripts/dtc/libfdt/libfdt_env.h
+++ b/scripts/dtc/libfdt/libfdt_env.h
@@ -5,19 +5,20 @@
 #include <stdint.h>
 #include <string.h>
 
-#define _B(n)	((unsigned long long)((uint8_t *)&x)[n])
+#define _XBYTE(n)	((unsigned long long)((uint8_t *)&x)[n])
 static inline uint32_t fdt32_to_cpu(uint32_t x)
 {
-	return (_B(0) << 24) | (_B(1) << 16) | (_B(2) << 8) | _B(3);
+	return (_XBYTE(0) << 24) | (_XBYTE(1) << 16) | (_XBYTE(2) << 8) | _XBYTE(3);
 }
 #define cpu_to_fdt32(x) fdt32_to_cpu(x)
 
 static inline uint64_t fdt64_to_cpu(uint64_t x)
 {
-	return (_B(0) << 56) | (_B(1) << 48) | (_B(2) << 40) | (_B(3) << 32)
-		| (_B(4) << 24) | (_B(5) << 16) | (_B(6) << 8) | _B(7);
+	return (_XBYTE(0) << 56) | (_XBYTE(1) << 48) | (_XBYTE(2) << 40)
+		| (_XBYTE(3) << 32) | (_XBYTE(4) << 24) | (_XBYTE(5) << 16)
+		| (_XBYTE(6) << 8) | _XBYTE(7);
 }
 #define cpu_to_fdt64(x) fdt64_to_cpu(x)
-#undef _B
+#undef _XBYTE
 
 #endif /* _LIBFDT_ENV_H */
-- 
1.7.4.1


^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH] Rename _B to _XBYTE in libfdt_env.h.
  2012-04-03  6:35     ` [PATCH] Rename _B to _XBYTE in libfdt_env.h Andrej Krutak
@ 2012-04-09 13:49       ` Jon Loeliger
  0 siblings, 0 replies; 7+ messages in thread
From: Jon Loeliger @ 2012-04-09 13:49 UTC (permalink / raw)
  To: Andrej Krutak; +Cc: devtree-discuss, Michal Marek, linux-kbuild

> The _B macro is also defined by cygwin in ctype.h.
> Rename _B to _XBYTE to better avoid name collisions.
> 
> Signed-off-by: Andrej Krutak <andree@andree.sk>
> ---
>  scripts/dtc/libfdt/libfdt_env.h |   11 ++++++-----
>  1 files changed, 6 insertions(+), 5 deletions(-)
> 
> diff --git a/scripts/dtc/libfdt/libfdt_env.h b/scripts/dtc/libfdt/libfdt_env.h
> index 449bf60..4ec8565 100644
> --- a/scripts/dtc/libfdt/libfdt_env.h
> +++ b/scripts/dtc/libfdt/libfdt_env.h

This patch is against the kernel _copy_ of the DTC sources.
Technically, we'll need it against the upstream sources
as found here:

    git://git.jdl.com/software/dtc.git

Later, the patch will appear in the kernel when it updates
with a newer source drop.

Thanks,
jdl

^ permalink raw reply	[flat|nested] 7+ messages in thread

* [PATCH] Rename _B to _XBYTE in libfdt_env.h.
@ 2012-04-10 14:39 Jon Loeliger
  0 siblings, 0 replies; 7+ messages in thread
From: Jon Loeliger @ 2012-04-10 14:39 UTC (permalink / raw)
  To: devicetree-discuss-uLR06cmDAlY/bJ5BZ2RsiQ


OK.  Let's review how development works, by convention, in the Open
Source Community.  For starters, it's not my itch to scratch, as I don't
care about Cygwin.  As follow up, here's a public posting of the patch
for review.

Thanks for understanding,
jdl

------- Forwarded Message

Return-Path: andree182-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org
Delivery-Date: Tue Apr 10 04:42:59 2012
Return-path: <andree182-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>
Envelope-to: jdl-CYoMK+44s/E@public.gmane.org
Delivery-date: Tue, 10 Apr 2012 04:42:59 -0500
Received: from mail-qc0-f174.google.com ([209.85.216.174])
	by jdl.com with esmtp (Exim 4.72)
	(envelope-from <andree182-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>)
	id 1SHXbG-0003H3-CM
	for jdl-CYoMK+44s/E@public.gmane.org; Tue, 10 Apr 2012 04:42:59 -0500
Received: by qcro28 with SMTP id o28so3406084qcr.5
        for <jdl-CYoMK+44s/E@public.gmane.org>; Tue, 10 Apr 2012 02:42:51 -0700 (PDT)
Received: by 10.224.53.6 with SMTP id k6mr13439024qag.25.1334050971671; Tue,
 10 Apr 2012 02:42:51 -0700 (PDT)
MIME-Version: 1.0
Sender: andree182-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org
Received: by 10.229.230.18 with HTTP; Tue, 10 Apr 2012 02:42:31 -0700 (PDT)
In-Reply-To: <E1SHExs-0001cI-6E-CYoMK+44s/E@public.gmane.org>
References: <E1SEpdZ-0000dW-8Z-CYoMK+44s/E@public.gmane.org> <1333434921-14153-1-git-send-email-andree-/tK0A0Qp8GRaa/9Udqfwiw@public.gmane.org>
 <E1SHExs-0001cI-6E-CYoMK+44s/E@public.gmane.org>
From: =?ISO-8859-1?Q?Andrej_Krut=E1k?= <andree-/tK0A0Qp8GRaa/9Udqfwiw@public.gmane.org>
Date: Tue, 10 Apr 2012 11:42:31 +0200
X-Google-Sender-Auth: Shpb895xEpu8vb2twHQiSB32YTQ
Message-ID: <CAFnc+wXNyeBeUifgTXWdrMQ5vkze+sW-QpM4N16KQ1wQw5r=SQ-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>
Subject: Re: [PATCH] Rename _B to _XBYTE in libfdt_env.h.
To: Jon Loeliger <jdl-CYoMK+44s/E@public.gmane.org>
Content-Type: multipart/alternative; boundary=20cf3074d9a8475ab904bd4ff20c
Received-SPF: pass
X-SPF-Guess: pass
X-Spam-Score: 1.5

- --20cf3074d9a8475ab904bd4ff20c
Content-Type: text/plain; charset=ISO-8859-1

Ok, here is the version against your git repo head.
If there are any more problems, please do the one-line sed yourself, as
this probably costs us both significantly more time compared to if you did
it yourself.


Best regards,

Andrej



The _B macro is also defined by cygwin in ctype.h.
Rename _B to _XBYTE to better avoid name collisions.

Signed-off-by: Andrej Krutak <andree-/tK0A0Qp8GRaa/9Udqfwiw@public.gmane.org>
- ---
 libfdt/libfdt_env.h |   13 +++++++------
 1 files changed, 7 insertions(+), 6 deletions(-)

diff --git a/libfdt/libfdt_env.h b/libfdt/libfdt_env.h
index da952e7..e8d2992 100644
- --- a/libfdt/libfdt_env.h
+++ b/libfdt/libfdt_env.h
@@ -5,25 +5,26 @@
 #include <stdint.h>
 #include <string.h>

- -#define _B(n)    ((unsigned long long)((uint8_t *)&x)[n])
+#define _XBYTE(n)    ((unsigned long long)((uint8_t *)&x)[n])
 static inline uint16_t fdt16_to_cpu(uint16_t x)
 {
- -    return (_B(0) << 8) | _B(1);
+    return (_XBYTE(0) << 8) | _XBYTE(1);
 }
 #define cpu_to_fdt16(x) fdt16_to_cpu(x)

 static inline uint32_t fdt32_to_cpu(uint32_t x)
 {
- -    return (_B(0) << 24) | (_B(1) << 16) | (_B(2) << 8) | _B(3);
+    return (_XBYTE(0) << 24) | (_XBYTE(1) << 16) | (_XBYTE(2) << 8) |
_XBYTE(3);
 }
 #define cpu_to_fdt32(x) fdt32_to_cpu(x)

 static inline uint64_t fdt64_to_cpu(uint64_t x)
 {
- -    return (_B(0) << 56) | (_B(1) << 48) | (_B(2) << 40) | (_B(3) << 32)
- -        | (_B(4) << 24) | (_B(5) << 16) | (_B(6) << 8) | _B(7);
+    return (_XBYTE(0) << 56) | (_XBYTE(1) << 48) | (_XBYTE(2) << 40)
+        | (_XBYTE(3) << 32) | (_XBYTE(4) << 24) | (_XBYTE(5) << 16)
+        | (_XBYTE(6) << 8) | _XBYTE(7);
 }
 #define cpu_to_fdt64(x) fdt64_to_cpu(x)
- -#undef _B
+#undef _XBYTE

 #endif /* _LIBFDT_ENV_H */
- -- 
1.7.4.1



On Mon, Apr 9, 2012 at 3:49 PM, Jon Loeliger <jdl-CYoMK+44s/E@public.gmane.org> wrote:

> > The _B macro is also defined by cygwin in ctype.h.
> > Rename _B to _XBYTE to better avoid name collisions.
> >
> > Signed-off-by: Andrej Krutak <andree-/tK0A0Qp8GRaa/9Udqfwiw@public.gmane.org>
> > ---
> >  scripts/dtc/libfdt/libfdt_env.h |   11 ++++++-----
> >  1 files changed, 6 insertions(+), 5 deletions(-)
> >
> > diff --git a/scripts/dtc/libfdt/libfdt_env.h
> b/scripts/dtc/libfdt/libfdt_env.h
> > index 449bf60..4ec8565 100644
> > --- a/scripts/dtc/libfdt/libfdt_env.h
> > +++ b/scripts/dtc/libfdt/libfdt_env.h
>
> This patch is against the kernel _copy_ of the DTC sources.
> Technically, we'll need it against the upstream sources
> as found here:
>
>    git://git.jdl.com/software/dtc.git
>
> Later, the patch will appear in the kernel when it updates
> with a newer source drop.
>
> Thanks,
> jdl


------- End of Forwarded Message

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH] Rename _B to _XBYTE in libfdt_env.h.
@ 2012-04-09 15:28 Jon Loeliger
  0 siblings, 0 replies; 7+ messages in thread
From: Jon Loeliger @ 2012-04-09 15:28 UTC (permalink / raw)
  To: devicetree-discuss-uLR06cmDAlY/bJ5BZ2RsiQ

[ Drat.  It's devicetree-discuss-uLR06cmDAlY/bJ5BZ2RsieG/Ez6ZCGd0@public.gmane.org  Sorry. -- jdl]

------- Forwarded Message

To: Andrej Krutak <andree-/tK0A0Qp8GRaa/9Udqfwiw@public.gmane.org>
cc: devtree-discuss-uLR06cmDAlY/bJ5BZ2RsiQ@public.gmane.org, Michal Marek <mmarek-AlSwsSmVLrQ@public.gmane.org>,
    linux-kbuild-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
Subject: Re: [PATCH] Rename _B to _XBYTE in libfdt_env.h.
In-reply-to: <1333434921-14153-1-git-send-email-andree-/tK0A0Qp8GRaa/9Udqfwiw@public.gmane.org>
References: <E1SEpdZ-0000dW-8Z-CYoMK+44s/E@public.gmane.org> <1333434921-14153-1-git-send-email-andree-/tK0A0Qp8GRaa/9Udqfwiw@public.gmane.org>
Comments: In-reply-to Andrej Krutak <andree-/tK0A0Qp8GRaa/9Udqfwiw@public.gmane.org>
   message dated "Tue, 03 Apr 2012 08:35:21 +0200."
Date: Mon, 09 Apr 2012 08:49:04 -0500
From: Jon Loeliger <jdl-CYoMK+44s/E@public.gmane.org>
X-Spam-Score: -0.0

> The _B macro is also defined by cygwin in ctype.h.
> Rename _B to _XBYTE to better avoid name collisions.
> 
> Signed-off-by: Andrej Krutak <andree-/tK0A0Qp8GRaa/9Udqfwiw@public.gmane.org>
> ---
>  scripts/dtc/libfdt/libfdt_env.h |   11 ++++++-----
>  1 files changed, 6 insertions(+), 5 deletions(-)
> 
> diff --git a/scripts/dtc/libfdt/libfdt_env.h b/scripts/dtc/libfdt/libfdt_env.h
> index 449bf60..4ec8565 100644
> --- a/scripts/dtc/libfdt/libfdt_env.h
> +++ b/scripts/dtc/libfdt/libfdt_env.h

This patch is against the kernel _copy_ of the DTC sources.
Technically, we'll need it against the upstream sources
as found here:

    git://git.jdl.com/software/dtc.git

Later, the patch will appear in the kernel when it updates
with a newer source drop.

Thanks,
jdl

- --ED70BB7024.1333981658/ozlabs.org--

------- End of Forwarded Message

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2012-04-10 14:39 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-04-02 14:05 [PATCH] Fix build failure on cygwin Andrej Krutak
2012-04-02 21:31 ` Michal Marek
2012-04-02 22:22   ` Jon Loeliger
2012-04-03  6:35     ` [PATCH] Rename _B to _XBYTE in libfdt_env.h Andrej Krutak
2012-04-09 13:49       ` Jon Loeliger
2012-04-09 15:28 Jon Loeliger
2012-04-10 14:39 Jon Loeliger

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.