All of lore.kernel.org
 help / color / mirror / Atom feed
* [RFC][PATCH] introduce SIZE_MAX
@ 2012-04-19  4:27 Xi Wang
  2012-04-20 23:03 ` Andrew Morton
  0 siblings, 1 reply; 3+ messages in thread
From: Xi Wang @ 2012-04-19  4:27 UTC (permalink / raw)
  To: linux-kernel
  Cc: Alex Elder, Andrew Morton, David Airlie, Pekka Enberg, Xi Wang

ULONG_MAX is often used to check for integer overflow when calculating
allocation size.  While ULONG_MAX happens to work on most systems,
there is no guarantee that `size_t' must be the same size as `long'.

This patch introduces SIZE_MAX, the maximum value of `size_t', to
improve portability and readability for allocation size validation.

Signed-off-by: Xi Wang <xi.wang@gmail.com>
---
This patch uses ceph and drm for demonstration purpose.  I will resend
and split the patch if the new macro is found useful.
---
 fs/ceph/snap.c             |    2 +-
 include/drm/drm_mem_util.h |    4 ++--
 include/linux/kernel.h     |    1 +
 include/linux/slab.h       |    2 +-
 4 files changed, 5 insertions(+), 4 deletions(-)

diff --git a/fs/ceph/snap.c b/fs/ceph/snap.c
index f04c096..e5206fc 100644
--- a/fs/ceph/snap.c
+++ b/fs/ceph/snap.c
@@ -331,7 +331,7 @@ static int build_snap_context(struct ceph_snap_realm *realm)
 
 	/* alloc new snap context */
 	err = -ENOMEM;
-	if (num > (ULONG_MAX - sizeof(*snapc)) / sizeof(u64))
+	if (num > (SIZE_MAX - sizeof(*snapc)) / sizeof(u64))
 		goto fail;
 	snapc = kzalloc(sizeof(*snapc) + num*sizeof(u64), GFP_NOFS);
 	if (!snapc)
diff --git a/include/drm/drm_mem_util.h b/include/drm/drm_mem_util.h
index 6bd325f..19a2404 100644
--- a/include/drm/drm_mem_util.h
+++ b/include/drm/drm_mem_util.h
@@ -31,7 +31,7 @@
 
 static __inline__ void *drm_calloc_large(size_t nmemb, size_t size)
 {
-	if (size != 0 && nmemb > ULONG_MAX / size)
+	if (size != 0 && nmemb > SIZE_MAX / size)
 		return NULL;
 
 	if (size * nmemb <= PAGE_SIZE)
@@ -44,7 +44,7 @@ static __inline__ void *drm_calloc_large(size_t nmemb, size_t size)
 /* Modeled after cairo's malloc_ab, it's like calloc but without the zeroing. */
 static __inline__ void *drm_malloc_ab(size_t nmemb, size_t size)
 {
-	if (size != 0 && nmemb > ULONG_MAX / size)
+	if (size != 0 && nmemb > SIZE_MAX / size)
 		return NULL;
 
 	if (size * nmemb <= PAGE_SIZE)
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
index 645231c..b795ee5 100644
--- a/include/linux/kernel.h
+++ b/include/linux/kernel.h
@@ -35,6 +35,7 @@
 #define LLONG_MAX	((long long)(~0ULL>>1))
 #define LLONG_MIN	(-LLONG_MAX - 1)
 #define ULLONG_MAX	(~0ULL)
+#define SIZE_MAX	(~(size_t)0)
 
 #define STACK_MAGIC	0xdeadbeef
 
diff --git a/include/linux/slab.h b/include/linux/slab.h
index a595dce..67d5d94 100644
--- a/include/linux/slab.h
+++ b/include/linux/slab.h
@@ -242,7 +242,7 @@ size_t ksize(const void *);
  */
 static inline void *kmalloc_array(size_t n, size_t size, gfp_t flags)
 {
-	if (size != 0 && n > ULONG_MAX / size)
+	if (size != 0 && n > SIZE_MAX / size)
 		return NULL;
 	return __kmalloc(n * size, flags);
 }
-- 
1.7.5.4


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [RFC][PATCH] introduce SIZE_MAX
  2012-04-19  4:27 [RFC][PATCH] introduce SIZE_MAX Xi Wang
@ 2012-04-20 23:03 ` Andrew Morton
  2012-04-21  2:59   ` Xi Wang
  0 siblings, 1 reply; 3+ messages in thread
From: Andrew Morton @ 2012-04-20 23:03 UTC (permalink / raw)
  To: Xi Wang; +Cc: linux-kernel, Alex Elder, David Airlie, Pekka Enberg

On Thu, 19 Apr 2012 00:27:51 -0400
Xi Wang <xi.wang@gmail.com> wrote:

> ULONG_MAX is often used to check for integer overflow when calculating
> allocation size.  While ULONG_MAX happens to work on most systems,
> there is no guarantee that `size_t' must be the same size as `long'.
> 
> This patch introduces SIZE_MAX, the maximum value of `size_t', to
> improve portability and readability for allocation size validation.
>
> ...
>
> @@ -331,7 +331,7 @@ static int build_snap_context(struct ceph_snap_realm *realm)
>  
>  	/* alloc new snap context */
>  	err = -ENOMEM;
> -	if (num > (ULONG_MAX - sizeof(*snapc)) / sizeof(u64))
> +	if (num > (SIZE_MAX - sizeof(*snapc)) / sizeof(u64))
>  		goto fail;
>  	snapc = kzalloc(sizeof(*snapc) + num*sizeof(u64), GFP_NOFS);
>  	if (!snapc)

hm, yes, I suppose that's better - hardwiring the assumption that
size_t has type unsigned long is pretty ugly.

Will we need something for ssize_t also?

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [RFC][PATCH] introduce SIZE_MAX
  2012-04-20 23:03 ` Andrew Morton
@ 2012-04-21  2:59   ` Xi Wang
  0 siblings, 0 replies; 3+ messages in thread
From: Xi Wang @ 2012-04-21  2:59 UTC (permalink / raw)
  To: Andrew Morton; +Cc: linux-kernel, Alex Elder, David Airlie, Pekka Enberg

On Apr 20, 2012, at 7:03 PM, Andrew Morton wrote:

> Will we need something for ssize_t also?

Did you mean something like SSIZE_MAX for replacing LONG_MAX?  That's
a good question since we have ssize_t.

I tried to grep `LONG_MAX' and `size'.  The only place I have found
so far is the following:

fs/xfs/xfs_aops.c:1247, in __xfs_get_blocks()

	if (mapping_size > LONG_MAX)
		mapping_size = LONG_MAX;

	bh_result->b_size = mapping_size;

Not sure if SSIZE_MAX works better here (`b_size' is size_t).

- xi

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2012-04-21  2:59 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-04-19  4:27 [RFC][PATCH] introduce SIZE_MAX Xi Wang
2012-04-20 23:03 ` Andrew Morton
2012-04-21  2:59   ` Xi Wang

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.