All of lore.kernel.org
 help / color / mirror / Atom feed
* [RFC/PATCH] m68k: fix compiler warning by properly inlining flat_set_persistent()
@ 2012-04-23 13:50 Ezequiel Garcia
  2012-04-23 21:07 ` Geert Uytterhoeven
  0 siblings, 1 reply; 7+ messages in thread
From: Ezequiel Garcia @ 2012-04-23 13:50 UTC (permalink / raw)
  To: geert; +Cc: linux-m68k, Ezequiel Garcia

Signed-off-by: Ezequiel Garcia <elezegarcia@gmail.com>
---
To define or to inline that is the question:
The current definition of flat_set_persistent produces a compiler 
warning; arch/sh/ does it in a different way defining it to 
a macro that uses persistent var. IMHO, an inline is easier to read.
---
 arch/m68k/include/asm/flat.h |    7 ++++++-
 1 files changed, 6 insertions(+), 1 deletions(-)

diff --git a/arch/m68k/include/asm/flat.h b/arch/m68k/include/asm/flat.h
index a0e2907..f9454b8 100644
--- a/arch/m68k/include/asm/flat.h
+++ b/arch/m68k/include/asm/flat.h
@@ -11,6 +11,11 @@
 #define	flat_get_addr_from_rp(rp, relval, flags, p)	get_unaligned(rp)
 #define	flat_put_addr_at_rp(rp, val, relval)	put_unaligned(val,rp)
 #define	flat_get_relocate_addr(rel)		(rel)
-#define	flat_set_persistent(relval, p)		0
+
+static inline int flat_set_persistent(unsigned long relval,
+				      unsigned long *persistent)
+{
+	return 0;
+}
 
 #endif /* __M68KNOMMU_FLAT_H__ */
-- 
1.7.3.4

^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [RFC/PATCH] m68k: fix compiler warning by properly inlining flat_set_persistent()
  2012-04-23 13:50 [RFC/PATCH] m68k: fix compiler warning by properly inlining flat_set_persistent() Ezequiel Garcia
@ 2012-04-23 21:07 ` Geert Uytterhoeven
  2012-04-23 22:43   ` Ezequiel García
  0 siblings, 1 reply; 7+ messages in thread
From: Geert Uytterhoeven @ 2012-04-23 21:07 UTC (permalink / raw)
  To: Ezequiel Garcia; +Cc: linux-m68k, uClinux development list

On Mon, Apr 23, 2012 at 15:50, Ezequiel Garcia <elezegarcia@gmail.com> wrote:
> Signed-off-by: Ezequiel Garcia <elezegarcia@gmail.com>
> ---
> To define or to inline that is the question:
> The current definition of flat_set_persistent produces a compiler
> warning; arch/sh/ does it in a different way defining it to
> a macro that uses persistent var. IMHO, an inline is easier to read.

What's the compiler warning?
It seems several other nommu arches use the same definition for
flat_set_persistent()?

> ---
>  arch/m68k/include/asm/flat.h |    7 ++++++-
>  1 files changed, 6 insertions(+), 1 deletions(-)
>
> diff --git a/arch/m68k/include/asm/flat.h b/arch/m68k/include/asm/flat.h
> index a0e2907..f9454b8 100644
> --- a/arch/m68k/include/asm/flat.h
> +++ b/arch/m68k/include/asm/flat.h
> @@ -11,6 +11,11 @@
>  #define        flat_get_addr_from_rp(rp, relval, flags, p)     get_unaligned(rp)
>  #define        flat_put_addr_at_rp(rp, val, relval)    put_unaligned(val,rp)
>  #define        flat_get_relocate_addr(rel)             (rel)
> -#define        flat_set_persistent(relval, p)          0
> +
> +static inline int flat_set_persistent(unsigned long relval,
> +                                     unsigned long *persistent)
> +{
> +       return 0;
> +}
>
>  #endif /* __M68KNOMMU_FLAT_H__ */
> --
> 1.7.3.4

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [RFC/PATCH] m68k: fix compiler warning by properly inlining flat_set_persistent()
  2012-04-23 21:07 ` Geert Uytterhoeven
@ 2012-04-23 22:43   ` Ezequiel García
  2012-04-24  2:13     ` Greg Ungerer
  0 siblings, 1 reply; 7+ messages in thread
From: Ezequiel García @ 2012-04-23 22:43 UTC (permalink / raw)
  To: Geert Uytterhoeven; +Cc: linux-m68k, uClinux development list

Hi Geert,

On Mon, Apr 23, 2012 at 6:07 PM, Geert Uytterhoeven
<geert@linux-m68k.org> wrote:
> On Mon, Apr 23, 2012 at 15:50, Ezequiel Garcia <elezegarcia@gmail.com> wrote:
>> Signed-off-by: Ezequiel Garcia <elezegarcia@gmail.com>
>> ---
>> To define or to inline that is the question:
>> The current definition of flat_set_persistent produces a compiler
>> warning; arch/sh/ does it in a different way defining it to
>> a macro that uses persistent var. IMHO, an inline is easier to read.
>
> What's the compiler warning?
> It seems several other nommu arches use the same definition for
> flat_set_persistent()?
>

Here's the warning:
  fs/binfmt_flat.c: In function ‘load_flat_file’:
  fs/binfmt_flat.c:752: warning: unused variable ‘persistent’

Yes, every arch except sh is using the same definition.
My first thought was to extend the arch/sh definition:

  #define flat_set_persistent(relval, p)          ({ (void)p; 0; })

but in a conversation in the janitors list I was told that inlining
to a return-only function is a common pattern.
Plus, if you compare fs/built-in.o there is no extra code generated:

$ size fs-built-in-flat-inline
   text	   data	    bss	    dec	    hex	filename
 233332	   1908	   1640	 236880	  39d50	built-in-flat-inline
$ size fs/built-in.o
   text	   data	    bss	    dec	    hex	filename
 233332	   1908	   1640	 236880	  39d50	fs/built-in.o

FWIW, this is my compiler, I built it using gentoo's crossdev tool.
  gcc version 4.4.5 (Gentoo 4.4.5 p1.3, pie-0.4.5)

So, what's your opinion?
Thanks,
Ezequiel.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [RFC/PATCH] m68k: fix compiler warning by properly inlining flat_set_persistent()
  2012-04-23 22:43   ` Ezequiel García
@ 2012-04-24  2:13     ` Greg Ungerer
  2012-04-24  2:35       ` Ezequiel García
  0 siblings, 1 reply; 7+ messages in thread
From: Greg Ungerer @ 2012-04-24  2:13 UTC (permalink / raw)
  To: Ezequiel García
  Cc: Geert Uytterhoeven, linux-m68k, uClinux development list

Hi Ezequiel,

On 24/04/12 08:43, Ezequiel García wrote:
> On Mon, Apr 23, 2012 at 6:07 PM, Geert Uytterhoeven
> <geert@linux-m68k.org>  wrote:
>> On Mon, Apr 23, 2012 at 15:50, Ezequiel Garcia<elezegarcia@gmail.com>  wrote:
>>> Signed-off-by: Ezequiel Garcia<elezegarcia@gmail.com>

Normally this signed-off-by goes after your patch description
(Documentation/SubmittingPatches section 12).


>>> ---
>>> To define or to inline that is the question:
>>> The current definition of flat_set_persistent produces a compiler
>>> warning; arch/sh/ does it in a different way defining it to
>>> a macro that uses persistent var. IMHO, an inline is easier to read.
>>
>> What's the compiler warning?
>> It seems several other nommu arches use the same definition for
>> flat_set_persistent()?
>>
>
> Here's the warning:
>    fs/binfmt_flat.c: In function æload_flat_fileÆ:
>    fs/binfmt_flat.c:752: warning: unused variable æpersistentÆ

I like to see the actual compiler messages in the git message
description as well.


> Yes, every arch except sh is using the same definition.
> My first thought was to extend the arch/sh definition:
>
>    #define flat_set_persistent(relval, p)          ({ (void)p; 0; })
>
> but in a conversation in the janitors list I was told that inlining
> to a return-only function is a common pattern.
> Plus, if you compare fs/built-in.o there is no extra code generated:
>
> $ size fs-built-in-flat-inline
>     text	   data	    bss	    dec	    hex	filename
>   233332	   1908	   1640	 236880	  39d50	built-in-flat-inline
> $ size fs/built-in.o
>     text	   data	    bss	    dec	    hex	filename
>   233332	   1908	   1640	 236880	  39d50	fs/built-in.o
>
> FWIW, this is my compiler, I built it using gentoo's crossdev tool.
>    gcc version 4.4.5 (Gentoo 4.4.5 p1.3, pie-0.4.5)
>
> So, what's your opinion?

I see the same warning on my gcc-4.5.1 based toolchain as well.
No surprise really given none of the m68k macros use the persistent arg.

If you want to move that signed-off-by and put the warning text in
the message description I will carry this in the m68knommu git tree.

Thanks
Greg


------------------------------------------------------------------------
Greg Ungerer  --  Principal Engineer        EMAIL:     gerg@snapgear.com
SnapGear Group, McAfee                      PHONE:       +61 7 3435 2888
8 Gardner Close                             FAX:         +61 7 3217 5323
Milton, QLD, 4064, Australia                WEB: http://www.SnapGear.com

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [RFC/PATCH] m68k: fix compiler warning by properly inlining flat_set_persistent()
  2012-04-24  2:13     ` Greg Ungerer
@ 2012-04-24  2:35       ` Ezequiel García
  2012-04-24  3:10         ` Greg Ungerer
  0 siblings, 1 reply; 7+ messages in thread
From: Ezequiel García @ 2012-04-24  2:35 UTC (permalink / raw)
  To: Greg Ungerer; +Cc: Geert Uytterhoeven, linux-m68k, uClinux development list

Hi Greg,

2012/4/23 Greg Ungerer <gerg@snapgear.com>:
>
> Normally this signed-off-by goes after your patch description
> (Documentation/SubmittingPatches section 12).

I know. That text wasn't intended to be part of the commit message, it was
to trigger the discussion. I'll resend the patch with a proper commit message,
including the warning.

Same warning will appear on every other arch, since the only one using
flat_set_persistent() is arch/blackfin...
do you think it would be nice to submit that also (to the proper
lists, of course)?

Thanks for the review,
Ezequiel.

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [RFC/PATCH] m68k: fix compiler warning by properly inlining flat_set_persistent()
  2012-04-24  2:35       ` Ezequiel García
@ 2012-04-24  3:10         ` Greg Ungerer
  0 siblings, 0 replies; 7+ messages in thread
From: Greg Ungerer @ 2012-04-24  3:10 UTC (permalink / raw)
  To: Ezequiel García
  Cc: Geert Uytterhoeven, linux-m68k, uClinux development list

Hi Ezequiel,

On 24/04/12 12:35, Ezequiel García wrote:
> 2012/4/23 Greg Ungerer<gerg@snapgear.com>:
>>
>> Normally this signed-off-by goes after your patch description
>> (Documentation/SubmittingPatches section 12).
>
> I know. That text wasn't intended to be part of the commit message, it was
> to trigger the discussion. I'll resend the patch with a proper commit message,
> including the warning.

Ok, sorry, I thought that was supposed to be the commit message.


> Same warning will appear on every other arch, since the only one using
> flat_set_persistent() is arch/blackfin...
> do you think it would be nice to submit that also (to the proper
> lists, of course)?

Yes, I think that is a good idea.

Regards
Greg


------------------------------------------------------------------------
Greg Ungerer  --  Principal Engineer        EMAIL:     gerg@snapgear.com
SnapGear Group, McAfee                      PHONE:       +61 7 3435 2888
8 Gardner Close                             FAX:         +61 7 3217 5323
Milton, QLD, 4064, Australia                WEB: http://www.SnapGear.com

^ permalink raw reply	[flat|nested] 7+ messages in thread

* [RFC/PATCH] m68k: fix compiler warning by properly inlining flat_set_persistent()
@ 2012-04-23 14:11 Ezequiel Garcia
  0 siblings, 0 replies; 7+ messages in thread
From: Ezequiel Garcia @ 2012-04-23 14:11 UTC (permalink / raw)
  To: geert; +Cc: linux-m68k, Ezequiel Garcia

Signed-off-by: Ezequiel Garcia <elezegarcia@gmail.com>
---
To define or to inline that is the question:
The current definition of flat_set_persistent produces a compiler 
warning; arch/sh/ does it in a different way defining it to 
a macro that uses persistent var. IMHO, an inline is easier to read.
---
 arch/m68k/include/asm/flat.h |    7 ++++++-
 1 files changed, 6 insertions(+), 1 deletions(-)

diff --git a/arch/m68k/include/asm/flat.h b/arch/m68k/include/asm/flat.h
index a0e2907..f9454b8 100644
--- a/arch/m68k/include/asm/flat.h
+++ b/arch/m68k/include/asm/flat.h
@@ -11,6 +11,11 @@
 #define	flat_get_addr_from_rp(rp, relval, flags, p)	get_unaligned(rp)
 #define	flat_put_addr_at_rp(rp, val, relval)	put_unaligned(val,rp)
 #define	flat_get_relocate_addr(rel)		(rel)
-#define	flat_set_persistent(relval, p)		0
+
+static inline int flat_set_persistent(unsigned long relval,
+				      unsigned long *persistent)
+{
+	return 0;
+}
 
 #endif /* __M68KNOMMU_FLAT_H__ */
-- 
1.7.3.4

^ permalink raw reply related	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2012-04-24  3:10 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-04-23 13:50 [RFC/PATCH] m68k: fix compiler warning by properly inlining flat_set_persistent() Ezequiel Garcia
2012-04-23 21:07 ` Geert Uytterhoeven
2012-04-23 22:43   ` Ezequiel García
2012-04-24  2:13     ` Greg Ungerer
2012-04-24  2:35       ` Ezequiel García
2012-04-24  3:10         ` Greg Ungerer
2012-04-23 14:11 Ezequiel Garcia

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.