All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] mfd: palmas: is_palmas_charger needed by multiple drivers
@ 2013-02-26 14:47 Ian Lartey
  2013-03-04 10:44 ` Samuel Ortiz
  0 siblings, 1 reply; 6+ messages in thread
From: Ian Lartey @ 2013-02-26 14:47 UTC (permalink / raw)
  To: linux-kernel
  Cc: grant.likely, linus.walleij, ldewangan, sameo, Ian Lartey,
	Graeme Gregory

is_palmas_charger checks for the presence of charging
functionality in the device

Signed-off-by: Graeme Gregory <gg@slimlogic.co.uk>
Signed-off-by: Ian Lartey <ian@slimlogic.co.uk>
Acked-by: Laxman Dewangan<ldewangan@nvidia.com>
---
 include/linux/mfd/palmas.h |    5 +++++
 1 files changed, 5 insertions(+), 0 deletions(-)

diff --git a/include/linux/mfd/palmas.h b/include/linux/mfd/palmas.h
index 3129f9a..98c0567 100644
--- a/include/linux/mfd/palmas.h
+++ b/include/linux/mfd/palmas.h
@@ -26,6 +26,11 @@
 /* The ID_REVISION NUMBERS */
 #define PALMAS_CHIP_OLD_ID		0x0000
 #define PALMAS_CHIP_ID			0xC035
+#define PALMAS_CHIP_CHARGER_ID		0xC036
+
+#define is_palmas(a)	(((a) == PALMAS_CHIP_OLD_ID) || \
+			((a) == PALMAS_CHIP_ID))
+#define is_palmas_charger(a) ((a) == PALMAS_CHIP_CHARGER_ID)
 
 struct palmas_pmic;
 struct palmas_gpadc;
-- 
1.7.0.4


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* Re: [PATCH] mfd: palmas: is_palmas_charger needed by multiple drivers
  2013-02-26 14:47 [PATCH] mfd: palmas: is_palmas_charger needed by multiple drivers Ian Lartey
@ 2013-03-04 10:44 ` Samuel Ortiz
  2013-03-06  1:09   ` Grant Likely
  0 siblings, 1 reply; 6+ messages in thread
From: Samuel Ortiz @ 2013-03-04 10:44 UTC (permalink / raw)
  To: Ian Lartey
  Cc: linux-kernel, grant.likely, linus.walleij, ldewangan, Graeme Gregory

Hi Ian,

On Tue, Feb 26, 2013 at 02:47:28PM +0000, Ian Lartey wrote:
> is_palmas_charger checks for the presence of charging
> functionality in the device
> 
> Signed-off-by: Graeme Gregory <gg@slimlogic.co.uk>
> Signed-off-by: Ian Lartey <ian@slimlogic.co.uk>
> Acked-by: Laxman Dewangan<ldewangan@nvidia.com>
Acked-by: Samuel Ortiz <sameo@linux.intel.com>

Cheers,
Samuel.

-- 
Intel Open Source Technology Centre
http://oss.intel.com/

^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] mfd: palmas: is_palmas_charger needed by multiple drivers
  2013-03-04 10:44 ` Samuel Ortiz
@ 2013-03-06  1:09   ` Grant Likely
  0 siblings, 0 replies; 6+ messages in thread
From: Grant Likely @ 2013-03-06  1:09 UTC (permalink / raw)
  To: Samuel Ortiz, Ian Lartey
  Cc: linux-kernel, linus.walleij, ldewangan, Graeme Gregory

On Mon, 4 Mar 2013 11:44:49 +0100, Samuel Ortiz <sameo@linux.intel.com> wrote:
> Hi Ian,
> 
> On Tue, Feb 26, 2013 at 02:47:28PM +0000, Ian Lartey wrote:
> > is_palmas_charger checks for the presence of charging
> > functionality in the device
> > 
> > Signed-off-by: Graeme Gregory <gg@slimlogic.co.uk>
> > Signed-off-by: Ian Lartey <ian@slimlogic.co.uk>
> > Acked-by: Laxman Dewangan<ldewangan@nvidia.com>
> Acked-by: Samuel Ortiz <sameo@linux.intel.com>

Hi Samuel,

I think you better take this through the mfd tree. I can't take it in
gpio because there are other trees that need it also. I'll drop the gpio
patch that depends on this one and let Ian submit a new series that goes
on top of this.

g.


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] mfd: palmas: is_palmas_charger needed by multiple drivers
  2013-02-26 14:01 ` Laxman Dewangan
@ 2013-02-26 14:12   ` Graeme Gregory
  0 siblings, 0 replies; 6+ messages in thread
From: Graeme Gregory @ 2013-02-26 14:12 UTC (permalink / raw)
  To: Laxman Dewangan
  Cc: Ian Lartey, linux-kernel, grant.likely, linus.walleij, sameo

On 26/02/13 14:01, Laxman Dewangan wrote:
> On Tuesday 26 February 2013 06:46 PM, Ian Lartey wrote:
>> is_palmas_charger checks for the presence of charging
>> functionality in the device
>>
>> Signed-off-by: Graeme Gregory <gg@slimlogic.co.uk>
>> Signed-off-by: Ian Lartey <ian@slimlogic.co.uk>
>> ---
>>   include/linux/mfd/palmas.h |    5 +++++
>>   1 files changed, 5 insertions(+), 0 deletions(-)
>>
>> diff --git a/include/linux/mfd/palmas.h b/include/linux/mfd/palmas.h
>> index 3129f9a..98c0567 100644
>> --- a/include/linux/mfd/palmas.h
>> +++ b/include/linux/mfd/palmas.h
>> @@ -26,6 +26,11 @@
>>   /* The ID_REVISION NUMBERS */
>>   #define PALMAS_CHIP_OLD_ID        0x0000
>>   #define PALMAS_CHIP_ID            0xC035
>> +#define PALMAS_CHIP_CHARGER_ID        0xC036
>> +
>> +#define is_palmas(a)    (((a) == PALMAS_CHIP_OLD_ID) || \
>> +            ((a) == PALMAS_CHIP_ID))
>> +#define is_palmas_charger(a) ((a) == PALMAS_CHIP_CHARGER_ID)
>>   
>
> TI says this as TPS80036 and original palma as TPS65913/TPS65914. Not
> sure whether palma_charger is correct or not here.
>
> But above change looks good.
>
> Acked-by: Laxman Dewangan<ldewangan@nvidia.com>
I can confirm that the generic name of TPS80036 is palmas-charger as
decided at TI!

Graeme


^ permalink raw reply	[flat|nested] 6+ messages in thread

* Re: [PATCH] mfd: palmas: is_palmas_charger needed by multiple drivers
  2013-02-26 13:16 Ian Lartey
@ 2013-02-26 14:01 ` Laxman Dewangan
  2013-02-26 14:12   ` Graeme Gregory
  0 siblings, 1 reply; 6+ messages in thread
From: Laxman Dewangan @ 2013-02-26 14:01 UTC (permalink / raw)
  To: Ian Lartey
  Cc: linux-kernel, grant.likely, linus.walleij, sameo, Graeme Gregory

On Tuesday 26 February 2013 06:46 PM, Ian Lartey wrote:
> is_palmas_charger checks for the presence of charging
> functionality in the device
>
> Signed-off-by: Graeme Gregory <gg@slimlogic.co.uk>
> Signed-off-by: Ian Lartey <ian@slimlogic.co.uk>
> ---
>   include/linux/mfd/palmas.h |    5 +++++
>   1 files changed, 5 insertions(+), 0 deletions(-)
>
> diff --git a/include/linux/mfd/palmas.h b/include/linux/mfd/palmas.h
> index 3129f9a..98c0567 100644
> --- a/include/linux/mfd/palmas.h
> +++ b/include/linux/mfd/palmas.h
> @@ -26,6 +26,11 @@
>   /* The ID_REVISION NUMBERS */
>   #define PALMAS_CHIP_OLD_ID		0x0000
>   #define PALMAS_CHIP_ID			0xC035
> +#define PALMAS_CHIP_CHARGER_ID		0xC036
> +
> +#define is_palmas(a)	(((a) == PALMAS_CHIP_OLD_ID) || \
> +			((a) == PALMAS_CHIP_ID))
> +#define is_palmas_charger(a) ((a) == PALMAS_CHIP_CHARGER_ID)
>   

TI says this as TPS80036 and original palma as TPS65913/TPS65914. Not 
sure whether palma_charger is correct or not here.

But above change looks good.

Acked-by: Laxman Dewangan<ldewangan@nvidia.com>

^ permalink raw reply	[flat|nested] 6+ messages in thread

* [PATCH] mfd: palmas: is_palmas_charger needed by multiple drivers
@ 2013-02-26 13:16 Ian Lartey
  2013-02-26 14:01 ` Laxman Dewangan
  0 siblings, 1 reply; 6+ messages in thread
From: Ian Lartey @ 2013-02-26 13:16 UTC (permalink / raw)
  To: linux-kernel
  Cc: grant.likely, linus.walleij, ldewangan, sameo, Ian Lartey,
	Graeme Gregory

is_palmas_charger checks for the presence of charging
functionality in the device

Signed-off-by: Graeme Gregory <gg@slimlogic.co.uk>
Signed-off-by: Ian Lartey <ian@slimlogic.co.uk>
---
 include/linux/mfd/palmas.h |    5 +++++
 1 files changed, 5 insertions(+), 0 deletions(-)

diff --git a/include/linux/mfd/palmas.h b/include/linux/mfd/palmas.h
index 3129f9a..98c0567 100644
--- a/include/linux/mfd/palmas.h
+++ b/include/linux/mfd/palmas.h
@@ -26,6 +26,11 @@
 /* The ID_REVISION NUMBERS */
 #define PALMAS_CHIP_OLD_ID		0x0000
 #define PALMAS_CHIP_ID			0xC035
+#define PALMAS_CHIP_CHARGER_ID		0xC036
+
+#define is_palmas(a)	(((a) == PALMAS_CHIP_OLD_ID) || \
+			((a) == PALMAS_CHIP_ID))
+#define is_palmas_charger(a) ((a) == PALMAS_CHIP_CHARGER_ID)
 
 struct palmas_pmic;
 struct palmas_gpadc;
-- 
1.7.0.4


^ permalink raw reply related	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2013-03-06  1:09 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-02-26 14:47 [PATCH] mfd: palmas: is_palmas_charger needed by multiple drivers Ian Lartey
2013-03-04 10:44 ` Samuel Ortiz
2013-03-06  1:09   ` Grant Likely
  -- strict thread matches above, loose matches on Subject: below --
2013-02-26 13:16 Ian Lartey
2013-02-26 14:01 ` Laxman Dewangan
2013-02-26 14:12   ` Graeme Gregory

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.